summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2019-09-12 08:43:56 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2019-09-12 08:43:56 +0000
commit7a5653729877b8c697da7dfb8ded2b313b8d1d71 (patch)
tree2937d2e4a32688b8ea04afd1efcf7efb011bccfb
parentReleasing progress-linux version 6.2.1+ds+~0.4.0+~4.0.0+really4.0.0+~1.0.0+~5... (diff)
downloadacorn-7a5653729877b8c697da7dfb8ded2b313b8d1d71.tar.xz
acorn-7a5653729877b8c697da7dfb8ded2b313b8d1d71.zip
Merging debian version 6.2.1+ds+~0.4.0+~4.0.0+really4.0.0+~1.0.0+~5.0.1+ds+~1.7.0+ds+~0.1.1+~0.3.1+~0.2.0+~0.1.0+~0.3.0+~0.3.0-3.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
-rw-r--r--debian/.git-dpm4
-rw-r--r--debian/changelog8
-rw-r--r--debian/control2
-rw-r--r--debian/patches/0004-Depends-on-lastest-unicode.patch35
-rw-r--r--debian/patches/series1
5 files changed, 47 insertions, 3 deletions
diff --git a/debian/.git-dpm b/debian/.git-dpm
index a01f210..b1c83c5 100644
--- a/debian/.git-dpm
+++ b/debian/.git-dpm
@@ -1,6 +1,6 @@
# see git-dpm(1) from git-dpm package
-006ff68587b46bd138f7d823f377df82f00775df
-006ff68587b46bd138f7d823f377df82f00775df
+bfd5fd73a7e408f827542a8f5087e342e7255adb
+bfd5fd73a7e408f827542a8f5087e342e7255adb
5c86bbcb577f340371b0ddd062bf02b8e35d73c6
5c86bbcb577f340371b0ddd062bf02b8e35d73c6
acorn_6.2.1+ds+~0.4.0+~4.0.0+really4.0.0+~1.0.0+~5.0.1+ds+~1.7.0+ds+~0.1.1+~0.3.1+~0.2.0+~0.1.0+~0.3.0+~0.3.0.orig.tar.xz
diff --git a/debian/changelog b/debian/changelog
index 45fd13f..e892c1e 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,11 @@
+acorn (6.2.1+ds+~0.4.0+~4.0.0+really4.0.0+~1.0.0+~5.0.1+ds+~1.7.0+ds+~0.1.1+~0.3.1+~0.2.0+~0.1.0+~0.3.0+~0.3.0-3) experimental; urgency=medium
+
+ * Bug fix: "build depends on older node-unicode-*", thanks to
+ daniel.baumann@progress-linux.org</a>; (Closes: #934079). Depends
+ on newly introduced node-unicode-lastest
+
+ -- Bastien Roucari├Ęs <rouca@debian.org> Fri, 06 Sep 2019 12:37:01 +0200
+
acorn (6.2.1+ds+~0.4.0+~4.0.0+really4.0.0+~1.0.0+~5.0.1+ds+~1.7.0+ds+~0.1.1+~0.3.1+~0.2.0+~0.1.0+~0.3.0+~0.3.0-2~progress5+u1) engywuck-backports; urgency=medium
* Uploading to engywuck-backports, remaining changes:
diff --git a/debian/control b/debian/control
index b0260a2..bd72a8a 100644
--- a/debian/control
+++ b/debian/control
@@ -14,7 +14,7 @@ Build-Depends: debhelper-compat (= 12),
nodejs (>= 6),
rollup,
node-rollup-plugin-babel,
- node-unicode-12.0.0,
+ node-unicode-lastest,
node-babel-preset-latest,
node-babel-preset-airbnb,
node-babel-cli,
diff --git a/debian/patches/0004-Depends-on-lastest-unicode.patch b/debian/patches/0004-Depends-on-lastest-unicode.patch
new file mode 100644
index 0000000..ea53d27
--- /dev/null
+++ b/debian/patches/0004-Depends-on-lastest-unicode.patch
@@ -0,0 +1,35 @@
+From bfd5fd73a7e408f827542a8f5087e342e7255adb Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Bastien=20Roucari=C3=A8s?= <rouca@debian.org>
+Date: Fri, 6 Sep 2019 12:34:24 +0200
+Subject: Depends on lastest unicode
+
+Depends on newly virtual package node-unicode-lastest
+
+bug-debian; https://bugs.debian.org/934079
+Forwarded: not-needed
+---
+ bin/generate-identifier-regex.js | 6 ++++--
+ 1 file changed, 4 insertions(+), 2 deletions(-)
+
+diff --git a/bin/generate-identifier-regex.js b/bin/generate-identifier-regex.js
+index d661d72..eea22f3 100644
+--- a/bin/generate-identifier-regex.js
++++ b/bin/generate-identifier-regex.js
+@@ -1,13 +1,15 @@
+ 'use strict';
+
+ // Which Unicode version should be used?
++/*
+ let pkg = require('../package.json')
+ let dependencies = Object.keys(pkg.devDependencies)
+ let unicodeVersion = dependencies.find((name) => /^unicode-\d/.test(name))
++*/
+
+-let start = require(unicodeVersion + '/Binary_Property/ID_Start/code-points.js').filter(ch => ch > 0x7f)
++let start = require('unicode-lastest' + '/Binary_Property/ID_Start/code-points.js').filter(ch => ch > 0x7f)
+ let last = -1
+-let cont = [0x200c, 0x200d].concat(require(unicodeVersion + '/Binary_Property/ID_Continue/code-points.js')
++let cont = [0x200c, 0x200d].concat(require('unicode-lastest' + '/Binary_Property/ID_Continue/code-points.js')
+ .filter(ch => ch > 0x7f && search(start, ch, last + 1) === -1))
+
+ function search(arr, ch, starting) {
diff --git a/debian/patches/series b/debian/patches/series
index ec1bcae..62cd031 100644
--- a/debian/patches/series
+++ b/debian/patches/series
@@ -1,3 +1,4 @@
0001-Use-babel-if-needed.patch
0002-Transpile-for-node-v8.patch
0003-Do-not-transcode-lib-for-node-acorn-node.patch
+0004-Depends-on-lastest-unicode.patch