summaryrefslogtreecommitdiffstats
path: root/REQUIREMENTS.html
blob: 70fcb6a003f115b9ddb26f823d22d0013c25323d (plain)
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
96
97
98
99
100
101
102
103
104
105
106
107
108
109
110
111
112
113
114
115
116
117
118
119
120
121
122
123
124
125
126
127
128
129
130
131
132
133
134
135
136
137
138
139
140
141
142
143
144
145
146
147
148
149
150
151
152
153
154
155
156
157
158
159
160
161
162
163
164
165
166
167
168
169
170
171
172
173
174
175
176
177
178
179
180
181
182
183
184
185
186
187
188
189
190
191
192
193
194
195
196
197
198
199
200
201
202
203
204
205
206
207
208
209
210
211
212
213
214
215
216
217
218
219
220
221
222
223
224
225
226
<!doctype html public "-//w3c//dtd html 4.0 transitional//en">
<html>
<head>
 <meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1">
 <title>REQUIREMENTS to compile GRASS GIS 7</title>
 <link rel="stylesheet" href="grassdocs.css" type="text/css">
</head>
<body bgcolor="#FFFFFF">

<h2>REQUIREMENTS to compile GRASS GIS 7</h2>

A workstation running some flavor of UNIX including GNU/Linux, Solaris, IRIX, BSD,
Mac OSX, Cygwin or MinGW (on Win32/Win64). Ideally, you should have at least 800 MB of
free disk space. The source code package needs disk space of around 26 MB compressed
and 440MB uncompressed. The resulting binaries may need between 20 MB and 180 MB
depending on your platform and compiler flags. During a full compilation you may need
temporarily up to 550MB including the source code.
<p>
To enable and disable features please read the <a href="INSTALL">INSTALL</a> file.

<h3>General requirements:</h3>

(most tools are standard tools on GNU/Linux, for other platforms you may have
to install some of them.)

<ul>
<li><b>C-compiler</b> (cc, gcc, egcs, ...)
<br>gcc: <a href="http://www.gnu.org/software/gcc/gcc.html">http://www.gnu.org/software/gcc/gcc.html</a>
</li>

<li><b>GNU make</b> is recommended (at least version 3.81)
<br><a href="http://www.gnu.org/software/make/make.html">http://www.gnu.org/software/make/make.html</a>
</li>

<li><b>zlib</b> compression library (already installed on most modern systems)
<br>It is used to internally compress GRASS raster maps.
<br>libz: <a href="http://www.zlib.net">http://www.zlib.net</a>
</li>

<li><b>flex</b> lexical analyzer generator (flex)
<br>Note: lex is no longer supported, please use flex instead.
<br>flex: <a href="http://www.gnu.org/software/flex/flex.html">http://www.gnu.org/software/flex/flex.html</a>
</li>

<li><b>parser generator</b> (yacc, bison)
<br>bison: <a href="http://www.gnu.org/software/bison/bison.html">http://www.gnu.org/software/bison/bison.html</a>
</li>

<li><b>PROJ4</b> - Cartographic Projection Library<br>
<a href="http://trac.osgeo.org/proj">http://trac.osgeo.org/proj</a>
</li>

<li><b>GDAL/OGR</b> for import and export of most external raster and vector
map formats<br>
<a href="http://gdal.org">http://gdal.org</a>
</li>

<li><b>Python &gt;= 2.7</b> (for temporal framework, scripts, wxGUI, and ctypes interface)<br>
<i>Note:</i> Python 3 support is in development and will be completed for the GRASS GIS 7.8.0 release<br>
<a href="http://www.python.org">http://www.python.org</a>
</li>

</ul>

<h3>Optional requirements:</h3>

Note: also the respective development packages (commonly named xxx-dev or xxx-devel) need
to be installed.

<ul>

<li><b>C++ Compiler</b> (required for the various C++ GRASS module)<br>
gcc: <a href="http://www.gnu.org/software/gcc/gcc.html">http://www.gnu.org/software/gcc/gcc.html</a>
</li>

<li><b>FFTW 2.x or 3.x</b> (library for computing the Discrete Fourier Transform), required
for i.fft and i.ifft and other modules<br>
<a href="http://www.fftw.org">http://www.fftw.org</a>
</li>

<li><b>GEOS</b> (Geometry Engine library), needed for v.buffer and adds extended options
to the v.select module<br>
<a href="http://trac.osgeo.org/geos">http://trac.osgeo.org/geos</a>
</li>

<li><b>LAPACK / BLAS</b> (libraries for numerical computing) for GMATH library (GRASS Numerical Library)<br>
<a href="http://www.netlib.org/lapack">http://www.netlib.org/lapack</a> (usually available on Linux distros)
<br>
<i>Note:</i> LAPACK/BLAS support is at time only needed for selected Addons

<li><b>NetCDF</b> (for 3D raster netcdf export)<br>
<a href="http://www.unidata.ucar.edu/software/netcdf/">http://www.unidata.ucar.edu/software/netcdf/</a>
</li>

<li>If hardware openGL support is missing in the X Server, <b>Mesa-3.x</b> (openGL clone)
may be required for wxNVIZ<br>
<a href="http://mesa3d.sourceforge.net">http://mesa3d.sourceforge.net</a>
</li>

<li><b>libpng</b> (for r.out.png and the PNG driver), usually already installed.<br>
<a href="http://www.libpng.org/pub/png/libpng.html">http://www.libpng.org/pub/png/libpng.html</a>
</li>

<li><b>libtiff</b> (for r.out.tiff), usually already installed.<br>
<a href="http://www.remotesensing.org/libtiff">http://www.remotesensing.org/libtiff</a>
</li>

<li><b>readline</b> for extra command prompt functionality
<br><a href="http://tiswww.case.edu/~chet/readline/rltop.html">http://tiswww.case.edu/~chet/readline/rltop.html</a>
<br><a href="ftp://ftp.gnu.org/gnu/readline">ftp://ftp.gnu.org/gnu/readline</a>
</li>

<li><b>PostgreSQL libraries</b> (for the PostgreSQL database interface and PostGIS support)<br>
<a href="http://www.postgresql.org">http://www.postgresql.org</a>
</li>

<li><b>MySQL libraries</b> (for the MySQL database interface)<br>
<a href="http://www.mysql.org">http://www.mysql.org</a>
</li>

<li><b>SQLite libraries</b> (for the SQLite database interface)<br>
<a href="http://www.sqlite.org">http://www.sqlite.org</a>
</li>

<li><b>unixODBC</b> (for the ODBC database interface)<br>
<a href="http://www.unixodbc.org">http://www.unixodbc.org</a>
</li>

<li><b>R Statistics</b> (for the R statistical language interface)<br>
<a href="http://cran.r-project.org">http://cran.r-project.org</a>
</li>

<li><b>FreeType2</b> (for TrueType font support and d.text.freetype)<br>
  <a href="http://freetype.sourceforge.net">http://freetype.sourceforge.net</a>
</li>

<li><b>Ctypes</b> (for ctypes interface)<br>
Ctypes can be added as a third-party module in Python 2.3 and 2.4
- <a href="http://pypi.python.org/pypi/ctypes/1.0.2">http://pypi.python.org/pypi/ctypes/1.0.2</a><br>
<a href="http://docs.python.org/library/ctypes.html">http://docs.python.org/library/ctypes.html</a>
</li>

<li><b>wxPython &gt;= 2.8.10.1</b> (for wxGUI)<br>
<a href="http://www.wxpython.org">http://www.wxpython.org</a>
</li>

<li><b>NumPy &gt;= 1.0.4</b> (for various wxGUI components and pyGRASS)<br>
<a href="http://numpy.org">http://numpy.org</a>
</li>

<li><b>Python dateutil Library</b> ("python-dateutil", needed for the tgrass modules t.*)<br>
<a href="http://labix.org/python-dateutil">http://labix.org/python-dateutil</a>
</li>

<li><b>Python PLY Library (Python Lex-Yacc)</b> ("python-ply", needed for the temporal algebra in tgis)<br>
<a href="http://www.dabeaz.com/ply">http://www.dabeaz.com/ply</a>
</li>

<li><b>Python Imaging Library or PILLOW</b> (highly recommended for wxGUI and necessary for wxGUI Cartographic Composer)<br>
<a href="http://www.pythonware.com/products/pil">http://www.pythonware.com/products/pil</a>,
newer versions are named "python-pillow"
</li>

<li><b>Python matplotlib &gt; 1.2</b> ("python-matplotlib", needed for the several wxGUI tools)<br>
<a href="http://matplotlib.org/">http://matplotlib.org/</a>
</li>

<li><b>Python wxPython backend for python-matplotlib</b> ("python-matplotlib-wx", needed for e.g. g.gui.timeline)<br>
<a href="http://matplotlib.org/">http://matplotlib.org/</a>
</li>

<li><b>python-termcolor</b> (recommended for g.search.modules)<br>
<a href="https://pypi.python.org/pypi/termcolor">https://pypi.python.org/pypi/termcolor</a>
</li>

<li><b>FFMPEG or alternative</b> (for wxGUI Animation tool - g.gui.module),
    specifically ffmpeg tool<br>
<a href="http://ffmpeg.org">http://ffmpeg.org</a>
</li>

<li><b>mpeg_encode or ppmtompeg tool</b> (for r.out.mpeg module)<br>
<a href="http://ffmpeg.org">http://ffmpeg.org</a>
</li>

<li><b>Cairo &gt;= 1.5.8</b> (for Cairo driver)<br>
<a href="http://cairographics.org">http://cairographics.org</a>
</li>

<!-- really needed? -->
<li><b>AVCE00 and E00Compr Libraries</b> (avcimport)<br>
<a href="http://avce00.maptools.org">http://avce00.maptools.org</a>
</li>

<li><b>Subversion</b> (svn for g.extension)<br>
<a href="https://subversion.apache.org/">https://subversion.apache.org/</a><br>
</li>

</ul>


<h3>Note:</h3>

<!-- since 2014 no longer supported: -->
SUN Solaris users may go here to download precompiled libraries etc.:
<br><a href="http://www.sunfreeware.com">http://www.sunfreeware.com</a>

<p>
<!-- no longer supported: -->
SGI IRIX users may go here to download precompiled libraries etc.:
<br><a href="http://freeware.sgi.com">http://freeware.sgi.com</a>

<p>
MacOSX users may go here to download precompiled libraries etc.:
<br><a href="http://fink.sourceforge.net">http://fink.sourceforge.net</a>

<p>

<hr width="100%">
<i>&copy; GRASS Development Team 1997-2019</i>
<p>Please report bugs here:
<br><a href="https://grass.osgeo.org/development/bug-tracking/">https://grass.osgeo.org/development/bug-tracking/</a>

<p>
<i>Last changed: $Date: 2019-03-07 00:21:50 +0100 (Thu, 07 Mar 2019) $</i>
</body>
</html>