summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2019-08-20 16:28:29 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2019-08-20 16:28:29 +0000
commit2864709ec7757e2ba6df030fc5918fc3dc1b7da4 (patch)
treea9708b624dc04115e06e845cc2533c594a8b3b85
parentAdding upstream version 1.2. (diff)
downloadlibvdpau-2864709ec7757e2ba6df030fc5918fc3dc1b7da4.tar.xz
libvdpau-2864709ec7757e2ba6df030fc5918fc3dc1b7da4.zip
Adding debian version 1.2-1.debian/1.2-1
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
-rw-r--r--debian/README.source25
-rw-r--r--debian/bug-script28
-rw-r--r--debian/changelog412
-rw-r--r--debian/clean1
-rw-r--r--debian/control99
-rw-r--r--debian/copyright65
-rw-r--r--debian/gbp.conf11
-rw-r--r--debian/libvdpau-dev.README.Debian9
-rw-r--r--debian/libvdpau-dev.install3
-rw-r--r--debian/libvdpau-doc.doc-base9
-rw-r--r--debian/libvdpau-doc.docs1
-rw-r--r--debian/libvdpau1.install3
-rw-r--r--debian/libvdpau1.symbols3
-rw-r--r--debian/patches/doxygen-no-timestamps.patch14
-rw-r--r--debian/patches/link-with-libx11.patch28
-rw-r--r--debian/patches/series4
-rw-r--r--debian/patches/simplify-dlopen-path-length-error-handling.patch47
-rw-r--r--debian/patches/vdpau-module-searchpath.patch43
-rwxr-xr-xdebian/rules50
-rw-r--r--debian/source/format1
-rw-r--r--debian/upstream/metadata3
-rw-r--r--debian/upstream/signing-key.asc16
-rw-r--r--debian/watch4
23 files changed, 879 insertions, 0 deletions
diff --git a/debian/README.source b/debian/README.source
new file mode 100644
index 0000000..4887ace
--- /dev/null
+++ b/debian/README.source
@@ -0,0 +1,25 @@
+The upstream repository:
+
+ git remote add libvdpau git://people.freedesktop.org/~aplattner/libvdpau
+ git fetch --all --prune
+
+Importing a new upstream tarball:
+
+The tarball contains all the autotools generated files that we don't need
+in the master branch thanks to dh_autoreconf.
+
+ VER=0.7
+ git-import-orig --upstream-vcs-tag libvdpau-$VER libvdpau-$VER.tar.bz2
+
+Merge the new upstream release:
+
+ git checkout upstream
+ git merge --ff-only libvdpau-$VER^{commit}
+ git tag -m "Upstream version $VER" upstream/$VER libvdpau-$VER^{commit}
+
+ git checkout master
+ git merge upstream/$VER
+
+Pushing to origin:
+
+ git push origin libvdpau-$VER tarball pristine-tar tarball/$VER upstream upstream/$VER master
diff --git a/debian/bug-script b/debian/bug-script
new file mode 100644
index 0000000..b002ffc
--- /dev/null
+++ b/debian/bug-script
@@ -0,0 +1,28 @@
+#!/bin/sh
+
+exec >&3
+
+if [ -z "$VDPAU_DRIVER" ]; then
+ echo "VDPAU_DRIVER is not set"
+else
+ echo "VDPAU_DRIVER is set to '$VDPAU_DRIVER'"
+fi
+if [ -z "$VDPAU_DRIVER_PATH" ]; then
+ echo "VDPAU_DRIVER_PATH is not set"
+else
+ echo "VDPAU_DRIVER_PATH is set to '$VDPAU_DRIVER_PATH'"
+fi
+echo
+
+if [ -x /usr/bin/vdpauinfo ]; then
+ echo "vdpauinfo:"
+ /usr/bin/vdpauinfo 2>&1
+else
+ echo "vdpauinfo is not installed"
+fi
+echo
+
+echo "available drivers:"
+ls -la /usr/lib*/vdpau/libvdpau_* /usr/lib/*/vdpau/libvdpau_* "$VDPAU_DRIVER_PATH"/libvdpau_* 2>/dev/null
+
+exit 0
diff --git a/debian/changelog b/debian/changelog
new file mode 100644
index 0000000..6601f30
--- /dev/null
+++ b/debian/changelog
@@ -0,0 +1,412 @@
+libvdpau (1.2-1) unstable; urgency=medium
+
+ [ Luca Boccassi ]
+ * gbp.conf: switch upstream tag to upstream's format.
+ * Merge tag 'libvdpau-1.2'.
+ * Drop missing-configh-include.patch, merged upstream.
+ * Update upstream metadata, repository is now on gitlab.
+
+ [ Andreas Beckmann ]
+ * Drop versioned constraints that are satisfied in wheezy.
+ * Bump Standards-Version to 4.4.0. No changes needed.
+
+ -- Andreas Beckmann <anbe@debian.org> Tue, 09 Jul 2019 18:43:58 +0200
+
+libvdpau (1.1.1-10) unstable; urgency=medium
+
+ * Switch to debhelper-compat (= 12).
+ * Bump Standards-Version to 4.3.0. No changes needed.
+
+ -- Andreas Beckmann <anbe@debian.org> Sun, 20 Jan 2019 20:19:20 +0100
+
+libvdpau (1.1.1-9) unstable; urgency=medium
+
+ * Switch to debhelper-compat (= 11).
+ * Set Rules-Requires-Root: no.
+ * Switch Vcs-* URLs to salsa.debian.org.
+ * Bump Standards-Version to 4.2.1. No changes needed.
+ * Add debian/upstream/metadata.
+ * Mark libvdpau-doc as Multi-Arch: foreign.
+ * libvdpau1.symbols: add Build-Depends-Package field.
+
+ -- Andreas Beckmann <anbe@debian.org> Wed, 12 Dec 2018 01:40:52 +0100
+
+libvdpau (1.1.1-8) unstable; urgency=medium
+
+ * Re-enable check for docs dependencies presence at build time,
+ as they are build-depends-indep and are not installed on
+ buildds when not building arch: all packages. Fixes FTBFS.
+
+ -- Luca Boccassi <bluca@debian.org> Sun, 03 Sep 2017 19:20:02 +0100
+
+libvdpau (1.1.1-7) unstable; urgency=medium
+
+ [ Luca Boccassi ]
+ * Use HTTPS for upstream URLs in d/copyright, d/watch and d/control.
+ * Add support for "nodoc" build profile and DEB_BUILD_OPTIONS.
+ * Bump Standards-Version to 4.1.0.
+
+ [ Russ Allbery ]
+ * Remove myself from Uploaders.
+
+ [ Luca Boccassi ]
+ * Switch to my Debian email address.
+
+ -- Luca Boccassi <bluca@debian.org> Sun, 03 Sep 2017 18:11:59 +0100
+
+libvdpau (1.1.1-6) unstable; urgency=medium
+
+ * Switch to debhelper compat level 10.
+
+ -- Andreas Beckmann <anbe@debian.org> Fri, 13 Jan 2017 01:51:57 +0100
+
+libvdpau (1.1.1-5) unstable; urgency=medium
+
+ * Enable more hardening.
+
+ -- Andreas Beckmann <anbe@debian.org> Sun, 09 Oct 2016 19:22:54 +0200
+
+libvdpau (1.1.1-4) unstable; urgency=medium
+
+ [ Helmut Grohne ]
+ * Fix FTCBFS: Let dh_auto_configure pass --host. (Closes: #838395)
+
+ [ Andreas Beckmann ]
+ * Drop -dbg package in favor of autogenerated -dbgsym package.
+ * Bump Standards-Version to 3.9.8. No changes needed.
+ * Update Vcs-Git URL.
+ * Suggest more non-free driver packages.
+
+ -- Andreas Beckmann <anbe@debian.org> Fri, 23 Sep 2016 09:05:28 +0200
+
+libvdpau (1.1.1-3) unstable; urgency=medium
+
+ [ Luca Boccassi ]
+ * Cherry-pick patch for DRI_PRIME crash. (Closes: #802625)
+ * Upload to unstable.
+
+ -- Andreas Beckmann <anbe@debian.org> Thu, 29 Oct 2015 00:47:28 +0100
+
+libvdpau (1.1.1-2) experimental; urgency=medium
+
+ * Add vdpau-driver-all driver metapackage. (Closes: #800657)
+ * libvdpau1: Recommends: vdpau-driver-all | vdpau-driver.
+ * Upload to experimental.
+
+ -- Andreas Beckmann <anbe@debian.org> Thu, 08 Oct 2015 10:15:00 +0200
+
+libvdpau (1.1.1-1) unstable; urgency=medium
+
+ [ Andreas Beckmann ]
+ * simplify d/rules
+
+ [ Luca Boccassi ]
+ * New upstream release.
+ - Use secure_getenv(3) to improve security
+ (CVE-2015-5198, CVE-2015-5199, CVE-2015-5200). Closes: #797895.
+ * Do not check for pdftex, removed upstream
+ * Add myself to Uploaders
+ * Refresh dlopen-path patch, upstream changes
+ * Refresh patch module-searchpath, upstream changes
+
+ -- Luca Boccassi <luca.boccassi@gmail.com> Thu, 03 Sep 2015 23:31:59 +0100
+
+libvdpau (1.1-1) unstable; urgency=medium
+
+ * New upstream release.
+ * Remove Jean-Yves Avenard from Uploaders. Inactive.
+ * Update Vcs-Browser URL.
+ * Import upstream signing key
+ pub 1024D/09BA9635 2005-09-28 Aaron Plattner <aplattner@nvidia.com>
+ sub 2048R/8B1DA2D0 2007-08-23 [expires: 2011-08-22]
+ sub 2048R/ED9D97C2 2007-08-23 [expires: 2011-08-22]
+ sub 2048R/DDF35B94 2011-08-16 [expires: 2015-08-15]
+ sub 2048R/7FE346B2 2011-08-16 [expires: 2015-08-15]
+ sub 2048g/76DE8572 2005-09-28 [expires: 2006-09-28]
+ sub 4096R/01A68861 2012-08-24 [expires: 2016-08-23]
+ sub 4096R/E5083582 2012-08-24 [expires: 2016-08-23]
+ * Update watch file, verify signature.
+ * Cleanup doc/doxygen_sqlite3.db to build twice in a row.
+ * doxygen-no-timestamps.patch: New, disable doxygen timestamping for
+ reproducible builds.
+ * Upload to unstable.
+
+ -- Andreas Beckmann <anbe@debian.org> Mon, 27 Apr 2015 16:52:14 +0200
+
+libvdpau (0.9-1) experimental; urgency=medium
+
+ * New upstream release.
+ * Drop patches cherry-picked from upstream git.
+ * hardening.patch: Remove, fixed upstream.
+ * link-with-libx11.patch: Refresh.
+ * Upload to experimental.
+
+ -- Andreas Beckmann <anbe@debian.org> Sat, 24 Jan 2015 18:07:15 +0100
+
+libvdpau (0.8-3) unstable; urgency=medium
+
+ * Add a bug-script to collect some driver information.
+ * libvdpau-dev.README.Debian: Document required Depends/Enhances/Provides
+ for packages containing VDPAU drivers.
+
+ -- Andreas Beckmann <anbe@debian.org> Sun, 19 Oct 2014 22:15:30 +0200
+
+libvdpau (0.8-2) unstable; urgency=medium
+
+ * Bump Standards-Version to 3.9.6. No changes needed.
+ * hardening.patch: Build the tests with hardening enabled, too.
+
+ -- Andreas Beckmann <anbe@debian.org> Fri, 17 Oct 2014 22:13:27 +0200
+
+libvdpau (0.8-1) unstable; urgency=medium
+
+ [ Vincent Cheng ]
+ * New upstream release.
+ - Remove 0001-Fix-incorrect-VdpPictureInfo-typedef.patch, applied upstream.
+ * Add myself to Uploaders.
+
+ [ Andreas Beckmann ]
+ * Refresh vdpau driver searchpath patches.
+ * Cherry-pick upstream commits:
+ - [9d27eb0] 0001-trace-properly-annotate-private-functions-as-static.patch
+ - [6cb973e] 0002-vdpau-do-not-export-_vdp_DRI2-functions.patch
+ * libvdpau1.symbols: Remove private symbols.
+ * libvdpau-doc: Do not ship useless autogenerated doxygen files: *.map.
+ * libvdpau1-dbg: New package for debug symbols. (Closes: #763142)
+
+ -- Andreas Beckmann <anbe@debian.org> Mon, 29 Sep 2014 13:41:39 +0200
+
+libvdpau (0.7-2) unstable; urgency=medium
+
+ * Remove Andres Mejia from Uploaders. Thanks for your work on libvdpau!
+ (Closes: #743563)
+ * Bump Standards-Version to 3.9.5. No changes needed.
+ * Cherry-pick upstream commit:
+ - [186195b] 0001-Fix-incorrect-VdpPictureInfo-typedef.patch
+
+ -- Andreas Beckmann <anbe@debian.org> Mon, 21 Apr 2014 23:08:42 +0200
+
+libvdpau (0.7-1) unstable; urgency=low
+
+ * New upstream release. (LP: #1313614)
+ * Add README.source describing the import of a new upstream release.
+
+ -- Andreas Beckmann <anbe@debian.org> Thu, 15 Aug 2013 00:59:45 +0200
+
+libvdpau (0.6-2) unstable; urgency=low
+
+ * Drop Conflicts/Replaces against obsolete squeeze packages.
+ * libvdpau1: Drop postinst, ancient cleanup code already in squeeze.
+ * Bump Standards-Version to 3.9.4. No changes needed.
+ * Use canonical Vcs-* URLs.
+ * Upload to unstable.
+
+ -- Andreas Beckmann <anbe@debian.org> Mon, 06 May 2013 00:42:22 +0200
+
+libvdpau (0.6-1) experimental; urgency=low
+
+ * New upstream release.
+ * Drop patches cherry-picked from upstream git: 0001, 0002, 0003.
+
+ -- Andreas Beckmann <anbe@debian.org> Tue, 12 Feb 2013 20:27:10 +0100
+
+libvdpau (0.5-1) experimental; urgency=low
+
+ * New upstream release. (Closes: #689586)
+ * Drop patches that are now applied upstream: libvdpau_flashplayer.patch,
+ track_dynamic_library_handles_and_free_them_on_exit.patch.
+ * Update my email address and remove DMUA.
+ * Cherry-pick upstream commits:
+ - 0001-Make-use-of-dri2proto_CFLAGS-when-building.patch
+ - 0002-Change-mailing-list-to-vdpau-lists.freedesktop.org.patch
+ - 0003-Fix-leaked-extension-info-on-library-unload.patch (Closes: #592204)
+ * libvdpau1.symbols: Add _vdp_DRI2RemoveExtension, added in above patches.
+ * Change Upstream-Contact to vdpau@lists.freedesktop.org.
+ * Upload to experimental.
+
+ -- Andreas Beckmann <anbe@debian.org> Fri, 25 Jan 2013 21:59:57 +0100
+
+libvdpau (0.4.1-8) unstable; urgency=low
+
+ * Update my email address and remove DMUA.
+ * Cherry-pick upstream commit 3b43955 from 0.5+git:
+ 0003-Fix-leaked-extension-info-on-library-unload.patch (Closes: #592204)
+ * libvdpau1.symbols: Add _vdp_DRI2RemoveExtension, added in above patch.
+ * Change Upstream-Contact to vdpau@lists.freedesktop.org.
+
+ -- Andreas Beckmann <anbe@debian.org> Sun, 27 Jan 2013 01:49:23 +0100
+
+libvdpau (0.4.1-7) unstable; urgency=low
+
+ * The last (and only) reverse dependency of lib32vdpau1 was the non-free
+ nvidia-vdpau-driver-ia32 which is now an empty transitional package.
+ * d/{control,lib32vdpau1.*}: Drop lib32vdpau1 package. (Closes: #679524)
+ * d/{control,rules}: Remove support for building the extra 32-bit biarch
+ library on amd64.
+ * libvdpau1: Add Replaces/Conflicts: lib32vdpau1 to ensure the old biarch
+ package gets removed properly.
+ * Update lintian overrides for duplicate files generated by doxygen.
+
+ -- Andreas Beckmann <debian@abeckmann.de> Thu, 16 Aug 2012 02:05:59 +0200
+
+libvdpau (0.4.1-6) unstable; urgency=low
+
+ [ Maurizio Avogadro ]
+ * Apply the wise patch supplied by Stephen Warren to fix Adobe Flash
+ insanities. (Closes: #668512)
+
+ [ Andreas Beckmann ]
+ * debian/copyright: Switch to copyright-format 1.0 and update years.
+
+ -- Andreas Beckmann <debian@abeckmann.de> Tue, 22 May 2012 23:13:00 +0200
+
+libvdpau (0.4.1-5) unstable; urgency=low
+
+ * Use debhelper 9 to use hardened compiler flags.
+
+ -- Andres Mejia <amejia@debian.org> Mon, 19 Mar 2012 10:21:23 -0400
+
+libvdpau (0.4.1-4) unstable; urgency=low
+
+ * Allow dev package to be multiarch installable.
+ * Bump to Standards-Version 3.9.3.
+
+ -- Andres Mejia <amejia@debian.org> Fri, 16 Mar 2012 19:01:46 -0400
+
+libvdpau (0.4.1-3) unstable; urgency=low
+
+ [ Andres Mejia ]
+ * Update to my @debian.org email.
+
+ [ Andreas Beckmann ]
+ * Build for multiarch. Patch from Daniel Schaal. (Closes: #631174)
+ * Search the vdpau module in multiple directories, starting with
+ ${ORIGIN}/vdpau and fall back to /usr/lib/vdpau in the end.
+ * Add Conflicts to prevent mixing biarch and multiarch packages (i.e.
+ lib32vdpau1:amd64 and libvdpau1:i386).
+ * Use unversioned Conflicts/Replaces on nvidia-libvdpau* to remove the old
+ transitional packages.
+ * Use binary:Version for relationship between libvdpau1 and libvdpau-dev.
+ * Switch Build-Depends-Indep to doxygen-latex, graphviz, ghostscript.
+ (Closes: #616264)
+ * track_dynamic_library_handles_and_free_them_on_exit.patch: Pick upstream
+ commit 4262513e: "vdpau_wrapper.c: Track dynamic library handles and free
+ them on exit using __attribute__((destructor))".
+ * Switch to debhelper 8.
+ * Switch to dh-autoreconf: add to B-D, use dh --with autoreconf and drop
+ autoreconf_-fi.patch.
+ * Remove debian/libvdpau-get-orig-source, repackaging is no longer necessary
+ with dh-autoreconf.
+ * Build with LDFLAGS="-Wl,--as-needed".
+ * Add myself to Uploaders.
+
+ -- Andreas Beckmann <debian@abeckmann.de> Thu, 08 Sep 2011 10:32:24 +0200
+
+libvdpau (0.4.1-2) unstable; urgency=high
+
+ * Provide an upload to unstable to fix build failure. (Closes: #603220)
+ * Set urgency to high so it enters testing ASAP.
+
+ -- Andres Mejia <mcitadel@gmail.com> Fri, 12 Nov 2010 17:14:33 -0500
+
+libvdpau (0.4.1-1) experimental; urgency=low
+
+ * New upstream release.
+ * Use script to generate latest source.
+ * Add get-orig-source rule that runs libvdpau-get-orig-source script.
+ * Update Vcs-* entries for new location for packaging.
+ * Refresh patches.
+ * Change Build-Depends of ia32-libs to ia32-libs-dev.
+ * Bump Standards-Version to 3.9.1. No other changes needed.
+ * Use proper Depends versioning for a binary-all package depending on
+ a binary-any package.
+
+ -- Andres Mejia <mcitadel@gmail.com> Mon, 20 Sep 2010 13:52:11 -0400
+
+libvdpau (0.4-5) unstable; urgency=low
+
+ [ Russ Allbery ]
+ * Also version the Conflicts and Replaces for libvdpau-dev so that the
+ nvidia-libvdpau-dev transitional package will work properly.
+ * Add an explicit license for the Debian packaging files.
+
+ [ Andreas Beckmann ]
+ * Add Depends: libx11-dev to libvdpau-dev because vdpau_x11.h includes
+ X11/Xlib.h.
+ * Tighten the dependency of libvdpau-dev on libvdpau1 to only allow the
+ matching binary:Version or binary NMUs thereof.
+ * Remove dh_make boilerplate code and comments from maintainer scripts.
+ * Unify symbols control files.
+
+ -- Russ Allbery <rra@debian.org> Sat, 12 Jun 2010 18:33:51 -0700
+
+libvdpau (0.4-4) unstable; urgency=low
+
+ [ Andreas Beckmann ]
+ * Build lib32vdpau1 [amd64], so we can replace nvidia-libvdpau-ia32.
+ Build rules inspired by lib32z1. (Closes: #572206)
+ * lib32vdpau1: take over postinst script from nvidia-libvdpau-ia32.
+ * Add lib{,32}vdpau1.symbols.
+ * libvdpau-dev: do not ship /usr/lib/vdpau/libvdpau_trace.so, won't be used.
+ * libvdpau1: cleanup /usr/lib/libvdpau_trace.so left over by some old
+ versions of the nvidia-libvdpau* packages.
+
+ [ Russ Allbery ]
+ * Link libvdpau with libX11 since it uses symbols from that library.
+ * Add myself to Uploaders.
+ * Convert debian/copyright to the DEP-5 format and add the slightly
+ different license used for two of the source files.
+ * Version the Conflicts and Replaces against nvidia-libvdpau1*.
+ * Also remove /usr/lib/libvdpau_nvidia.so, left by some old versions of
+ the nvidia-libvdpau* packages.
+
+ -- Russ Allbery <rra@debian.org> Sat, 22 May 2010 19:11:37 -0700
+
+libvdpau (0.4-3) unstable; urgency=low
+
+ * Enable dri2 feature. Requires x11proto-dri2-dev (>= 2.2) and libxext-dev.
+
+ -- Andres Mejia <mcitadel@gmail.com> Thu, 25 Feb 2010 20:08:17 -0500
+
+libvdpau (0.4-2) unstable; urgency=low
+
+ * Add dependencies for documentation to Build-Depends-Indep.
+ * Define a function in debian/rules that can be used to enable or disable
+ building of the documentation depending on if the necessary dependencies
+ are installed.
+
+ -- Andres Mejia <mcitadel@gmail.com> Wed, 10 Feb 2010 19:53:29 -0500
+
+libvdpau (0.4-1) unstable; urgency=low
+
+ * New upstream release.
+ * Bump Standards-Version to 3.8.4.
+ * Fix libvdpau-dev dependency on libvdpau1.
+ * Perform autoreconf -fi.
+ * Explicitly enable documentation.
+ * Use texlive-binaries instead of texlive-base-bin for pdftex build
+ dependency.
+ * Fix build error install texlive-binaries, which depends on tex-common. Just
+ Build-Depend on texlive-base for now, until bug #567714 is resolved.
+
+ -- Andres Mejia <mcitadel@gmail.com> Wed, 10 Feb 2010 19:20:49 -0500
+
+libvdpau (0.3-2) unstable; urgency=low
+
+ [ Andres Mejia ]
+ * Have libvdpau1 suggest a vdpau driver package to install, rather than
+ depend on one.
+ (Closes: #558434)
+ (Closes: #558464)
+ * Remove libvdpau-driver package.
+ * Move libvdpau to main.
+
+ -- Randall Donald <rdonald@debian.org> Wed, 02 Dec 2009 14:22:14 -0800
+
+libvdpau (0.3-1) unstable; urgency=low
+
+ [ Andres Mejia ]
+ * Initial release.
+ (Closes: #549626)
+
+ -- Randall Donald <rdonald@debian.org> Wed, 25 Nov 2009 10:30:10 -0800
diff --git a/debian/clean b/debian/clean
new file mode 100644
index 0000000..683c12f
--- /dev/null
+++ b/debian/clean
@@ -0,0 +1 @@
+doc/doxygen_sqlite3.db
diff --git a/debian/control b/debian/control
new file mode 100644
index 0000000..e61eb1e
--- /dev/null
+++ b/debian/control
@@ -0,0 +1,99 @@
+Source: libvdpau
+Section: libs
+Priority: optional
+Maintainer: Debian NVIDIA Maintainers <pkg-nvidia-devel@lists.alioth.debian.org>
+Uploaders:
+ Andreas Beckmann <anbe@debian.org>,
+ Vincent Cheng <vcheng@debian.org>,
+ Luca Boccassi <bluca@debian.org>
+Build-Depends:
+ debhelper-compat (= 12),
+ pkg-config,
+ libx11-dev,
+ x11proto-dri2-dev,
+ libxext-dev,
+Build-Depends-Indep:
+ doxygen-latex <!nodoc>,
+ graphviz <!nodoc>,
+ ghostscript <!nodoc>,
+Rules-Requires-Root: no
+Standards-Version: 4.4.0
+Homepage: https://cgit.freedesktop.org/~aplattner/libvdpau
+Vcs-Browser: https://salsa.debian.org/nvidia-team/libvdpau
+Vcs-Git: https://salsa.debian.org/nvidia-team/libvdpau.git
+
+Package: libvdpau-dev
+Multi-Arch: same
+Architecture: any
+Section: libdevel
+Depends:
+ libvdpau1 (= ${binary:Version}),
+ libx11-dev,
+ ${misc:Depends}
+Suggests: libvdpau-doc
+Description: Video Decode and Presentation API for Unix (development files)
+ VDPAU (Video Decode and Presentation API for Unix) is an open source
+ library (libvdpau) and API designed by NVIDIA originally for its GeForce
+ 8 series and later GPU hardware, targeted at the X Window System on Unix
+ operating-systems (including Linux, FreeBSD, and Solaris). This VDPAU API
+ allows video programs to offload portions of the video decoding process
+ and video post-processing to the GPU video-hardware.
+ .
+ This package contains the files necessary for development with VDPAU.
+
+Package: libvdpau1
+Architecture: any
+Multi-Arch: same
+Pre-Depends: ${misc:Pre-Depends}
+Depends: ${shlibs:Depends}, ${misc:Depends}
+Recommends:
+ vdpau-driver-all | vdpau-driver,
+Description: Video Decode and Presentation API for Unix (libraries)
+ VDPAU (Video Decode and Presentation API for Unix) is an open source
+ library (libvdpau) and API designed by NVIDIA originally for its GeForce
+ 8 series and later GPU hardware, targeted at the X Window System on Unix
+ operating-systems (including Linux, FreeBSD, and Solaris). This VDPAU API
+ allows video programs to offload portions of the video decoding process
+ and video post-processing to the GPU video-hardware.
+ .
+ This package contains the VDPAU wrapper and trace libraries.
+
+Package: libvdpau-doc
+Architecture: all
+Multi-Arch: foreign
+Section: doc
+Build-Profiles: <!nodoc>
+Depends: ${misc:Depends}
+Description: Video Decode and Presentation API for Unix (documentation)
+ VDPAU (Video Decode and Presentation API for Unix) is an open source
+ library (libvdpau) and API designed by NVIDIA originally for its GeForce
+ 8 series and later GPU hardware, targeted at the X Window System on Unix
+ operating-systems (including Linux, FreeBSD, and Solaris). This VDPAU API
+ allows video programs to offload portions of the video decoding process
+ and video post-processing to the GPU video-hardware.
+ .
+ This package contains the VDPAU documentation.
+
+Package: vdpau-driver-all
+Section: video
+Architecture: any
+Multi-Arch: same
+Depends:
+ libvdpau-va-gl1 [linux-any],
+ mesa-vdpau-drivers [linux-any kfreebsd-any],
+ ${misc:Depends}
+Suggests:
+ nvidia-vdpau-driver [amd64 i386],
+ nvidia-legacy-340xx-vdpau-driver [amd64 i386],
+ nvidia-legacy-304xx-vdpau-driver [amd64 i386],
+Description: Video Decode and Presentation API for Unix (driver metapackage)
+ VDPAU (Video Decode and Presentation API for Unix) is an open source
+ library (libvdpau) and API designed by NVIDIA originally for its GeForce
+ 8 series and later GPU hardware, targeted at the X Window System on Unix
+ operating-systems (including Linux, FreeBSD, and Solaris). This VDPAU API
+ allows video programs to offload portions of the video decoding process
+ and video post-processing to the GPU video-hardware.
+ .
+ This package depends on the full suite of drivers for the VDPAU API.
+ It does not provide any drivers itself, and may be removed if you wish to
+ only have certain drivers installed.
diff --git a/debian/copyright b/debian/copyright
new file mode 100644
index 0000000..e39f1f5
--- /dev/null
+++ b/debian/copyright
@@ -0,0 +1,65 @@
+Format: https://www.debian.org/doc/packaging-manuals/copyright-format/1.0/
+Upstream-Name: VDPAU wrapper and trace libraries
+Upstream-Contact: <vdpau@lists.freedesktop.org>
+Source: https://people.freedesktop.org/~aplattner/vdpau/
+
+Files: *
+Copyright: © 2008-2010 NVIDIA Corporation
+ © 2008 Red Hat, Inc.
+License: Expat
+
+Files: debian/*
+Copyright: 2009-2012 Andres Mejia <mcitadel@gmail.com>
+ © 2010-2019 Andreas Beckmann <anbe@debian.org>
+ 2010 Russ Allbery <rra@debian.org>
+License: Expat
+
+Files: src/mesa_dri2.c src/mesa_dri2.h
+Copyright: © 2007,2008 Red Hat, Inc.
+ © 2010 NVIDIA Corporation
+License: other
+ Permission is hereby granted, free of charge, to any person obtaining a
+ copy of this software and associated documentation files (the "Soft-
+ ware"), to deal in the Software without restriction, including without
+ limitation the rights to use, copy, modify, merge, publish, distribute,
+ and/or sell copies of the Software, and to permit persons to whom the
+ Software is furnished to do so, provided that the above copyright
+ notice(s) and this permission notice appear in all copies of the Soft-
+ ware and that both the above copyright notice(s) and this permission
+ notice appear in supporting documentation.
+ .
+ THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS
+ OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABIL-
+ ITY, FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT OF THIRD PARTY
+ RIGHTS. IN NO EVENT SHALL THE COPYRIGHT HOLDER OR HOLDERS INCLUDED IN
+ THIS NOTICE BE LIABLE FOR ANY CLAIM, OR ANY SPECIAL INDIRECT OR CONSE-
+ QUENTIAL DAMAGES, OR ANY DAMAGES WHATSOEVER RESULTING FROM LOSS OF USE,
+ DATA OR PROFITS, WHETHER IN AN ACTION OF CONTRACT, NEGLIGENCE OR OTHER
+ TORTIOUS ACTION, ARISING OUT OF OR IN CONNECTION WITH THE USE OR PERFOR-
+ MANCE OF THIS SOFTWARE.
+ .
+ Except as contained in this notice, the name of a copyright holder shall
+ not be used in advertising or otherwise to promote the sale, use or
+ other dealings in this Software without prior written authorization of
+ the copyright holder.
+
+License: Expat
+ Permission is hereby granted, free of charge, to any person obtaining a
+ copy of this software and associated documentation files (the
+ "Software"), to deal in the Software without restriction, including
+ without limitation the rights to use, copy, modify, merge, publish,
+ distribute, sublicense, and/or sell copies of the Software, and to permit
+ persons to whom the Software is furnished to do so, subject to the
+ following conditions:
+ .
+ The above copyright notice and this permission notice (including the next
+ paragraph) shall be included in all copies or substantial portions of the
+ Software.
+ .
+ THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS
+ OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF
+ MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT.
+ IN NO EVENT SHALL THE AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY
+ CLAIM, DAMAGES OR OTHER LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT
+ OR OTHERWISE, ARISING FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR
+ THE USE OR OTHER DEALINGS IN THE SOFTWARE.
diff --git a/debian/gbp.conf b/debian/gbp.conf
new file mode 100644
index 0000000..0508e8f
--- /dev/null
+++ b/debian/gbp.conf
@@ -0,0 +1,11 @@
+[DEFAULT]
+upstream-branch = upstream
+debian-branch = master
+upstream-tag = libvdpau-%(version)s
+debian-tag = debian/%(version)s
+pristine-tar = True
+
+[git-import-orig]
+upstream-branch = tarball
+upstream-tag = tarball/%(version)s
+merge = False
diff --git a/debian/libvdpau-dev.README.Debian b/debian/libvdpau-dev.README.Debian
new file mode 100644
index 0000000..3a04527
--- /dev/null
+++ b/debian/libvdpau-dev.README.Debian
@@ -0,0 +1,9 @@
+Packaging a VDPAU driver
+========================
+
+If you package a VDPAU driver, i.e. some library that is to be loaded by
+libvdpau.so.1, your package must include the following three relationships:
+
+ Depends: libvdpau1 (may be versioned)
+ Enhances: libvdpau1
+ Provides: vdpau-driver
diff --git a/debian/libvdpau-dev.install b/debian/libvdpau-dev.install
new file mode 100644
index 0000000..f02a5ba
--- /dev/null
+++ b/debian/libvdpau-dev.install
@@ -0,0 +1,3 @@
+usr/lib/*/libvdpau.so
+usr/lib/*/pkgconfig
+usr/include
diff --git a/debian/libvdpau-doc.doc-base b/debian/libvdpau-doc.doc-base
new file mode 100644
index 0000000..1e67199
--- /dev/null
+++ b/debian/libvdpau-doc.doc-base
@@ -0,0 +1,9 @@
+Document: libvdpau-doc
+Title: VDPAU Documentation
+Author: NVIDIA Corporation
+Abstract: Video Decode and Presentation API for Unix (VDPAU) Documentation.
+Section: Programming
+
+Format: HTML
+Index: /usr/share/doc/libvdpau-dev/html/index.html
+Files: /usr/share/doc/libvdpau-dev/html/*.html
diff --git a/debian/libvdpau-doc.docs b/debian/libvdpau-doc.docs
new file mode 100644
index 0000000..3904d8e
--- /dev/null
+++ b/debian/libvdpau-doc.docs
@@ -0,0 +1 @@
+usr/share/doc/libvdpau/html
diff --git a/debian/libvdpau1.install b/debian/libvdpau1.install
new file mode 100644
index 0000000..a9352c3
--- /dev/null
+++ b/debian/libvdpau1.install
@@ -0,0 +1,3 @@
+etc/vdpau_wrapper.cfg
+usr/lib/*/libvdpau.so.*
+usr/lib/*/vdpau/libvdpau_trace.so.*
diff --git a/debian/libvdpau1.symbols b/debian/libvdpau1.symbols
new file mode 100644
index 0000000..dbbf4a3
--- /dev/null
+++ b/debian/libvdpau1.symbols
@@ -0,0 +1,3 @@
+libvdpau.so.1 #PACKAGE# #MINVER#
+* Build-Depends-Package: libvdpau-dev
+ vdp_device_create_x11@Base 0.2
diff --git a/debian/patches/doxygen-no-timestamps.patch b/debian/patches/doxygen-no-timestamps.patch
new file mode 100644
index 0000000..a5cc904
--- /dev/null
+++ b/debian/patches/doxygen-no-timestamps.patch
@@ -0,0 +1,14 @@
+Author: Andreas Beckmann <anbe@debian.org>
+Description: disable timestamps in documentation for reproducible builds
+
+--- a/doc/Doxyfile
++++ b/doc/Doxyfile
+@@ -10,6 +10,8 @@
+ # TAG += value [value, ...]
+ # Values that contain spaces should be placed between quotes (" ")
+
++HTML_TIMESTAMP = NO
++
+ #---------------------------------------------------------------------------
+ # Project related configuration options
+ #---------------------------------------------------------------------------
diff --git a/debian/patches/link-with-libx11.patch b/debian/patches/link-with-libx11.patch
new file mode 100644
index 0000000..2ecd10f
--- /dev/null
+++ b/debian/patches/link-with-libx11.patch
@@ -0,0 +1,28 @@
+Subject: Link libvdpao with libX11 since it uses symbols from it
+Author: Russ Allbery <rra@debian.org>
+Forwarded: no
+
+libvdpau uses the symbols:
+
+ _XEatData
+ _XReply
+ _XFlush
+ _XReadPad
+ XFree
+
+which are provided by libX11, but wasn't linking with it directly, resulting
+in warnings during the package build (and possibly errors later with better
+linkers).
+
+--- a/src/Makefile.am
++++ b/src/Makefile.am
+@@ -22,7 +22,8 @@ endif
+ libvdpau_la_LIBADD = \
+ $(DLOPEN_LIBS) \
+ $(PTHREAD_LIBS) \
+- $(XEXT_LIBS)
++ $(XEXT_LIBS) \
++ $(X11_LIBS)
+
+ libvdpau_la_LDFLAGS = -version-info 1:0:0 -no-undefined
+
diff --git a/debian/patches/series b/debian/patches/series
new file mode 100644
index 0000000..0865fa5
--- /dev/null
+++ b/debian/patches/series
@@ -0,0 +1,4 @@
+link-with-libx11.patch
+simplify-dlopen-path-length-error-handling.patch
+vdpau-module-searchpath.patch
+doxygen-no-timestamps.patch
diff --git a/debian/patches/simplify-dlopen-path-length-error-handling.patch b/debian/patches/simplify-dlopen-path-length-error-handling.patch
new file mode 100644
index 0000000..964ccad
--- /dev/null
+++ b/debian/patches/simplify-dlopen-path-length-error-handling.patch
@@ -0,0 +1,47 @@
+From: Andreas Beckmann <debian@abeckmann.de>
+Subject: simplify path overflow error handling
+ "path too long" is not a fatal error, there may be other search paths
+ that don't overflow, so try them as well
+
+--- a/src/vdpau_wrapper.c
++++ b/src/vdpau_wrapper.c
+@@ -132,6 +132,8 @@ static VdpStatus _vdp_open_driver(
+ vdpau_driver = "nvidia";
+ }
+
++ _vdp_driver_dll = NULL;
++
+ /* Don't allow setuid apps to use VDPAU_DRIVER_PATH */
+ vdpau_driver_path = secure_getenv("VDPAU_DRIVER_PATH");
+ if (vdpau_driver_path &&
+@@ -141,12 +143,6 @@ static VdpStatus _vdp_open_driver(
+ DRIVER_LIB_FORMAT, VDPAU_MODULEDIR, vdpau_driver) >=
+ sizeof(vdpau_driver_lib)) {
+ fprintf(stderr, "Failed to construct driver path: path too long\n");
+- if (vdpau_driver_dri2) {
+- XFree(vdpau_driver_dri2);
+- vdpau_driver_dri2 = NULL;
+- }
+- _VDP_ERROR_BREAKPOINT();
+- return VDP_STATUS_NO_IMPLEMENTATION;
+ }
+ else {
+ _vdp_driver_dll = dlopen(vdpau_driver_lib, RTLD_NOW | RTLD_GLOBAL);
+@@ -154,11 +150,12 @@ static VdpStatus _vdp_open_driver(
+ }
+
+ if (!_vdp_driver_dll) {
+- /* Try again using the old path, which is guaranteed to fit in PATH_MAX
+- * if the complete path fit above. */
+- snprintf(vdpau_driver_lib, sizeof(vdpau_driver_lib),
+- DRIVER_FALLBACK_LIB_FORMAT, vdpau_driver);
+- _vdp_driver_dll = dlopen(vdpau_driver_lib, RTLD_NOW | RTLD_GLOBAL);
++ /* Try again using the old path. */
++ if (snprintf(vdpau_driver_lib, sizeof(vdpau_driver_lib),
++ DRIVER_FALLBACK_LIB_FORMAT, vdpau_driver) <
++ sizeof(vdpau_driver_lib)) {
++ _vdp_driver_dll = dlopen(vdpau_driver_lib, RTLD_NOW | RTLD_GLOBAL);
++ }
+ }
+
+ if (vdpau_driver_dri2) {
diff --git a/debian/patches/vdpau-module-searchpath.patch b/debian/patches/vdpau-module-searchpath.patch
new file mode 100644
index 0000000..9750871
--- /dev/null
+++ b/debian/patches/vdpau-module-searchpath.patch
@@ -0,0 +1,43 @@
+From: Andreas Beckmann <debian@abeckmann.de>
+Subject: search the vdpau module in multiple directories
+ start searching the vdpau module in ${ORIGIN}/vdpau, then the MODULEDIR and
+ finally fall back to /usr/lib/vdpau
+
+--- a/src/vdpau_wrapper.c
++++ b/src/vdpau_wrapper.c
+@@ -103,6 +103,13 @@ static char * _vdp_get_driver_name_from_
+ return driver_name;
+ }
+
++static char const * _vdpau_module_search_paths[] = {
++ "${ORIGIN}/vdpau",
++ VDPAU_MODULEDIR,
++ "/usr/lib/vdpau",
++ NULL
++};
++
+ static VdpStatus _vdp_open_driver(
+ Display * display,
+ int screen)
+@@ -117,6 +127,7 @@ static VdpStatus _vdp_open_driver(
+ char vdpau_driver_lib[PATH_MAX];
+ char const * vdpau_trace;
+ char const * func_name;
++ char const ** module_path;
+
+ vdpau_driver = secure_getenv("VDPAU_DRIVER");
+ if (vdpau_driver) {
+@@ -138,9 +146,11 @@ static VdpStatus _vdp_open_driver(
+
+ /* Fallback to VDPAU_MODULEDIR when VDPAU_DRIVER_PATH is not set,
+ * or if we fail to create the driver path/dlopen the library. */
+- if (!_vdp_driver_dll) {
++ for (module_path = _vdpau_module_search_paths;
++ !_vdp_driver_dll && *module_path;
++ ++module_path) {
+ if (snprintf(vdpau_driver_lib, sizeof(vdpau_driver_lib),
+- DRIVER_LIB_FORMAT, VDPAU_MODULEDIR, vdpau_driver) >=
++ DRIVER_LIB_FORMAT, *module_path, vdpau_driver) >=
+ sizeof(vdpau_driver_lib)) {
+ fprintf(stderr, "Failed to construct driver path: path too long\n");
+ }
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..101ba2b
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,50 @@
+#!/usr/bin/make -f
+
+#export DH_VERBOSE=1
+
+# see FEATURE AREAS in dpkg-buildflags(1)
+export DEB_BUILD_MAINT_OPTIONS = hardening=+all
+
+# see ENVIRONMENT in dpkg-buildflags(1)
+# package maintainers to append CFLAGS
+#export DEB_CFLAGS_MAINT_APPEND = -Wall -pedantic
+# package maintainers to append LDFLAGS
+export DEB_LDFLAGS_MAINT_APPEND = -Wl,--as-needed
+
+# Disable if dependencies are not available, like on buildd
+# arch-dependent builds, as they are Build-Depends-Indep
+define DOCS_CONF
+ $(shell if test -x /usr/bin/doxygen && test -x /usr/bin/dot; \
+ then echo --enable-documentation; else echo --disable-documentation; fi )
+endef
+
+ifneq (,$(findstring nodoc,$(DEB_BUILD_OPTIONS)))
+DOCS_CONF=--disable-documentation
+endif
+ifneq (,$(findstring nodoc,$(DEB_BUILD_PROFILES)))
+DOCS_CONF=--disable-documentation
+endif
+
+CONFIGURE_OPTIONS ?= $(DOCS_CONF) \
+ --enable-dri2
+
+%:
+ dh $@
+
+binary: binary-indep binary-arch ;
+
+override_dh_autoreconf:
+ dh_autoreconf --as-needed
+
+override_dh_auto_configure:
+ dh_auto_configure -- $(CONFIGURE_OPTIONS)
+
+override_dh_installdocs:
+ dh_installdocs -X.md5
+
+override_dh_bugfiles:
+ dh_bugfiles -A
+
+# ignore the plugin
+override_dh_makeshlibs:
+ dh_makeshlibs -Xvdpau/libvdpau_trace.so.1
diff --git a/debian/source/format b/debian/source/format
new file mode 100644
index 0000000..163aaf8
--- /dev/null
+++ b/debian/source/format
@@ -0,0 +1 @@
+3.0 (quilt)
diff --git a/debian/upstream/metadata b/debian/upstream/metadata
new file mode 100644
index 0000000..31a4a64
--- /dev/null
+++ b/debian/upstream/metadata
@@ -0,0 +1,3 @@
+Name: libvdpau
+Repository: https://gitlab.freedesktop.org/vdpau/libvdpau.git
+Repository-Browse: https://gitlab.freedesktop.org/vdpau/libvdpau
diff --git a/debian/upstream/signing-key.asc b/debian/upstream/signing-key.asc
new file mode 100644
index 0000000..96d3ffc
--- /dev/null
+++ b/debian/upstream/signing-key.asc
@@ -0,0 +1,16 @@
+-----BEGIN PGP PUBLIC KEY BLOCK-----
+
+mQGiBEM6DeERBACdbYV+8QzlucKuYDGG+BZZcmt3OMOqvH+Jd/Tl+gl7+xRizOuN
+3tK1dGVNfeHt6Wco5rBFgi4dkK7gsZ7KMJ2KM6yaYhiocgX1HiaDKozclGeoW+wR
+8L0h3iCNxkmrt23opXtbC4ABeoiV03T5qrfeqhLX8od/K50srfXO+h2enwCg/8RX
+BGwxS/UCEtDVC4LjomM/hzMD/33Ur/FD7t588DwL2Z49wr+JHNjJQD5lumaoM0QM
+Eo3IlB0e6sRjykC7BxUf3HK7S0TD1+PdS1OGhsvL4wKdOTDatPz4jEfscx95N+Z9
+ML020eX7wWEJR9lGHteyhYYujFJQEM+TNF6v6nG/OPphnCg6A794veDabtmT27Mo
+Mn4bA/96K32RCC5wpRLDeGBG4bnJvJEsTZhAApZa4oY1zh6hT/1EYegUvRp4X0nX
+X9ySCjGZs6SxEwokWMmzPHzf0n4AYUs8ZDd0ZRYTo/92vUM0/GLCRha8+j1sy7+Z
+4uz3vIORrVLld6hyv2Zp2aB0Fef+tVqIR92eNG7L5KXpilnDWbQlQWFyb24gUGxh
+dHRuZXIgPGFwbGF0dG5lckBudmlkaWEuY29tPoheBBMRAgAeAhsDBgsJCAcDAgMV
+AgMDFgIBAh4BAheABQJFCfprAAoJEPVqzI8JupY11hEAn2LA/Ak9HLeOo8CbMEvl
+u1boVsfoAJ9OtoNAmY+o7rtMuXrT11C+qc7eMg==
+=zPlZ
+-----END PGP PUBLIC KEY BLOCK-----
diff --git a/debian/watch b/debian/watch
new file mode 100644
index 0000000..89e11d9
--- /dev/null
+++ b/debian/watch
@@ -0,0 +1,4 @@
+version=3
+
+opts=uversionmangle=s/\.(tar.*|tgz|zip|gz|bz2)$//i,dversionmangle=s/[-.+~]?(cvs|svn|git|snapshot|pre|hg)(.*)$//i,pgpsigurlmangle=s/$/.sig/ \
+https://people.freedesktop.org/~aplattner/vdpau/libvdpau-([\d+\.]+|\d+)\.tar\.(?:gz|bz2)