summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2019-03-16 06:34:26 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2019-03-16 06:34:26 +0000
commit54253c364f0cb893cdbcf85ee3b0a74d4786042f (patch)
treeeda2489f17dd7ea289dc501e2ae7fe394b91f84e
parentAdding upstream version 200. (diff)
downloadpostgresql-common-54253c364f0cb893cdbcf85ee3b0a74d4786042f.tar.xz
postgresql-common-54253c364f0cb893cdbcf85ee3b0a74d4786042f.zip
Adding debian version 200.debian/200
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
-rw-r--r--debian/01autoremove-postgresql17
-rw-r--r--debian/README.Debian160
-rw-r--r--debian/README.Devel78
-rw-r--r--debian/changelog3996
-rw-r--r--debian/clean7
-rw-r--r--debian/compat1
-rw-r--r--debian/control193
-rw-r--r--debian/copyright17
-rw-r--r--debian/init.d-functions112
-rw-r--r--debian/maintscripts-functions253
-rw-r--r--debian/po/POTFILES.in1
-rw-r--r--debian/po/ca.po147
-rw-r--r--debian/po/cs.po128
-rw-r--r--debian/po/da.po143
-rw-r--r--debian/po/de.po146
-rw-r--r--debian/po/es.po176
-rw-r--r--debian/po/eu.po131
-rw-r--r--debian/po/fi.po126
-rw-r--r--debian/po/fr.po152
-rw-r--r--debian/po/gl.po129
-rw-r--r--debian/po/it.po136
-rw-r--r--debian/po/ja.po145
-rw-r--r--debian/po/nl.po150
-rw-r--r--debian/po/pt.po145
-rw-r--r--debian/po/pt_BR.po133
-rw-r--r--debian/po/ro.po133
-rw-r--r--debian/po/ru.po148
-rw-r--r--debian/po/sv.po130
-rw-r--r--debian/po/templates.pot117
-rw-r--r--debian/po/tr.po149
-rw-r--r--debian/po/vi.po131
-rw-r--r--debian/postgresql-client-common.dirs1
-rw-r--r--debian/postgresql-client-common.install6
-rw-r--r--debian/postgresql-client-common.links21
-rw-r--r--debian/postgresql-client-common.lintian-overrides21
-rw-r--r--debian/postgresql-client-common.manpages2
-rw-r--r--debian/postgresql-client-common.postrm12
-rw-r--r--debian/postgresql-common.NEWS47
-rw-r--r--debian/postgresql-common.config60
-rw-r--r--debian/postgresql-common.dirs4
-rw-r--r--debian/postgresql-common.docs4
-rw-r--r--debian/postgresql-common.install19
-rw-r--r--debian/postgresql-common.links1
-rw-r--r--debian/postgresql-common.lintian-overrides5
-rw-r--r--debian/postgresql-common.logrotate10
-rw-r--r--debian/postgresql-common.manpages9
-rw-r--r--debian/postgresql-common.postgresql.init61
-rw-r--r--debian/postgresql-common.postgresql.tmpfile4
-rw-r--r--debian/postgresql-common.postinst131
-rw-r--r--debian/postgresql-common.postrm32
-rw-r--r--debian/postgresql-common.preinst19
-rw-r--r--debian/postgresql-common.sysctl12
-rw-r--r--debian/postgresql-common.templates54
-rw-r--r--debian/postgresql-common.triggers5
-rw-r--r--debian/postgresql-server-dev-all.install5
-rw-r--r--debian/postgresql-server-dev-all.manpages2
-rwxr-xr-xdebian/rules46
-rw-r--r--debian/source/format1
-rwxr-xr-xdebian/supported-versions184
-rw-r--r--debian/tests/control3
-rwxr-xr-xdebian/tests/default-psql19
61 files changed, 8430 insertions, 0 deletions
diff --git a/debian/01autoremove-postgresql b/debian/01autoremove-postgresql
new file mode 100644
index 0000000..3f473d1
--- /dev/null
+++ b/debian/01autoremove-postgresql
@@ -0,0 +1,17 @@
+// File installed by postgresql-common. Currently not updated automatically,
+// but might be in future releases.
+//
+// We mark all PostgreSQL packages as NeverAutoRemove because otherwise apt
+// would remove the old postgresql-NN package when the "postgresql" meta
+// package changes its dependencies to a new version, rendering the old
+// database cluster inaccessible. As access to the cluster might depend on
+// other modules (like datatypes), we use a pretty wide pattern here. We might
+// tighten this to match only actually used PostgreSQL versions in the future.
+
+APT
+{
+ NeverAutoRemove
+ {
+ "^postgresql-";
+ };
+};
diff --git a/debian/README.Debian b/debian/README.Debian
new file mode 100644
index 0000000..f8966a9
--- /dev/null
+++ b/debian/README.Debian
@@ -0,0 +1,160 @@
+PostgreSQL for Debian
+=====================
+
+PostgreSQL is a fully featured object-relational database management system. It
+supports a large part of the SQL standard and is designed to be extensible by
+users in many aspects. Its features include ACID transactions, foreign keys,
+views, sequences, subqueries, triggers, outer joins, multiversion concurrency
+control, and user-defined types and functions.
+
+Since the on-disk data format of all major PostgreSQL versions (like 9.6,
+11, etc.) is incompatible to each other, Debian's PostgreSQL packaging
+architecture is designed to maintain clusters of different major versions in
+parallel.
+
+This postgresql-common package provides the common infrastructure and all
+frontend programs that users and administrators use. The version specific
+server and client programs are shipped in postgresql-*-<version> packages.
+
+For a detailed description of the architecture, please see
+
+ /usr/share/doc/postgresql-common/architecture.html
+
+First steps for the impatient
+-----------------------------
+Eventually you will not get around reading at least some parts of the manual,
+but if you want to get straight into playing SQL, here are the steps to create
+a database user and a database for the Unix user 'joe':
+
+1. Install a database server with the major version of your choice
+ ('postgresql-XY', e. g. 'postgresql-11'). Preferably the latest
+ version, which you can get by installing the metapackage
+ 'postgresql'. This will automatically create a default cluster
+ 'main' with the database superuser 'postgres'.
+
+2. Get a shell for the database superuser 'postgres'. If your system
+ has an active root user, use su:
+
+ # su -s /bin/bash postgres
+
+ If your system uses sudo to get administrative rights, use sudo instead:
+
+ joe$ sudo -u postgres bash
+
+3. In this postgres shell, create a database user with the same name as your
+ Unix login:
+
+ $ createuser -DRS joe
+
+ For details about the options, see createuser(1).
+
+4. Create a database "joework" which is owned by "joe":
+
+ $ createdb -O joe joework
+
+ For details about the options, see createdb(1).
+
+5. Exit the postgres shell.
+
+6. As user joe, you should now be able to connect to your database with
+
+ $ psql joework
+
+Cluster management
+------------------
+For managing clusters, the following commands are provided (each with its own
+manual page):
+
+ pg_createcluster - Create a new cluster or integrate an existing one into
+ the postgresql-common architecture.
+ pg_dropcluster - Completely remove a cluster.
+ pg_ctlcluster - Control the server process of a cluster (start, stop,
+ restart).
+ pg_lsclusters - Show a list of all existing clusters and their status.
+ pg_upgradecluster - Migrate a cluster from one major version to another one.
+ pg_renamecluster - Rename a cluster.
+
+Please note that you can of course also use the upstream tools for
+creating clusters, such as initdb(1). However, please note that in
+this case you cannot expect *any* of above pg_* tools to work, since
+they use different configuration settings (SSL, data directories,
+etc.) and file locations (e. g.
+/etc/postgresql/11/main/postgresql.conf). If in doubt, then do *not*
+use initdb, but only pg_createcluster. Since merely installing
+postgresql-NN will already set up a default cluster which is ready to
+work, most people do not need to bother about initdb or
+pg_createcluster at all.
+
+Port assignment
+---------------
+Please note that the pg_* tools automatically manage the server ports
+unless you specify them manually. The first cluster which is ever
+created (by any major version) will run on the default port 5432, and
+each new cluster will use the next higher free one.
+
+E. g. if you first install "postgresql-11" on a clean system, the
+default 11/main cluster will run on port 5432. If you then create
+another 11 cluster, or install the "postgresql-12" package, that new
+one will run on 5433.
+
+Please use "pg_lsclusters" for displaying the cluster <-> port
+mapping, and please have a look at the pg_createcluster manpage (the
+--port option) for details.
+
+Default clusters and upgrading
+------------------------------
+When installing a postgresql-NN package from scratch, a default
+cluster 'main' will automatically be created. This operation is
+equivalent to doing 'pg_createcluster NN main --start'.
+
+Due to this default cluster, an immediate attempt to upgrade an
+earlier 'main' cluster to a new version will fail and you need to
+remove the newer default cluster first. E. g., if you have
+postgresql-9.6 installed and want to upgrade to 11, you first install
+postgresql-11:
+
+ apt-get install postgresql-11
+
+Then drop the default 11 cluster that was just created:
+
+ pg_dropcluster 11 main --stop
+
+And then upgrade the 9.6 cluster to the latest installed version (e. g. 11):
+
+ pg_upgradecluster 9.6 main
+
+SSL
+---
+The PostgreSQL server packages support SSL, which provides encrypted and
+authenticated network communication. SSL should be used if you have an
+untrusted network between a database server and a client and these exchange
+security sensitive data like passwords or confidential database contents.
+
+When a cluster is created with pg_createcluster, SSL support will automatically
+be enabled. postgresql-common makes use of the 'snakeoil' SSL certificate that
+is generated by the ssl-cert package, so that SSL works out of the box
+(ssl_cert_file, ssl_key_file). In addition, if /etc/postgresql-common/root.crt
+exists, it will be used as CA certificate file (ssl_ca_file).
+
+/etc/postgresql-common/root.crt is a dummy file by default, so that
+client-side authentication is not performed. To enable it, you should
+add some root certificates to it. A reasonable choice is to just
+symlink the file to /etc/ssl/certs/ssl-cert-snakeoil.pem; in this
+case, client certificates need to be signed by the snakeoil
+certificate, which might be desirable in many cases. See
+
+ /usr/share/doc/postgresql-doc-11/html/ssl-tcp.html
+
+for details (in package postgresql-doc).
+
+Further documentation
+---------------------
+All commands shipped by postgresql-common have detailed manpages. See
+postgresql-common(7) for the documentation of the database client program
+wrapping, and user_clusters(5) and postgresqlrc(5) for the cluster
+configuration.
+
+The documentation of the database server and client functions, SQL commands,
+modules, etc. documented is shipped in the per-version packages
+postgresql-doc-<version>.
+
diff --git a/debian/README.Devel b/debian/README.Devel
new file mode 100644
index 0000000..5b31b89
--- /dev/null
+++ b/debian/README.Devel
@@ -0,0 +1,78 @@
+Development of the Debian PostgreSQL packages
+=============================================
+
+Package structure
+-----------------
+To keep the maintenance of the packages as easy as possible, as much
+packaging logic as possible should be put into postgresql-common. The
+server packages (postgresql-X.Y) should not contain any conffile but
+a generic init script (which just calls hook functions shipped by
+postgresql-common). Likewise, their maintainer scripts should only
+call the hooks offered by postgresql-common.
+
+This structure makes it easy to fix packaging bugs for all available
+major versions by only uploading a new version of the small
+postgresql-common package. It also keeps the effort of packaging a new
+major version as small as possible.
+
+Revision control system
+-----------------------
+Package development happens with the distributed revision
+control system "bazaar" (http://bazaar-vcs.org). This allows anybody
+to create and develop a personal branch of the official package
+without having write access to the trunk.
+
+If you want to help with developing the packages, you should work with
+bazaar to benefit from the features of a revision control system; this
+will also allow the Debian maintainers to easily merge your changes
+into the official packages.
+
+The official Debian package branches are at
+
+ http://anonscm.debian.org/bzr/pkg-postgresql/
+
+The orig.tar.gz files are not kept under revision control since they
+would only bloat the archive. They need to be downloaded separately
+from any Debian mirror. "bzr bd" (from the bzr-builddeb package) will
+fetch those automatically.
+
+Creating your personal branch
+-----------------------------
+First, please make sure that bzr can figure out a correct email
+address with
+
+ $ bzr whoami
+
+If it is not correct, please set the $EMAIL environment variable.
+
+If you want to help with the package development or just want to
+develop a feature you need, you should create your own branch where
+you can commit to. As an example, let's create a branch of the
+postgresql-common package:
+
+ $ bzr branch http://bzr.debian.org/bzr/pkg-postgresql/postgresql-common/trunk/
+
+Now you can happily use "bzr diff", "bzr commit", "bzr add", "bzr
+pull", "bzr merge", and all the other features of revision control.
+
+Publishing your branch
+----------------------
+
+You can use any server where you have ssh or sftp access (use sftp:// for the
+latter) and which is http accessible:
+
+ bzr push sftp://myuser@my.server.com:public_html/bzr/psql/common
+
+After this initial command, "bzr push" is enough for subsequent
+pushes, bzr remembers the last push location. This way you can keep
+your remote branch up to date.
+
+If you do not have any server available, you can create an account on Launchpad
+(https://launchpad.net) and push it to lp:~<username>/postgresql/<branchname>.
+
+If you developed a particular feature or bug fix and would like to see
+it in the official package, please send a mail to
+pkg-postgresql-public@lists.alioth.debian.org or to mpitt@debian.org,
+and state the URL of your branch.
+
+ -- Martin Pitt <mpitt@debian.org>
diff --git a/debian/changelog b/debian/changelog
new file mode 100644
index 0000000..58f61b0
--- /dev/null
+++ b/debian/changelog
@@ -0,0 +1,3996 @@
+postgresql-common (200) unstable; urgency=medium
+
+ * pg_createcluster: Don't refuse explicit -p argument even when port is
+ already in use. (Closes: #653870)
+ * pg_createcluster: Override suggested cluster start command in initdb.
+ (Closes: #872660)
+ * pg_upgradecluster, t/052_upgrade_encodings.t: pg_dumpall 11 retains the
+ database encoding, so switching encodings via dump-restore does not work
+ anymore.
+ * pg_upgradecluster: Deprecate 'replacement_sort_tuples' in version 11.
+ * pg_upgradecluster: Migrate postgresql.auto.conf to new cluster.
+ (Closes: #810615)
+ * pg_ctlcluster: Die early if logfile is not available. (Closes: #891234)
+ * pg_ctlcluster: Die early if pg_ctl cannot be found. (See: #918784)
+ * pg_ctlcluster: Document --skip-systemctl-redirect, and skip redirect if
+ --foreground is requested.
+ * pg_renamecluster: Notify systemd. (Closes: #839954)
+ * pg_renamecluster: Document that cluster_name is updated as well.
+ * pg_dropcluster: Delete tablespace directories. (Closes: #916449)
+ * pg_dropcluster: Silence warning if data_directory is already gone.
+ Spotted by Jean-Christophe Arnu, merci!
+ * get_cluster_port: Fall back to 5432 if port is not defined in config.
+ (Closes: #920248)
+ * read_cluster_conf_file: Use cluster_data_directory instead of hardcoding
+ /var/lib/postgresql.
+ * postgresql@.service: Add After=network.target to ensure the server is
+ stopped before networking goes down on shutdown. Thanks Elrond!
+ (Closes: #910991)
+ * postgresql@.service: Drop /var prefix from PIDFile, systemd complained
+ about legacy directory /var/run/postgresql.
+ * postgresql-generator: Don't attempt to auto-start removed versions.
+ (Closes: #918784)
+
+ -- Christoph Berg <myon@debian.org> Fri, 01 Mar 2019 20:47:06 +0100
+
+postgresql-common (199) unstable; urgency=medium
+
+ [ Antti Salmela ]
+ * pg_upgradecluster: Pass --jobs to pg_upgrade when using upgrade method.
+
+ [ Christoph Berg ]
+ * supported-versions: Drop support for 9.3 on apt.postgresql.org.
+
+ -- Christoph Berg <christoph.berg@credativ.de> Mon, 28 Jan 2019 16:27:27 +0100
+
+postgresql-common (198) unstable; urgency=medium
+
+ [ Christoph Berg ]
+ * Add gitlab-ci.yml file to be included in all PostgreSQL team packages.
+ * testsuite: Stop postgresql@* explicitly. (Workaround for #759725)
+
+ [ Michael Banck ]
+ * pg_buildext: Add support for passing Makefile variables via the new -m
+ option. (Closes: #915953)
+
+ -- Christoph Berg <myon@debian.org> Sun, 16 Dec 2018 11:55:10 +0100
+
+postgresql-common (197) unstable; urgency=medium
+
+ * dh_make_pgxs: Update Maintainer address and package URLs.
+ * pg_buildext: Fix problem with substitution pattern occurring multiple
+ times.
+ * pg_buildext: Set PG_REGRESS_DIFF_OPTS for unified diffs from pg_regress.
+
+ -- Christoph Berg <christoph.berg@credativ.de> Thu, 22 Nov 2018 11:59:06 +0100
+
+postgresql-common (196) unstable; urgency=medium
+
+ [ Christoph Berg ]
+ * Replace version 10 in examples by version 11. (Closes: #911391)
+ * Replace -X.Y version number template in examples by -NN.
+ * Updated Turkish translation by Atila Koç, thanks! (Closes: #912322)
+ * read_conf_file: Accept '+' in unquoted values for floats like 1.5+e3.
+ Thanks to David Barbion for spotting!
+ * pg_buildext: Handle multiple overlapping substitutions in
+ debian/tests/control.in better.
+
+ [ Jeremy Bicha ]
+ * Add Ubuntu 19.04 aka disco.
+
+ -- Christoph Berg <christoph.berg@credativ.de> Wed, 21 Nov 2018 12:32:11 +0100
+
+postgresql-common (195) unstable; urgency=medium
+
+ * apt.postgresql.org: Add 11 as default to supported versions.
+
+ -- Christoph Berg <christoph.berg@credativ.de> Thu, 18 Oct 2018 13:53:47 +0200
+
+postgresql-common (194) unstable; urgency=medium
+
+ * Remove iproute2 | net-tools dependency from postgresql-server-dev-all,
+ obsolete in pg_buildext since 178.
+ * Also save pg_controldata on catversion changes, pg_upgrade needs it.
+ Spotted by Dagfinn Ilmari Mannsåker, thanks!
+ * Chown /etc/postgresql to user postgres.
+ * pg_ctlcluster: Use "fast" shutdown by default, and remove code to kill -9
+ the server if it doesn't react to a --force stop. (Closes: #756008)
+ * pg_upgradecluster: Start upgraded cluster only if it was running before,
+ override with new --[no-]start option. (Closes: #876281)
+ * pg_upgradecluster: With pg_upgrade, set wal_level early so standby servers
+ can be upgraded via the instructions from pg_upgrade(1). (Closes: #876293)
+ * pg_upgradecluster: Notify systemd about disabling the old cluster.
+ * pg_upgradecluster: Drop sleep(4) that had been there since the first
+ version.
+ * pg_createcluster: Create stats_temp_directory, so pg_upgrade(cluster) can
+ use it even without invoking pg_ctlcluster before. (Closes: #827469)
+ * pg_upgradecluster: Drop check for pg_restore --no-data-for-failed-tables,
+ switch was introduced in 8.2; use it always and not only when upgrade
+ scripts are present. (Closes: #876282)
+ * Debian: Default PostgreSQL version in buster is 11.
+
+ -- Christoph Berg <christoph.berg@credativ.de> Thu, 11 Oct 2018 17:29:41 +0200
+
+postgresql-common (193) unstable; urgency=medium
+
+ [ Francois Marier ]
+ * Use /run in /usr/lib/tmpfiles.d/postgresql.conf to avoid deprecation
+ warning. (Closes: #902875)
+
+ [ Christoph Berg ]
+ * pg_buildext: Stop passing srcdir to make invocations.
+ * pg_buildext: Copy CFLAGS from environment to COPT so Makefile.global
+ picks it up. Notably this will make extension builds use
+ -f{debug,file}-prefix-map from dpkg-buildflags.
+
+ -- Christoph Berg <myon@debian.org> Thu, 23 Aug 2018 12:57:46 +0200
+
+postgresql-common (192) unstable; urgency=medium
+
+ * postgresql@.service: Use AssertPathExists instead of ConditionPathExists
+ so trying to operate on non-existing clusters fails loudly.
+ (Closes: #891836)
+ * postgresql@.service: Add "RequiresMountsFor /etc/postgresql/%I
+ /var/lib/postgresql/%I" to depend on mounts. (Closes: #855762)
+ * pg_createcluster: Fix error on importing existing clusters, spotted by
+ Mark Eichin, thanks! (Closes: #886871)
+ * postinst_check_catversion: Ignore errors while determining PGDATA.
+ * Move maintainer address to team+postgresql@tracker.debian.org.
+
+ -- Christoph Berg <christoph.berg@credativ.de> Wed, 08 Aug 2018 16:21:59 +0200
+
+postgresql-common (191) unstable; urgency=medium
+
+ [ Christoph Berg ]
+ * PgCommon cluster_data_directory: Support clusters in and symlinked from
+ /etc/postgresql/.
+ * t/170_extensions.t: Add dependencies of jsonb_pl{perl,python}.
+
+ [ Christian Ehrhardt ]
+ * supported-versions: Add Ubuntu 18.10. (Closes: #898166)
+
+ -- Christoph Berg <myon@debian.org> Thu, 10 May 2018 16:44:19 +0200
+
+postgresql-common (190) unstable; urgency=medium
+
+ * Move packaging repository to salsa.debian.org
+ * pg_lsclusters: Add --help.
+ * pg_virtualenv: Error out if no server packages are installed.
+ * postgresql-common recommends e2fsprogs, we are using chattr in
+ pg_createcluster. (Closes: #887251)
+ * PgCommon.pm: Fix include directives parser, spotted by ironhalik, thanks!
+ * postgresql@.service: Set Timeoutstart=0, which is the same as infinity,
+ but works on older systemd versions as well.
+ * Rewrite architecture.html as README.md.
+ * t/006_next_free_port.t: Drop -q argument from netcat, nmap-ncat.rpm
+ doesn't have it.
+ * t/032_ssl_key_permissions.t: Adjust for 9.4 in oldstable which still has
+ the old permissions check.
+
+ -- Christoph Berg <christoph.berg@credativ.de> Thu, 08 Feb 2018 13:26:44 +0100
+
+postgresql-common (189) unstable; urgency=medium
+
+ [ Chris Lamb ]
+ * Update README.Debian for postgresql-10. (Closes: #876438)
+
+ [ Christoph Berg ]
+ * dh_make_pgxs: Use PostgreSQL license as default, fix extension name.
+ * Modernize README.Debian's version numbers and SSL instructions.
+ * postgresql@.service: Ignore startup failure, recovery might take
+ arbitrarily long to finish. The actual service status still correctly
+ reflects if the postmaster process is running.
+ https://www.postgresql.org/message-id/20171111205316.u56lkmkakdmcx6zm%40msg.df7cb.de
+ * supported-versions: Version 10 on Ubuntu 18.04 (bionic). (Closes: #881501)
+ * debian/maintscripts-functions: bump update-alternatives priority of
+ version 1x to 1x0.
+ * Unsupport 9.2 on apt.postgresql.org.
+ * t/140_pg_config.t: Also test /usr/bin/pg_config.libpq-dev, and check
+ MKDIR_P and abs_top_build/srcdir in Makefile.global.
+
+ -- Christoph Berg <myon@debian.org> Thu, 14 Dec 2017 21:13:24 +0100
+
+postgresql-common (188) unstable; urgency=medium
+
+ * pg_ctlcluster, pg_createcluster, pg_upgradecluster: Use lchown instead
+ of chown to mitigate privilege escalation via symlinks. (CVE-2017-8806.
+ Related to CVE-2017-12172 in PostgreSQL; extends our earlier fix for
+ CVE-2016-1255.)
+ * dh_make_pgxs: Add options to set package name and version.
+ * pg_lsclusters: Raise error when called on a specific cluster that does not
+ exist. This was the behavior before the "accept dead postgresql.conf
+ symlinks" change, but not coded explicitly.
+
+ -- Christoph Berg <christoph.berg@credativ.de> Wed, 08 Nov 2017 16:03:19 +0100
+
+postgresql-common (187) unstable; urgency=medium
+
+ * Consistently call psql -X. (Closes: #877920)
+ * Update pt translation, thanks Ricardo Silva! (Closes: #872430)
+ * pg_virtualenv: Drop "BUG" message that really just means that
+ pg_createcluster threw an error.
+ * pg_createcluster: Drop new cluster if --start was requested and starting
+ fails.
+ * pg_createcluster: If not running as postgres or root, don't attempt to
+ install config and data parent directories with owner postgres.
+ * pg_lsclusters, postgresql-generator, get_version_clusters, cluster_info,
+ read_conf_file: Accept dead postgresql.conf symlinks, filesystem might not
+ be mounted yet.
+ * pg_virtualenv: Fix version comparison when determining newest PG major.
+ * pg_updatedicts, postgresql-common.postinst: Create tsearch dictionaries on
+ first install and set umask for correct permissions. (Closes: #868232)
+ Thanks to Christian Ehrhardt for the analysis!
+ * Demote postgresql-common hunspell/myspell triggers to noawait.
+
+ -- Christoph Berg <myon@debian.org> Sun, 22 Oct 2017 20:44:38 +0200
+
+postgresql-common (186) unstable; urgency=medium
+
+ * Team upload.
+ * Bump default apt.postgresql.org version to 10.
+ * t/020_create_sql_remove.t: Support 8.x xlog filenames.
+ * Update ca translation, thanks Innocent De Marchi! (Closes: #876472)
+ * PgCommon.pm: Use BSD ps syntax in check_pidfile_running.
+
+ -- Christoph Berg <christoph.berg@credativ.de> Thu, 05 Oct 2017 16:04:18 +0200
+
+postgresql-common (185) unstable; urgency=medium
+
+ * Team upload.
+
+ [ Christoph Berg ]
+ * Revert "Error out if a recovery.conf file is found in /etc/postgresql".
+ It caused too many false positives for setups where a recovery.conf
+ template is located in the etc directory. (Closes: #868367)
+ * Bump default PostgreSQL version to 10.
+
+ [ Marco Nenciarini ]
+ * supported-versions: correctly detect version 10 when using 'installed'.
+
+ -- Christoph Berg <christoph.berg@credativ.de> Thu, 21 Sep 2017 12:07:30 +0200
+
+postgresql-common (184) unstable; urgency=high
+
+ * debian/maintscripts-functions: Use deb-systemd-invoke instead of
+ invoke-rc.d to stop "postgresql@$ver-*"; jessie's invoke-rc.d does not
+ support service patterns.
+
+ -- Christoph Berg <myon@debian.org> Tue, 11 Jul 2017 20:19:21 +0200
+
+postgresql-common (183) unstable; urgency=medium
+
+ * Team upload.
+
+ [ Nishanth Aravamudan ]
+ * debian/supported-versions: add Ubuntu 17.10. (Closes: #862420)
+
+ [ Bernd Helmle ]
+ * postgresql-common.spec: Fix installation path of manpages.
+
+ [ Alex Badics ]
+ * pg_ctlcluster: Use pg_ctl.conf during stop too.
+
+ [ Christoph Berg ]
+ * PgCommon.pm: Sort get_versions and get_version_clusters output.
+ * PgCommon.pm: Revert to old quote_conf_value behavior, the new regexp was
+ too liberal. The new input behavior is retained, though.
+ * pg_ctlcluster: Error out if a recovery.conf file is found in
+ /etc/postgresql to catch a common mistake. (Closes: #853868)
+ * pg_upgradecluster: Allow configuring the maintenance database.
+ (Closes: #851874)
+ * pg_upgradecluster: Pass config directory to pg_upgrade instead of
+ symlinking the config files. This breaks using "-m upgrade" for upgrades
+ *to* versions before 9.2; upgrades from older versions are unaffected.
+ * pg_upgradecluster, pg_renamecluster: Use default pg_ctl timeout when
+ stopping cluster.
+ * pg_dropcluster: Remove custom xlog directory. (Closes: #830789)
+ * pg_createcluster, pg_ctlcluster: cd / to prevent warnings from PostgreSQL
+ tools. (Closes: #834264)
+ * pg_wrapper: Don't fail if no local cluster exists on port 5432.
+ Code cleanup. (Closes: #777623)
+ * pg_lsclusters: --start-conf shows start.conf information.
+ * createcluster.conf: Add add_include_dir='conf.d' for drop-in PostgreSQL
+ config snippets in /etc/postgresql/version/cluster/conf.d/ and
+ include_dir='/etc/postgresql-common/createcluster.d' for pg_createcluster
+ config snippets.
+ * t/051_inconsistent_encoding_upgrade.t: Remove, only relevant for <= 8.2.
+ * logrotate config: Ship as static conffile again and remove ucf handling.
+ * pg_conftool: Fix operation when no cluster exists yet.
+ * pg_conftool: --boolean normalizes boolean variable in output; use this in
+ debian/maintscripts-functions.
+ * debian/maintscripts-functions: Unconditionally call invoke-rc.d, and drop
+ path names from program invocations (Standards-Version 4.0.0).
+ * debian/maintscripts-functions: Use 'invoke-rc.d "postgresql@$ver-*" stop'
+ to prevent upgrading/removing server packages from stopping other major
+ version clusters when running systemd. (Closes: #809811)
+ * debian/maintscripts-functions: Avoid update-alternatives failing if the
+ user removed /usr/share/man. (Closes: #866729)
+ * t/TestLib.pm: Vacuum tests left behind when postmaster and pg_autovacuum
+ were removed. Update test counts in *.t.
+ * B-D on debhelper (>= 10.1) | dh-systemd (>= 1.19) to pick up
+ dh_systemd_start.
+
+ -- Christoph Berg <christoph.berg@credativ.de> Wed, 05 Jul 2017 16:15:48 +0200
+
+postgresql-common (182) experimental; urgency=medium
+
+ * Team upload.
+ * pg_buildext: Resurrect the previously deprecated "srcdir" mode to allow
+ building packages from a subdirectory, and make "loop" support it as well.
+ * t/001_packages.t: PostgreSQL 10 doesn't have a separate contrib package.
+ * t/020_create_sql_remove.t: Use CREATE EXTENSION, createlang is being
+ removed.
+ * t/120_pg_upgradecluster_scripts.t: Don't try to rename
+ pg_upgradecluster.d, fails on overlayfs.
+ * pg_lsclusters, t: pg_log directory name changed in 10.
+ * pg_lsclusters: Allow listing one version or one cluster only.
+ * pg_lsclusters: Support JSON output, suggest libjson-perl for that.
+ * pg_createcluster, createcluster.conf: Update for --waldir rename.
+ * pg_createcluster: Do not suppress initdb output, and use pg_lsclusters to
+ show created cluster info.
+ * pg_ctlcluster: Suppress "Redirecting to systemctl message".
+ * pg_upgradecluster: Deprecate min_parallel_relation_size and
+ sql_inheritance in 10.
+ * Symlink /usr/bin/pg_receivewal to pg_wrapper.
+ * PgCommon.pm: Include postgresql.conf in cluster_info and remove variables
+ directly copied from config; adjust callers.
+ * PgCommon.pm: Allow more characters in unquoted config values.
+ Spotted by Fabien Coelho, merci!
+ * postgresql-server-dev-all: dh_make_pgxs: Template mechanism for new
+ Debian packages based on PGXS Makefiles.
+
+ -- Christoph Berg <christoph.berg@credativ.de> Thu, 11 May 2017 14:01:59 +0200
+
+postgresql-common (181) unstable; urgency=medium
+
+ * debian/postgresql-common.config: Fix deprecation warning debconf message
+ to use a numerical comparison on the version number.
+ * pg_buildext: Fix to use a numerical comparison on the version number.
+ * pg_buildext.pod: Drop outdated PG_VIRTUALENV_UNSHARE=-n documentation.
+ * pgdg/apt.postgresql.org.sh: Add known distributions.
+ * Updated Danish debconf translation by Joe Dalton, thanks!
+ (Closes: #856787)
+
+ -- Christoph Berg <myon@debian.org> Sat, 15 Apr 2017 18:56:38 +0200
+
+postgresql-common (180) unstable; urgency=medium
+
+ * supported-versions: Retire 9.1 on apt.postgresql.org.
+
+ -- Christoph Berg <christoph.berg@credativ.de> Thu, 09 Feb 2017 15:30:23 +0100
+
+postgresql-common (179) unstable; urgency=medium
+
+ * Catch all pg_ctl output by redirecting it to /var/log/postgresql.
+ (Closes: #830485)
+ * Dump locale environment variables if setlocale fails.
+ (Closes: #848869)
+ * Set default log_line_prefix to '%m [%p] %q%u@%d ' to match upstream
+ moving to '%m [%p] ' in PostgreSQL 10.
+ * Support include_dir in read_conf_file. Patch by Andreas Dewes, thanks!
+ * Support adding include directives to the new postgresql.conf from
+ createcluster.conf; harness directives with an "add_" prefix, e.g.
+ "add_include_dir".
+ * Import new apt.postgresql.org key.
+ * Support 9.6 for jessie-backports.
+
+ -- Christoph Berg <myon@debian.org> Tue, 24 Jan 2017 23:03:12 +0100
+
+postgresql-common (178) unstable; urgency=medium
+
+ [ Christoph Berg ]
+ * pg_buildext: Don't ask pg_virtualenv for a new network namespace by
+ default.
+ * postgresql-all: New meta package depending on all server packages in all
+ supported versions. Intended to be used for installing test dependencies.
+ * pg_upgradecluster: Properly upgrade databases with non-login role owners.
+ (Closes: #614374, #838812)
+ * pg_upgradecluster, pg_renamecluster: Update cluster_name.
+ * Rebuild upgrades libreadline to 7 in unstable. (Closes: #845356)
+ * Replace most occurrences of "postmaster" by "postgres". Notable leftover
+ is the postmaster.1.gz leader of the manpages alternatives group.
+ * pg_ctlcluster, t/020_create_sql_remove.t: Protect against symlink in
+ /var/log/postgresql/ allowing the creation of arbitrary files elsewhere.
+ Discovered by Dawid Golunski, thanks! (CVE-2016-1255)
+
+ [ Martin Pitt ]
+ * debian/supported-versions: Add Ubuntu 17.04, drop EOLed releases.
+ * t/TestLib.pm, check_clean(): Quiesce stderr of netstat, which shows a "Not
+ all processes could be identified" warning in unprivileged containers.
+
+ -- Christoph Berg <myon@debian.org> Tue, 20 Dec 2016 17:11:15 +0100
+
+postgresql-common (177) unstable; urgency=medium
+
+ [ Martin Pitt ]
+ * Replace hardcoded Recommends: libreadline6 with a build-time detection of
+ the current ABI.
+
+ [ Christoph Berg ]
+ * Team upload.
+ * Mark 9.6 as stable for apt.postgresql.org.
+
+ -- Christoph Berg <christoph.berg@credativ.de> Wed, 28 Sep 2016 11:55:12 +0200
+
+postgresql-common (176) unstable; urgency=medium
+
+ * Team upload.
+ * Bump default PostgreSQL server version to 9.6.
+ * Use C.UTF-8 instead of C when the initial main cluster is created and no
+ locale is configured explicitly as system default. (Closes: #790507)
+ * Support "NN" major version numbers, next version will be PostgreSQL 10.
+ * debian/postgresql-common.templates: Properly mark not-to-be-translated
+ shell code-only chunk as such using flag:translate. Thanks to Rhonda for
+ the pointer! (See: #820756, #832282)
+ * testsuite: Run with umask 077 only by default.
+ * t/025_logging.t: Fix tests when grep thinks syslog is a binary file.
+ * t/031_errors_disk_full.t: Raise tmpfs size to account for larger cluster
+ footprint observed on ppc64el.
+ * t/032_ssl_key_permissions.t: Skip tests on 9.0 and earlier.
+ * pg_createcluster, t/025_logging.t: Skip logging_collector for 8.2.
+ * Ship /etc/postgresql-common/supported_versions even in non-backport
+ packages. (Closes: #808353)
+ * pg_createcluster: Error out if provided log file is a directory.
+ (Closes: #791556)
+ * pg_upgradecluster: Set dynamic_shared_memory_type from the new
+ postgresql.conf instead of defaulting to mmap. (Closes: #823209)
+ * pg_upgradecluster: Use data checksums in the new cluster if the old uses
+ them. (Closes: #830228)
+
+ -- Christoph Berg <christoph.berg@credativ.de> Fri, 23 Sep 2016 12:32:16 +0200
+
+postgresql-common (175) unstable; urgency=medium
+
+ * pg_createcluster, createcluster.conf: Set cluster_name on 9.5+.
+ * pg_buildext: Don't set any CFLAGS by default.
+ * start.conf: Update documentation/comments to recommend running
+ systemctl daemon-reload.
+
+ -- Christoph Berg <christoph.berg@credativ.de> Thu, 23 Jun 2016 12:26:27 +0200
+
+postgresql-common (174) unstable; urgency=medium
+
+ [ Christoph Berg ]
+ * postgresql-common: Enforce strict version dependency on
+ postgresql-client-common to avoid API mismatch bugs in PgCommon.pm.
+ * maintscripts-functions: Save pg_dump on catversion bumps as well.
+ * Updated ja translation by Takuma Yamada, thanks! (Closes: #820756)
+ * Remove not-to-be-translated shell code-only chunk from
+ debian/po/templates.pot. (debconf-updatepo --skip-pot to the rescue!)
+ (Closes: #821445)
+
+ [ Martin Pitt ]
+ * debian/supported-versions: Add Ubuntu 16.10.
+
+ -- Christoph Berg <christoph.berg@credativ.de> Wed, 11 May 2016 15:04:25 +0200
+
+postgresql-common (173) unstable; urgency=medium
+
+ [ Christoph Berg ]
+ * README.Debian: Fix a typo.
+ * Updated nl translation, thanks Frans Spiesschaert! (Closes: #812353)
+ * Updated ru translation, thanks Sergey Alyoshin! (Closes: #815596)
+ * Updated ja translation, thanks Takuma Yamada! (Closes: #816069)
+ * preinst_check_catversion: Handle missing catalog version file.
+ * pg_renamecluster: Don't try to rename a non-existing stats directory.
+ * pg_conftool: Refuse operation on non-existing clusters.
+ * maintscript-functions, templates: Remove '#' characters from upgrade
+ instructions on catalog version change for easier cut-and-paste.
+ * t/032_ssl_key_permissions.t: Validate server snakeoil key checks.
+ * pgdg/apt.postgresql.org.sh: Add xenial and trusty.
+
+ [ Adam Conrad ]
+ * pgcommon.sh: Adjust for >= xenial using Debian-style locale generation
+ methods, and allow fallback to the old Ubuntu method for old releases.
+
+ -- Christoph Berg <myon@debian.org> Wed, 30 Mar 2016 15:08:06 +0200
+
+postgresql-common (172) unstable; urgency=medium
+
+ [ Christoph Berg ]
+ * pg_buildext: Mute diff warning about missing debian/tests/control.in.
+ * pg_ctlcluster: Skip systemctl redirect with --bindir.
+ * pg_createcluster: Drop warning if /tmp is used as socket directory.
+ Instead, just print the socket directory on cluster creation.
+ * Update French debconf translations, thanks Julien Patriarca!
+ (Closes: #809800)
+ * 9.5 released! Setting as default.
+
+ [ Martin Pitt ]
+ * debian/supported-versions: Switch Ubuntu 16.04 to 9.5.
+ * debian/supported-versions: Drop obsolete Ubuntu versions.
+
+ -- Christoph Berg <christoph.berg@credativ.de> Thu, 07 Jan 2016 15:13:06 +0100
+
+postgresql-common (171) unstable; urgency=medium
+
+ [ Christoph Berg ]
+ * pgdg: Deprecate 8.4 and 9.0.
+ * Enable 9.4 for wheezy-backports.
+ * pg_createcluster: Fix stats_temp_directory handling on 8.3, thanks to
+ Marco Nenciarini for the inital patch.
+ * pg_createcluster: Mute verbose chattr output.
+ * pg_conftool: Don't quote output in '-s'hort mode.
+ * debian/maintscripts-functions: If the catalog version changes in
+ devel/alpha versions, save a minimal copy of the old version binaries in
+ the preinst to enable using pg_upgrade. Use debconf in the postinst to
+ instruct the user how to proceed with the upgrade.
+ * pg_buildext: Replace multiple occurrences of PGVERSION on the same line,
+ and implement replacing for debian/tests/control.in.
+ * t/015_start_stop.t: Validate pg_ctlcluster/systemctl exit codes.
+ * pg_ctlcluster: Redirect requests to systemd when invoked as root and no
+ extra pg_ctl or postgres options are given.
+ Trying to start already running clusters clusters will return 0 now
+ (was 2 in the native implementation). (Closes: #784878)
+ * pg_createcluster, pg_renamecluster: Warn on cluster names with dashes.
+ * pg_upgradecluster: Deprecate ssl_renegotiation_limit in 9.5.
+
+ [ Martin Pitt ]
+ * pg_upgradecluster: Fix "ANALZYE" typo.
+ * debian/supported-versions: Add Ubuntu 16.04.
+ * Update Turkish debconf translations, thanks Atila KOÇ!
+ (Closes: #799274)
+ * t/020_create_sql_remove.t: Skip postmaster OOM killer adjustment when
+ running in a container, as these often have restricted privileges.
+
+ -- Christoph Berg <christoph.berg@credativ.de> Fri, 18 Dec 2015 16:22:37 +0100
+
+postgresql-common (170) unstable; urgency=medium
+
+ [ Christoph Berg ]
+ * pg_createcluster, pg_dropcluster: When an auto-started cluster is created/
+ dropped by root, notify systemd to update the dependencies of
+ postgresql.service.wants.
+ * pg_dropcluster, pg_renamecluster: Handle stats_temp_directory.
+ * testsuite, pg_virtualenv: Remove the unshare hack, too much trouble.
+ * pg_buildext, pg_virtualenv: Add PG_VIRTUALENV_NEWPID and
+ PG_VIRTUALENV_UNSHARE variables; pg_buildext selects unshare -n by default.
+ * t/025_logging.t: Improve syslog detection in the test environment.
+ * pg_upgradecluster, t/030_errors.t: Unbreak after we changed the old=new
+ error message.
+ * PgCommon.pm: make read_cluster_conf_file read postgresql.auto.conf as well
+ (Closes: #787154)
+ * pg_upgradecluster: Support upgrading tablespaces. (Closes: #772202)
+ * t/TestLib.pm: New function program_ok().
+ * t/040_upgrade.t: Skip testing pg_upgrade with datallowconn = f, it does
+ not support that anymore as of May 2015.
+ * t/170_extensions.t: Catch warning with chkpass >= 9.5.
+ * debian/maintscripts-functions: Unset all locale-specific environment
+ variables when creating the initial database cluster. (Closes: #791526)
+ * Add /var/log/postgresql to /usr/lib/tmpfiles.d/postgresql.conf.
+ * Also set OOMScoreAdjust in postgresql@.service.
+ * pg_ctlcluster: OOM-protect 9.0 as well.
+ * pg_lsclusters: Color online/down clusters green/red.
+ * supported-versions: Accept DEB_PG_SUPPORTED_VERSIONS as well.
+ * Ship /etc/postgresql/ in postgresql-common. (Closes: #801140)
+
+ [ Martin Pitt ]
+ * pg_createcluster: Show the locale selected with --locale instead of the
+ current one. (LP: #1467061)
+
+ -- Christoph Berg <christoph.berg@credativ.de> Thu, 08 Oct 2015 13:48:26 +0200
+
+postgresql-common (169) unstable; urgency=medium
+
+ * t/022_recovery.t: New recovery tests to catch regression in 9.4.2 and
+ 9.1.16.
+ * pg_upgradecluster: Set default dynamic_shared_memory_type = mmap.
+ (Closes: #784005)
+ * pg_upgradecluster: Complain if --link is used without --method=upgrade.
+ * pg_upgradecluster: Better error message when old and new version are
+ equal.
+
+ -- Christoph Berg <myon@debian.org> Thu, 04 Jun 2015 12:09:53 +0200
+
+postgresql-common (168) unstable; urgency=medium
+
+ [ Martin Pitt ]
+ * Drop obsolete debian/backport-ppa script.
+ * debian/tests/default-psql: Skip test if default cluster creation is
+ disabled in createcluster.conf.
+
+ [ Christoph Berg ]
+ * t/170_extensions.t: Refactor dependency handling and add new extensions
+ shipped with 9.5.
+
+ -- Christoph Berg <christoph.berg@credativ.de> Thu, 21 May 2015 11:28:45 +0200
+
+postgresql-common (167) unstable; urgency=medium
+
+ [ Christoph Berg ]
+ * pg_conftool: Fix 'remove' operation. Spotted by François Henry, merci!
+ (Closes: #778243)
+ * t/007_pg_conftool.t: Add pg_conftool tests.
+
+ [ Martin Pitt ]
+ * debian/maintscripts-functions: Avoid package installation failure of -9.1
+ due to the pg_basebackup.1 alternative on systems which have both -9.1 and
+ a later version installed in parallel. On those, pg_basebackup.1 will
+ already be in the psql.1.gz group, thus -9.1 must not try to put it back
+ into the postmaster.1.gz group. (LP: #1357682)
+ * Add "default-psql" autopkgtest: Smoketest to verify that installing the
+ "postgresql" metapackage results in a running and working cluster.
+ * debian/maintscripts-functions, configure_cluster(): When running under
+ systemd, do a daemon-reload to re-run the generator and thus create a unit
+ for the newly created cluster.
+ * Move package maintenance to git, update Vcs-* tags accordingly.
+ * Bump Standards-Version to 3.9.6 (no changes necessary).
+ * supported-versions: Add Ubuntu 15.10.
+
+ -- Martin Pitt <mpitt@debian.org> Wed, 06 May 2015 11:28:26 +0200
+
+postgresql-common (166) unstable; urgency=medium
+
+ * postgresql-common: Breaks: systemd (<< 204). postgresql@.service uses
+ reload-related config options that are incompatible with the systemd
+ version in wheezy. (Consider upgrading to the wheezy-backports version.)
+ * pg_renamecluster: New tool to rename clusters.
+ * pg_upgradecluster: --rename allows renaming the upgraded cluster.
+ * pg_conftool: Allow to "edit" files.
+ * PgCommon.pm, pg_lsclusters: Fix thinko which broke logging to
+ /var/log/postgresql when log_destination was "syslog,stderr". The default
+ logfile is now always used even if logging_collector is enabled; it
+ receives the log messages produced before logging_collector is started.
+ * t/020_create_sql_remove.t: Versions >= 9.0 are OOM-protected.
+
+ -- Christoph Berg <myon@debian.org> Thu, 05 Feb 2015 22:19:07 +0100
+
+postgresql-common (165) unstable; urgency=medium
+
+ * Debconf translation updates, thanks!
+ + es by Manuel Venturi Porras Peralta. (Closes: #773598)
+
+ -- Christoph Berg <myon@debian.org> Sun, 04 Jan 2015 18:51:31 +0100
+
+postgresql-common (164) unstable; urgency=medium
+
+ * Init script: Always create /var/run/postgresql on start.
+ (Closes: #772824)
+ * Debconf translation updates, thanks!
+ + pt by Ricardo Silva. (Closes: #767399)
+ * t/100_upgrade_scripts.t: Incompatible with eatmydata, remove from
+ LD_PRELOAD when detected.
+ * t/170_extensions.t: Catch warning with chkpass on 9.5.
+ * debian/supported-versions: Support jessie in backports and
+ apt.postgresql.org, with 9.4 as default.
+ * pgdg/apt.postgresql.org.sh: Support jessie.
+
+ -- Christoph Berg <myon@debian.org> Wed, 17 Dec 2014 20:00:04 +0100
+
+postgresql-common (163) unstable; urgency=medium
+
+ [ Martin Pitt ]
+ * pg_createcluster: Disable copy-on-write semantics for data directory on
+ btrfs and similar file systems. It eats a lot of performance and isn't
+ necessary for data integrity.
+ * debian/supported-versions: Welcome Ubuntu 15.04!
+
+ [ Christoph Berg ]
+ * Update VCS URLs.
+
+ -- Martin Pitt <mpitt@debian.org> Sun, 26 Oct 2014 07:04:48 -0400
+
+postgresql-common (162) unstable; urgency=medium
+
+ [ Christoph Berg ]
+ * Move PgCommon.pm to /usr/share/perl5.
+ * t/020_create_sql_remove.t: Test psql -tx alignment to catch a bug in
+ 9.4beta2.
+ * supported-versions: Set 9.4 as pgdg default on Ubuntu 14.10.
+ * Debconf translation updates, thanks!
+ + nl by Frans Spiesschaert. (Closes: #762632)
+
+ [ Peter Michael Green ]
+ * Use ID_LIKE to identify deriviatives of Debian and Ubuntu.
+ (Closes: #761020)
+
+ [ Richard Hughes ]
+ * Use Type=forking in postgresql@.service and start before postgresql.
+ (Closes: #759725)
+
+ -- Christoph Berg <myon@debian.org> Tue, 07 Oct 2014 21:25:25 +0200
+
+postgresql-common (161) unstable; urgency=medium
+
+ * pg_ctlcluster: Refuse root operation when config owner does not match
+ data owner, and config owner is not root.
+ * Stop automatically updating debian/control from debian/control.in in
+ pgxs_debian_control.mk. Instead, implement "checkcontrol" and
+ "updatecontrol" actions in pg_buildext. checkcontrol is run from
+ pgxs_debian_control.mk and will warn if an update is required.
+ Backport and pgdg builds will still automatically update.
+ (Closes: #758570)
+ * pg_virtualenv, testsuite: Use "ip" to start lo when available.
+ * Add iproute2 | net-tools to postgresql-server-dev-all dependencies.
+ * Debconf translation updates, thanks!
+ + it by Luca Monducci. (Closes: #759808)
+
+ -- Christoph Berg <myon@debian.org> Fri, 15 Aug 2014 10:13:51 +0200
+
+postgresql-common (160) unstable; urgency=medium
+
+ [ Martin Pitt ]
+ * supported-versions: Set 9.4 as default for Ubuntu 14.10.
+ * debian/maintscripts-functions: Call update-alternatives under C locale to
+ fix parsing for non-English locales. (LP: #1293596)
+ * pg_createcluster: Fix test if specified owner/group ID is numeric. Thanks
+ Sven Berkvens-Matthijsse! (LP: #1329227)
+
+ [ Christoph Berg ]
+ * Use dh-systemd to enable postgresql.service on install. (Closes: #757612)
+ * Set Multi-Arch: foreign in postgresql-common, postgresql-client-common,
+ postgresql-client, and postgresql-doc, and document this in
+ doc/dependencies.{dia,png}. (Closes: #757520)
+ * Update examples in README.Debian for 9.4. (Closes: #756007)
+ * Install README.systemd.
+
+ -- Christoph Berg <christoph.berg@credativ.de> Mon, 11 Aug 2014 15:39:39 +0200
+
+postgresql-common (159) unstable; urgency=low
+
+ * supported-versions: Set 9.4 as default for jessie and unstable.
+ * systemd unit files are now installed to their proper locations.
+ * Install /usr/lib/tmpfiles.d/postgresql.conf.
+ * pgcommon.sh: New shell function module containing get_release and
+ locale_gen. Used by supported-versions and testsuite; also usable by other
+ packages.
+ * pg_ctlcluster, PgCommon.pm: Fix warning on corrupt empty pid files.
+ * pg_ctlcluster: New --stdlog option to be used with --foreground that
+ redirects stderr to our standard log files. Used in postgresql@.service.
+ * pg_ctlcluster: Ignore errors when stat'ing the logfile.
+ * pg_ctlcluster: use strict.
+ * Debconf translation updates, thanks!
+ + da by Joe Dalton. (Closes: #753952)
+
+ -- Christoph Berg <christoph.berg@credativ.de> Thu, 24 Jul 2014 11:52:57 +0200
+
+postgresql-common (158) experimental; urgency=medium
+
+ * supported-versions: Add 9.4 on Debian/unstable and pgapt (9.3 is still
+ default).
+ * Set default log_line_prefix = '%t [%p-%l] %q%u@%d '.
+ * Put stats_temp_directory aka pg_stat_tmp into /var/run/postgresql by
+ default. (Closes: #739276)
+ * pg_lsclusters: Print logfile from postgresql.conf when logging_collector
+ in use instead of "custom".
+ * Move pg_{create,ctl,upgrade,drop}cluster.8 to section 1, they are in
+ /usr/bin anyway.
+ * maintscripts-functions: Configure manpage alternatives in -doc packages
+ using SPI_connect.3.gz as master.
+ * pg_upgradecluster: Deprecate krb_srvname in 9.4. Failing upgrade hook
+ scripts will fail the upgrade.
+ * pg_ctlcluster: Configure OOM killer using PG_OOM_ADJUST_FILE in 9.5.
+ * pg_wrapper: Also accept --cluster=ver/name in a single argument.
+ * testsuite: Also mount /dev/shm; with -s, open shell on failure; -f nnn
+ starts tests at this sequence number.
+ * run-upgrade-scripts, t/100_upgrade_scripts.t: Fork and set uid for running
+ the upgrade scripts; use su -c for testing.
+ * Start porting the postgresql-common framework to RedHat, backed by the
+ PGDG PostgreSQL rpm packages.
+ * Debconf translation updates, thanks!
+ + fr by Julien Patriarca. (Closes: #751101)
+ + ja by victory. (Closes: #751131)
+ * debian/copyright: Update copyright holders.
+
+ -- Christoph Berg <myon@debian.org> Sat, 05 Jul 2014 16:40:16 +0200
+
+postgresql-common (157) unstable; urgency=medium
+
+ * Remove createcluster.conf on purge.
+ * Fix testsuite -i to install packages before invoking unshare so apt still
+ has network access.
+
+ -- Christoph Berg <myon@debian.org> Fri, 30 May 2014 21:31:36 +0200
+
+postgresql-common (156) unstable; urgency=medium
+
+ [ Christoph Berg ]
+ * pg_upgradecluster: Add missing psql -p argument when determining the
+ number of tablespaces in the old cluster.
+ * Link pg_archivecleanup from /usr/bin. (Closes: #740593)
+ * pg_virtualenv: Use fsync = off for speed.
+ * pg_buildext: Pass -cios options to pg_virtualenv.
+ * t/140_pg_config.t: Versions >= 9.3 have multiarch-enabled libpq et al.
+ * Bump to dh 9.
+
+ [ Martin Pitt ]
+ * Fix typo in German debconf translations. Thanks Rhonda for pointing out!
+
+ -- Christoph Berg <myon@debian.org> Fri, 30 May 2014 00:00:44 +0200
+
+postgresql-common (155) unstable; urgency=medium
+
+ [ Christoph Berg ]
+ * postgresql-common: Maintain createcluster.conf using ucf, and add a
+ debconf question about the default use of ssl (default true, priority
+ medium). (Closes: #743918)
+ * Use "mount --make-rprivate /" inside our "unshare -m" calls.
+ (See #739593.)
+ * pg_ctlcluster: Add status action, add --foreground option, accept dash
+ (and slash) between version and cluster.
+ * Add systemd unit files as examples (testers welcome!).
+ * postgresql-client: Wrap pg_recvlogical, introduced in 9.4.
+ * t/050_encodings.t: 9.4 emits COPY command tags, suppress with psql -q.
+ * postgresql: Add Suggests: postgresql-doc. (Closes: #743755)
+ * pg_conftool: New script to read and edit PostgreSQL configuration files,
+ based on the existing read/edit functions in PgCommon.pm.
+ * pg_upgradecluster: Don't abort the upgrade if the config file symlinks are
+ already there.
+ * testsuite: Fix testsuite where -v does not include the latest version.
+ * testsuite -v -i will install packages needed for these versions.
+
+ [ Martin Pitt ]
+ * supported-versions: Welcome, Ubuntu 14.10!
+
+ -- Christoph Berg <christoph.berg@credativ.de> Wed, 21 May 2014 17:34:09 +0200
+
+postgresql-common (154) unstable; urgency=medium
+
+ [ Martin Pitt ]
+ * debian/postgresql-common.preinst: Drop obsolete upgrade migration.
+ * debian/maintscripts-functions, _link_manpages(): The move of pg_basebackup
+ from server to client still affects upgrades from -9.1 to -9.3. Place the
+ upgrade fix here instead of postgresql-9.1.preinst (which does not exist
+ any more now). (LP: #1270597)
+ * Update Vcs-Bzr:, bzr.d.o. does not work any more.
+
+ [ Christoph Berg ]
+ * t/031_errors_disk_full.t: Drop cluster after tests.
+ * testsuite: Always umount the tmpfs overlays.
+
+ -- Christoph Berg <myon@debian.org> Fri, 21 Feb 2014 08:18:46 +0100
+
+postgresql-common (153) unstable; urgency=medium
+
+ [ Christoph Berg ]
+ * Replace the static logrotate configuration by generating the file
+ dynamically using ucf, triggered by watching /usr/sbin/logrotate.
+ This eases dist-upgrades that upgrade logrotate to >= 3.8 from an older
+ version (squeeze->wheezy, precise->trusty).
+ * postgresql-common.postinst: Stop debconf later so ucf can use it.
+ * postgresql-common.postinst: Call su without - to avoid a warning.
+ * t/003_package_checks.t: Add test case for logrotate.
+ * pg_createcluster, t/001_packages.t: Refactor the ssl cert test, and add
+ matching testcases in the testsuite.
+ * t/020_create_sql_remove.t: Make pipe writes unbuffered.
+ * pg_buildext: Document the loop action (present since version 141).
+ * pg_buildext: Add "installcheck" action for use with autopkgtest.
+ * pg_buildext: Support $action-$version when the loop is contained in the
+ calling script. (Mostly useful for installcheck-x.y.)
+ * postgresql-server-dev-all: Add "make" to depends because pg_buildext is
+ mostly useless without it; extensions using autopkgtest would otherwise
+ need to include it in their debian/tests/control files.
+ * pgxs_debian_control.mk: Add "clean: debian/control" and
+ ".PHONY: debian/control".
+ * pg_virtualenv: Fix exit code shown with -s.
+ * pg_createcluster, pg_virtualenv: -o will set postgresql.conf parameters.
+ * postgresql-common: In /usr/share/postgresql-common/pgdg/,
+ install apt.postgresql.org.sh to enable activating the pgdg repository.
+
+ [ Martin Pitt ]
+ * testsuite, pg_virtualenv: Don't fail if ifconfig is not installed. We
+ don't require it as a dependency, and this breaks e. g. autopkgtests in
+ minimal environments.
+ * t/150_tsearch_stemming.t: Add tests for stemming/searching with non-ASCII
+ characters. (See #689997)
+ * debian/postgresql-common.triggers: Also trigger on
+ /usr/share/postgresql/, so that installation of new server versions builds
+ the corresponding dictionaries.
+ * init.d-functions, start(): Update SELinux label of /run/postgresql if
+ restorecon is installed. Thanks Martin Lang! (Closes: #737661)
+
+ -- Christoph Berg <christoph.berg@credativ.de> Thu, 06 Feb 2014 15:21:00 +0100
+
+postgresql-common (152) unstable; urgency=low
+
+ [ Martin Pitt ]
+ * debian/backport-ppa: Drop oneiric/quantal for -9.2, only keep
+ lucid/precise.
+ * Drop support for obsolete oom_adj, all kernels in all supported
+ Debian/Ubuntu releases support oom_score_adj. (See #646245)
+ * debian/README.Debian: Fix commands to get a postgres user shell.
+ * Change all "su" invocations to system user to specify an explicit shell,
+ to fix breakage after latest base-passwd 3.5.30 (which changed system
+ users to have no shell).
+ * Bump Standards-Version to 3.9.5 (no changes necessary).
+
+ [ Christoph Berg ]
+ * pg_virtualenv: Fix program name in manpage.
+ * pg_createcluster: --start-conf should override the value from
+ createcluster.conf.
+ * testsuite: Also mount a tmpfs on /etc/postgresql-common.
+
+ -- Martin Pitt <mpitt@debian.org> Thu, 09 Jan 2014 10:56:12 +0100
+
+postgresql-common (151) unstable; urgency=low
+
+ * pg_createcluster: Create /var/run/postgresql when missing.
+ * pg_virtualenv: Set PG_CONFIG in single version mode.
+ * pg_wrapper: Always use the latest available version of "pg_isready"
+ instead of the target cluster's. pg_isready appeared only in 9.3, but is
+ usable with older versions as well. Suggested by Peter Eisentraut.
+ (Closes: #728599)
+
+ -- Christoph Berg <myon@debian.org> Thu, 05 Dec 2013 16:32:51 +0100
+
+postgresql-common (150) unstable; urgency=low
+
+ [ Christoph Berg ]
+ * Create the postgres group when missing, and add the postgres user to it.
+ Could happen when the postgres user was created manually.
+
+ [ Martin Pitt ]
+ * debian/supported-versions: Welcome, Ubuntu 14.04! Support 9.3 there.
+
+ -- Martin Pitt <mpitt@debian.org> Mon, 21 Oct 2013 22:08:20 +0200
+
+postgresql-common (149) unstable; urgency=low
+
+ * debian/supported-versions: Set default version to 9.3. Drop 9.2 from
+ wheezy-backports.
+ * /etc/apt/apt.conf.d/01autoremove-postgresql: Mark ^postgresql- as
+ NeverAutoRemove, so upgrading the "postgresql" meta package doesn't
+ automatically remove access to the old clusters. (Closes: #714725)
+ * pg_wrapper: Print a more informative error message when program to execute
+ was not found in /usr/lib/postgresql.
+ * debian/postgresql-client-common.links: Wrap pg_isready and pg_receivexlog.
+
+ -- Christoph Berg <myon@debian.org> Mon, 09 Sep 2013 14:15:18 +0200
+
+postgresql-common (148) unstable; urgency=low
+
+ [ Christoph Berg ]
+ * debian/supported-versions:
+ + Interface change: The *last* version returned here is the "default" one.
+ + Wheezy uses "7" in /etc/os-release.
+ + Add 9.3 for pgdg (default on testing/unstable).
+ * debian/rules:
+ + Set FLAVOR variable for the type of build we are doing. Set
+ PG_SUPPORTED_VERSIONS=$FLAVOR for debian/supported-versions so we don't
+ pick up configuration from the build environment.
+ + Pick the default version from the last line of
+ `debian/supported-versions` instead of sorting the output.
+ * debian/postgresql-common.config: Sort versions to determine the latest.
+ * pg_buildext: Support "X.Y+" and "all" in debian/pgversions so packages do
+ not need to hardcode the versions they support, as that's usually not
+ necessary.
+ * pgxs_debian_control.mk: Drop the previously redundant grep check on
+ debian/pgversions which would now break "X.Y+".
+ * t: Move $delay to TestLib.pm and increase to 500ms.
+ * t/005_PgCommon.t: Use twice the delay for waiting for the first nc child.
+
+ [ Martin Pitt ]
+ * debian/postgresql-common.postinst: Don't restart servers in dict update
+ trigger. (Closes: #719282)
+ * debian/README.Debian: Update examples for -9.1 and -9.3.
+
+ -- Martin Pitt <mpitt@debian.org> Tue, 27 Aug 2013 11:07:48 +0200
+
+postgresql-common (147) unstable; urgency=low
+
+ * Bump "really142" to "really146" to fix an error on apt.postgresql.org.
+
+ -- Christoph Berg <myon@debian.org> Thu, 18 Jul 2013 09:11:38 +0200
+
+postgresql-common (146) unstable; urgency=low
+
+ [ Christoph Berg ]
+ * debian/supported-versions: Use "7.*" to recognize wheezy; point releases
+ now increment the second version number component. (Closes: #712586)
+ * pg_virtualenv:
+ + On error, show tail of server log file.
+ + When no command is given, open a shell.
+ * pg_createcluster: Add --createclusterconf and --environment options.
+ * pg_ctlcluster: Create stats_temp_directory when missing.
+ * pg_ctlcluster: You must run this program as the cluster owner ... or root.
+ * postgresql-common: Demote dependency on logrotate to recommends.
+ (Closes: #714982).
+
+ [ Peter Eisentraut ]
+ * PgCommon.pm, pg_createcluster, pg_dropcluster: Don't call external
+ programs with full path where not necessary.
+
+ -- Christoph Berg <myon@debian.org> Tue, 16 Jul 2013 16:11:35 +0200
+
+postgresql-common (145) unstable; urgency=low
+
+ [ Christoph Berg ]
+ * pg_ctlcluster: Use "install" instead of File::Path to create
+ unix_socket_directory. (Introduced in 141, Closes: #710093)
+
+ [ Martin Pitt ]
+ * debian/maintscripts-functions, configure_cluster(): Do not trust the
+ locale from the environment, as programs like ssh and sudo propagate
+ remote and user locale by default. Instead, only use the locale settings
+ from /etc/environment and /etc/default/locale, to prevent trying to
+ configure the default cluster with a nonexisting or hard to predict
+ locale. (LP: #969462, also see Debian #700271)
+
+ -- Christoph Berg <myon@debian.org> Mon, 10 Jun 2013 17:01:01 +0200
+
+postgresql-common (144) unstable; urgency=low
+
+ * testsuite: Allow overriding the list of versions to test (-v).
+ * 040_upgrade: Add a test case for #688960 ("OLD used in query that is not
+ in a rule").
+ * pg_upgradecluster: Add --quote-all-identifiers to the pg_dump(all)
+ invocations so pg_dump-style upgrades do not fail when keywords get
+ un-reserved. (Closes: #688960; the pg_upgrade part of this will be fixed
+ in PostgreSQL upstream.)
+ * pg_ctlcluster: Add --mode shutdown option.
+ * pg_virtualenv: Allow running as non-root user.
+
+ -- Christoph Berg <myon@debian.org> Fri, 31 May 2013 21:37:47 -0700
+
+postgresql-common (143) unstable; urgency=low
+
+ * debian/supported-versions: Don't explicitly support 9.3 for
+ testing/unstable yet, it is still in experimental. (Closes: #707675)
+ * debian/rules: Hack the version number of the metapackages to be
+ 9.3+142really9.1-..., so that they are bigger than the previous botched
+ versions. This needs to stay until 9.3 actually goes into unstable.
+
+ -- Martin Pitt <mpitt@debian.org> Fri, 10 May 2013 17:53:49 +0200
+
+postgresql-common (142) unstable; urgency=low
+
+ [ Christoph Berg ]
+ * Make all scripts honor PGSYSCONFDIR (defaulting to
+ /etc/postgresql-common).
+ * The default behavior of pg_createcluster can be configured in
+ /etc/postgresql-common/createcluster.conf. This also allows to disable the
+ creation of "main" clusters when postgresql server packages are installed,
+ and to set parameters in the new postgresql.conf.
+ * pg_createcluster: Move setting of log_line_prefix to createcluster.conf.
+ * debian/postgresql-common.postgresql.init: Do not die of one cluster fails
+ to start. (Closes: #699911)
+ * pg_checksystem: Suppress error message for unavailable filesystems.
+ (Closes: #705219)
+ * pg_upgradecluster: Use a distinct name (pg_hba.conf.pg_upgradecluster) for
+ the pg_hba.conf backup, and handle the case where this file already exists
+ gracefully.
+ * pg_upgradecluster: On upgrades to 9.3, rename unix_socket_directory to
+ unix_socket_directories.
+ * pg_upgradecluster, t/043_upgrade_ssl_cert.t: Copy server.crt and friends
+ in the data directory on upgrade. (Closes: #698958)
+ * pg_ctlcluster: Set LANG so non-ascii chars in the server log are not
+ replaced by '?'. Thanks to Adrian Vondendriesch for help debugging this.
+ (Closes: #671915)
+
+ [ Martin Pitt ]
+ * debian/supported-versions: Add 9.3 for testing/unstable.
+ * debian/supported-versions: Add Ubuntu 13.10.
+ * Bump Standards-Versio to 3.9.4 (no changes necessary).
+ * pg_upgradecluster: For upgrades to 9.3, migrate "replication_timeout" to
+ "wal_sender_timeout".
+ * t/060_obsolete_confparams.t: Add full 9.2 configuration, to test 9.2 → 9.3
+ upgrades.
+
+ -- Martin Pitt <mpitt@debian.org> Tue, 07 May 2013 11:11:58 +0200
+
+postgresql-common (141) experimental; urgency=low
+
+ [ Christoph Berg ]
+ * debian/maintscripts-functions: Fix configure_client_version to call
+ _link_manpages correctly, spotted by Kris Shannon. (Closes: #701602)
+ * debian/postgresql-common.sysctl: Note that the file is Linux-specifc and
+ do some rewording of the comments.
+ * debian/supported-versions:
+ + Deprecate 8.3 for pgdg builds.
+ + Handle missing os-release and lsb_release gracefully, just print a
+ warning. (Affects squeeze systems, Introduced by the fix for #697182).
+ * pg_buildext: Deprecate <srcdir> parameter. The docs do not mention it
+ anymore, but the script will still accept it.
+ * pg_createcluster, pg_upgradecluster: For 9.2 and higher, use the new
+ ssl_ca_file option instead of creating a root.crt symlink in the data
+ directory. (Related to the fix for #680162 below.)
+ * pg_createcluster: If /etc/postgresql-common/root.crl is present, symlink
+ it (<= 9.1), or set ssl_crl_file (>= 9.2).
+ * pg_ctlcluster: Create (first) unix_socket_directory if missing.
+ * pg_ctlcluster: Document start.conf by pointing at pg_createcluster(8).
+ * pg_lsclusters: Make output column widths dynamically adjust to contents;
+ shorten "Version" in header to "Ver".
+ * pg_upgradecluster: Get cluster encoding before shutting down the cluster
+ so we don't need to restart it in pg_upgrade mode; temporarily start the
+ cluster if needed.
+ * postgresql-client-common: For apt.postgresql.org builds (with "pgdg" in
+ the version number), depend on pgdg-keyring.
+ * Add a "apt.postgresql.org.sh" script to add that archive to sources.list.
+
+ [ Martin Pitt ]
+ * debian/backport-ppa: Stop building raring packages. The PPA is declared
+ deprecated now, moving to apt.postgresql.org.
+ * pg_createcluster: Drop "Moving configuration file.." message as it's not
+ all that interesting and we are going to add more status output.
+ * pg_createcluster: Print configuration and data directory on separate
+ lines, and also show the current locale that the cluster will use.
+ (Closes: #700271)
+ * pg_updatedicts: Cleanup tsearch data files which do not have a
+ corresponding hunspell or myspell dictionary installed any more.
+ (Closes: #689996)
+ * Adjust upgrade tests according to the changed pg_lscluster formatting.
+
+ [ Peter Eisentraut ]
+ * Add support for pg_upgrade: (Closes: #682938)
+ - pg_upgradecluster: Add options to select pg_upgrade instead of
+ dump/restore, and call pg_upgrade when selected.
+ - t/040_upgrade.t: Test all upgrade methods.
+
+ -- Christoph Berg <myon@debian.org> Wed, 10 Apr 2013 16:25:06 +0200
+
+postgresql-common (140) experimental; urgency=low
+
+ [ Martin Pitt ]
+ * t/001_packages.t: Also check that -contrib is installed.
+ * debian/backport-ppa: Backport -common for Ubuntu 12.10.
+ * PgCommon.pm: Recognize "include_if_exists" directive. (LP: #1098986)
+ * pg_ctlcluster: Recreate a missing /var/log/postgresql/ if needed.
+ (LP: #1009989)
+ * debian/postgresql-client-common.links: Wrap pgbench with pg_wrapper.
+ (LP: #1068194)
+
+ [ Christoph Berg ]
+ * testsuite: The default list of umasks to test (022 077) can be overridden
+ by setting the environment variable PG_UMASKS.
+ * t/003_package_checks.t: Ensure psql is linked against libedit.
+ * t/005_PgCommon.t: Increase sleep time after netcat launch to 200ms.
+ * t/020_create_sql_remove.t: Test process title update.
+ * pg_createcluster: Allow passing of initdb arguments on the command line.
+ If --auth parameters are passed, skip updating the generated pg_hba.conf
+ file.
+ * pg_virtualenv: Allow passing initdb arguments to pg_createcluster.
+ * pg_upgradecluster: Print a helpful message when invoked on the target
+ version. Problem seen on #postgresql.
+ * t/030_errors.t: Adjust testsuite for this.
+ * debian/supported-versions: Handle unset variables from /etc/os-release
+ gracefully. Spotted by x4rlos on #postgresql.
+ * pg_buildext: Set USE_PGXS=1, and srcdir (needed by plr).
+
+ -- Christoph Berg <myon@debian.org> Thu, 31 Jan 2013 10:36:41 +0100
+
+postgresql-common (139) experimental; urgency=low
+
+ [ Christoph Berg ]
+ * pg_virtualenv: New program to create throw-away clusters for running
+ regression tests.
+ * testsuite: unshare needs "--" or else it eats our options.
+ * testsuite: Require netcat-openbsd to be installed.
+ * testsuite: Move locale generation here from debian/tests/system, also
+ generate en_US.utf8 locale; unset LC_ALL.
+ * Drop debian/tests, moved to the postgresql-* server packages.
+ * testsute 005_PgCommon: Do the ipv4 tests before the ipv6 ones; skip
+ the ipv6 for perl <= 5.10 (i.e. on squeeze and lucid).
+ * PgCommon.pm, pg_ctlcluster, pg_createcluster, t/030_errors.t: 9.3 renames
+ unix_socket_directory to unix_socket_directories.
+ * pg_wrapper: Document that PGHOST overrides PGCLUSTER. (Closes: #697291)
+ * pg_wrapper: Skip cluster selection if --host is given on the command line.
+ (Closes: #637017) While we are at it, improve --port parsing, too.
+ * t/010_defaultport_cluster.t: Add test cases for the above pg_wrapper
+ changes.
+ * t/040_upgrade.t: dup2 psql stderr to suppress warning 'could not change
+ directory to "/tmp/pgtest'.
+ * postgresql-client-common: Add Depends: netbase for getprotobyname() in
+ PgCommon.pm. (Closes: #697377)
+
+ [ Martin Pitt ]
+ * debian/supported-versions: Read /etc/os-release if present, and fall back
+ to lsb-release. Exit with a proper error message if neither is present.
+ This gets rid of the (currently undeclared) strict dependency on
+ lsb-release. (Closes: #697182)
+ * debian/README.Debian: Update versions to 8.4/9.1, as current for Squeeze
+ and Wheezy. (Closes: #697239)
+
+ -- Christoph Berg <myon@debian.org> Sun, 06 Jan 2013 10:24:49 +0100
+
+postgresql-common (138) experimental; urgency=low
+
+ [ Christoph Berg ]
+ * testsuite: start localhost interface which is down after unshare -n.
+
+ [ Martin Pitt ]
+ * testsuite: Stop currently running clusters, just as the script has done
+ until 136.
+ * testsuite: Use a more elegant way of re-execing ourselves through unshare.
+
+ -- Martin Pitt <mpitt@debian.org> Sun, 16 Dec 2012 18:57:12 +0100
+
+postgresql-common (137) experimental; urgency=low
+
+ [ Martin Pitt ]
+ * debian/backport-ppa: Disable xz compression for lucid.
+ * debian/backport-ppa: Disable libraries for -9.1/natty as well, built by
+ 9.2 now.
+ * debian/backport-ppa: Ensure that backport PPA versions are always smaller
+ than the versions in -updates.
+ * pg_wrapper: Always use the latest available client version of "psql"
+ instead of the target cluster's. psql is backwards compatible to all major
+ versions that we support in any release. Update tests to use "createdb"
+ instead of "psql" for --version tests, and add a new test for the psql
+ special case to t/020_create_sql_remove.t. (Closes: #639108)
+ * debian/postgresql-common.triggers: Also watch for changes in
+ /usr/share/hunspell/; pg_updatedicts handles these as well.
+ (Closes: #689994)
+ * debian/tests/control: Add netcat-openbsd test dependency for the
+ next_free_port() tests added below.
+ * debian/backport-ppa: Drop natty (EOL), add raring for 9.2.
+ * debian/supported-versions: Add Ubuntu 13.04.
+ * testsuite: Run with overlaid tmpfses on the postgresql /etc/ and /var
+ directories in an unshared namespace. This is more robust against
+ protecting existing clusters, always cleans up after itself properly, and
+ also speeds up testing.
+ * t/031_errors_disk_full.t: Drop check for existence of unshare, as
+ ./testsuite now unconditionally requires it.
+ * debian/postgresql-common.postinst: Only chown /var/lib/postgresql if it
+ does not already have the correct ownership. This avoids failures when the
+ directory is NFS mounted. Thanks Hugh Davenport! (Closes: #693958)
+
+ [ Christoph Berg ]
+ * testsuite: Move 'disk full' tests from 030_errors to new file
+ 031_errors_disk_full.
+ * testsuite: Note that Test::More 0.87 is required for done_testing() in
+ 170_extensions.
+ * testsuite 005_PgCommon: Add next_free_port tests (using /bin/nc).
+ * supported-versions: Make output configurable via $PG_SUPPORTED_VERSIONS,
+ ~/.pg_supported_versions, and /etc/postgresql-common/supported_versions.
+ (Closes: #646700)
+ * supported-versions: Add debian-backports and pgdg sections.
+ (Closes: #650680)
+ * For bpo and pgdg builds (determined by the version number), create
+ /etc/postgresql-common/supported_versions with appropriate content.
+ * Replace version string comparisions in perl scripts to use numerical
+ operators, so things will continue to work when PostgreSQL 10.0 is
+ released.
+ * debian/rules: Use sort -n for sorting supported-versions output.
+ * debian/rules: Use apt-cache policy instead of apt-cache show to determine
+ the "candidate" logrotate version.
+ * testsuite 020_create_sql_remove: Fix plperl test to work with 8.2.
+ * testsuite 085_pg_ctl.conf: Skip for 8.2.
+
+ -- Martin Pitt <mpitt@debian.org> Sat, 15 Dec 2012 21:32:30 +0100
+
+postgresql-common (136) experimental; urgency=low
+
+ [ Martin Pitt ]
+ * debian/backport-ppa: Do first upload with orig tarball, subsequent ones
+ without.
+ * debian/backport-ppa: Do not run lintian.
+ * debian/backport-ppa: When building postgresql-9.1 for lucid, drop the
+ library packages as they collide with the ones built from postgresql-9.2.
+ * debian/backport-ppa: Build 9.2 for Quantal and Natty.
+ * debian/supported-versions: Add Ubuntu 12.10.
+ * t/030_errors.t: For the "fails on insufficient disk space test", move from
+ setting up a loop device to a tmpfs in unshare -m. This is more robust for
+ cleaning up after itself, and faster as well.
+ * pg_ctlcluster: Fix log output to stderr if the log file started out being
+ empty. Add test case to t/030_errors.t.
+ * debian/maintscripts-functions: Only try to remove the tsearch_data
+ directory if it already exists. Thanks Peter Palfrader. (Closes: #688105)
+
+ [ Christoph Berg ]
+ * pg_buildext: Fix supported-versions not to die when the last version is
+ not supported.
+ * testsuite: Add getopt handling, and make the list of umasks to loop
+ through configurable (-u).
+ * t/001_packages.t: Print list of installed versions for information.
+ * As debian/supported-versions is also used at build-time, add a
+ build-dependency on lsb-release for lsb_release to be available. Also,
+ print supported versions from debian/rules for easier debugging.
+
+ -- Martin Pitt <mpitt@debian.org> Thu, 20 Sep 2012 09:04:26 +0200
+
+postgresql-common (135) experimental; urgency=low
+
+ [ Martin Pitt ]
+ * pg_createcluster: For 9.2 and higher, use the new ssl_{cert,key}_file
+ options instead of creating symlinks in the data directory.
+ (Closes: #680162)
+ * pg_upgradecluster: Set above options to the old cluster's SSL cert/key
+ symlink destinations, if they exist.
+ * debian/maintscripts-functions: Configure alternatives for manpages in
+ -contrib. This will only take effect after (re)installing
+ postgresql-contrib-9.2. (Closes: #680571)
+ * debian/postgresql-common.postgresql.init: Fix "status" output to be more
+ useful and legible, and exit with code 3 if any cluster is down.
+ (Closes: #656363)
+ * debian/postgresql-common.postgresql.init: Show a warning message if no
+ clusters exist. (Closes: #677604)
+ * t/041_upgrade_custompaths.t: Run test with a cluster that is down, to
+ verify that pg_upgradecluster works for non-running clusters, too.
+ * pg_upgradecluster: Move encoding detection after restarting the cluster
+ with restricted connections, and drop the check that the cluster is
+ running. With this, pg_upgradecluster also works for clusters which are
+ not running. (Closes: #681344)
+
+ [ Peter Eisentraut ]
+ * pg_createcluster: For PostgreSQL >= 9.2, use initdb options to set the
+ default authentication methods, instead of modifying the configuration
+ file directly. (Closes: #685043)
+
+ -- Martin Pitt <mpitt@debian.org> Fri, 17 Aug 2012 15:28:35 +0200
+
+postgresql-common (134) unstable; urgency=low
+
+ * debian/backport-ppa: Fix syntax error.
+ * PgCommon.pm: Drop unconditional import of Socket::IN6ADDR_ANY and only do
+ the IPv6 check if it is available. This keeps this version backwards
+ compatible with Debian/Ubuntu releases with older Perl versions.
+
+ -- Martin Pitt <mpitt@debian.org> Thu, 26 Jul 2012 21:29:48 +0200
+
+postgresql-common (133) unstable; urgency=low
+
+ [ Christoph Berg ]
+ * Add .bzrignore file.
+ * PgCommon.pm: Check IPv4 and IPv6 in next_free_port(). (Closes: #678858)
+
+ [ Peter Eisentraut ]
+ * debian/control: Add myself to Uploaders.
+ * debian/postgresql-common.lintian-overrides: Remove unused
+ binary-without-manpage overrides (files were moved to
+ postgresql-client-common package).
+ * debian/rules: Catch errors in for loops.
+ * pg_wrapper: Avoid Perl warnings if psql is linked against libreadline
+ instead of libedit, even though that is not standard anymore.
+ * testsuite: Reset core limit for pg_ctl tests.
+ * testsuite: Allow running individual tests by passing them on the
+ command line.
+
+ [ Martin Pitt ]
+ * pg_ctlcluster: Do not remove the PID file after SIGKILLing the
+ postmaster in the "last-ditch effort to shut down" in --force mode. This
+ is a potentially dangerous thing to do when trying to start a second
+ postmaster in parallel while the first one is still being shut down.
+ (see http://archives.postgresql.org/pgsql-general/2012-07/msg00475.php)
+
+ -- Martin Pitt <mpitt@debian.org> Thu, 26 Jul 2012 13:20:10 +0200
+
+postgresql-common (132) unstable; urgency=low
+
+ [ Martin Pitt ]
+ * debian/control: Add XS-Testsuite: header, as per current DEP-8.
+ * debian/tests/control: Drop undefined "no-build-needed" feature.
+
+ [ Christoph Berg ]
+ * Recognize "online,recovery" clusters in init script. (Closes: #678936)
+ Spotted by Gilbert Roulot.
+
+ -- Christoph Berg <myon@debian.org> Sat, 30 Jun 2012 21:31:49 +0200
+
+postgresql-common (131) unstable; urgency=low
+
+ [ Martin Pitt ]
+ * debian/backport-ppa: Adjust for lucid, build -9.2 for oneiric as well.
+ * debian/control: Move bzr branches to alioth, so that other members of
+ pkg-postgresql can commit. Update Vcs-* tags.
+ * debian/control: Set Maintainer: to pkg-postgresql group, and move myself
+ to Uploaders:.
+ * debian/README.Devel: Update for moved packaging branches.
+ * debian/backport-ppa: Disable dpkg 1.16.2 build dependency for natty as
+ well.
+ * debian/tests/control: Drop "breaks-computer" restriction. While DEP-8
+ mentions it, autopkgtest does not understand it yet and skips the test.
+ * debian/tests/system: Run testsuite under en_US.UTF-8, as autopkgtests sets
+ it to C by default.
+ * t/180_ecpg.t: Ensure that test.pgc is readable for nobody.
+ * debian/tests/system: Run the packaged tests instead of the ones in the
+ local build tree.
+ * debian/tests/system: Unset $TMPDIR so that 'postgres' and 'nobody' do not
+ fall over the autopkgtest provided $TMPDIR which is not world writable.
+ * t/030_errors.t: Fix nonzero exit code which caused stderr output.
+
+ [ Christoph Berg ]
+ * pg_buildext: Also set DESTDIR and VPATH for the configure, build and clean
+ targets.
+ * Add myself to Uploaders.
+
+ -- Martin Pitt <mpitt@debian.org> Tue, 19 Jun 2012 19:26:12 +0200
+
+postgresql-common (130) unstable; urgency=low
+
+ [ Christoph Berg ]
+ * pg_ctlcluster: Add 'promote' action.
+ * pg_updatedicts: Fix a typo.
+ * pg_lsclusters, PgCommon.pm: Show "recovery" in status column.
+ * pg_createcluster: Fix a doc typo.
+
+ [ Martin Pitt ]
+ * Add support for 9.2:
+ - pg_createcluster: Add 9.2 configuration method.
+ - t/060_obsolete_confparams.t: Add full configuration for 9.1 to test the
+ configuration update to 9.2.
+ - pg_upgradecluster: On upgrades to 9.2, deprecate the 'wal_sender_delay',
+ 'silent_mode', and 'custom_variable_classes' postgresql.conf options, as
+ they do not exist any more.
+ - pg_upgradecluster: In the tablespace test, don't query the "spclocation"
+ column, which does not exist any more in 9.2. Just check whether we have
+ any table space other than the two default ones.
+ - t/050_encodings.t: Adjust expected "invalid UTF-8" error to also match
+ the 9.2 format.
+ - t/170_extensions.t: Adjust the "hstore" exfail to only apply to 9.1.
+ 9.2's version works without a warning.
+ * debian/backport-ppa: Update Ubuntu releases.
+
+ -- Martin Pitt <mpitt@debian.org> Tue, 15 May 2012 13:44:17 +0200
+
+postgresql-common (129) unstable; urgency=low
+
+ * pg_ctlcluster: Fix wrong configuration file name in documentation, thanks
+ Peter Eisentraut. (Closes: #653098)
+ * t/050_encodings.t: Add alternative Russian translation for expected error
+ message, to match against what 9.1.3 has.
+ * debian/copyright: Update to official 1.0 format.
+ * debian/control: Bump Standards-Version to 3.9.3.
+
+ -- Martin Pitt <mpitt@debian.org> Tue, 06 Mar 2012 12:00:12 +0100
+
+postgresql-common (128) unstable; urgency=low
+
+ * debian/backport-ppa: Make this work for postgresql-X.Y packages, too.
+ * debian/postgresql-client-common.links: Wrap pg_basebackup.
+ (Closes: #647224)
+ * pg_buildext: Fix wrong exit code if "pgversions" does not exist.
+ (Closes: #646698)
+ * pgxs_debian_control.mk: Some robustifications: Write to temporary control
+ file first and rename only after everything succeeds, otherwise delete it.
+ Catch errors from pg_buildext and abort the build. (Closes: #646702)
+ * pg_buildext, pg_buildext.pod: If second parameter (srcdir) is not
+ specified, assume the current directory. (Closes: #646712, part 1)
+ * pgxs_debian_control.mk: Drop $(SRCDIR) requirement so that this doesn't
+ need to be set separately. Just use $(CURDIR). (Closes: #646712, part 2)
+
+ -- Martin Pitt <mpitt@debian.org> Wed, 21 Dec 2011 12:04:01 +0100
+
+postgresql-common (127) unstable; urgency=low
+
+ * debian/backport-ppa: Add oneiric.
+ * logrotate 3.8 landed in unstable, rebuild against this to get a proper
+ logrotate config snippet and adjust the depends/breaks. (See Debian
+ #640493)
+ * debian/rules: Fix logrotate dependency generation logic to only consider
+ the most recent logrotate version.
+
+ -- Martin Pitt <mpitt@debian.org> Tue, 06 Dec 2011 06:18:32 +0100
+
+postgresql-common (126) unstable; urgency=low
+
+ * pg_ctlcluster: Prefer setting oom_score_adj over oom_adj, as the latter is
+ deprecated. (Closes: #646096)
+ * Add debian/tests/{control,system}: DEP-8/autopkgtest control files for
+ running the integration tests.
+ * t/020_create_sql_remove.t: Set stdin for forked psql process, so that the
+ test suite run does not need a defined stdin.
+ * debian/control: Clean up metapackage descriptions. (Closes: #649400)
+
+ -- Martin Pitt <mpitt@debian.org> Fri, 25 Nov 2011 11:20:29 +0100
+
+postgresql-common (125) unstable; urgency=low
+
+ * Add debian/backport-ppa: Script to generate and upload backport packages
+ to my Ubuntu PPA. Only for personal use.
+ * Add t/160_alternate_confroot.t: Test creation, operation, upgrading, and
+ removal of clusters as user nobody using $PG_CLUSTER_CONF_ROOT. This
+ reproduces LP#835630 and other bugs.
+ * PgCommon.pm: If $PG_CLUSTER_CONF_ROOT is set, untaint it.
+ * pg_upgradecluster: Don't hardcode /etc/postgresql/, use
+ $PgCommon::confroot to respect $PG_CLUSTER_CONF_ROOT. (LP: #835630)
+ * pg_upgradecluster: Add --logfile option to specify a custom log file for
+ the upgraded cluster. Necessary if you want to run this on
+ per-user clusters and can't write into /var/log/postgresql/.
+ * pg_ctlcluster: When starting as root for >= 9.1, adjust the OOM killer
+ protection to -16, so that the postmaster does not get OOM-killed so
+ easily (as it appears to claim all the shared memory). 9.1.1-3 and later
+ resets oomadj of child processes to 0, so that the client backends can
+ still get OOM-killed. Add tests to t/020_create_sql_remove.t.
+ (LP: #854590)
+ * debian/control: Add Breaks: to postgresql-9.1 versios before 9.1.1-3, as
+ they do not reset oomadj for child processes. This is a precaution to
+ avoid running all the client backends with -16 as well.
+ * Add t/170_extensions.t: Check that all shipped extensions install and
+ remove.
+ * Add t/180_ecpg.t: Check that ecpg works. In t/001_packages.t, check that
+ libecpg-dev is installed.
+
+ -- Martin Pitt <mpitt@debian.org> Thu, 20 Oct 2011 12:17:30 +0200
+
+postgresql-common (124) unstable; urgency=medium
+
+ * Keeping urgency medium, as 123 did not make it into testing yet.
+ * PgCommon.pm, cluster_info(): Use /bin/ps instead of reading /proc/*/comm,
+ the latter was reported to not work on some systems.
+ * pg_ctlcluster: Use PgCommon::check_pidfile_running and drop duplicated
+ code.
+ * pg_wrapper: The previous multiarch globbing was wrong, as it looked for
+ the architecture in uname() (which doesn't work on i386, where uname says
+ i686). Now get the multiarch library path from whereever psql expects
+ libedit.so to be, so that this even works if you install postgresql-client
+ for a foreign architecture.
+
+ -- Martin Pitt <mpitt@debian.org> Sat, 08 Oct 2011 11:48:46 +0200
+
+postgresql-common (123) unstable; urgency=medium
+
+ * Urgency medium, as bug 644078 slipped into testing, and is quite a nasty
+ regression for people that it affects.
+ * t/001_packages.t: Check that the -plpython3 package is installed for
+ >= 9.1.
+ * t/020_create_sql_remove.t: Check that the "plpython3u" language works.
+ * t/020_create_sql_remove.t: More thoroughly check PL/Perl and PL/PerlU.
+ * PgCommon.pm, cluster_info(): If we have a PID file and can read it (i. e.
+ as root), prefer doing this over probing the port. This delivers the
+ correct result with e. g. "pg_ctlcluster restart" when the port got
+ changed in the configuration file. (Closes: #643850)
+ * pg_wrapper: Drop dpkg-architecture call; we don't want to introduce a
+ dependency to dpkg-dev, and DEB_HOST_MULTIARCH also isn't available in
+ backports. Just extend the libreadline.so globbing to cover multiarch
+ paths as well. (Closes: #644078)
+ * t/070_non_postgres_clusters.t: Test pg_upgradecluster. This reproduces
+ #644477.
+ * pg_upgradecluster: Supply socket argument for the tablespace test. Thanks
+ to Piotr Szydełko for the patch! (Closes: #644477)
+
+ -- Martin Pitt <mpitt@debian.org> Fri, 07 Oct 2011 14:10:27 +0200
+
+postgresql-common (122) unstable; urgency=low
+
+ * debian/control: Fix duplicate package description. (Closes: #639562)
+ * debian/control: Add lsb-release dependency to -server-dev-all, as the
+ pg_buildext tool needs it.
+ * pg_wrapper: Find libreadline in multiarch directory, too.
+ (Closes: #640520)
+ * debian/rules: logrotate 3.8.0 requires specifying the "su" option, which
+ is not backportable. Dynamically check the available logrotate version,
+ and add it if it is >= 3.8. Also dynamically generate a dependency or
+ breaks to logrorate 3.8+. (Closes: #640493)
+ * PgCommon.pm: Allow '@' characters in LC_CTYPE/LC_COLLATE values. Thanks to
+ Willi Mann for the patch. (Closes: #640031)
+ * pg_upgradecluster: Print message for running the upgrade.d scripts, thanks
+ Karsten Hilbert.
+ * t/040_upgrade.t: Add test case for a database with read only default
+ transactions. Reproduces #599085.
+ * pg_upgradecluster: Set superuser configuration value of
+ 'default_transaction_read_only' to 'off' during the upgrade, so that
+ upgrading databases with read only default transactions actually works.
+ Thanks Karsten Hilbert for the suggestion. (Closes: #599085)
+ * t/040_upgrade.t, pg_upgradecluster: Consistently use upper case for SQL
+ keywords.
+ * Correct wrong bug reference in previous changelog.
+
+ -- Martin Pitt <mpitt@debian.org> Sun, 25 Sep 2011 21:38:20 +0200
+
+postgresql-common (121) unstable; urgency=low
+
+ [ Martin Pitt ]
+ * debian/supported-versions: Switch Ubuntu 11.10 to 9.1 (LP: #833684) and
+ also preemtively add Ubuntu 12.04 (which will ship with 9.1, too).
+ * debian/control: Bump Standards-Version to 3.9.2, no changes necessary.
+ * debian/rules: Call dh_installinit with -r to avoid restarting on upgrade.
+ (Closes: #639140)
+ * debian/control: Wrap dependencies.
+ * debian/control, debian/rules: Convert from cdbs to dh, and bump
+ Standards-Version to 7.
+ * debian/control, debian/rules: Build the versionless metapackages from this
+ source instead of the current postgresql-X.Y source. This behaves better
+ with backports. Thanks to Christoph Berg for the suggestion.
+ * debian/postgresql-common.lintian-overrides: Don't complain about missing
+ manpage for pg_config, it's shipped by libpq-dev.
+ * debian/control: Update description of the metapackages to actually say
+ "metapackage" to quiesce lintian.
+ * Split POD of pg_buildext into pg_buildext.pod, and update debian/rules to
+ build the manpage from there. Fixes lintian "shell syntax failure"
+ error.
+
+ [ Peter Eisentraut ]
+ * pg_createcluster:
+ - Use "peer" instead of "ident" on local socket connections from 9.1 on.
+ - Apply pg_hba.conf adjustments to replication connections as well.
+ - (Closes: #639016)
+
+ -- Martin Pitt <mpitt@debian.org> Sat, 27 Aug 2011 14:01:11 +0200
+
+postgresql-common (120) unstable; urgency=low
+
+ * PgCommon.pm, cluster_info(): Do not consider external_pid_file
+ configuration as valid if it is '(none)'. Fixes test suite regression in
+ version 119.
+ * debian/supported-versions: Switch to 9.1 as default and testing/unstable
+ supported version. This will also cause -server-dev-all to only pull in
+ -9.1.
+ * PgCommon.pm: Partially revert changes for #606336: postmaster does not
+ clean up the PID file when it stops, and it is not world readable, so only
+ its absence is a definitive result. If the PID file is present, do the
+ port probe to check if it is really running.
+
+ -- Martin Pitt <mpitt@debian.org> Tue, 23 Aug 2011 14:05:09 +0200
+
+postgresql-common (119) unstable; urgency=low
+
+ [ Martin Pitt ]
+ * PgCommon.pm, set_conf_value(): Fix the case where a key exists first as a
+ commented value, and then uncommented. Add appropriate test cases to
+ t/005_PgCommon.t. (Closes: #539651)
+ * debian/postgresql-common.postgresql.init: Fix "status" command when some
+ clusters are down. (Closes: #635594)
+ * pg_upgradecluster: Only call pg_ctl with the -t option with old clusters
+ >= 8.4, as earlier versions do not yet support it. (Closes: #633801)
+ * debian/postgresql-common.postinst: Remove some obsolete transition
+ logic.
+ * architecture.html, cleanpg, debian/init.d-functions, pg_createcluster:
+ Remove obsolete references to per-version init scripts. (Closes: #636957)
+ * debian/maintscripts-functions: Remove our tsearch data symlinks on
+ removal. (Closes: #539611)
+ * PgCommon.pm: Make {read,set,disable,replace}_conf_value() case
+ independent for *.conf files, as per upstream specification. Add
+ appropriate test cases to t/005_PgCommon.t. (Closes: #618577)
+ * PgCommon.pm: Make {read,set,disable,replace}_conf_value() accept "key
+ value" lines without '=', as this is optional as per upstream
+ specification. Add appropriate test cases to t/005_PgCommon.t. Thanks
+ to Frederic Junod for the original patch suggestion. (Closes: #618583)
+ * PgCommon.pm, cluster_info(): If postgresql.conf defines an external PID
+ file, check its existence for determining if a cluster is running, instead
+ of poking the port. This is more efficient, and also gives correct results
+ for overlapping port numbers. Based on a patch from Jens Wilke, thanks!
+ (Closes: #606336)
+ * pg_buildext: Apply various improvements from Christoph Berg, thanks!
+
+ [ Peter Eisentraut ]
+ * pg_createcluster: Update comment alignment to match existing file better.
+ (Closes: #632702)
+
+ -- Martin Pitt <mpitt@debian.org> Mon, 08 Aug 2011 15:31:17 +0200
+
+postgresql-common (118) unstable; urgency=low
+
+ * Update Catalan debconf translations, thanks Innocent De Marchi.
+ (Closes: #628370)
+ * t/050_encodings.t: Update \' escaping test case for 9.1, as this
+ finally has been deprecated.
+ * debian/control: Add p-server-dev-all dependency to p-common, so that
+ packages that build-dep on it get the pg_config wrapper.
+
+ -- Martin Pitt <mpitt@debian.org> Tue, 14 Jun 2011 14:52:08 +0200
+
+postgresql-common (117) unstable; urgency=low
+
+ * Update Dutch debconf translations, thanks Vincent Zweije.
+ (Closes: #627520)
+ * Add Catalan debconf translations, thanks Innocent De Marchi.
+ (Closes: #628370)
+ * debian/control, debian/rules: Let -server-dev-all depend on all supported
+ -server-dev-X.Y packages. (Closes: #624749)
+ * Add pg_config wrapper: If postgresql-server-dev-* is installed, this calls
+ pg_config from the latest available one. Otherwise this falls back to
+ libpq-dev's version. This should fix a common confusion for people who
+ want to build e. g. 9.0 server-side extensions with a newer (like 9.1
+ beta) libpq-dev installed. In debian/postgresql-common.{preinst,postrm}:
+ Divert libpq-dev's /usr/bin/pg_config to pg_config.libpq-dev.
+
+ -- Martin Pitt <mpitt@debian.org> Sun, 29 May 2011 19:22:27 +0200
+
+postgresql-common (116) unstable; urgency=low
+
+ * debian/supported-versions: Move Debian testing/unstable and Ubuntu 11.10
+ to 9.0.
+ * pg_upgradecluster: Revert to the previous encode()/decode() wrapping in
+ the "probin" fixup for cluster upgrades from versions < 9.0. Earlier
+ versions' replace() function indeed does work on bytea types, not strings,
+ so this broke upgrades to 8.4. (Closes: #627227)
+ * pg_upgradecluster: Drop all unversioned configuration option transitions,
+ which were still from the 7.4 → 8.0 days. These are obsolete, and
+ versions >= 96 only support clusters >= 8.1 anyway. In some cases they
+ actively break stuff, like inadvertently setting log_statement=all.
+ (Closes: #617493)
+ * t/060_obsolete_confparams.t: Fix remaining "{,log_}timezone=unknown"
+ example configuration files, to also fix upgrade tests for 8.4 → 9.1.
+
+ -- Martin Pitt <mpitt@debian.org> Thu, 19 May 2011 11:30:16 +0200
+
+postgresql-common (115) unstable; urgency=low
+
+ * Add Danish debconf translations, thanks Joe Dalton. (Closes: #619057)
+ * debian/README.Devel: Modernize a bit.
+ * pg_upgradecluster: In the "probin" fixup, drop the wrapping in
+ encode()/decode(). This has been wrong all the time, as the "probin"
+ column already is of "text" datatype, and now breaks with 9.1.
+ * Add support for 9.1:
+ - Add 9.1 configuration method to pg_createcluster.
+ - cleanpg: Stop 9.1 clusters.
+ - t/040_upgrade.t: Don't call createlang for upgrades from 9.0 on, as
+ PL/pgsql is enabled there by default.
+ - t/050_encodings.t: Update for changed error message for invalid usage of
+ \' in 9.1.
+ - t/060_obsolete_confparams.t: Add full configuration for 9.0 to test the
+ configuration update to 9.1.
+
+ -- Martin Pitt <mpitt@debian.org> Wed, 11 May 2011 09:40:00 +0200
+
+postgresql-common (114) unstable; urgency=low
+
+ * debian/supported-versions: Add Ubuntu 11.04. Drop versions which are newer
+ than the ones supported in the released versions, as backports are now
+ generally accepted by our .config scripts, but having those newer versions
+ confuses pg_buildext.
+ * debian/postgresql-common.config: Silence warning from --compare-versions
+ when being called through a trigger and $2 is not a version number.
+ This works around the underlying dpkg problem. (Closes: #608522)
+ * Add debian/postgresql-common.sysctl: sysctl.d/ template for changing
+ kernel.shmmax and kernel.shmall, which is very common with PostgreSQL.
+ Install it in debian/rules. Thanks to Peter Eisentraut for the suggestion!
+ (Closes: #607946)
+ * testsuite: Take new unified init script into account when stopping
+ existing clusters. Thanks Steve Beattie! (LP: #712200)
+ * pg_wrapper: If libreadline is installed, LD_PRELOAD this for "psql", to
+ avoid using the rather broken libedit. We need to build the postgresql-X.Y
+ packages against libedit for license reasons (#603599), but as libreadline
+ has a drop-in compatible ABI, this works around the licensing
+ restrictions. Thanks to Andreas Barth for working this out! Add a
+ recommends to libreadline6. (Closes: #608442, #607907, #607109, #611918)
+
+ -- Martin Pitt <mpitt@debian.org> Sun, 13 Feb 2011 22:28:33 +0100
+
+postgresql-common (113) unstable; urgency=medium
+
+ * Urgency medium, as this is a straightforward bug fix for an important
+ upgrade bug.
+ * debian/supported-versions: Split testing/squeeze and unstable cases. 9.0
+ is not officially supported in Squeeze and testing, it's only available as
+ a backport. This will make the "obsolete version installed" debconf note
+ point to 8.4 in squeeze, not 9.0. (Closes: #604423)
+
+ -- Martin Pitt <mpitt@debian.org> Sat, 04 Dec 2010 15:04:40 +0100
+
+postgresql-common (112) unstable; urgency=medium
+
+ * Urgency medium since this fixes an RC bug.
+ * debian/changelog: Fix changelog entry in version 111 for #597654: init
+ script priority was fixed to S19, not S29.
+ * pg_ctlcluster: Also pass additional pg_ctl arguments in "stop" and
+ "reload" mode.
+ * pg_ctlcluster: Pass correct exit code from pg_ctl in case of errors.
+ * PgCommon.pm, get_db_encoding(): Fix uninitialized variable if psql fails.
+ * t/040_upgrade.t: Check that pg_upgradecluster exits early and gracefully
+ if the old cluster does not stop (usually because there are still active
+ connections to it). This reproduces #509050.
+ * pg_upgradecluster: Move stopping of old cluster and disabling connections
+ to it much ealier, and properly fail without starting the upgrade.
+ (Closes: #509050)
+ * debian/postgresql-common.preinst: Remove obsolete init script from
+ postgresql-8.3 for upgrades from Lenny. It provides "postgresql" which is
+ also provided by our common init script, and insserv chokes on this. Our
+ common init script handles 8.3 as well and will just take over. Note that
+ this is a policy violation, but we can't clean up in -8.3 since that does
+ not exist any more in Squeeze. (Closes: #591924)
+
+ -- Martin Pitt <mpitt@debian.org> Sun, 21 Nov 2010 13:52:25 +0100
+
+postgresql-common (111) unstable; urgency=high
+
+ * Urgency high since this fixes two RC bugs.
+ * t/030_errors.t: Check that pg_createcluster leaves the original one intact
+ if the cluster already exists, also when the original one is not running.
+ This reproduces #597097.
+ * pg_createcluster: Be more careful with cleaning up the created cluster if
+ an error occurs: Do not start the cleanup until we actually passed our
+ sanity checks and created files for the new cluster. Before, it would
+ erroneously remove an already existing cluster on a sanity check fail, if
+ that cluster happened to not be running at the time. (Closes: #597097)
+ * debian/supported-versions: Be more robust against lsb_release failing, e.
+ g. in the case where it is not fully configured yet. (Closes: #597561)
+ * debian/supported-versions: Drop check for /etc/debian_version if
+ lsb_release is not working/existing. Derivatives have debian_version as
+ well, and we don't actually evaluate it, so just print a meaningful error
+ message and go with the default versions.
+ * debian/rules: Put init script priority back to S19/K21 to match the
+ previous postgresql-8.4 init script. Fix the priorities on upgrade in
+ debian/postgresql-common.preinst. (Closes: #597654)
+
+ -- Martin Pitt <mpitt@debian.org> Wed, 22 Sep 2010 12:04:00 +0200
+
+postgresql-common (110) unstable; urgency=low
+
+ [ Martin Pitt ]
+ * t/080_start.conf.t: Update for common init.d script.
+ * debian/rules: Drop installation of lintian overrides and let dh_lintian do
+ it for us. Adapt override file accordingly.
+ * debian/control: Drop unnecessary debconf dependency from -client-common.
+ * Bump Standards-Version to 3.9.1, no changes necessary.
+ * debian/postgresql-common.postgresql.init: Fix force-reload, thanks Pascal
+ Volk. (Closes: #591185)
+ * debian/rules: Stop man page build/clean being package dependent.
+ * pg_buildext: Remove bashishms and convert to plain /bin/sh.
+
+ [ Dimitri Fontaine ]
+ * Add new package postgresql-server-dev-all:
+ - "pg_buildext" tool for easy building of extension packages for multiple
+ server versions.
+ - pgxs_debian_control.mk debian/rules include for generating
+ debian/control.
+
+ -- Martin Pitt <mpitt@debian.org> Sun, 01 Aug 2010 16:50:41 +0200
+
+postgresql-common (109) unstable; urgency=low
+
+ * pg_lsclusters: Fix "uninitialized value" warning when a cluster's data
+ directory is not set. This is a rather fatal problem anyway, but we can
+ present it in a nicer way. Thanks Christoph Berg! (Closes: #589014)
+ * Migrate to a common init script for all server versions, to avoid
+ providing the "postgresql" service in multiple packages (which causes
+ insserv to complain bitterly):
+ - debian/init.d-functions: Add function get_versions() which returns all
+ installed versions, but filters out the ones which have their own init
+ script. With that, we can run newer common versions with older server
+ packages.
+ - debian/maintscripts-functions: Add function stop_version() (to be called
+ from "prerm upgrade"), and start cluster in configure_version() if there
+ is no version specific init script.
+ - Add debian/postgresql-common.postgresql.init: Common init script for all
+ installed server versions.
+ - debian/rules: Install common init script.
+ - (Closes: #589524)
+ * Add debian/source/format: 3.0 (native).
+ * debian/control: Bump Standards-Version to 3.9.0 (no changes necessary).
+
+ -- Martin Pitt <mpitt@debian.org> Mon, 19 Jul 2010 23:20:13 +0200
+
+postgresql-common (108) unstable; urgency=low
+
+ * debian/supported-versions: Drop 8.3 from squeeze/unstable. Add 9.0 to all
+ Debian/Ubuntu versions to support backports.
+ * debian/README.Debian: Talk about 8.3 and 8.4, since those are the versions
+ relevant to squeeze installs and upgrades.
+ * pg_upgradecluster POD: Describe allowed characters in upgrade script file
+ names.
+ * debian/supported-versions: Add Ubuntu 10.10. Welcome, Maverick Meerkat!
+
+ -- Martin Pitt <mpitt@debian.org> Wed, 02 Jun 2010 10:42:17 +0200
+
+postgresql-common (107) unstable; urgency=low
+
+ [ Peter Eisentraut ]
+ * Add initial support for 9.0 (pre-release snapshots for now):
+ - cleanpg: Remove 9.0 clusters.
+ - pg_createcluster: Clone configure_8_4() as configure_9_0().
+ - pg_upgradecluster: Migrate obsolete/changed configuration parameters.
+ * pg_wrapper: Fix spelling.
+ * In maintainer scripts, instead of "#!/bin/sh -e" use a separate "set -e",
+ per lintian.
+ * debian/control: Bump Standards-Version to 3.8.4; no changes necessary.
+
+ [ Martin Pitt ]
+ * cleanpg: Do not remove the /var/log/postgresql/ directory itself, only its
+ contents, to avoid logcheck falling over.
+ * t/020_create_sql_remove.t: Do not consider $PG_GRANDPARENT_PID an unsafe
+ environment, it's set by 9.0 servers.
+ * t/060_obsolete_confparams.t: Add a full configuration for 8.4, so that
+ upgrades to 9.0 can be tested.
+ * t/052_upgrade_encodings.t: Specify 'C' locale when creating the ASCII
+ encoded test database for versions >= 8.4, otherwise we have a
+ locale/encoding mismatch.
+ * t/TestLib.pm: Abort tests on FAILURE=shell and the shell exits with
+ nonzero. This avoids endless followup error shells once it's clear that
+ the following ones are doomed anyway.
+ * PgCommon.pm: Add new function get_db_locales() which reads lc_ctype and
+ lc_locales for a particular database. This replaces the
+ get_cluster_locales() function for >= 8.4 server versions (which moved
+ from global to per-database locales).
+ * pg_upgradecluster: Use get_db_locales() instead of get_cluster_locales()
+ for upgrades from >= 8.4.
+ * pg_ctlcluster: Drop check for valid locales. We can only determine them
+ (using pg_controldata through get_cluster_locales()) for <= 8.3 clusters,
+ which are obsolete in sid/lenny. For >= 8.4 clusters, we need to start the
+ server to find out the locales, at which point the check is pointless.
+ * pg_upgradecluster: Run pg_restore with --disable-triggers when running in
+ --data-only mode. (Closes: #579768)
+ * t/020_create_sql_remove.t: We now assume that /var/log/postgresql/ always
+ exists, and is writable by the "postgres" user. Thus if we delete the log,
+ running "pg_ctlcluster start" should be able to recreate it. This fixes
+ the 020_create_sql_remove.t test failure in "umask 077" mode, and uncovers
+ some more inconsistencies wrt. log directory permissions.
+ * pg_createcluster, testsuite: Fix permissions of /var/log/postgresql/ if
+ this script creates it.
+
+ -- Martin Pitt <mpitt@debian.org> Mon, 03 May 2010 17:40:09 +0200
+
+postgresql-common (106) unstable; urgency=low
+
+ * t/001_packages.t: Check for ".utf8" locale instead of ".UTF-8". This
+ seems to be the new canonical spelling now.
+ * t/TestLib.pm, check_clean(): Require that /var/log/postgresql/ still
+ exists. If we remove it entirely, current versions of logcheck complain
+ loudly. This was already fixed a while ago in squeeze, this will ensure it
+ stays so. (Closes: #576180)
+ * t/040_upgrade.t: Check upgrade of database and table ACL, an ALTER
+ DATABASE option, and correct upgrading of a custom pg_hba.conf. This
+ reproduces #543506.
+ * pg_upgradecluster: Rework logic to use "pg_dumpall -s" instead of
+ "pg_dumpall -g", to also catch ACLs, global settings, and the like. Drop
+ manual database creation and encoding special-cases, since those are being
+ taken care of by the -s commands already. (Closes: #543506, #562676)
+ * pg_upgradecluster: Re-enable connections after the upgrade is done, not in
+ between.
+ * t/120_pg_upgradecluster_scripts.t: Upgrade scripts should not create
+ tables in the "init" phase, since they will be overwritten during
+ dump/restore. Change the test case to move table changes into the "finish"
+ phase, and update documentation in pg_upgradecluster to point out this
+ potential problem.
+ * debian/init.d-functions, status(): More appropriate output formatting for
+ "status" init script commands. (Closes: #522679)
+
+ -- Martin Pitt <mpitt@debian.org> Mon, 05 Apr 2010 17:58:25 +0200
+
+postgresql-common (105) unstable; urgency=low
+
+ * debian/postgresql-common.postinst: Fix upgrade failure if no tsearch
+ dictionaries exist. (Closes: #565966)
+
+ -- Martin Pitt <mpitt@debian.org> Wed, 20 Jan 2010 12:33:10 +0100
+
+postgresql-common (104) unstable; urgency=low
+
+ * pg_updatedicts: Process dictionaries from /usr/share/hunspell, too.
+ * debian/control: Add Vcs-* fields.
+ * Add standard license headers to all programs, and update copyright.
+ * debian/copyright: Update to DEP-5 (Machine-readable debian/copyright), and
+ drop Oliver's copyright, since there is nothing left that was written by
+ him.
+ * pg_updatedicts: Do not create system_<locale>.{affix,dict} symlinks any
+ more, but use the actual names that upstream PostgreSQL looks for (without
+ system_ prefix). This allows us to drop the system_ lookup patch from
+ PostgreSQL. Update t/150_tsearch_stemming.t accordingly and remove the old
+ system_* symlinks on upgrade in debian/postgresql-common.postinst.
+
+ -- Martin Pitt <mpitt@debian.org> Tue, 19 Jan 2010 23:16:21 +0100
+
+postgresql-common (103) unstable; urgency=low
+
+ * Move the lsb-release dependency of p-common to a recommends of
+ p-client-common. (Closes: #562642)
+ * Drop Oliver from Uploaders:, he has not been active any more for years.
+ * t/005_PgCommon.t: Add '.' to library search path, so that this prefers
+ testing PgCommon.pm from the source tree.
+ * t/005_PgCommon.t: Add test cases for {set,disable,replace}_conf_value().
+ * PgCommon.pm, replace_conf_value(): Do not append the new parameter if the
+ old is not found.
+ * PgCommon.pm, {set,disable,replace}_conf_value(): Intercept errors on
+ writing data (which could happen when running out of disk space). Write
+ into a new file and rename it in the end, instead of directly writing into
+ the original file. Thanks to Yann Dirson for the original patch.
+ (Closes: #549206)
+ * pg_createcluster: Change effective gid as well when setting the socket
+ directory, to avoid moving postgresql.conf's group to root (which would
+ happen with the previous change).
+ * Add t/042_upgrade_tablespaces.t: Test upgrading a cluster with
+ tablespaces. Since this is not currently supported (and hard to do in an
+ automated fashion due to the nature of tablespaces), just check that this
+ errors out with a sane message and does not do any damage.
+ * pg_upgradecluster: Add an early check for tablespaces. (Closes: #523574)
+ * pg_lsclusters: Fix undefined value if owneruid cannot be determined (which
+ can happen in special setups). Thanks to Daniel Pittman! (Closes: #541434)
+ * t/020_create_sql_remove.t: Verify permissions of the data and
+ configuration directories.
+ * pg_createcluster: Make /etc/postgresql/<version> and
+ /var/lib/postgresql/<version> owned by 'postgres', so that they can be
+ administrated with 'postgres' privileges. Update t/030_errors.t
+ accordingly. (LP: #236704, Closes: #525294)
+ * t/020_create_sql_remove.t: Check that a missing log file is recreated by
+ pg_ctlcluster (if it has enough permissions).
+ * pg_ctlcluster: Make re-creation of log file actually work. (LP: #391119,
+ #372476)
+
+ -- Martin Pitt <mpitt@debian.org> Wed, 30 Dec 2009 23:06:10 +0100
+
+postgresql-common (102) unstable; urgency=low
+
+ * debian/postgresql-common.postinst: Create /var/log/postgresql/ if it does
+ not exist, before trying to chown/chmod it.
+ * t/001_packages.t: Check that -server-dev-* is installed (for
+ t/140_pg_config.t)
+ * t/001_packages.t: Check that the system default locale is an UTF-8 one.
+ * debian/supported-versions: Add Ubuntu 10.04.
+ * t/050_encodings.t: Disable Russian error message encoding test for now,
+ since Russian translations were dropped upstream (too incomplete).
+
+ -- Martin Pitt <mpitt@debian.org> Mon, 14 Dec 2009 19:05:19 +0100
+
+postgresql-common (101) unstable; urgency=low
+
+ * debian/supported-versions: Only support 8.4 in Ubuntu 9.10. (LP: #403381)
+ * PgCommon.pm, change_ugid(): Fix taint error. (LP: #403693)
+ * Update Swedish debconf translations, thanks Martin Bagge!
+ (Closes: #539216)
+ * t/090_multicluster.t: Run psql error tests under LC_MESSAGES=C to not fail
+ under non-English locales.
+ * pg_upgradecluster: Do not try to migrate "stats_*" settings to
+ "track_counts" again if track_counts is already set. This led to disabling
+ autovacuum on a 8.3 → 8.4 migration. (Closes: #540351)
+ * pg_upgradecluster: Fix owner of pg_hba.conf after upgrade, to also work in
+ tight umask settings.
+ * debian/control: Bump Standards-Version to 3.8.3; no changes necessary.
+ * debian/control: Re-promote ssl-cert to Depends:. Dropping to recommends
+ does not buy anything and causes regressions. (Closes: #540982)
+
+ -- Martin Pitt <mpitt@debian.org> Sun, 06 Sep 2009 21:30:40 +0200
+
+postgresql-common (100) unstable; urgency=low
+
+ * t/005_PgCommon.t: Add test case for read_conf_file() for configuration
+ files with an include directive. This reproduces #535428.
+ * PgCommon.pm, read_conf_file(): Correctly handle includes.
+ (Closes: #535428)
+ * PgCommon.pm: Check environment variable $PG_CLUSTER_CONF_ROOT for an
+ alternative configuration root (default: /etc/postgresql/). For
+ testing/development purposes you can change this to point to e. g. your
+ home directory, so that you can use the postgresql-common tools without
+ root privileges. Thanks to Aidan Van Dyk for the suggestion and patch!
+ * pg_createcluster: If calling as non-root user, default to effective user
+ id for owneruid instead of root. This makes using $PG_CLUSTER_CONF_ROOT
+ more convenient.
+ * pg_wrapper: Document PG_CLUSTER_CONF_ROOT in the POD.
+ * debian/control: Add missing ${misc:Depends}.
+ * debian/control: Bump Standards-Version to 3.8.2; no changes necessary.
+
+ -- Martin Pitt <mpitt@debian.org> Sun, 05 Jul 2009 22:57:11 +0200
+
+postgresql-common (99) unstable; urgency=low
+
+ * Update Czech debconf translations, thanks Miroslav Kure.
+ (Closes: #534794)
+ * PgCommon.pm, cluster_info(): Do not set a default log file if the cluster
+ uses syslog for logging. Thanks Antti Merenluoto!
+ * debian/supported-versions: Add Ubuntu 9.10.
+ * t/030_errors.t: Fix "invalid pg_hba.conf" test for translated PostgreSQL
+ error message.
+
+ -- Martin Pitt <mpitt@debian.org> Sun, 28 Jun 2009 21:38:08 +0200
+
+postgresql-common (98) unstable; urgency=low
+
+ * debian/control: Add missing lsb-release dependency (which now ships the
+ lsb_release program). (Closes: #520992)
+ * Add support for 8.4 (pre-release snapshots for now):
+ - debian/supported-versions: Support 8.4 everywhere (for backports).
+ - cleanpg: Remove 8.4 clusters.
+ - pg_createcluster: Clone configure_8_3() as configure_8_4().
+ - t/060_obsolete_confparams.t: Add complete set of 8.3 configuration
+ options, to test configuration migration to 8.4.
+ - PgCommon.pm, get_cluster_locales(): Bail out if calling on 8.4 or later
+ cluster (where locales are not associated to clusters any more).
+ PgCommon.pm, get_cluster_databases(): Ignore lines from psql -Atl which
+ just describe access permissions.
+ - pg_ctlcluster: Only do locales check for <= 8.3 for now.
+ - "ident sameuser" does not exist any more in 8.4, just use "ident" from
+ 8.4 on.
+ - pg_createcluster: Do not symlink root.crt if
+ /etc/postgresql-common/root.crt does not have actual certificates (just
+ the help text), since 8.4 gets royally confused about the dummy one.
+ - pg_upgradecluster: Migrate obsolete/changed configuration parameters.
+ - t/020_create_sql_remove.t: Fix parsing of psql -Atl output for new 8.4
+ format.
+ - t/030_errors.t: 8.4 now fails on invalid pg_hba.conf, update
+ accordingly.
+ - t/050_encodings.t: Stop using pg_controldata for checking cluster
+ encoding. Just check psql -Atl.
+ * pg_upgradecluster: Don't call createdb/dropdb with -q; it got dropped in
+ 8.4 and is not necessary any more with 8.3 either.
+ * t/010_defaultport_cluster.t: Ensure that we run the test with
+ LC_MESSAGES=C, so that it succeeds in non-English locales, too.
+ * t/051_inconsistent_encoding_upgrade.t: Disable if the oldest available
+ cluster is 8.3 or newer; the test is not relevant there, and will fail.
+
+ -- Martin Pitt <mpitt@debian.org> Thu, 09 Apr 2009 21:58:35 -0700
+
+postgresql-common (97) unstable; urgency=low
+
+ * t/030_errors.t: Fix "no space left on device" test for non-English
+ locales.
+ * Add cleanpg: Script to remove all PostgreSQL related processes and files.
+ This isn't shipped in the package, just kept in the source as a developer
+ tool.
+ * debian/control: Update section to "database".
+ * debian/control: Bump Standards-Version to 3.8.1 (no changes required).
+ * t/TestLib.pm, deb_installed(): Properly close the dpkg file descriptor.
+ Thanks to Cyril Bouthors for pointing this out!
+ * t/001_packages.t: Check that postgres user is in the ssl-cert group.
+ Thanks to Cyril Bouthors for the patch!
+ * Added support for passing additional options to pg_ctl through a new
+ configuration file pg_ctl.conf, or as additional CLI arguments to
+ pg_ctlcluster. Add tests in t/085_pg_ctl.conf.t. Thanks to Cyril Bouthors
+ <cyril@bouthors.org> for the patch! (Closes: #492843)
+ * t/070_non_postgres_clusters.t: Update number of tests for new pg_ctl.conf
+ file.
+ * t/090_multicluster.t: Check that explicit port specification with
+ -p/--port/$PGPORT selects the right cluster in the case of multiple
+ existing clusters where none runs on the default port. This reproduces
+ #517527.
+ * pg_wrapper: Default to latest version if -p, --port, or $PGPORT is
+ specified, multiple clusters are available, and none is running on the
+ default port 5432. (Closes: #517527)
+
+ -- Martin Pitt <mpitt@debian.org> Mon, 23 Mar 2009 07:41:50 +0100
+
+postgresql-common (96) unstable; urgency=low
+
+ * debian/supported-versions: Add "Debian 5.0" aka Lenny.
+ (Closes: #509144)
+ * debian/README.Debian: Document port handling, and point to
+ relevant manpages and tools. (Closes: #508977)
+ * debian/README.Debian: Fix "confident" typo. (Closes: #512648)
+ * Drop pg_autovacuum handling, which was only necessary for 7.4 (8.0
+ and above have internal autovacuuming). This was kept for Lenny to
+ allow Etch backports. This also gets rid of pg_maintenance and
+ /etc/cron.d/postgresql-common. (Closes: #425914, #481025)
+ * Add debian/postgresql-common.preinst: Remove obsolete conffiles
+ (cronjob and /etc/postgresql-common/autovacuum.conf) on upgrade.
+ * Drop support for pre-8.1 clusters, together with all hacks and
+ workarounds for those. Add Conflicts: to postgresql-{7.4,8.0}, to
+ ensure that this version isn't used with ancient servers any more.
+ * t/030_errors.t: Check that clusters on the same port can run side
+ by side if they are using different Unix socket directories and
+ different TCP addresses. This reproduces #514132.
+ * pg_ctlcluster: Replace overly harsh port conflict check (which
+ broke clusters on the same port, but different Unix/TCP
+ namespaces) with a more modest one which just checks conflict on
+ the same Unix socket directory. Thanks to Bernd Helmle for the
+ patch! (Closes: #514132, #472627)
+ * debian/postgresql-common.postinst: Do not call pg_updatedicts with
+ full path (DP 6.1).
+ * pg_lsclusters, pg_upgradecluster: Fix forgotten "=back" after
+ itemize list in the POD. Thanks lintian.
+ * debian/compat, debian/control: Bump compat level to 6.
+ * pg_updatedicts: Ensure generated tsearch dictionaries are world
+ readable when being generated under umask 077.
+ * debian/README.Debian: Point out incompatibility between using the
+ upstream tools (initdb) and the Debian tools (pg_createcluster)
+ and give some recommendations. (LP: #138793)
+ * debian/maintscripts-functions: Unset $GREP_OPTIONS. Thanks to
+ Carlo Calderoni for noticing!
+
+ -- Martin Pitt <mpitt@debian.org> Sun, 15 Feb 2009 17:37:58 +0100
+
+postgresql-common (95) experimental; urgency=low
+
+ * Add automatic building of PostgreSQL tsearch/stem dictionaries:
+ - Add pg_updatedicts: Build dictionaries and affix files from installed
+ hunspell/myspell dictionary packages.
+ - Add t/150_tsearch_stemming.t: Test cases for pg_updatedicts, tsearch
+ functionality, and word stem handling.
+ - t/001_packages.t: Ensure that hunspell-en-us is installed, above new
+ test relies on it.
+ - debian/postgresql-common.install: Install pg_updatedicts.
+ - debian/rules: Create man page from pg_udpatedicts POD.
+ - Add debian/postgresql-common.triggers: Register interest on
+ /usr/share/myspell/dicts.
+ - debian/postgresql-common.postinst: Call pg_updatedicts on upgrade to
+ this version, fresh install, and our trigger.
+ - debian/postgresql-common.postrm: Remove /var/cache/postgresql on purge.
+ - (LP: #301770)
+
+ -- Martin Pitt <mpitt@debian.org> Sat, 06 Dec 2008 11:35:52 -0800
+
+postgresql-common (94) unstable; urgency=low
+
+ * t/070_non_postgres_clusters.t: Test that all cluster configuration files
+ are owned by the cluster superuser. Reproduces #481349.
+ * pg_createcluster: Make the cluster configuration directory, "start.conf",
+ and "environment" owned by the cluster superuser instead of root.
+ (Closes: #481349)
+ * t/030_errors.t: Check behaviour of starting of clusters with colliding
+ ports. Reproduces #472627.
+ * pg_ctlcluster: Error out with a port collision message if another cluster
+ is already running on the port. (Closes: #472627)
+ * t/090_multicluster.t: Don't reconfigure cluster on conflicting port, since
+ that now fails with above fix.
+
+ -- Martin Pitt <mpitt@debian.org> Sat, 06 Dec 2008 11:19:54 -0800
+
+postgresql-common (93) unstable; urgency=low
+
+ * t/060_obsolete_confparams.t: Test a direct upgrade from oldest to newest
+ version in addition to consecutive version-by-version upgrades. This
+ checks that parameters which changed several times between the versions
+ are correctly converted. Reproduces #502106.
+ * pg_upgradecluster: Re-read configuration file after doing the "syslog" ->
+ "redirect_stderr" migration, so that the followup "redirect_stderr" ->
+ "logging_collector" rename will actually be done. This fixes a direct 7.4
+ -> 8.3 upgrade. (Closes: #502106)
+
+ -- Martin Pitt <mpitt@debian.org> Sun, 16 Nov 2008 19:45:34 +0100
+
+postgresql-common (92) unstable; urgency=low
+
+ * debian/supported-versions: Add Ubuntu 8.10 and 9.04.
+ * pg_upgradecluster: Clarify POD about manual mode of the old cluster.
+ Thanks to Toni Mueller for noticing.
+ * Demote ssl-cert Depends: to Recommends:. (Closes: #498406)
+ * pg_upgradecluster: Provide --locale and -lc-* options similar to
+ pg_createcluster, to provide easy UTF-8 migration from previous
+ legacy-encoded clusters. (Closes: #505785)
+ * t/052_upgrade_encodings.t: Test cases for pg_upgradecluster default and
+ explicit encoding behaviour.
+ * debian/init.d-functions: Use --force for forcefully stopping a running
+ cluster for "restart" init.d operation as well. Otherwise restart is not
+ guaranteed to succeed and could hang on existing connections.
+ (Closes: #481359)
+ * t/052_upgrade_encodings.t: Test upgrading of an SQL_ASCII database in a
+ cluter running under a proper locale. This reproduces #505449.
+ * pg_upgradecluster: Preserve SQL_ASCII encoded databases on upgrade.
+ (Closes: #505449)
+
+ -- Martin Pitt <mpitt@debian.org> Sun, 16 Nov 2008 13:42:31 +0100
+
+postgresql-common (91) unstable; urgency=low
+
+ * Update Brazilian Portugese debconf translations, thanks Eder L. Marques!
+ (Closes: #493031)
+ * Add Romanian debconf translations, thanks Igor Stirbu!
+ (Closes: #491823)
+ * debian/control: Bump Standards-Version (no changes necessary).
+
+ -- Martin Pitt <mpitt@debian.org> Sat, 06 Sep 2008 10:44:15 +0200
+
+postgresql-common (90) unstable; urgency=low
+
+ * Update Swedish debconf translations, thanks Martin Bagge!
+ (Closes: #490677)
+ * Add Turkish debconf translations, thanks Mert Dirik!
+ (Closes: #491007)
+ * Update Vietnamese debconf translations, thanks Clytie Siddall!
+ (Closes: #491048)
+ * Update Russian debconf translations, thanks Sergey Alyoshin!
+ (Closes: #491420)
+ * PgCommon.pm, change_ugid(): Use /usr/bin/id instead of manual parsing with
+ getgrent(), which is reportedly magnitudes faster for environments with
+ a large number of groups in remote databases. Thanks to Rodrigo Gallardo!
+ (Closes: #491136)
+ * debian/postgresql-common.postinst: Update root.crt header comment for
+ PostgreSQL 8.3. (Closes: #491276)
+ * pg_ctlcluster: Fix typo in pg_ctl error messages. Thanks to Aaron Schrab!
+ (Closes: #488280)
+ * pg_createcluster, pg_ctlcluster: Set the log file group to "adm" if
+ the cluster is owned by a system user (like "postgres"). In the "owned by
+ human user" case, keep it as that user's primary group. Check both cases in
+ the test suite. (Closes: #483017)
+ * t/TestLib.pm: Return "1" at the end, to avoid "TestLib.pm did not return a
+ true value" error on import.
+ * PgCommon.pm, read_conf_file(): Fix parsing of escaped quotes in string
+ values. Add tests to t/005_PgCommon.t. (Closes: #481055)
+
+ -- Martin Pitt <mpitt@debian.org> Mon, 21 Jul 2008 12:01:08 +0200
+
+postgresql-common (89) unstable; urgency=low
+
+ * Update Italian debconf translations, thanks Luca Monducci!
+ (Closes: #479360)
+ * Update Galician debconf translations, thanks Jacobo Tarrio!
+ (Closes: #480971)
+ * Update Euskara debconf translations, thanks Piarres Beobide!
+ (Closes: #483239)
+ * t/051_inconsistent_encoding_upgrade.t: Don't error out if there is just
+ one major version installed.
+ * Update Portugese debconf translations, thanks Luis Matos
+ (Closes: #488570) and Ricardo Silva! (Closes: #489820)
+
+ -- Martin Pitt <mpitt@debian.org> Tue, 08 Jul 2008 08:44:59 +0200
+
+postgresql-common (88) unstable; urgency=low
+
+ * t/030_errors.t: Add various test cases for stopping stopped clusters with
+ stale or corrupt PID files, with and without --force. This reproduces
+ #473879.
+ * pg_ctlcluster: On stop, clean up stale/corrupt PID files if the server is
+ not running. Also fix a taint error and simplify the code a bit.
+ (Closes: #473879)
+ * t/030_errors.t: Test graceful handling of absent /var/lib/postgresql.
+ (Reproduces LP #210322). Adapt 020_create_sql_remove.t accordingly.
+ * pg_ctlcluster: Check early whether the data directory exists and is
+ accessible, to avoid lots of Perl warning clutter. (LP: #210322)
+ * pg_createcluster POD: Clarify what "integrating existing cluster data
+ directory" means: configuration files must already be present, we cannot
+ create them out of thin air. (Closes: #475954)
+ * pg_maintenance: Sort versions for predictable output (looks nicer and
+ unbreaks the test suite).
+
+ -- Martin Pitt <mpitt@debian.org> Wed, 23 Apr 2008 19:35:30 +0200
+
+postgresql-common (87) unstable; urgency=medium
+
+ * Urgency medium since #472930 is an important bug fix.
+ * debian/init.d-functions: If there are no clusters, exit with 4 (LSB-code
+ for "unknown status") instead of 0 (which means "service is running", but
+ it is debatable and confusing whether all clusters are running if there
+ are none at all). (LP: #203966)
+ * Update Spanish debconf translations, thanks Javier Fernández-Sanguino
+ Peña. (Closes: #473405)
+ * t/060_obsolete_confparams.t: Run upgrades under
+ default_transaction_read_only=on. t/040_upgrade.t still uses the default
+ "off", so both cases get tested. This replicates the problem report from
+ Karsten Hilbert.
+ * pg_upgradecluster: Work with default_transaction_read_only=on.
+ * debian/autovacuum.conf, architecture.html: Point out that this file is
+ only relevant for PostgreSQL versions earlier than 8.1. Thanks to Ross
+ Boylan for pointing this out.
+ * Add t/051_inconsistent_encoding_upgrade.t: Check that upgrades from
+ pre-8.3 to 8.3 succeed and have correct encodings if the old DB had a
+ database whose encoding did not match the server locale. This reproduces
+ #472930.
+ * pg_upgradecluster: Fix handling of database encodings on upgrade, since
+ 8.3 now forces DB encodings and server locale to match:
+ - With C locale, keep encoding of DBs on upgrade, just as in previous
+ versions. (C is compatible with all encodings, and causes lots of string
+ functions not to work correctly, but people still use it deliberately.)
+ - With other locales, create the target DB manually with a compatible
+ encoding, and call pg_restore in a way to not create the target DB and
+ automatically convert encoding.
+ - Closes: #472930, LP: #207779
+
+ -- Martin Pitt <mpitt@debian.org> Mon, 31 Mar 2008 11:32:39 +0200
+
+postgresql-common (86) unstable; urgency=low
+
+ * Update Japanese debconf translations, thanks Hideki Yamane!
+ (Closes: #464769)
+ * Update French debconf translations, thanks Guilhelm Panaget!
+ (Closes: #467660)
+ * Update Finish debconf translations, thanks Esko Arajärvi!
+ (Closes: #468548)
+ * pg_upgradecluster: Document 'datadir' argument. (Closes: #466258)
+
+ -- Martin Pitt <mpitt@debian.org> Sat, 01 Mar 2008 16:47:05 +0100
+
+postgresql-common (85) unstable; urgency=low
+
+ * debian/README.Debian: Fix fatal typo that suggested dropping the wrong
+ cluster on upgrade. (Closes: #464064)
+ * pg_upgradecluster: Fix some typos in the POD, thanks to Brendan Jurd!
+
+ -- Martin Pitt <mpitt@debian.org> Wed, 06 Feb 2008 15:22:03 +0100
+
+postgresql-common (84) unstable; urgency=low
+
+ * Add t/140_pg_config.t: Check correct output of pg_config, to avoid bugs
+ like #455509 and #462037 in the future.
+ * t/040_upgrade.t: Create and cd into an inaccessible test directory.
+ * pg_upgradecluster: Chdir to / before the upgrade to avoid confusing error
+ messages about inaccessible cwd.
+ * debian/README.Debian: Update for 8.3 being the default version. Drop
+ description of 7.4 autovacuum daemon magic, since it is obsolete now.
+ * debian/postgresql-common.templates: Point to README.Debian.
+ * debian/postgresql-common.cron.d: Update for 8.3, and add warnings and doc
+ pointer about enabling regular VACUUM FULL. (LP: #186831)
+ * PgCommon.pm, get_cluster_locales(): Print proper error message when server
+ package is removed, but not purged, and a cluster still exists.
+ (Closes: #463070)
+ * t/030_errors.t, t/130_nonroot_admin.t: Check pg_dropcluster/
+ pg_createcluster error message when being called with insufficient
+ privileges.
+ * pg_createcluster, pg_dropcluster: Point out that program needs to be run
+ as root when creating/removing config or data directory fails.
+ (Closes: #460576)
+ * t/090_multicluster.t: Remove test case for nonexisting PGSERVICE value,
+ since this is not reliably reported in psql.
+ * t/140_pg_config.t: Skip pg_config test for 8.1. It's known broken in Etch
+ (pg_config was only shipped in libpq-def) and irrelevant in Lenny.
+
+ -- Martin Pitt <mpitt@debian.org> Sun, 03 Feb 2008 17:50:29 +0100
+
+postgresql-common (83) unstable; urgency=low
+
+ * Drop the "If you have openssl installed..." from the package description,
+ since ssl-cert depends on it.
+ * t/050_encodings.t: Add alternative unicode representation 0xc827 for the
+ CVE-2006-2313 test, so that the testsuite runs cleanly in Ubuntu 6.06.
+ * debian/supported-versions: Drop 8.1 from fallback set of supported
+ versions.
+ * debian/postgresql-common.config: Add check for forcing the obsoletion
+ notifications when upgrading over a particular version. This provides the
+ notification when upgrading from Etch to Lenny, and when obsoleting a
+ major version within unstable.
+ * debian/supported-versions: Drop support for 8.2 in unstable, 8.3 is the
+ version du jour.
+ * debian/supported-versions: Drop Ubuntu 5.10, fix a typo in the versions
+ for Ubuntu 6.06.
+ * t/090_multicluster.t: Test correct behaviour of pg_service.conf. (See
+ #439026)
+ * debian/supported-versions: Only support 8.3 in Ubuntu 8.04.
+
+ -- Martin Pitt <mpitt@debian.org> Sun, 20 Jan 2008 11:08:04 +0100
+
+postgresql-common (82) unstable; urgency=low
+
+ * debian/control: Fix 'commmon' typo. (Closes: #449532)
+ * t/030_errors.t: Check that an /etc/postgresql/postgresql.conf leftover is
+ not regarded as a cluster directory. This reproduces #450565.
+ * PgCommon.pm, get_versions()/get_version_clusters(): Filter out '.' and
+ '..' from readdir() output. (Closes: #450565)
+ * pg_ctlcluster: Use "smart" mode shutdown by default, and add option
+ -f/--force to use "fast" -> "immediate" -> kill -9 approach. (LP: #154012)
+ * debian/init.d-functions: Use --force when stopping all clusters, since
+ default smart mode can potentially block forever and thus fail to shut
+ down a machine.
+ * debian/README.Devel: Update for current bzr versions and hosting on
+ code.launchpad.net.
+ * Update Japanese debconf translations (Closes: #450902)
+
+ -- Martin Pitt <mpitt@debian.org> Sun, 30 Dec 2007 22:27:08 +0100
+
+postgresql-common (81) unstable; urgency=low
+
+ * debian/supported_versions: Welcome, Ubuntu Hardy (8.04)!
+ * debian/postgresql-common.templates, debian/control: Language and grammar
+ improvements, thanks a lot to Christian Perrier and the l10n teams!
+ (Closes: #446457)
+ * Update debconf translations, thanks to all translators!
+ - French (Christian Perrier) (Closes: #446978)
+ - Vietnamese (Clytie Siddall) (Closes: #447009)
+ - Finnish (Esko Arajärvi) (Closes: #447045)
+ - Italian (Luca Monducci) (Closes: #447052)
+ - Galician (Jacobo Tarrio) (Closes: #447054)
+ - Basque (Piarres Beobide) (Closes: #447131)
+ - Spanish (Javier Fernández-Sanguino Peña) (Closes: #447417)
+ - Czech (Miroslav Kure) (Closes: 447436)
+ - Portugese (Miguel Figueiredo) (Closes: #447642)
+ - Brazilian Portugese (Eder L. Marques) (Closes: #447881)
+ - Russian (Sergey Alyoshin) (Closes: #448768)
+ - German (Martin Pitt)
+
+ -- Martin Pitt <mpitt@debian.org> Sat, 03 Nov 2007 10:13:46 -0400
+
+postgresql-common (80) unstable; urgency=low
+
+ * pg_upgradecluster: Fix locale error checking.
+ * pg_upgradecluster: Use cluster_exists() instead of
+ cluster_data_directory().
+ * PgCommon.pm: Fix cluster_data_directory() to consider the data_directory
+ setting in postgresql.conf, which should trump the /pgdata symbolic link.
+ * debian/init.d-functions: Check for 'postgresql.conf' instead of 'pgdata'
+ in the test for a valid cluster configuration directory, since 'pgdata' is
+ optional now.
+ * pg_createcluster: Do not create pgdata symlinks to the data directory in
+ /etc any more when configuring a >= 8.0 cluster. Use the data_directory
+ configuration option instead. (Part of #444689)
+ * t/020_create_sql_remove.t: Check that clusters still work when replacing
+ the data_directory setting with a pgdata symbolic link, and that
+ the data_directory setting trumps the symlink.
+ * pg_upgradecluster: Set correct data_directory config option after copying
+ over the old configuration files.
+ * t/060_obsolete_confparams.t: Restore data_directory setting after
+ scribbling over the configuration file with our template.
+ * PgCommon.pm, cluster_info(): Only return a value for 'logfile' when it is
+ not explicitly configured with log_directory and/or log_filename. The
+ previous guessing was wrong anyway, since PostgreSQL always appends a
+ pretty unpredictable timestamp.
+ * pg_ctlcluster: Only do log file checks and pass pg_ctl -l option when the
+ log file default is used. Otherwise let PostgreSQL do its logfile handling
+ and waive log file checks, since we don't know which file is used.
+ * pg_ctlcluster: Redirect pg_ctl's stdout and stderr to /dev/null, otherwise
+ it will hang forever when using a custom log file (and thus not passing
+ -l).
+ * pg_lsclusters: Print "custom" as log file location if a custom one was set
+ in postgresql.conf.
+ * pg_upgradecluster: Enable 'redirect_stderr' in the 7.4 -> 8.x migration of
+ 'syslog' -> 'log_destination', so that the log output is actually
+ complete.
+ * t/060_obsolete_confparams.t: Enable 'redirect_stderr' in the template
+ postgresql.conf's, so that we actually capture log output.
+ * t/020_create_sql_remove.t: Check proper handling of logs when configuring
+ log file in postgresql.conf, using the log symlink, or having neither.
+ * PgCommon.pm, cluster_info(): Return default log file in 'logfile' if
+ neither postgresql.conf nor a 'log' symlink explicitly specify a log file.
+ * pg_createcluster: Do not create log symlink if using the default log file
+ (i. e. when not using -l). (Closes: #444689)
+ * t/020_create_sql_remove.t: Verify that log symlink is not created by
+ default.
+ * architecture.html: Update to current reality.
+ * debian/postgresql-common.config: Do not consider versions as obsolete if
+ they are newer than the latest officially supported version. This avoids
+ confusion when testing new betas in experimental or using backports.
+ (Closes: #446635)
+ * t/TestLib.pm: Make exec_as() work with user name 'root' (not just uid 0).
+ * Add t/130_nonroot_admin.t: Check that administrative pg_ tools work as
+ non-root, too, if the invoker has sufficient permissions on the
+ directories (test case for LP #90036).
+ * pg_{create,drop,upgrade}cluster: Small tweaks to make the scripts work for
+ non-root users with sufficient write permissions to
+ /etc/postgresql/<version>, /var/lib/postgresql/<version>, and
+ /var/log/postgresql. (LP: #90036)
+
+ -- Martin Pitt <mpitt@debian.org> Sun, 21 Oct 2007 16:01:08 +0200
+
+postgresql-common (79) unstable; urgency=low
+
+ * debian/supported-versions: Welcome, version 8.3!
+ * pg_createcluster: Add configure_8_3().
+ * PgCommon.pm, cluster_info(): 8.3 defaults to 'autovacuum = On' when not
+ given, reflect that in the avac_enable return value.
+ * t/050_encodings.t: 8.3 onwards refuses to create a cluster with an
+ inconsistent locale/encoding combination. Just drop the test case, it does
+ not make too much sense anyway.
+ * t/090_multicluster.t: Do not rely on output of createdb, call it with -q.
+ 8.3 behaves differently here.
+ * t/060_obsolete_confparams.t: Add full set of 8.2 postgresql.conf options
+ for testing upgrades to 8.3.
+ * pg_upgradecluster: When upgrading to 8.3, transition changed configuration
+ options:
+ - bgwriter_lru_percent, bgwriter_all_percent, bgwriter_all_maxpages,
+ stats_start_collector, and stats_reset_on_server_start: deprecated.
+ - redirect_stderr -> logging_collector
+ - stats_command_string -> track_activities
+ - stats_block_level || stats_row_level -> track_counts
+ - Explicitly enable archive_mode when archive_command is set.
+
+ -- Martin Pitt <mpitt@debian.org> Wed, 10 Oct 2007 00:27:41 +0200
+
+postgresql-common (78) unstable; urgency=low
+
+ * debian/postgresql-common.postinst: Only clean up
+ /usr/lib/postgresql/dumpall/ on upgrades if it is actually a directory.
+ (Closes: #440596)
+
+ -- Martin Pitt <mpitt@debian.org> Sun, 16 Sep 2007 20:59:30 +0200
+
+postgresql-common (77) unstable; urgency=low
+
+ * debian/control: Fix obsolete ${Source-Version}.
+ * t/020_create_sql_remove.t: Create fake rotated log files to check that
+ they are cleaned up properly.
+ * pg_dropcluster: Remove rotated logs, too. (part of #431643)
+ * debian/postgresql-common.postinst: Clean up /usr/lib/postgresql/dumpall/
+ junk from the Sarge->Etch postgresql transition. This needs to be kept
+ until after Lenny's release. (part of #431643)
+ * Add debian/postgresql-client-common.postrm: Clean up
+ /var/lib/postgresql/.psql_history on purge. Closes: #431643
+ * debian/postgresql-common.postinst: Create /var/lib/postgresql/ if it does
+ not exist. This should not usually happen, but apparently did anyway.
+ (Closes: #438698)
+
+ -- Martin Pitt <mpitt@debian.org> Mon, 20 Aug 2007 15:45:28 +0200
+
+postgresql-common (76) unstable; urgency=medium
+
+ * Priority medium since this unbreaks client programs like psql in testing.
+ * pg_wrapper: Revert changes of version 74 to make this work with taint
+ mode. It breaks too many custom setups, and Perl just doesn't allow to
+ untaint $PATH bluntly. If you run pg_wrapper from a perl script with taint
+ checks enabled, you have to clean $PATH yourself. Closes: #427894
+ * t/020_create_sql_remove.t: Check that PL/TCL and PL/TCLu work, so that we
+ now have complete test coverage of all four PLs that are shipped with the
+ core package.
+ * t/001_packages.t: Check that postgresql-pltcl-<version> is installed.
+ * PgCommon.pm, get_cluster_socketdir(): Improve error message if data
+ directory parent is not readable. Closes: #428698
+
+ -- Martin Pitt <mpitt@debian.org> Sat, 23 Jun 2007 21:52:58 +0200
+
+postgresql-common (75) unstable; urgency=low
+
+ The "Never run the test suite without 7.4 just because it is deprecated and
+ about to be removed" release. Sorry for the trouble.
+
+ * pg_ctlcluster: Partially revert PATH cleansing to make pg_ctl work on 7.4
+ again. This can be dropped again once 7.4 is actually removed from the
+ archive. Closes: #425594
+
+ -- Martin Pitt <mpitt@debian.org> Thu, 24 May 2007 09:26:45 +0200
+
+postgresql-common (74) unstable; urgency=low
+
+ * debian/supported_versions:
+ - Match any 4.0* as Debian Etch to get the correct set of supported
+ versions. Closes: #420915
+ - Add Lenny/unstable: only support 8.2.
+ - Add Ubuntu 7.10.
+ - Don't fail if the distribution cannot be determined at all, only print
+ out a warning.
+ * pg_createcluster, pg_ctlcluster, pg_dropcluster, pg_maintenance,
+ pg_upgradecluster: Strip down PATH untainting to the absolute minimum, to
+ not fall over if e. g. /usr/local/bin is misconfigured to be world
+ writable. Closes: #420565
+ * pg_wrapper: Make this script work with taint checks enabled. This happens
+ in a pretty blunt way, since it does not actually make sense to enforce
+ environment variables, etc. It should just not fail when being called from
+ a -T perl script. Closes: #422129
+ * debian/postgresql-common.postinst: Do not hide failures of the init
+ script on restart.
+ * debian/postgresql-common.config, debian/postgresql-common.templates:
+ Remove the check for an untransitioned postgresql, since it was only
+ necessary for the Sarge->Etch upgrade. Update debian/po/*.po.
+ * Remove debian/postgresql-common.preinst, we only needed it for the
+ "untransitioned" test.
+ * debian/control: Move cdbs and debhelper from B-D-I to B-D, since we need
+ them for 'clean'.
+ * Add debian/postgresql-client-common.lintian: Lintian overrides for 'binary
+ without manpage'. The stuff in /usr/bin is just a symlink to pg_wrapper,
+ postgresql-client-* ships the actual manpages for those.
+
+ -- Martin Pitt <mpitt@debian.org> Sun, 20 May 2007 15:30:19 +0200
+
+postgresql-common (73) unstable; urgency=low
+
+ * debian/postgresql-common.dirs: Ship /var/lib/postgresql again, creating it
+ dynamically causes various upgrade failures. Closes: #416146, #416228
+ * debian/postgresql-common.postinst: Call adduser with --no-create-home.
+ This avoids the 'wrong owner' warning as well.
+
+ -- Martin Pitt <mpitt@debian.org> Mon, 26 Mar 2007 18:51:27 +0200
+
+postgresql-common (72) unstable; urgency=low
+
+ * debian/postgresql-common.postinst: Set default /var/log/postgresql
+ permissions to root:postgres 1775. Closes: #410852
+ * Update Russian debconf translations. Thanks to Yuriy Talakan'!
+ Closes: #414067
+ * postgresql-common/debian/postgresql-common.dirs: Remove
+ /var/lib/postgresql, so that adduser does not complain about a preexisting
+ directory with the wrong owner any more. This also avoids removing the
+ home directory of postgres when removing the package. Closes: #415444
+
+ -- Martin Pitt <mpitt@debian.org> Sat, 24 Mar 2007 16:06:47 +0100
+
+postgresql-common (71) unstable; urgency=low
+
+ * Add Swedish debconf translations. Thanks to Andreas Henriksson!
+ Closes: #407865
+ * Add Galician debconf translations. Thanks to Jacobo Tarrio!
+ Closes: #408121
+ * debian/supported-versions: Only 8.2 is supported in Ubuntu 7.04.
+ * pg_ctlcluster: Check that $version and $cluster are still defined after
+ untainting to avoid confusing (but harmless) error message.
+ Closes: #406117
+
+ -- Martin Pitt <mpitt@debian.org> Mon, 29 Jan 2007 16:22:55 +0100
+
+postgresql-common (70) unstable; urgency=low
+
+ * t/050_encodings: Check that $LC_ALL dominates $LANG on pg_createcluster.
+ This reproduces bug #403239.
+ * pg_createcluster: If $LC_ALL is defined, fix $LANG to $LC_ALL. Servers
+ prior to 8.2 get this wrong and fail over an invalid $LANG even if that is
+ dominated by a valid $LC_ALL. Closes: #403239
+ * Add Brazilian Portugese debconf translations. Thanks to André Luís Lopes!
+ Closes: #403563
+ * t/040_upgrade.t: Check that pg_upgradecluster does not have any stderr
+ output (such as error messages from pg_restore, the server, or Perl
+ warnings). This uncovers #403529.
+ * pg_upgradecluster: Do not mangle {hba,ident,external_pid}_file values from
+ old postgresql.conf if they do not exist at all. This removes the Perl
+ warnings during upgrades from 7.4. Closes: #403529
+ * debian/README.Debian: Describe default cluster setup and give an example
+ for upgrading a cluster if a newer version with the same name already
+ exists.
+
+ -- Martin Pitt <mpitt@debian.org> Tue, 19 Dec 2006 17:00:27 +0100
+
+postgresql-common (69) unstable; urgency=medium
+
+ * Urgency medium, only safe fixes and this needs to go into Etch due to
+ first bug fix.
+ * debian/supported_versions: Gracefully fall back on an unknown
+ distribution, instead of failing package installation completely.
+ Closes: #400628
+ * debian/supported_versions: Some minor factorization.
+ * Add Spanish debconf translations, thanks to Javier Fernández-Sanguino
+ Peña! Closes: #402198
+ * pg_createcluster: Add --locale and the various --lc_* options that initdb
+ supports, and mention in POD that directly setting --encoding is not
+ recommended. Closes: #395083
+ * t/050_encodings.t: Use pg_createcluster's new --locale option in some test
+ cases.
+ * Make testsuite work with just one installed major version (mainly boils
+ down to disabling upgrade tests).
+
+ -- Martin Pitt <mpitt@debian.org> Sat, 9 Dec 2006 14:37:42 +0100
+
+postgresql-common (68) unstable; urgency=low
+
+ * debian/supported-versions: Add Debian 4.0. Closes: #399978
+ * debian/postgresql-common.postinst: Use adduser option --quiet for adding
+ postgres to ssl-cert. Closes: #399979
+ * pg_createcluster: Enable timestamps in log files by default. Other system
+ log files have timestamps, too, and they are useful. Closes: #395554
+ * t/040_upgrade.t: Fix number of tests if oldest installed PostgreSQL
+ version is < 8.0.
+
+ -- Martin Pitt <mpitt@debian.org> Fri, 24 Nov 2006 21:01:30 +0100
+
+postgresql-common (67) unstable; urgency=low
+
+ *t/040_upgrade.t: Skip the user/group name clash test when there are only
+ servers >= 8.1 installed, since it does not apply to them and breaks the
+ test suite.
+ * t/040_upgrade.t: Check that the upgraded cluster still works after
+ removing the old one, to check for stale paths of configuration files.
+ * pg_upgradecluster: Adapt path to configuration files in the target
+ cluster, so that they do not refer to the files of the old cluster. (This
+ fixes an upgrade regression introduced in version 62).
+ * debian/supported-versions: Add Ubuntu 7.04.
+ * Add Italian debconf translations. Thanks to Luca Monducci
+ <luca.mo@tiscali.it>! Closes: #396947
+
+ -- Martin Pitt <mpitt@debian.org> Thu, 16 Nov 2006 00:11:58 -0800
+
+postgresql-common (66) unstable; urgency=low
+
+ * Add Japanese debconf translations. Thanks to Hideki Yamane!
+ Closes: #393055
+ * pg_upgradecluster: Use -X no-data-for-failed-tables only for 8.1. In
+ 8.2beta2 this got renamed to --no-data-for-failed-tables.
+
+ -- Martin Pitt <mpitt@debian.org> Fri, 27 Oct 2006 11:38:50 +0200
+
+postgresql-common (65) unstable; urgency=low
+
+ * pg_upgradecluster: Quiesce dropdb for already existing 'postgres'
+ database.
+ * pg_upgradecluster: Avoid harmless, but confusing error messages about role
+ creation:
+ - Do not use -c for pg_dumpall, since the target roles should not yet
+ exist anyway.
+ - Filter out the 'CREATE (ROLE|USER)' command for the db superuser, since
+ it will already exist.
+ - Testsuite: Check that pg_upgradecluster output contains no server error
+ messages.
+ - Closes: #389930
+
+ -- Martin Pitt <mpitt@debian.org> Sat, 7 Oct 2006 13:54:34 +0200
+
+postgresql-common (64) unstable; urgency=low
+
+ * Fix pg_ctlcluster regression from 63: 'database system is starting up'
+ fatal error message caused immediate abortion of startup checks. Make the
+ check easier and more robust, adapt test cases accordingly.
+ * t/020_create_sql_remove.t: Add check that PL/Perl works. Check that
+ -plperl-X.Y. is installed in t/001_packages.t.
+ * t/{040_upgrade.t,041_upgrade_custompaths.t}: Check for pg_restore error
+ messages during upgrade.
+ * pg_upgradecluster: Avoid pg_restore errors during upgrade (they were
+ nonfatal, but look ugly:)
+ - Drop 'postgres' db in 8.1+ target cluster if the source cluster already
+ has it.
+ - Do not use pg_restore's --create for template1.
+ - Fix hardcoded library paths before dumping/restoring the cluster, not
+ after, to avoid error messages about failed library loads.
+
+ -- Martin Pitt <mpitt@debian.org> Fri, 6 Oct 2006 18:35:46 +0200
+
+postgresql-common (63) unstable; urgency=low
+
+ * t/090_multicluster.t, t/100_upgrade_scripts.t: Replace hardcoded '8.1'
+ versions in test data with appropriate $MAJORS values.
+ * pg_createcluster: Add configure_8_2().
+ * pg_ctlcluster, check_running_postmaster(): Check for both 'postmaster' and
+ 'postgres' processes to also work for 8.2.
+ * t/TestLib.pm, check_clean(): Also check for running 'postgres' processes
+ (since that's how the server is called in 8.2+). Update number of tests
+ everywhere.
+ * t/TestLib.pm, check_clean(): Fix regexp for netstat port grepping so that
+ ports like '54321' do not match.
+ * t/TestLib.pm, pidof(): Make pidof() strict enough to not catch the stats
+ collector and writer subprocesses.
+ * t/*.t: Various small adaptions to work with 8.2, too.
+ * t/060_obsolete_confparams.t: Add full configuration for 8.1, to test
+ 8.1->8.2 upgrade.
+ * pg_upgradecluster: When upgrading to 8.2, transition changed configuration
+ options:
+ - preload_libraries -> shared_preload_libraries
+ - australian_timezones -> timezone_abbreviations
+ * pg_ctlcluster: Instead of parsing pg_hba.conf, just try to connect with
+ setting PGPASSWORD to a bogus value, and check for authentication errors.
+ This is more robust and more elegant, and also covers nonstandard
+ authentication schemes correctly. Closes: #388419
+ * debian/supported-versions: Recklessly consider 8.2 as supported to avoid
+ whining if 8.2 package gets backported.
+
+ -- Martin Pitt <mpitt@debian.org> Sat, 30 Sep 2006 12:44:08 +0200
+
+postgresql-common (62) unstable; urgency=low
+
+ * t/080_start.conf.t: Check that stop'ing a cluster works even if the
+ cluster is disabled (test for bug #386996).
+ * pg_ctlcluster: Allow 'stop' and 'autovac-stop' for disabled clustes.
+ Closes: #386996
+ * Reduce options passed to postmaster at runtime to shorten command line and
+ make the configuration more obvious and explicit:
+ - pg_ctlcluster: Do not pass unix_socket_dir/hba_file/ident_file if it is
+ already defined in postgresql.conf.
+ - pg_createcluster: If we create a cluster >= 8.0, set hba_file,
+ ident_file, and external_pid_file in postgresql.conf.
+ - 070_non_postgres_clusters.t: Fix expected output accordingly and
+ use 'ls' for socket check instead of looking at the command line.
+ - Closes: #384999
+
+ -- Martin Pitt <mpitt@debian.org> Mon, 18 Sep 2006 09:12:20 +0200
+
+postgresql-common (61) unstable; urgency=low
+
+ * pg_lsclusters: Remove trailing spaces from output, adapt test suite
+ accordingly.
+ * pg_upgradecluster: Correctly pass custom datadir to pg_createcluster.
+ Closes: #385034
+ * Add t/041_upgrade_custompaths.t: Test upgrading with a custom data
+ directory and log file path (this also covers bug #385034).
+
+ -- Martin Pitt <mpitt@debian.org> Mon, 11 Sep 2006 13:08:58 +0200
+
+postgresql-common (60) unstable; urgency=low
+
+ * Update Czech debconf translations, thanks to Miroslav Kure.
+ Closes: #384757
+ * t/090_multicluster.t: Check that $PGHOST and $PGDATABASE environment
+ variables are respected and have the correct precedence. (This reproduces
+ #385971). Now this test has full coverage of all libpq environment
+ variables but $PGUSER (which is not used at all anywhere).
+ * pg_wrapper: Do not override $PGDATABASE and $PGHOST with user_clusters
+ map. Closes: #385971
+ * Update Dutch debconf translations, thanks to Vincent Zweije.
+ Closes: #386704
+ * pg_createcluster: Fix POD to have consistent long-option syntax. Thanks to
+ Bastian Kleineidam! (Part of bug #386148)
+ * Improve handling of custom socket directories:
+ - pg_createcluster: Create a nonexisting directory.
+ - pg_dropcluster: Remove empty socket directory unless it's /tmp or
+ /var/run/postgresql.
+ - Thanks to Bastian Kleineidam for the suggestions.
+ - t/030_errors.t: Do not create our custom socket dir ourselves any more,
+ since pg_createcluster is now supposed to handle that (thus providing a
+ test case).
+ - Closes: #386148
+
+ -- Martin Pitt <mpitt@debian.org> Sun, 10 Sep 2006 13:31:11 +0200
+
+postgresql-common (59) unstable; urgency=low
+
+ * t/001_packages.t: Check that p-plpython-X.Y is installed.
+ * t/020_create_sql_remove.t: Check that PL/Python works properly.
+ * Update French debconf translations, thanks to Guilhelm Panaget
+ <guilhelm.panaget@free.fr>. Closes: #382447
+ * Add Portugese debconf translations, thanks to Rui Branco
+ <ruipb@debianpt.org>. Closes: #381946
+ * postgresql-common/debian/postgresql-common.config:
+ - Ensure that the 'untransitioned' critical debconf note is always shown,
+ not just once. Otherwise the preinst just fails without giving any hint
+ about the reason after the first failure.
+ - Additionally print a small hint to stderr, for the case that people do
+ not use the interactive frontend.
+ - Closes: #382134
+
+ -- Martin Pitt <mpitt@debian.org> Sat, 12 Aug 2006 18:40:21 +0200
+
+postgresql-common (58) unstable; urgency=low
+
+ * pg_wrapper: Improve manpage POD, describe the precise rules for cluster
+ selection.
+ * t/090_multicluster.t: Check for proper error message of pg_wrapper (no
+ suitable default cluster) if several local clusters exist and none are on
+ the default port.
+ * pg_wrapper: Print proper error message if no cluster is suitable as
+ default target and point to man pg_wrapper.
+ * pg_upgradecluster:
+ - Support /etc/postgresql-common/pg_upgradecluster.d/ hook scripts. These
+ are called after creating the virgin new version cluster (phase 'init')
+ and a second time after the upgrade is complete (phase 'finish').
+ PostgreSQL extensions like PostGIS can use these hooks to initialize
+ metadata which must not be upgraded from the old cluster, but
+ initialized from scratch. Closes: #351571
+ - Document this feature in the manpage POD.
+ - If upgrade scripts are present, call pg_restore with the new -X
+ no-data-for-failed-tables option to not clutter already existing tables
+ in the new cluster with data from the old cluster. Abort with an error
+ if the installed pg_restore does not support this option.
+ - debian/postgresql-common.dirs: Ship
+ /etc/postgresql-common/pg_upgradecluster.d/.
+ * Add t/120_pg_upgradecluster_scripts.t: Selftest for pg_upgradecluster.d
+ hooks and proper pg_restore -X no-data-for-failed-tables behaviour.
+ * PgCommon.pm, get_cluster_locales(): Fix parsing of locales out of
+ pg_controldata output by calling it under the locale 'C' and being more
+ liberal in the regular expression. (https://launchpad.net/bugs/50755)
+
+ -- Martin Pitt <mpitt@debian.org> Tue, 25 Jul 2006 22:34:42 +0200
+
+postgresql-common (57) unstable; urgency=low
+
+ * debian/postgresql-common.{preinst,config}: Check if there is a removed,
+ but not purged pre-transition postgresql-client or postgresql package.
+ Packages in this state subtly break operation, but are not caught by the
+ Conflicts: statements. Display a critical note in that case and abort
+ installation. Closes: #368827
+
+ -- Martin Pitt <mpitt@debian.org> Thu, 29 Jun 2006 23:07:30 +0200
+
+postgresql-common (56) unstable; urgency=low
+
+ * debian/init.d-functions, status(): Exit with code 3 if any cluster is
+ down, to get a bit closer to LSB specification (which does not
+ sufficiently specify the case of controlling multiple processes in one
+ init script). Thanks to Ross Boylan <RossBoylan@stanfordalumni.org>!
+ Closes: #358152
+ * pg_ctlcluster:
+ - start: Create an external PID file /var/run/postgresql/
+ <version>-<cluster>.pid for 8.0+ versions (7.4 doesn't support this yet)
+ unless 'external_pid_file' is already set in postgresql.conf.
+ Closes: #180849, #184782
+ - stop: Remove this external pid file (this should be done by the
+ postmaster itself, but 8.1.4 does not).
+ * t/020_create_sql_remove.t: Check that starting a cluster creates a PID
+ file in /var/run/postgresql/, but doesn't if external_pid_file was set
+ explicitly.
+ * t/030_errors.t: Adapt to new PID file creation behaviour.
+ * t/030_errors.t: modprobe loop before setting up the test loopback device.
+ * debian/supported-versions: Add Ubuntu 6.10.
+
+ -- Martin Pitt <mpitt@debian.org> Mon, 26 Jun 2006 19:02:41 +0200
+
+postgresql-common (55) unstable; urgency=low
+
+ * Add missing procps dependency to p-common. Closes: #369768
+ * pg_dropcluster: Clean up half-existing broken cluster configurations
+ (which happen when disk becomes full, etc) instead of failing. (part of
+ bug #368335).
+ * t/030_errors.t: Test that pg_dropcluster copes with broken cluster
+ configurations.
+ * debian/maintscripts-functions: Do not fail package installation if
+ pg_createcluster fails (/var might be full and the admin might want to use
+ a different directory). Merely print out an error message and point to
+ pg_createcluster and its manpage. (part of bug #368335)
+ * t/030_errors.t: Create a temporary 10 MB loop mount on /var/lib/postgresql
+ and check that pg_createcluster fails with an appropriate error and leaves
+ no cruft behind.
+ * pg_createcluster: Call pg_dropcluster to clean up cruft if anything fails
+ in the cluster creation process. This avoids an inconsistent system if e.
+ g. running out of disk space during installation. Closes: #368335
+
+ -- Martin Pitt <mpitt@debian.org> Fri, 2 Jun 2006 00:17:07 +0200
+
+postgresql-common (54) unstable; urgency=low
+
+ * pg_wrapper: Support specifying remote clusters with $PGCLUSTER, --cluster,
+ user_clusters, and ~/.postgresqlrc with 'host:[port]' as cluster name.
+ Closes: #340162
+ * t/090_multicluster.t: Add tests for above feature.
+ * user_clusters.5, postgresqlrc.5: Document format for remote clusters.
+ * debian/supported-versions:
+ - Also recognize Ubuntu dapper version number '6.06LTS'.
+ - Fix bashism: 'type -p' -> type.
+ * debian/control: Have p-common always depend on the recent p-client-common,
+ since the latter ships PgCommon.pm. If the library is out of date, this
+ can break operations horribly. Closes: #369289
+ * Add Dutch debconf translation, thanks to Vincent Zweije
+ <zweije@xs4all.nl>! Closes: #369237
+ * t/TestLib.pm: If the test suite is called with FAILURE=shell environment,
+ spawn bash before continuing. This makes it easier to debug obscure
+ failures.
+ * t/TestLib.pm, check_clean(): Check that PostgreSQL TCP sockets are closed.
+ Adapt number of tests in all t/*.t.
+ * t/090_multicluster.t: Just before checking for cleanness, wait until all
+ TIME_WAIT sockets on the server ports went away, so that the following
+ tests will not stumble over them. This seems to be a 7.4 server bug which
+ is fixed in 8.1 at least.
+ * t/050_encodings.t: Add tests for recent SQL injection vulnerabilities
+ through invalidly encoded strings and usage of \' escaping.
+
+ -- Martin Pitt <mpitt@debian.org> Tue, 30 May 2006 00:59:57 +0200
+
+postgresql-common (53) unstable; urgency=medium
+
+ * Urgency medium since this fixes a quite serious bug; no intrusive changes
+ otherwise.
+ * Add Russian debconf translation, thanks to Yuriy Talakan'
+ <yt@amur.elektra.ru>! Closes: #367152
+ * t/001_packages.t: Check that the locales used in the tests are installed
+ so that the test suite fails early if not.
+ * t/050_encodings.t, t/060_obsolete_confparams.t: Use ru_RU{,.UTF-8} for
+ tests, since they have more potential for failure.
+ * t/050_encodings.t:
+ - Add check for https://launchpad.net/bugs/39177: Correct encoding of
+ server error messages under various locales.
+ - Add check for bug #343057: Correct startup if client_encoding and
+ lc_messages settings do not match.
+ * pg_ctlcluster: Set LC_CTYPE environment variable to unbreak server error
+ messages. (Closes https://launchpad.net/bugs/39177). By only setting CTYPE
+ we also avoid reintroducing bug #343057. (Yay for postmaster being so anal
+ about its environment)
+ * t/020_create_sql_remove.t: Consider LC_CTYPE a safe environment variable.
+ * debian/postgresql-common.postinst: Bump version comparison for restarting
+ postgresql servers to this version, to ensure that above bug fix becomes
+ active.
+
+ -- Martin Pitt <mpitt@debian.org> Fri, 19 May 2006 18:58:25 +0200
+
+postgresql-common (52) unstable; urgency=low
+
+ * Bump Standards-Version to 3.7.2.
+ * Merge support for system wide snakeoil SSL certificate from Ubuntu branch
+ and eliminate our custom SSL certificate juggling:
+ - debian/control:
+ + Depend on ssl-cert which provides snakeoil cert and the ssl-cert
+ group.
+ + Remove Recommends: openssl.
+ - debian/postgresql-common.postinst:
+ + Remove generation of PostgreSQL specific SSL certificate.
+ + Add postgres user to the ssl-cert group on upgrades to this version or
+ on fresh installs.
+ - pg_createcluster:
+ + Adapt cert/key paths to snakeoil.
+ + Update manpage documentation POD.
+ + Enable SSL only if SSL key can be accessed with the cluster owner's
+ privileges.
+ - debian/README.Debian: Update documentation of SSL certificate handling.
+
+ -- Martin Pitt <mpitt@debian.org> Fri, 12 May 2006 22:25:49 +0200
+
+postgresql-common (51) unstable; urgency=low
+
+ * PgCommon.pm: Add function read_pg_hba() to parse pg_hba.conf.
+ * Add t/005_PgCommon.t: Designated for testing PgCommon.pm library
+ functions; test read_pg_hba() for now.
+ * pg_ctlcluster: Check pg_hba.conf if the database superuser can connect
+ locally without a password. If not, disable startup checks to avoid asking
+ for the superuser password. (https://launchpad.net/bugs/37640)
+ * t/030_errors.t: Test above pg_ctlcluster checks.
+
+ -- Martin Pitt <mpitt@debian.org> Mon, 1 May 2006 14:38:53 +0200
+
+postgresql-common (50) unstable; urgency=low
+
+ * t/030_errors.t: Check that pg_wrapper and administration programs give
+ sane error messages instead of 'Invalid symbolic link blabla' for a
+ nonexisting cluster.
+ * pg_ctlcluster, pg_dropcluster: Print meaningful error message on
+ nonexisting cluster. Closes: #360701
+ * pg_dropcluster: Rename --stop-server to --stop to be consistent with
+ pg_createcluster's --start, and update documentation. --stop-server still
+ works for backward compatibility, though. Closes: #360697
+ * debian/README.Debian:
+ - Update createuser invocation description for 8.1+. Closes: #361731
+ - Update autovacuum daemon description; explain integrated autovacuuming
+ for 8.1+.
+ * pg_ctlcluster: Fail autovac-* commands for 8.1+ clusters. Closes: #360888
+ * debian/init.d-functions: Fix handling of failing pg_ctlcluster
+ invocations. Closes: #362825
+ * pg_createcluster: Explain syntax of the environment file in more detail.
+ * Add t/110_integrate_cluster.t: Test various scenarios of integrating
+ already existing clusters.
+ * pg_createcluster: Determine correct owner and group when integrating an
+ already existing cluster.
+
+ -- Martin Pitt <mpitt@debian.org> Thu, 20 Apr 2006 23:09:36 +0200
+
+postgresql-common (49) unstable; urgency=low
+
+ * debian/supported-versions:
+ - Do not fail the package installation if an unknown LSB release is
+ encountered; merely print a warning and assume just the latest
+ PostgreSQL version is supported.
+ - Fix Ubuntu Dapper release version (6.04 -> 6.06).
+ (https://launchpad.net/bugs/36921)
+ * pg_createcluster: Add option -p/--port to set the cluster port.
+ Closes: #359249
+ * t/030_errors.t: Check that pg_createcluster's --port option validates the
+ port number (invalid number, already used port).
+ * t/090_multicluster.t: Check that pg_createcluster's --port option works.
+ * t/050_encodings.t: Check correct input/output with Latin-1 and UTF-8
+ client encodings in all server locale/encoding combinations.
+ * pg_ctlcluster: Do not set LC_ALL and LANG environment variables for the
+ postmaster; it handles locales by itself, and explicitly setting them
+ breaks sometimes. Thanks to Olleg Samoylov for analyzing this.
+ Closes: #343057
+ * t/TestLib.pm: Sort list of major versions, since we rely on a sorted list.
+ * debian/init.d-functions, do_ctl_all(): Fix 'return' statements to
+ explicitlly return 0 to not break with dash.
+ * pg_lsclusters: Sort output by version, then by cluster name.
+
+ -- Martin Pitt <mpitt@debian.org> Mon, 3 Apr 2006 09:03:15 +0200
+
+postgresql-common (48) unstable; urgency=low
+
+ * t/001_packages.t: Do not fail if postgresql-8.0 is not installed, so that
+ the complete test suite works with just 7.4 and 8.1.
+ * Remove manual conffile transition handling in p-client-common maintainer
+ scripts, since current dpkg now gets it right.
+ * t/090_multicluster.t: Remove test user_clusters so that the broken one
+ does not stay around if no user_clusters file existed before.
+ * testsuite: Set all variables that potentially cause Perl taint check
+ errors (IFS, CDPATH, ENV, BASH_ENV) to catch taint check bugs.
+ * PgCommon.pm: Add two functions prepare_exec() and restore_exec() which set
+ up a save (untainted) environment for calling external programs.
+ * pg_ctlcluster, pg_maintenance, pg_dropcluster, pg_upgradecluster: Clean
+ environment to not call external programs with potentially tainted
+ variables.
+
+ -- Martin Pitt <mpitt@debian.org> Wed, 22 Mar 2006 00:03:46 +0100
+
+postgresql-common (47) unstable; urgency=low
+
+ * debian/control: Have p-client-common Replace: all versions of
+ postgresql-common; this is a quick workaround for a dpkg bug (orphaned
+ conffiles cause package conflicts). Closes: #357909, #357910
+
+ -- Martin Pitt <mpitt@debian.org> Mon, 20 Mar 2006 19:12:29 +0100
+
+postgresql-common (46) unstable; urgency=low
+
+ * t/020_create_sql_remove.t: Make check of pg_maintenance output stricter to
+ catch things like taint errors.
+ * PgCommon.pm, get_versions() and get_version_clusters(): Check return
+ values to untaint them. Fixes taint error in pg_maintenance (and maybe
+ some more). Closes: #357237
+ * debian/control: Bump lsb-base dependency to >= 3.0-3 to ensure that
+ log_daemon_msg() and friends are available. Closes: #357108
+
+ -- Martin Pitt <mpitt@debian.org> Tue, 14 Mar 2006 22:59:03 +0100
+
+postgresql-common (45) experimental; urgency=low
+
+ * PgCommon.pm, read_conf_file(): Allow '.' characters in configuration keys.
+ Closes: #352524
+ * debian/rules: Move pg_ctlcluster, pg_createcluster, pg_dropcluster, and
+ pg_upgradecluster man pages from section 1 to 8, since they are only for
+ administrators.
+ * Split off a new package postgresql-client-common. This is to avoid having
+ cron jobs, logrotate scripts, etc. if only the client apps are installed
+ on a box. (https://launchpad.net/bugs/34167)
+ * debian/postgresql-client-common.{pre,post}inst: Migrate user_clusters
+ conffile from postgresql-common to avoid dpkg questions.
+
+ -- Martin Pitt <mpitt@debian.org> Tue, 14 Mar 2006 22:43:04 +0100
+
+postgresql-common (44) unstable; urgency=low
+
+ * PgCommon.pm, change_ugid(): Fix the order of $< and $> assignment so that
+ we don't trash the saved uid and can switch back later. This allows us to
+ make use of this function in the test suite, too.
+ * t/TestLib.pm: Use change_ugid() in exec_as() get auxiliary groups. This
+ makes the test suite work with SSL keys which are only readable by
+ ssl-cert group members.
+ * pg_ctlcluster: Untaint PID value read from autovacuum.pid.
+ * t/020_create_sql_remove.t: Add check that SSL is automatically enabled on
+ >= 8.0 clusters.
+ * pg_createcluster: Improve SSL key access check to be more robust.
+ * Enable taint checking in all programs and fix the resulting breakage.
+ * PgCommon.pm: Replace backticks program calling with proper |- pipe
+ opening to avoid intermediate shell and argument quoting problems.
+ * testsuite: Only execute tests ending with .t.
+ * Add t/100_upgrade_scripts.t: Test upgrade scripts.
+ * run-upgrade-scripts:
+ - Filter out the 'postgres' database on 8.1+ clusters.
+ - Temporarily enable connections to databases which disable them.
+ - Execute scripts in asciibetical order.
+ * debian/postgresql-common.postinst: Ensure that /var/lib/postgresql is
+ owned by postgres:postgres. (https://launchpad.net/bugs/32696)
+ * t/*.t: Remove hashbang lines to avoid lintian warnings.
+ * debian/postgresql-common.postinst: Only restart servers if upgrading from
+ a version with important pg_ctlcluster changes in between (currently,
+ prior than 40).
+ * t/090_multicluster.t: Add test for user_clusters behaviour.
+ * PgCommon.pm, user_cluster_map(): Print a meaningful error message instead
+ of 'invalid symbolic link' gibberish if a cluster in user_clusters or
+ .postgresqlrc does not exist.
+ * pg_ctlcluster:
+ - Exit with code 2 if the cluster is already (start)/not (stop) running
+ and fix error messages to be consistent. (See bug #355004)
+ - Document the exit codes in the POD.
+ - t/030_errors.t: Adapt test suite.
+ * debian/init.d-functions:
+ - Use log_daemon_msg/log_progress_msg to show all clusters of a particular
+ version on the same line, to better conform to standards.
+ - Call restart instead of stop/start.
+ - Do not fail if cluster is already (start)/not (stop) running to conform
+ to LSB.
+ - t/080_start.conf.t: Adapt test suite.
+ - Thanks to Peter Eisentraut for the original patch.
+ - Closes: #355004
+
+ -- Martin Pitt <mpitt@debian.org> Sun, 12 Mar 2006 09:57:57 +0100
+
+postgresql-common (43) unstable; urgency=low
+
+ * debian/postgresql-common.cron.d: Update documentation for 8.1 and correct
+ paths in it. Closes: #351891
+ * pg_createcluster: Fix typos in POD. Closes: #351835
+ * debian/postgresql-common.dirs: Add /var/lib/postgresql to ensure that the
+ postgres user always has an existant home directory. Closes: #351985
+ * debian/supported-versions, lsb_debian(): Add 'testing'. Closes: #353754
+ * PgCommon.pm, change_ugid():
+ - Suppress warning on nonexistant user names.
+ - Do not split group list at comma; getgrent already converts commas in
+ /etc/groups to spaces, and splitting on commas breaks pam-ldap
+ environments. Thanks to Chmouel Boudjnah.
+ - Closes: #353674
+ * pg_wrapper: Set PGSYSCONFDIR to /etc/postgresql-common if it is unset, to
+ provide a sane default for the location of pg_service.conf.
+ Closes: #353832
+ * pg_dropcluster: Remove /etc/postgresql/<version> and
+ /var/lib/postgresql/<version> if empty.
+ * t/TestLib.pm: Added check_clean() method to test for empty PostgreSQL
+ related directories and processes, and use it in all tests.
+ * pg_dropcluster: Remove default log file. This avoids leaving it behind if
+ the log file directory was changed in postgresql.conf.
+
+ -- Martin Pitt <mpitt@debian.org> Tue, 21 Feb 2006 20:59:04 +0100
+
+postgresql-common (42) unstable; urgency=low
+
+ * PgCommon.pm, change_ugid(): Implement initgroups() like behaviour to allow
+ running the postmaster in auxiliary groups. This is necessary for e. g.
+ reading shared SSL certificates.
+ * t/TestLib.pm, exec_as(): Also change group id, in order to be able to read
+ SSL certificates which are only group readable (which previously caused
+ the test suite to fail).
+ * debian/supported-versions: Add lsb_release output case 'unstable' to cope
+ with recent lsb-release change. Closes: #351475
+
+ -- Martin Pitt <mpitt@debian.org> Sun, 5 Feb 2006 12:36:53 +0000
+
+postgresql-common (41) unstable; urgency=low
+
+ * pg_createcluster: Make the definition of 'cluster already exists' less
+ strict: check for files that indicate a cluster configuration instead of
+ requiring the directory to be completely empty.
+ * debian/maintscripts-functions, configure_version(): Improve check for
+ already existing clusters to not catch subdirectories with non-cluster
+ files (e. g. a single *.old and similar).
+ * pg_ctlcluster: Add option -o to pass parameters to the postmaster process.
+ * debian/postgresql-common.postinst: Avoid error message from ls if
+ /usr/lib/postgresql does not exist.
+ * PgCommon.pm, cluster_info(): Respect log_{directory,filename} settings;
+ only use Debian's log directory if neither is set. Thanks to Scott Chapman
+ for discovering this issue.
+ * pg_ctlcluster: Create the log file if it does not yet exist; this ensures
+ that we always know the file postmaster really uses and avoids the race
+ condition with nonexisting files if log_filename contains time macros.
+ * pg_createcluster: Explain possibility of overriding the log symlink with
+ log_* in postgresql.conf.
+ * architecture.html: Fix some typos, remove obsolete pg_upgradecluster
+ procedure.
+
+ -- Martin Pitt <mpitt@debian.org> Sun, 29 Jan 2006 11:38:01 +0000
+
+postgresql-common (40) unstable; urgency=low
+
+ * debian/supported-versions: Add 8.1 to Ubuntu 5.10 to properly support
+ backport.
+ * PgCommon.pm: If /etc/postgresql-common/user_clusters does not exist, use
+ the default cluster instead of returning an invalid value. Also, do not
+ complain if the file does not exist (which is legitime). Closes: #348447
+ * debian/README.Debian: Fix 'detailled' typo. Closes: #346442
+ * Replace most calls to get_conf_value() with the much more efficient new
+ function read_cluster_conf_file().
+ * pg_upgradecluster: Factorized and cleaned up parameter deprecation/upgrade
+ code.
+ * Support auxiliary environment variables for postmaster:
+ - pg_createcluster: Create /etc/postgresql/version/cluster/environment
+ file (empty, just a comment).
+ - pg_dropcluster: Remove environment file.
+ - pg_ctlcluster: Clear environment and only set variables mentioned in
+ environment file and LANG/LC_ALL.
+ - Closes: #345516
+ * t/020_create_sql_remove.t: Check save environment and correct function of
+ the environment file.
+ * PgCommon.pm, next_free_port(): Check if the port is already in use, skip
+ it if so. Closes: #348875.
+ * t/090_multicluster.t: Create a socket bound to port 5434 and check that it
+ is not used by pg_createcluster.
+
+ -- Martin Pitt <mpitt@debian.org> Sat, 21 Jan 2006 17:16:32 +0100
+
+postgresql-common (39) unstable; urgency=low
+
+ * Add t/090_multicluster.t: Test multicluster operation and environment
+ variable handling (PGCLUSTER, PGPORT).
+ * pg_upgradecluster: When upgrading from < 8.1 to >= 8.1, check for users
+ and groups with the same name and abort if there are any. Closes: #343622
+ * t/040_upgrade.t: Add self test for above bug (clashing role names on
+ upgrade).
+ * testsuite: Run the tests twice; once with umask 022, once with umask 077.
+ * Fix operation under umask 077:
+ - pg_createcluster: Create /var/log/postgresql with mode 0755.
+ - PgCommon.pm, set_cluster_start_conf(): Always create start.conf with
+ 0644 mode by default, but preserve permissions when changing the file.
+ - pg_upgradecluster: Ensure correct permissions of the temporary
+ pg_hba.conf that only allows superuser connections. Closes: #345670
+
+ -- Martin Pitt <mpitt@debian.org> Tue, 3 Jan 2006 20:27:10 +0100
+
+postgresql-common (38) unstable; urgency=low
+
+ * pg_ctlcluster: Remove --setuid option, it does not make too much sense
+ after all and only confuses users. Closes: #343063
+ * Remove pg_ctlcluster's -s option from all scripts.
+ * pg_wrapper: Fix 'postgreqsl' typo in POD. Closes: #343938
+ * pg_createcluster: Do not simply close STDOUT, but reopen it to /dev/null
+ to avoid initdb complaining about invalid filehandles. Closes: #344180
+ * debian/init.d-functions: Check if the requested version's postmaster is
+ available before trying to start/stop a cluster to avoid errors when a
+ server package is removed, but not purged. Closes: #343730
+
+ -- Martin Pitt <mpitt@debian.org> Thu, 22 Dec 2005 18:41:23 +0100
+
+postgresql-common (37) unstable; urgency=low
+
+ * debian/postgresql-common.config: Only show the obsolete version warning
+ once.
+ * Add French debconf translations, thanks to Guilhelm Panaget.
+ Closes: #340200, #341267
+ * debian/postgresql-common.postinst: Change default permissions of the
+ private SSL key to root:postgres 0640 to prevent potential modification of
+ the certificate by the postmaster. Closes: #341141
+ * Add Czech debconf translations, thanks to Miroslav Kure. Closes: #341951
+ * debian/postgresql-common.postinst: Check that the postgres user/group is
+ not root; fail installation with a meaningful error message if it is.
+ Closes: #340459
+ * t/040_upgrade.t: Check upgrading of sequence and stored PL/PgSQL
+ procedure.
+ * pg_upgradecluster: Change hardcoded and obsolete library paths to
+ '$libdir' in the new cluster. This fixes upgrades of 7.4 clusters that
+ were upgraded from woody. Closes: #338031
+
+ -- Martin Pitt <mpitt@debian.org> Sat, 10 Dec 2005 23:36:41 +0100
+
+postgresql-common (36) unstable; urgency=low
+
+ * pg_createcluster: Add --start-conf option to set start.conf value.
+ * t/080_start.conf.t: Test --start-conf option.
+ * debian/postgresql-common.config: Fix determination of latest version: Use
+ highest supported version, not highest installed one.
+
+ -- Martin Pitt <mpitt@debian.org> Mon, 28 Nov 2005 23:23:18 +0100
+
+postgresql-common (35) unstable; urgency=low
+
+ * pg_ctlcluster: If the socket already responds, but connections fail
+ several times in a row, give the postmaster some more time (5s) to
+ actually accept connections.
+ * t/060_obsolete_confparams.t: Start with a full configuration file for
+ every tested version, instead of just upgrading the previously upgraded
+ version. This gives an exhaustive check for obsolete parameters.
+ * pg_upgradecluster: Handle all outstanding obsolete parameters when
+ upgrading to 8.1:
+ - bgwriter_percent -> bgwriter_{lru,all}_percent
+ - bgwriter_maxpages -> bgwriter_{lru,all}_maxpages
+ * PgCommon.pm: Add new function set_cluster_start_conf() for easier change
+ of start.conf.
+ * Rename test 030_create_errors.t to 030_errors.t since it covers more
+ errors than just creation failures.
+ * Add test t/080_start.conf.t: Check start.conf handling and upgrading.
+ * debian/supported-versions: Add Debian release 3.1.
+ Closes: #340397, #340483
+ * debian/postgresql-common.config: Ignore things in /usr/lib/postgresql that
+ are not a version-specific postgresql subdirectory. Closes: #340470
+ * t/001_packages.t: Check that procps is installed, the selftests need it.
+
+ -- Martin Pitt <mpitt@debian.org> Thu, 24 Nov 2005 22:27:51 +0100
+
+postgresql-common (34) unstable; urgency=low
+
+ * debian/postgresql-common.postrm: Fix syntax error.
+ * Add debian/supported-versions: Script to determine the set of supported
+ PostgreSQL major versions for the running distro/release. Currently covers
+ Debian sid/testing, Ubuntu 5.10 and Ubuntu 6.04.
+ * debian/postgresql-common.config: Remove hardcoded versions, use
+ supported-versions now.
+ * Minor test suite variable cleanup.
+ * debian/README.Debian: Update for version 8.1.
+
+ -- Martin Pitt <mpitt@debian.org> Tue, 22 Nov 2005 01:17:32 +0100
+
+postgresql-common (33) unstable; urgency=low
+
+ * pg_wrapper: Instead of checking $0 against a static list, just check
+ whether the program is available in postgresql's bin dir. This allows
+ other packages which provide stuff in pg_bin to install additional
+ symlinks and get pg_wrapper support for free.
+ * pg_checksystem, pg_createcluster, pg_dropcluster, pg_upgradecluster: Check
+ that effective user is root before doing anything to avoid confusing error
+ messages.
+ * pg_ctlcluster: Enhance the check if cluster is up and running to make it
+ more reliable. This should fix the 'Database system is starting up' errors
+ on autovacuum startup.
+ * debian/init.d-functions: Remove legacy init script output and always use
+ LSB functions. Add lsb-base dependency.
+ * debian/po/de.po: Fix cluster version in German translation.
+ Closes: #340096
+ * debian/postgresql-common.postrm: Check if /etc/postgresql-common exists
+ before trying to remove it. Closes: #340187
+ * pg_upgradecluster:
+ - Fix error message for nonexisting cluster.
+ - Use pg_dump/pg_restore with custom format to support BLOBs.
+ - Upgrade databases with disabled connection.
+ - Execute ANALYZE after upgrade instead of pg_maintenance.
+ - Set correct autovacuum option in postgresql.conf when
+ upgrading to 8.1, depending on whether autovacuuming was used for the
+ old cluster.
+ - Restrict access to the clusters to the cluster owner and to the local
+ Unix socket during upgrade. Closes: #338025
+ - Convert to 'strict' Perl mode.
+
+ -- Martin Pitt <mpitt@debian.org> Mon, 21 Nov 2005 23:30:34 +0100
+
+postgresql-common (32) unstable; urgency=low
+
+ * debian/postgresql-common.config: Fix stderr redirection when checking for
+ installed packages. Closes: #339457
+ * pg_createcluster: Add a POD stanza about cluster names and their purpose.
+ * Explained why and how to delete the main cluster of the new version before
+ upgrading the old main cluster. Closes: #339392
+ * pg_ctlcluster: Call setsid() to unbind from controlling terminal before
+ starting the daemon. Closes: #338862
+ * t/020_create_sql_remove.t: Add selftest for associated terminal (bug
+ #338862).
+ * debian/control: Version dependency on debconf to (>= 0.5.00) to make
+ lintian happy.
+
+ -- Martin Pitt <mpitt@debian.org> Fri, 18 Nov 2005 00:42:48 +0100
+
+postgresql-common (31) unstable; urgency=low
+
+ * Completely new test suite rewritten from scratch; the new suite now uses
+ perl instead of shell, can be extented more easily, handles changing of
+ supported major versions and does more tests.
+ * Fix start.conf handling of pg_upgradecluster:
+ - Disable automatic startup of old backup cluster in start.conf.
+ - Preserve the original start.conf in new cluster.
+ - Error out if original cluster is disabled.
+ * Add debconf note about upgrading from obsolete version 8.0.
+ * debian/control: Add debconf dependency.
+ * Disable automatic autovacuum invocation for -contrib-8.1:
+ - pg_ctlcluster: Check version before (not after) complaining about a
+ missing pg_autovacuum
+ - debian/maintscripts-functions: Check version before trying to call
+ autovac-{start,stop}
+ - Closes: #337925
+ * pg_maintenance: Add --cluster option to work only on selected cluster.
+ * pg_upgradecluster: Vacuum and analyze the target cluster after upgrade.
+ Closes: #338010
+ * pg_ctlcluster: Exit with nonzero if cluster is already running.
+ * pg_upgradecluster configuration parameter upgrading:
+ - When upgrading to 8.1+, disable obsolete 'rendezvous_name' option.
+ - When upgrading to 8.0+, rename sort_mem to work_mem.
+
+ -- Martin Pitt <mpitt@debian.org> Tue, 15 Nov 2005 12:38:48 +0100
+
+postgresql-common (30) unstable; urgency=high
+
+ * Urgency high since this fixes a stupid bug introduced in 29.
+ * pg_lsclusters: Add -h/--no-header option to suppress header output.
+ * pg_createcluster: Fix the default start.conf to contain "auto" by default.
+ * PgCommon.pm, [sg]et_conf_value: Regard fractional and negative values as
+ simple values that do not need quoting. Closes: #336675
+
+ -- Martin Pitt <mpitt@debian.org> Thu, 3 Nov 2005 16:30:25 -0500
+
+postgresql-common (29) unstable; urgency=low
+
+ * pg_wrapper: Do not override an already defined PGPORT environment
+ variable. Closes: #335692
+ * debian/postgresql-common.cron: Check if pg_maintenance is available before
+ calling it, to avoid errors when package is removed, but not purged.
+ Closes: #333803
+ * pg_createcluster: Do not enable SSL on 7.4 clusters since enabling it
+ without enabling the TCP socket breaks.
+ * Add support for configuring the start/stop behavior in start.conf:
+ - debian/init.d-functions: Only start/stop the cluster in 'auto' mode.
+ - pg_ctlcluster: Only operate in 'auto' and 'manual' modes, print an error
+ in 'disabled' mode.
+ - pg_createcluster: Create a default start.conf file.
+ - pg_dropcluster: Remove start.conf file.
+ - architecture.html, pg_createcluster POD: Document the file and the
+ possible options.
+ - Closes: #224047
+ * Fix testsuite expected output for new upstream versions (7.4.9 and 8.0.4).
+
+ -- Martin Pitt <mpitt@debian.org> Thu, 27 Oct 2005 23:09:45 -0400
+
+postgresql-common (28) unstable; urgency=high
+
+ * Urgency high since this version only fixes a very important bug with a
+ safe patch.
+ * Moved package development to bazaar-ng, updated debian/README.Devel.
+ * debian/postgresql-common.postinst: Revert change of version 26: Do create
+ the socket directory in the postinst, otherwise clusters will default to
+ socket directory /tmp in some cases.
+
+ -- Martin Pitt <mpitt@debian.org> Thu, 20 Oct 2005 12:56:36 +0200
+
+postgresql-common (27) unstable; urgency=low
+
+ * Changed my debuild alias to explicitly ignore .arch-ids directories (a
+ mere -i catched some, but not all arch directories). Closes: #328204
+ * Add lintian overrides for missing manpages; manpages are provided by
+ postgresql-client-X.Y packages.
+ * pg_ctlcluster: Have autovac-* commands error out with a meaningful message
+ instead of claiming success if pg_autovacuum is not available.
+ * pg_ctlcluster:
+ - Increase the timeout for the started postmaster to 30 seconds to cope
+ with slow startup. Closes: #320444
+ - Immediately fail if the postmaster produced log output and does not run
+ any more. This avoids unnecessary timeouts on configuration errors and
+ the like.
+ * pg_createcluster: Listen on localhost by default only since upstream
+ considers listening on all interfaces by default not safe enough.
+ Closes: #318820
+ * pg_dropcluster: Handle missing data directories gracefully.
+ Closes: #330135
+
+ -- Martin Pitt <mpitt@debian.org> Wed, 28 Sep 2005 22:59:04 +0200
+
+postgresql-common (26) unstable; urgency=low
+
+ * Fix permissions of socket directory:
+ - debian/postgresql-common.postinst: Drop creation of socket directory
+ since we do it in the init script anyway.
+ - debian/init.d-functions: Create directory with permissions 2775 instead
+ of 755 and also correct the permissions of an already existing
+ directory.
+ - Closes: #326049
+ * debian/postgresql-common.postinst: Remove --no-create-home option from
+ adduser call to ensure that the postgres user always has a sensible home
+ directory that does not break "su - postgres".
+ * pg_wrapper: Give a meaningful error message if no client packages are
+ installed, instead of "Invalid PostgreSQL cluster version".
+ Closes: #326771
+ * debian/README.Devel: Explain the structure and development of Debian's
+ PostgreSQL packages.
+
+ -- Martin Pitt <mpitt@debian.org> Wed, 7 Sep 2005 10:50:31 +0200
+
+postgresql-common (25) unstable; urgency=low
+
+ * PgCommon.pm, get_cluster_socketdir():
+ - If the socket directory is configured in postgresql.conf, use it right
+ away instead of doing experiments before.
+ - Improved sanity checking.
+ - Error out if the data directory cannot be stat'ed, since we cannot
+ determine a sensible directory in this case.
+ * pg_upgradecluster: Don't call cluster_info() on the yet nonexistant
+ new cluster, just check for the data directory for determining if the new
+ cluster already exists.
+ * debian/control: Add adduser dependency.
+ * testsuite: Generalize stopping of servers to work with all versions.
+ * Avoid whinging during log rotation if there is no log file at all:
+ - debian/postgresql-common.logrotate: Add "missingok".
+ - debian/postgresql-common.dirs: Create /var/log/postgresql/.
+ - Server packges have been changed to not clean away /var/log/postgresql/
+ on purge.
+ - Closes: #325330
+ * pg_ctlcluster: When starting the autovacuum daemon, don't just wait for 1
+ second, but actually test if the server is running (timeout: 5 seconds);
+ this should make the daemon startup much more reliable.
+ * Remove test upgrade script upgrade-scripts/all_test_t1.sql, it has done
+ its purpose now.
+
+ -- Martin Pitt <mpitt@debian.org> Wed, 31 Aug 2005 01:01:49 +0200
+
+postgresql-common (24) unstable; urgency=low
+
+ * Add /usr/share/postgresql-common/pg_checksystem: Check system parameters
+ which are relevant to PostgreSQL. Right now this checks if write caching
+ is enabled on any disk containing PostgreSQL clusters.
+ * debian/postgresql-common.postinst: Call pg_checksystem. Closes: #318928
+ * Bump Standards-Version to 3.6.2.
+ * debian/postgresql-common.postinst: Setup user 'postgres' with /bin/bash as
+ default shell. Closes: #320810
+ * pg_wrapper, debian/postgresql-common.links: Wrap reindexdb, it is a
+ standard client program in 8.1.
+ * pg_createcluster: Do not create autovacuum log file for servers >= 8.1.
+ * PgCommon.pm: For determining avac_enable on 8.1+ servers, read
+ "autovacuum" setting from postgresql.conf.
+ * pg_maintenance: Use avac_enable flag instead of checking for the
+ pg_autovacuum pid file to determine whether autovacuuming is enabled. This
+ is a more general approach and works for all server versions.
+ * pg_ctlcluster: Do not attempt to start pg_autovacuum on 8.1+ servers.
+ * pg_createcluster: Add hook for version specific function to configure
+ postgresql.conf.
+ * pg_createcluster: Add default configuration for 7.4 clusters:
+ - tcpip_socket = true
+ - stats_row_level = true
+ * pg_createcluster: Add default configuration for 8.0 clusters:
+ - listen_addresses = '*'
+ - stats_row_level = true
+ * pg_createcluster: Add default configuration for 8.1 clusters:
+ - listen_addresses = '*'
+ - stats_row_level = on
+ - autovacuum = on
+ * PgCommon.pm, set_conf_value(): Preserve comments.
+ * debian/postgresql-common.postinst: Generalized restarting of all clusters
+ to make it automatically work for future versions.
+ * pg_createcluster: Adapt pg_hba.conf to the current default (md5 for host
+ connections, ident sameuser for local ones); this obsoletes the
+ default-pg_hba.conf patches in the server packages.
+ * user_clusters: Update comments, throw out bogus documentation.
+ Closes: #324749
+ * pg_createcluster: Only mangle configuration files (pg_hba.conf, SSL
+ enabling, etc.) if we create a new cluster, not if we integrate an already
+ existing one. Closes: #323878
+ * Add debian/postgresql-common.logrotate: Simple log rotation.
+ Closes: #316100
+
+ -- Martin Pitt <mpitt@debian.org> Tue, 23 Aug 2005 23:10:09 +0200
+
+postgresql-common (23) unstable; urgency=low
+
+ * pg_maintenance: Change directory to / before changing uid to avoid "could
+ not change directory" errors. Closes: #318604.
+ * Drop upgrade-scripts/all_vacuum_t1.sql since it causes too much trouble
+ with big databases. Replace it with upgrade-scripts/all_test_t1.sql which
+ just counts the tables in the database. This should be unintrusive, fast,
+ and still appropriate for testing the upgrade scripts mechanism.
+ Closes: #319035
+ * pg_ctlcluster: Check if autovacuum log file symlink is dangling and avoid
+ warnings about uninitialized warnings. Instead print out a meaningful
+ error message. Closes: #318717
+ * debian/postgresql-common.postinst: Generate a dummy
+ /etc/postgresql-common/root.crt if not present. Closes: #319110
+ * debian/postgresql-common.postrm: Remove /etc/postgresql-common/root.crt on
+ purge.
+ * pg_createcluster: If /etc/postgresql-common/root.crt exists, symlink
+ root.crt from the data directory. Closes: #318818
+ * debian/README.Debian: Document root.crt handling.
+
+ -- Martin Pitt <mpitt@debian.org> Thu, 21 Jul 2005 00:44:52 +0200
+
+postgresql-common (22) unstable; urgency=low
+
+ * pg_createcluster: Set default authentication for TCP connections to "md5"
+ instead of the old "ident sameuser" default since it makes a lot more
+ sense.
+ * tests/000_debs: Fix detection of whether a package is installed.
+ * tests/100_encodings: Fix filtering of postmaster processes.
+
+ -- Martin Pitt <mpitt@debian.org> Thu, 14 Jul 2005 12:00:16 +0300
+
+postgresql-common (21) unstable; urgency=low
+
+ * README.Debian: Explain that a server is required, give postgresql-8.0
+ example. (The descriptions of the packages have been updated in
+ postgresql-{7.4,8.0}.) Closes: #313247
+ * README.Debian: Add "-s /bin/sh" to su command to also work with disabled
+ shells for postgres.
+ * README.Debian: Document autovacuum handling.
+
+ -- Martin Pitt <mpitt@debian.org> Tue, 12 Jul 2005 09:41:30 +0300
+
+postgresql-common (20) unstable; urgency=low
+
+ * Add infrastructure for executing SQL or executable scripts on clusters and
+ databases on upgrade. This can be useful to apply security updates which
+ need to change database layouts (like for CAN-2005-1409), do checks on
+ upgrades, and maybe other things.
+ - Add run-upgrade-scripts and call it in the postinst.
+ - Add /usr/share/postgresql-common/upgrade-scripts/ where scripts are
+ stored into.
+ - Add /usr/share/postgresql-common/upgrade-scripts/SPECIFICATION.
+ - This checks for available databases, thus will not fail on a nonexisting
+ template0. Closes: #312707
+ - Tests are run right after starting all clusters. Also, the package
+ installation does not fail if the upgrade fails on a single cluster or
+ database. Closes: #308685
+ * pg_ctlcluster: pg_ctl's -o option is not cumulative, fix postmaster
+ argument passing. This ensures that "-c unix_socket_directory" is always
+ passed to the postmaster.
+ * pg_createcluster: Do not configure a cluster for SSL if the owner is not
+ the owner of /etc/postgresql-common/postgresql.pem. This fixes cluster
+ creation for non-postgres owners.
+ * Add test 130_nonpostgres_clusters: Check cluster creation and operation
+ for a cluster owned by "nobody".
+ * Add upgrade-scripts/all_vacuum_t1.sql: Upgrade script that will just
+ vacuum all available databases. This is pretty useful and harmless, and is
+ a good thing to test upgrade scripts at a larger scale.
+ * init.d-functions: Rename autovac-* to autovac_* to comply to POSIX shell
+ identifier rules. Closes: #315551
+
+ -- Martin Pitt <mpitt@debian.org> Sun, 26 Jun 2005 14:26:56 +0200
+
+postgresql-common (19) unstable; urgency=low
+
+ * debian/postgresql-common.postinst: Generate an SSL certificate and key if
+ it doesn't exist yet and openssl is installed. Closes: #212526
+ * debian/control: Recommend openssl and explain its purpose.
+ * pg_createcluster: If SSL certificate and key exist, symlink it to the
+ cluster directory where the postmaster looks for them and enable SSL in
+ the configuration.
+ * debian/postgresql-common.postinst: Only restart servers when configuring.
+ * debian/init.d-functions: "pg_ctl restart" does not seem to re-read certain
+ configuration parameters like the socket directory, so replace it with
+ stop+start.
+ * debian/postgresql-common.postinst: Create /var/run/postgresql before
+ creating the initial cluster to ensure that the socket directory will be
+ present. Closes: #312899
+ * Added debian/postgresql-common.postrm: Clean up on purge.
+ * debian/postgresql-common.postinst: Check whether the user postgres exists
+ before calling adduser to avoid confusing warning messages.
+
+ -- Martin Pitt <mpitt@debian.org> Wed, 22 Jun 2005 17:33:50 +0200
+
+postgresql-common (18) unstable; urgency=low
+
+ * pg_ctlcluster: Change directory to /var/lib/postgresql to avoid error
+ messages when doing an operation in a directory which the database owner
+ cannot access.
+ * pg_ctlcluster: Pass the default socket directory to the postmaster,
+ otherwise it will always be /tmp if unix_socket_directory is not specified
+ in postgresql.conf. Closes: #314537
+ * Added tests/041_server_default_socketdir: Check that the socket is created
+ in /var/run/postgresql if unix_socket_directory is not specified.
+ * pg_ctlcluster:
+ - On startup, check for a stale or invalid PID file and remove it if
+ appropriate.
+ - On stop, bail out on an invalid PID file. Closes: #304466.
+ * Added tests/021_invalid_pidfile: Corrupt the pid file in various ways
+ while the server is running and down. Also check double start/stop.
+
+ -- Martin Pitt <mpitt@debian.org> Sat, 18 Jun 2005 20:30:10 +0200
+
+postgresql-common (17) unstable; urgency=low
+
+ * PgCommon.pm, cluster_port_running(): Attempt to connect() to the server
+ socket for probing if the server is running. The previous method of using
+ 'psql -l' asked for a password if md5/password authentication is used
+ locally. Closes: #314292
+ * testsuite: Ignore whitespace changes in expected vs. actual output.
+ * tests/100_encodings: Fix race condition when showing postmaster processes:
+ If we catch the postmaster right at fork() time, ps shows two postmaster
+ instances instead of one. Filter them away to get the expected output.
+
+ -- Martin Pitt <mpitt@debian.org> Thu, 16 Jun 2005 11:44:08 +0200
+
+postgresql-common (16) unstable; urgency=low
+
+ * pg_createcluster: Add --logfile parameter.
+ * pg_wrapper(1): Clarify synopsis.
+ * debian/rules: Deuglify manpages by building them with --quotes=none.
+ * debian/maintscripts-functions: Do not create a default "main" cluster when
+ upgrading a server package.
+ * pg_upgradecluster: Handle more configuration parameter transitions:
+ - syslog -> log_destination
+ - log_statement: false/true -> none/all
+ - log_{pid,timestamp,hostname,source_port} -> log_line_prefix
+ - obsolete max_expr_depth
+ * pg_upgradecluster: Use new replace_conf_value() function which
+ produces nicer configuration files with transitioned parameters.
+ * Add test 120_obsolete_confparams: Upgrade a 7.4 cluster with all
+ possible 7.4 options enabled.
+ * PgCommon.pm: Fix parsing of autovacuum parameters.
+ * pg_ctlcluster: Respect the avac_debug autovacuum configuration option.
+ * pg_createcluster: Since the new default socket directory is
+ /var/run/postgresql, explicitly set /tmp as socket directory for clusters
+ if /var/run/postgresql is not writable by the cluster owner.
+ * PgCommon.pm, get_cluster_socketdir(): If unix_socket_directory is not
+ specified explicitly in postgresql.conf, default to /var/run/postgresql
+ for postgres-owned clusters. Closes: #313651
+ * pg_ctlcluster: Do not sleep at all after starting the postmaster if we
+ don't run the autovacuum daemon; sleep for a full second if we do.
+
+ -- Martin Pitt <mpitt@debian.org> Wed, 15 Jun 2005 01:01:11 +0200
+
+postgresql-common (15) unstable; urgency=low
+
+ * First unstable upload, welcome to the PostgreSQL future.
+ * Quiet maintenance:
+ - pg_maintenance: Supply -q to vacuumdb unless in verbose mode.
+ - postgresql-common.cron.d: Direct stdout to /dev/null.
+ - Adapted tests/060_maintenance expected output.
+ - Closes: #312298
+
+ -- Martin Pitt <mpitt@debian.org> Tue, 7 Jun 2005 12:11:48 +0200
+
+postgresql-common (14) experimental; urgency=low
+
+ * pg_ctlcluster: Check whether mutually exclusive log_*_stats are enabled
+ to avoid the "FATAL: invalid cache id: 30" error on client invocations.
+ * Added test 110_invalid_conf: test checking of invalid configurations.
+ * Ship test suite in /usr/share/postgresql-common.
+ * pg_ctlcluster: Fix logging of autovacuum daemon.
+ * pg_ctlcluster: Check if autovacuum daemon is really running, exit with an
+ error and print log if not.
+
+ -- Martin Pitt <mpitt@debian.org> Sun, 5 Jun 2005 11:19:08 +0200
+
+postgresql-common (13) experimental; urgency=low
+
+ * pg_createcluster: Add option --start to start the new cluster right after
+ creating it.
+ * tests/000_existing_clusters: Check for stale postmaster and pg_autovacuum
+ processes.
+ * testsuite:
+ - Temporarily stop existing servers and move away existing files before
+ executing the tests.
+ - Restore the original files after the tests.
+ * pg_upgradecluster: Check return value of pg_dumpall and psql and fail if
+ they are not successful.
+ * pg_createuser: Fix indentation of socket warning.
+ * pg_upgradecluster: Check if cluster is running, exit with an error if not.
+ * pg_createcluster: Added option --encoding to override detection from
+ locale.
+ * pg_createcluster: Guess default encoding from locale for clusters older
+ than 8.0 to get the same behaviour as for 8.0.
+ * debian/control: Conflict to postgresql-7.4 << 1:7.4.8-5 since earlier
+ versions do not support non-ASCII encodings (due to missing pg_encoding).
+ * pg_ctlcluster: Check that the cluster owner uid/gid really exist.
+ Closes: #311546
+ * pg_lsclusters: Ensure that there is at least one space between the colums.
+ * Added tests/100_encodings which checks cluster creation and updates
+ for different encodings and locales.
+ * pg_upgradecluster: Preserve socket directory, locales, and encoding.
+ * tests/100_encodings: Check the locale the postmaster is running under.
+
+ -- Martin Pitt <mpitt@debian.org> Sat, 4 Jun 2005 15:44:40 +0200
+
+postgresql-common (12) experimental; urgency=low
+
+ * pg_ctlcluster: Remove "status" command, it's not documented and not
+ really useful.
+ * PgCommon: Fix cluster_info for avac_logfile to make pg_dropcluster clean
+ away the autovacuum log file.
+ * pg_maintenance: -v only influences vacuumdb output now, always show
+ clusters.
+ * Added a test suite:
+ - Test scripts are in tests/*.
+ - Expected output is in tests/*.ex.
+ - Test suite is run with './testsuite' as root.
+ * pg_createcluster:
+ - Converted optional third parameter to option --datadir.
+ - Rework POD to have a separate OPTIONS section.
+ - Add option description to online help.
+ * pg_ctlcluster: Improve POD.
+ * pg_upgradecluster:
+ - Initial framework for handling obsolete configuration parameters.
+ - Handle transition of {tcpip_socket, virtual_host} -> listen_addresses.
+ * debian/init.d-functions: If /lib/lsb/init-functions is available, use LSB
+ init script functions.
+ * pg_ctlcluster: After start, check whether the cluster is really running.
+ If it does not come up after 5 seconds, fail and print the recent log
+ portion.
+
+ -- Martin Pitt <mpitt@debian.org> Tue, 31 May 2005 12:16:26 +0200
+
+postgresql-common (11) experimental; urgency=low
+
+ * pg_ctlcluster: Cleaned up variables.
+ * Factored out change_ugid() to PgCommon.pm and use it in the scripts.
+ * Added pg_maintenance(8) program.
+ * Activated formerly disabled postgresql-common.cron.d which calls
+ pg_maintenance.
+ * pg_createcluster: Default to cluster owner 'postgres' if no owner is
+ specified.
+ * pg_ctlcluster: Fix pg_controldata output parsing and call pg_controldata
+ under locale 'C' to work with all locales. Closes: #310716
+ * pg_createcluster: Added --socket-dir option.
+ * PgCommon.pm: Fix declaration of @lines in set_conf_value() to avoid
+ duplicating the lines in configuration files.
+ * PgCommon.pm: Converted to use strict to avoid future errors.
+ * pg_maintenance: Removed option '-e' from vacuumdb call (leftover from
+ debugging).
+ * PgCommon.pm, user_cluster_map(): If several clusters exist, but no
+ mapping is configured, return not only the default port's cluster version,
+ but also its name. This fixes the socket directory determination for this
+ case.
+ * debian/rules: Fix clean target to remove the manpages created from POD
+ again.
+ * pg_upgradecluster: Provide socket directory arguments to psql and
+ pg_dumpall to make it work for sockets which are not in /tmp.
+
+ -- Martin Pitt <mpitt@debian.org> Sat, 28 May 2005 16:02:59 +0200
+
+postgresql-common (10) experimental; urgency=low
+
+ * pg_ctlcluster: Supply cluster socket directory to pg_autovacuum.
+
+ -- Martin Pitt <mpitt@debian.org> Tue, 24 May 2005 22:57:33 +0200
+
+postgresql-common (9) experimental; urgency=low
+
+ * Add README.Debian with some general introduction, "first steps for the
+ impatient", and pointers to further documentation.
+ * pg_ctlcluster: Check validity of postmaster locale before setting it.
+ * pg_createcluster: Check validity of locale before calling initdb under it.
+ * pg_wrapper: Support PGCLUSTER environment variable. Closes: #305912
+ * pg_upgradecluster:
+ - Copy original configuration files.
+ - Configure the target cluster to use the original port, move the old
+ cluster to a previously unused port.
+ - Start the new cluster after upgrade.
+ * debian/init.d-functions: Create /var/run/postgresql if it does not exist.
+ * pg_createcluster: Set the socket directory to /var/run/postgresql for
+ postgres-owned clusters. Print a warning to change the directory for other
+ owners. Closes: #308597
+ * pg_wrapper: If PGHOST is not defined, set it to the cluster's socket
+ directory to make client programs work with non-default socket
+ directories.
+
+ -- Martin Pitt <mpitt@debian.org> Sun, 22 May 2005 22:22:38 +0200
+
+postgresql-common (8) experimental; urgency=low
+
+ * pg_ctlcluster: Check whether owner is in the shadow group, and keep shadow
+ group privilege in this case; this is a poor workaround for Perl's lack of
+ an initgroups() functions. Closes: #305427
+ * debian/postgresql-common.postinst: Fix adduser invocation, set home
+ directory to /var/lib/postgresql. Closes: #308589
+ * Remove pg_default.1 and pg_exec.1, these programs do not exist. Closes:
+ #305724
+ * debian/postgresql-common.links: Add a symlink postgresql-common(7) to
+ pg_wrapper(1) to make finding the manpage a bit more obvious.
+ * PgCommon.pm, user_cluster_map(): If there are no clusters, use the latest
+ version; this makes it possible to use remote clusters with no local ones.
+ Closes: #306836
+
+ -- Martin Pitt <mpitt@debian.org> Fri, 13 May 2005 00:35:35 +0200
+
+postgresql-common (7) experimental; urgency=low
+
+ * Fix warning when calling pg_wrapper with an invalid cluster.
+ * PgCommon.pm, user_cluster_map(): If only one cluster exists, return that
+ if no match is found in the map files.
+ * pg_ctlcluster: Start the postmaster under the locale that was used with
+ initdb.
+ * Updated documentation in architecture.html.
+
+ -- Martin Pitt <mpitt@debian.org> Wed, 20 Apr 2005 02:34:19 +0200
+
+postgresql-common (6) experimental; urgency=low
+
+ * pg_dropcluster: Check if postmaster and autovacuum log file paths are
+ defined before unlinking them to avoid a warning. Closes: #303259
+ * pg_ctlcluster: Documented the autovacuum stuff in the POD.
+ * debian/init.d-functions: Add autovacuum commands.
+ * debian/maintscripts-functions: (Re)start/stop autovacuum daemons on
+ configuration/removal of p-contrib-*.
+ * pg_ctlcluster, autovacuum_start(): Check for already running daemon before
+ starting a new one.
+ * pg_createcluster: Add an explicit "local all" entry for the database
+ superuser to pg_hba.conf. Closes: #303274
+
+ -- Martin Pitt <mpitt@debian.org> Wed, 6 Apr 2005 20:59:28 +0200
+
+postgresql-common (5) experimental; urgency=low
+
+ * PgCommon.pm: Internalize get/set_conf_value, export get/set_cluster_port
+ instead.
+ * pg_ctlcluster: Integrated pg_autovacuum startup if -contrib is installed
+ (based on some patches from Adam R. Skutt, thanks).
+ * pg_createcluster: Create autovacuum_log symlink and log file.
+ * pg_dropcluster: Remove autovacuum_log symlink and log file.
+ * PgCommon.pm: If a configuration file is not found in the cluster conf dir,
+ fall back to the one in /etc/postgresql-common.
+ * Install /etc/postgresql-common/autovacuum.conf as a fallback default
+ configuration file for pg_autovacuum.
+
+ -- Martin Pitt <mpitt@debian.org> Sun, 3 Apr 2005 09:10:27 +0200
+
+postgresql-common (4) experimental; urgency=low
+
+ * pg_upgradecluster: Uncomment library search path (artifact from
+ debugging).
+ * debian/postgresql-common.postinst: Don't create postgres user with home /,
+ this can lead to problems sometimes.
+ * pg_ctlcluster: Fixed pg_ctl invocation (dangling -o argument with versions
+ < 8.0, caused errors when using dash as /bin/sh). Closes: #300896
+
+ -- Martin Pitt <mpitt@debian.org> Tue, 22 Mar 2005 23:32:47 +0100
+
+postgresql-common (3) experimental; urgency=low
+
+ * Add richer set of common maintainer scripts functions (for package
+ removal, and also for client and contrib packages).
+ * Use alternatives system to link manpages from
+ /usr/share/postgresql/<version>/man/... to /usr/share/man.
+
+ -- Martin Pitt <mpitt@debian.org> Mon, 21 Mar 2005 00:33:22 +0100
+
+postgresql-common (2) experimental; urgency=low
+
+ * pg_wrapper: Check that specified cluster actually exists.
+ * Fix some Perl warnings.
+ * Added initial version of pg_upgradecluster(8).
+
+ -- Martin Pitt <mpitt@debian.org> Mon, 14 Mar 2005 17:51:22 +0100
+
+postgresql-common (1) experimental; urgency=low
+
+ * New package to provide a common infrastructure for different PostgreSQL
+ versions. This finally fixes all bugs concerning failed automatic
+ upgrades. Closes: #277700, #282803, #224047, #229240, #232553, #279184,
+ #241337, #247261, #157282, #167864, #305347
+ * pg_wrapper now has a central role for mapping clients to clusters, so it
+ is not "overkill" any more. Closes: #201702
+
+ -- Martin Pitt <mpitt@debian.org> Sun, 20 Feb 2005 23:54:54 +0100
+
diff --git a/debian/clean b/debian/clean
new file mode 100644
index 0000000..cb12eb3
--- /dev/null
+++ b/debian/clean
@@ -0,0 +1,7 @@
+tags
+rpm/BUILD/
+rpm/BUILDROOT/
+rpm/RPMS/
+rpm/SOURCES/
+rpm/SPECS/
+rpm/SRPMS/
diff --git a/debian/compat b/debian/compat
new file mode 100644
index 0000000..ec63514
--- /dev/null
+++ b/debian/compat
@@ -0,0 +1 @@
+9
diff --git a/debian/control b/debian/control
new file mode 100644
index 0000000..dd65d31
--- /dev/null
+++ b/debian/control
@@ -0,0 +1,193 @@
+Source: postgresql-common
+Section: database
+Priority: optional
+Maintainer: Debian PostgreSQL Maintainers <team+postgresql@tracker.debian.org>
+Uploaders:
+ Martin Pitt <mpitt@debian.org>,
+ Christoph Berg <myon@debian.org>,
+ Peter Eisentraut <petere@debian.org>,
+Standards-Version: 4.3.0
+Vcs-Git: https://salsa.debian.org/postgresql/postgresql-common.git
+Vcs-Browser: https://salsa.debian.org/postgresql/postgresql-common
+Build-Depends:
+ debhelper (>= 9),
+ debhelper (>= 10.1) | dh-systemd (>= 1.19),
+ libreadline-dev,
+ lsb-release,
+
+Package: postgresql-common
+Architecture: all
+Multi-Arch: foreign
+Depends:
+ adduser,
+ debconf (>= 0.5.00) | debconf-2.0,
+ lsb-base (>= 3.0-3),
+ postgresql-client-common (= ${source:Version}),
+ procps,
+ ssl-cert (>= 1.0.11),
+ ucf,
+ ${misc:Depends},
+Recommends:
+ e2fsprogs,
+ logrotate,
+Suggests:
+ libjson-perl,
+Breaks:
+ postgresql-9.1 (<< 9.1.1-3~),
+ systemd (<< 204),
+Description: PostgreSQL database-cluster manager
+ The postgresql-common package provides a structure under which
+ multiple versions of PostgreSQL may be installed and/or multiple
+ clusters maintained at one time.
+ .
+ The commands provided are pg_conftool, pg_createcluster, pg_ctlcluster,
+ pg_dropcluster, pg_lsclusters, pg_renamecluster, pg_upgradecluster,
+ pg_virtualenv.
+ .
+ PostgreSQL is a fully featured object-relational database management
+ system. It supports a large part of the SQL standard and is designed
+ to be extensible by users in many aspects. Its features include ACID
+ transactions, foreign keys, views, sequences, subqueries, triggers,
+ outer joins, multiversion concurrency control, and user-defined types
+ and functions.
+
+Package: postgresql-client-common
+Architecture: all
+Multi-Arch: foreign
+Depends:
+ netbase,
+ ${misc:Depends},
+ ${pgdg:Depends},
+Recommends:
+ lsb-release,
+ ${readline:Recommends},
+Description: manager for multiple PostgreSQL client versions
+ The postgresql-client-common package provides a structure under which
+ multiple versions of PostgreSQL client programs may be installed at
+ the same time. It provides a wrapper which selects the right version
+ for the particular cluster you want to access (with a command line
+ option, an environment variable, /etc/postgresql-common/user_clusters,
+ or ~/.postgresqlrc).
+ .
+ PostgreSQL is a fully featured object-relational database management
+ system. It supports a large part of the SQL standard and is designed
+ to be extensible by users in many aspects. Its features include ACID
+ transactions, foreign keys, views, sequences, subqueries, triggers,
+ outer joins, multiversion concurrency control, and user-defined types
+ and functions.
+
+Package: postgresql-server-dev-all
+Architecture: all
+Depends:
+ dctrl-tools,
+ lsb-release,
+ make,
+ postgresql-common (>= 117~),
+ ${misc:Depends},
+ ${server-dev-all-depends},
+Description: extension build tool for multiple PostgreSQL versions
+ The postgresql-server-dev-all package provides the pg_buildext script for
+ simplifying packaging of a PostgreSQL extension supporting multiple major
+ versions of the product.
+ .
+ PostgreSQL is a fully featured object-relational database management
+ system. It supports a large part of the SQL standard and is designed
+ to be extensible by users in many aspects. Its features include ACID
+ transactions, foreign keys, views, sequences, subqueries, triggers,
+ outer joins, multiversion concurrency control, and user-defined types
+ and functions.
+
+Package: postgresql
+Architecture: all
+Depends:
+ postgresql-${default-version},
+ ${misc:Depends},
+Suggests:
+ postgresql-doc,
+Description: object-relational SQL database (supported version)
+ This metapackage always depends on the currently supported PostgreSQL
+ database server version.
+ .
+ PostgreSQL is a fully featured object-relational database management
+ system. It supports a large part of the SQL standard and is designed
+ to be extensible by users in many aspects. Some of the features are:
+ ACID transactions, foreign keys, views, sequences, subqueries,
+ triggers, user-defined types and functions, outer joins, multiversion
+ concurrency control. Graphical user interfaces and bindings for many
+ programming languages are available as well.
+
+Package: postgresql-client
+Architecture: all
+Multi-Arch: foreign
+Depends:
+ postgresql-client-${default-version},
+ ${misc:Depends},
+Description: front-end programs for PostgreSQL (supported version)
+ This metapackage always depends on the currently supported database
+ client package for PostgreSQL.
+ .
+ PostgreSQL is a fully featured object-relational database management
+ system. It supports a large part of the SQL standard and is designed
+ to be extensible by users in many aspects. Some of the features are:
+ ACID transactions, foreign keys, views, sequences, subqueries,
+ triggers, user-defined types and functions, outer joins, multiversion
+ concurrency control. Graphical user interfaces and bindings for many
+ programming languages are available as well.
+
+Package: postgresql-doc
+Architecture: all
+Multi-Arch: foreign
+Section: doc
+Depends:
+ postgresql-doc-${default-version},
+ ${misc:Depends},
+Description: documentation for the PostgreSQL database management system
+ This metapackage always depends on the currently supported PostgreSQL
+ database documentation package.
+ .
+ PostgreSQL is a fully featured object-relational database management
+ system. It supports a large part of the SQL standard and is designed
+ to be extensible by users in many aspects. Some of the features are:
+ ACID transactions, foreign keys, views, sequences, subqueries,
+ triggers, user-defined types and functions, outer joins, multiversion
+ concurrency control. Graphical user interfaces and bindings for many
+ programming languages are available as well.
+
+Package: postgresql-contrib
+Architecture: all
+Depends:
+ postgresql-contrib-${default-version},
+ ${misc:Depends},
+Description: additional facilities for PostgreSQL (supported version)
+ This metapackage always depends on the currently supported PostgreSQL
+ database contrib package.
+ .
+ PostgreSQL is a fully featured object-relational database management
+ system. It supports a large part of the SQL standard and is designed
+ to be extensible by users in many aspects. Some of the features are:
+ ACID transactions, foreign keys, views, sequences, subqueries,
+ triggers, user-defined types and functions, outer joins, multiversion
+ concurrency control. Graphical user interfaces and bindings for many
+ programming languages are available as well.
+
+Package: postgresql-all
+Architecture: all
+Depends:
+ libecpg-dev,
+ libpq-dev,
+ postgresql-server-dev-all,
+ ${postgresql-all-depends},
+ ${misc:Depends},
+Description: metapackage depending on all PostgreSQL server packages
+ This metapackage depends on all PostgreSQL server packages, in all
+ supported versions (excluding documentation and debug symbols). It
+ exists to facilitate depending on the server packages in test
+ environments.
+ .
+ PostgreSQL is a fully featured object-relational database management
+ system. It supports a large part of the SQL standard and is designed
+ to be extensible by users in many aspects. Some of the features are:
+ ACID transactions, foreign keys, views, sequences, subqueries,
+ triggers, user-defined types and functions, outer joins, multiversion
+ concurrency control. Graphical user interfaces and bindings for many
+ programming languages are available as well.
diff --git a/debian/copyright b/debian/copyright
new file mode 100644
index 0000000..ffab18e
--- /dev/null
+++ b/debian/copyright
@@ -0,0 +1,17 @@
+Format: http://www.debian.org/doc/packaging-manuals/copyright-format/1.0/
+Upstream-Contact: Debian PostgreSQL Maintainers <pkg-postgresql-public@lists.alioth.debian.org>
+
+Files: *
+Copyright: 2005-2014 Martin Pitt <mpitt@debian.org>
+ 2009 Cyril Bouthors <cyril@bouthors.org>
+ 2010 Dimitri Fontaine <dfontaine@hi-media.com>
+ 2011-2014 Christoph Berg <myon@debian.org>
+ 2013 Peter Eisentraut <petere@debian.org>
+License: GPL-2+
+ This program is free software; you can redistribute it and/or modify
+ it under the terms of the GNU General Public License as published by
+ the Free Software Foundation; either version 2 of the License, or
+ (at your option) any later version.
+ .
+ The full text of the GPL is distributed as in
+ /usr/share/common-licenses/GPL-2 on Debian systems.
diff --git a/debian/init.d-functions b/debian/init.d-functions
new file mode 100644
index 0000000..a413198
--- /dev/null
+++ b/debian/init.d-functions
@@ -0,0 +1,112 @@
+# This file contains common functionality for all postgresql server
+# package init.d scripts. It is usually included by
+# /etc/init.d/postgresql
+
+init_functions=/lib/lsb/init-functions
+#redhat# init_functions=/usr/share/postgresql-common/init-functions-compat
+. $init_functions
+
+PGBINROOT="/usr/lib/postgresql/"
+#redhat# PGBINROOT="/usr/pgsql-"
+
+# do pg_ctlcluster action $1 to all clusters of version $2 with command
+# description $3; output according to Debian Policy for init scripts
+do_ctl_all() {
+ [ "$1" ] || { echo "Error: invalid command '$1'" >&2; exit 1; }
+ [ "$2" ] || { echo "Error: invalid version '$2'" >&2; exit 1; }
+ [ -d "/etc/postgresql/$2" ] || return 0
+ [ "$(ls /etc/postgresql/$2)" ] || return 0
+ [ -x "$PGBINROOT$2/bin/postgres" ] || return 0
+
+ status=0
+ log_daemon_msg "$3"
+ for c in /etc/postgresql/"$2"/*; do
+ [ -e "$c/postgresql.conf" ] || continue
+ name=$(basename "$c")
+
+ # evaluate start.conf
+ if [ -e "$c/start.conf" ]; then
+ start=$(sed 's/#.*$//; /^[[:space:]]*$/d; s/^\s*//; s/\s*$//' "$c/start.conf")
+ else
+ start=auto
+ fi
+ [ "$start" = "auto" ] || continue
+
+ log_progress_msg "$name"
+ set +e
+ if [ "$1" = "stop" ] || [ "$1" = "restart" ]; then
+ ERRMSG=$(pg_ctlcluster --force "$2" "$name" $1 2>&1)
+ else
+ ERRMSG=$(pg_ctlcluster "$2" "$name" $1 2>&1)
+ fi
+ res=$?
+ set -e
+ # Do not fail on success or if cluster is already/not running
+ [ $res -eq 0 ] || [ $res -eq 2 ] || status=$(($status || $res))
+ done
+ if [ $status -ne 0 -a -n "$ERRMSG" ]; then
+ log_failure_msg "$ERRMSG"
+ fi
+ log_end_msg $status
+ return $status
+}
+
+# create /var/run/postgresql
+create_socket_directory() {
+ if [ -d /var/run/postgresql ]; then
+ chmod 2775 /var/run/postgresql
+ else
+ install -d -m 2775 -o postgres -g postgres /var/run/postgresql
+ [ -x /sbin/restorecon ] && restorecon -R /var/run/postgresql || true
+ fi
+}
+
+# start all clusters of version $1
+# output according to Debian Policy for init scripts
+start() {
+ do_ctl_all start "$1" "Starting PostgreSQL $1 database server"
+}
+
+# stop all clusters of version $1
+# output according to Debian Policy for init scripts
+stop() {
+ do_ctl_all stop "$1" "Stopping PostgreSQL $1 database server"
+}
+
+# restart all clusters of version $1
+# output according to Debian Policy for init scripts
+restart() {
+ do_ctl_all restart "$1" "Restarting PostgreSQL $1 database server"
+}
+
+# reload all clusters of version $1
+# output according to Debian Policy for init scripts
+reload() {
+ do_ctl_all reload "$1" "Reloading PostgreSQL $1 database server"
+}
+
+status() {
+ CLUSTERS=`pg_lsclusters -h | grep "^$1[[:space:]]"`
+ # no clusters -> unknown status
+ [ -n "$CLUSTERS" ] || exit 4
+ echo "$CLUSTERS" | awk 'BEGIN {rc=0; printf("Running clusters: ")} {if (match($4, "online")) printf ("%s/%s ", $1, $2); else rc=3} END { printf("\n"); exit rc }'
+}
+
+# return all installed versions which do not have their own init script
+get_versions() {
+ versions=''
+ local v dir skipinit
+
+ skipinit=continue
+ #redhat# skipinit=true # RedHat systems will have /etc/init.d/postgresql-* provided by the yum.pg.o package
+ dir=$PGBINROOT
+ #redhat# dir="-d /usr/pgsql-*"
+
+ for v in `ls $dir 2>/dev/null`; do
+ #redhat# v=${v#*-}
+ [ -x /etc/init.d/postgresql-$v ] && $skipinit
+ if [ -x $PGBINROOT$v/bin/pg_ctl ]; then
+ versions="$versions $v"
+ fi
+ done
+}
diff --git a/debian/maintscripts-functions b/debian/maintscripts-functions
new file mode 100644
index 0000000..d510f6d
--- /dev/null
+++ b/debian/maintscripts-functions
@@ -0,0 +1,253 @@
+# This file contains common functionality for all postgresql server
+# package maintainer scripts.
+
+# arguments: version master package [package]
+_link_manpages() {
+ MANS=$(unset GREP_OPTIONS; dpkg -L $3 $4 $5 2>/dev/null|egrep '/man/.*\.[1-9](\.gz)?$' | grep -v "$2") || true
+ [ -n "$MANS" ] || return 0
+
+ SLAVES=$(for i in $MANS; do TARGET=$(echo $i | sed "s/postgresql\/$1\///"); echo -n " --slave $TARGET $(basename $i) $i"; done)
+ # pg_basebackup once moved from server to client; upgrades are still
+ # affected by this for quite a while, so remove this alternative before
+ # reinstalling it to avoid failure. This needs to be kept until we stop
+ # supporting upgrades from -9.1.
+ if [ "$2" = "psql.1.gz" ]; then
+ OUT=$(LC_ALL=C update-alternatives --display postmaster.1.gz 2> /dev/null) || true
+ if [ "${OUT#*auto mode}" != "$OUT" ] && [ "${OUT#*pg_basebackup.1.gz}" != "$OUT" ]; then
+ echo "Adjusting postmaster.1.gz alternatives for pg_basebackup move..."
+ update-alternatives --remove postmaster.1.gz /usr/share/postgresql/9.1/man/man1/postmaster.1.gz
+ fi
+ # similarly, if we have both 9.1 and e. g. 9.3 installed, pg_basebackup.1
+ # will already be in the psql.1.gz alternative group; if we upgrade 9.1, we
+ # then must not try to put it into postmaster.1.gz again, as that will
+ # fail
+ elif [ "$2" = "postmaster.1.gz" ] && [ "$1" = "9.1" ]; then
+ if update-alternatives --display psql.1.gz 2>/dev/null | grep -q pg_basebackup; then
+ #echo "Skipping postmaster.1.gz alternatives as pg_basebackup.1 is already in psql.1.gz group"
+ return
+ fi
+ fi
+
+ # user might have removed the directories, allow u-a to succeed
+ mkdir -p /usr/share/man/man1 /usr/share/man/man3 /usr/share/man/man7
+ section=$(echo "$2" | sed -e 's/.*\.\(.*\)\..*/man\1/')
+ case $1 in
+ [89]*) priority=$(echo "$1" | tr -cd 0-9) ;;
+ *) priority="${1}0" ;;
+ esac
+ update-alternatives --install /usr/share/man/$section/$2 \
+ $2 /usr/share/postgresql/$1/man/$section/$2 \
+ $priority $SLAVES
+}
+
+# arguments: version master
+_unlink_manpages() {
+ # user might have removed the directories, allow u-a to succeed
+ mkdir -p /usr/share/man/man1 /usr/share/man/man3 /usr/share/man/man7
+ section=$(echo "$2" | sed -e 's/.*\.\(.*\)\..*/man\1/')
+ update-alternatives --remove $2 /usr/share/postgresql/$1/man/$section/$2
+}
+
+_remove_tsearch() {
+ if [ -e /usr/share/postgresql/$1/tsearch_data ]; then
+ find /usr/share/postgresql/$1/tsearch_data -type l \( -name '*.dict' -o -name '*.affix' \) -exec rm '{}' \;
+ fi
+}
+
+# Determine and set system's default locale; we do not want to trust the
+# environment here, as ssh and sudo both propagate the user's locale from
+# potentially a remote host, and that might not even exist; also, we want to be
+# predictable. /etc/default/locale overrides /etc/environment. Note that
+# /etc/environment is not a shell script, so we must be careful with parsing.
+set_system_locale() {
+ loc_vars="LANG LANGUAGE LC_CTYPE LC_NUMERIC LC_TIME LC_COLLATE LC_MONETARY LC_MESSAGES LC_PAPER LC_NAME LC_ADDRESS LC_TELEPHONE LC_MEASUREMENT LC_IDENTIFICATION LC_ALL"
+ unset $loc_vars
+ LANG="C.UTF-8" # fallback locale if nothing is configured explicitly
+ for v in $loc_vars; do
+ unset val
+ val=`pam_getenv -l $v` || true
+ [ -z "$val" ] || export $v="$val"
+ done
+ [ -e /etc/default/locale ] && . /etc/default/locale || true
+ export $loc_vars
+}
+
+# arguments: <major version> <most recently configured package version>
+configure_version() {
+ VERSION="$1"
+
+ # Create a main cluster for given version ($1) if no cluster already exists
+ # for that version and we are installing from scratch.
+ [ "$VERSION" ] || { echo "Error: configure_version: need version parameter" >&2; exit 1; }
+ if [ ! -d "/etc/postgresql/$VERSION" ] || [ -z "$(ls /etc/postgresql/$VERSION)" ] || \
+ [ -z "$(ls /etc/postgresql/$VERSION/*/postgresql.conf 2>/dev/null)" ]; then
+ # skip creating the main cluster when this is not the first install, or
+ # when explicitly disabled ($create is on/off/"")
+ create=$(pg_conftool /etc/postgresql-common/createcluster.conf show -bs create_main_cluster || :)
+ if [ -z "$2" ] && [ "$create" != "off" ]; then
+ set_system_locale
+ pg_createcluster -u postgres $VERSION main ||
+ echo "Error: could not create default cluster. Please create it manually with
+
+ pg_createcluster $VERSION main --start
+
+or a similar command (see 'man pg_createcluster')." >&2
+ fi
+ fi
+
+ _link_manpages "$VERSION" postmaster.1.gz "postgresql-$1" "postgresql-contrib-$1"
+
+ # check if our catalog version changed
+ postinst_check_catversion "$VERSION"
+
+ # done with debconf
+ db_stop
+
+ # reload systemd to let the generator pick up the new unit
+ if [ -d /run/systemd/system ]; then
+ systemctl daemon-reload
+ fi
+ invoke-rc.d postgresql start $VERSION # systemd: argument ignored, starts all versions
+}
+
+stop_version() {
+ if [ -d /run/systemd/system ]; then
+ # cannot use invoke-rc.d here because jessie's version doesn't like patterns
+ deb-systemd-invoke stop "postgresql@$1-*"
+ else
+ invoke-rc.d postgresql stop $1
+ fi
+}
+
+remove_version() {
+ _unlink_manpages "$1" postmaster.1.gz
+ _remove_tsearch "$1"
+}
+
+configure_client_version() {
+ _link_manpages "$1" psql.1.gz "postgresql-client-$1"
+}
+
+remove_client_version() {
+ _unlink_manpages "$1" psql.1.gz
+}
+
+configure_contrib_version() {
+ _link_manpages "$1" postmaster.1.gz "postgresql-$1" "postgresql-contrib-$1"
+}
+
+remove_contrib_version() {
+ # we still want to retain the alternatives for the server packages
+ _link_manpages "$1" postmaster.1.gz "postgresql-$1"
+}
+
+configure_doc_version() {
+ _link_manpages "$1" SPI_connect.3.gz "postgresql-doc-$1"
+}
+
+remove_doc_version() {
+ _unlink_manpages "$1" SPI_connect.3.gz
+}
+
+# Compare the catalog version number of the installed package and the new
+# package. When differing, check if any clusters present are using the old
+# catalog version. If so, copy a minimal set of files from the old package to
+# /var/tmp to enable pg_upgrade to upgrade to the new version.
+
+preinst_check_catversion()
+{
+ MAJOR_VER="$1"
+ NEW_CATVERSION="$2"
+ case $NEW_CATVERSION in
+ *CATVERSION*) echo "BUG: override_dh_installdeb failed to set CATVERSION" >&2
+ return ;;
+ esac
+
+ CATFILE="/usr/share/postgresql/$MAJOR_VER/catalog_version"
+ [ -f "$CATFILE" ] || return 0 # file introduced in 9.6
+ OLD_CATVERSION="$(cat $CATFILE)"
+ [ -z "$OLD_CATVERSION" ] && return
+
+ [ "$OLD_CATVERSION" = "$NEW_CATVERSION" ] && return # no change, nothing to do
+
+ PGCONTROLDATA="/usr/lib/postgresql/$MAJOR_VER/bin/pg_controldata"
+ [ -x "$PGCONTROLDATA" ] || return 0
+
+ echo "PostgreSQL $MAJOR_VER catalog version number changed from $OLD_CATVERSION to $NEW_CATVERSION, checking for clusters using the old version ..."
+
+ pg_lsclusters -h | \
+ while read version cluster port status owner pgdata logfile; do
+ [ "$version" = "$MAJOR_VER" ] || continue
+ [ -d "$pgdata" ] || continue
+ DB_CATVERSION=$(LC_ALL=C $PGCONTROLDATA $pgdata | sed -ne 's/^Catalog version number: *\([0-9]\+\)/\1/p')
+
+ if [ "$DB_CATVERSION" = "$OLD_CATVERSION" ]; then
+ echo "Cluster $MAJOR_VER/$cluster is using catalog version $DB_CATVERSION"
+
+ VARTMPDIR="/var/tmp/postgresql-$MAJOR_VER-$OLD_CATVERSION"
+ if [ ! -d "$VARTMPDIR" ]; then
+ echo "Saving binaries for PostgreSQL $MAJOR_VER catalog version $OLD_CATVERSION in $VARTMPDIR ..."
+ mkdir "$VARTMPDIR" # will fail&exit if (potentially rogue) file exists
+ (
+ cd "$VARTMPDIR"
+ mkdir bin lib # lib needs to exists, but we do not copy files there
+ for f in pg_ctl pg_controldata pg_dump pg_resetwal postgres; do
+ cp -a /usr/lib/postgresql/$MAJOR_VER/bin/$f bin
+ done
+ )
+ fi
+ fi
+ done
+}
+
+postinst_check_catversion()
+{
+ MAJOR_VER="$1"
+
+ CATFILE="/usr/share/postgresql/$MAJOR_VER/catalog_version"
+ [ -f "$CATFILE" ] || return 0 # file introduced in 9.6
+ NEW_CATVERSION="$(cat $CATFILE)"
+ [ -z "$NEW_CATVERSION" ] && return
+
+ PGCONTROLDATA="/usr/lib/postgresql/$MAJOR_VER/bin/pg_controldata"
+ [ -x "$PGCONTROLDATA" ] || return 0
+
+ for cluster in $(pg_lsclusters -h | awk "/^$MAJOR_VER / { print \$2 }"); do
+ pgdata=$(pg_conftool -s $MAJOR_VER $cluster show data_directory) || continue
+ [ -d "$pgdata" ] || continue
+
+ DB_CATVERSION=$(LC_ALL=C $PGCONTROLDATA $pgdata | sed -ne 's/^Catalog version number: *\([0-9]\+\)/\1/p')
+ [ -z "$DB_CATVERSION" ] && continue
+ [ "$DB_CATVERSION" = "$NEW_CATVERSION" ] && continue
+
+ VARTMPDIR="/var/tmp/postgresql-$MAJOR_VER-$DB_CATVERSION"
+ [ -d "$VARTMPDIR" ] || continue
+ [ -O "$VARTMPDIR" ] || continue # test if owned by root
+
+ # tell the user about it
+ cat <<-EOF
+ Cluster $MAJOR_VER $cluster needs upgrading due to catalog version change:
+ pg_renamecluster ${MAJOR_VER} ${cluster} ${cluster}.old
+ pg_upgradecluster ${MAJOR_VER} ${cluster}.old --rename ${cluster} -m upgrade --old-bindir=${VARTMPDIR}/bin
+ pg_dropcluster ${MAJOR_VER} ${cluster}.old
+ rm -rf ${VARTMPDIR}
+ EOF
+ db_fset postgresql-common/catversion-bump seen false
+ db_subst postgresql-common/catversion-bump version $MAJOR_VER
+ db_subst postgresql-common/catversion-bump cluster $cluster
+ db_subst postgresql-common/catversion-bump db_catversion $DB_CATVERSION
+ db_subst postgresql-common/catversion-bump new_catversion $NEW_CATVERSION
+ db_subst postgresql-common/catversion-bump vartmpdir $VARTMPDIR
+ db_input high postgresql-common/catversion-bump || true
+ db_go || true
+ done
+}
+
+# start debconf if we are in the server's postinst (can't run from a function)
+if [ "${DPKG_MAINTSCRIPT_NAME:-}" = "postinst" ] && [ "$1" = "configure" ]; then
+ case $DPKG_MAINTSCRIPT_PACKAGE in
+ postgresql-[89].?|postgresql-[1-9]?)
+ . /usr/share/debconf/confmodule
+ ;;
+ esac
+fi
diff --git a/debian/po/POTFILES.in b/debian/po/POTFILES.in
new file mode 100644
index 0000000..f728f9a
--- /dev/null
+++ b/debian/po/POTFILES.in
@@ -0,0 +1 @@
+[type: gettext/rfc822deb] postgresql-common.templates
diff --git a/debian/po/ca.po b/debian/po/ca.po
new file mode 100644
index 0000000..8d847cb
--- /dev/null
+++ b/debian/po/ca.po
@@ -0,0 +1,147 @@
+# postgresql-common po-debconf translation to Catalan
+# Copyright (C) 2006 Software in the Public Interest, SPI Inc.
+# This file is distributed under the same license as the postgresql-common
+# package.
+# Innocent De Marchi <tangram.peces@gmail.com>, 2011, 2017.
+#
+msgid ""
+msgstr ""
+"Project-Id-Version: postgresql-common 184\n"
+"Report-Msgid-Bugs-To: postgresql-common@packages.debian.org\n"
+"POT-Creation-Date: 2016-03-05 11:47+0100\n"
+"PO-Revision-Date: 2017-09-07 18:59+0200\n"
+"Last-Translator: Innocent De Marchi <tangram.peces@gmail.com>\n"
+"Language-Team: Catalan <debian-l10n-catalan@lists.debian.org>\n"
+"Language: ca\n"
+"MIME-Version: 1.0\n"
+"Content-Type: text/plain; charset=utf-8\n"
+"Content-Transfer-Encoding: 8bit\n"
+"X-Generator: Poedit 2.0.3\n"
+
+#. Type: error
+#. Description
+#: ../postgresql-common.templates:1001
+msgid "Obsolete major version ${old}"
+msgstr "Versió principal ${old} obsoleta"
+
+#. Type: error
+#. Description
+#: ../postgresql-common.templates:1001
+msgid ""
+"The PostgreSQL version ${old} is obsolete, but the server or client packages "
+"are still installed. Please install the latest packages (postgresql-"
+"${latest} and postgresql-client-${latest}) and upgrade the existing "
+"${oldversion} clusters with pg_upgradecluster (see manpage)."
+msgstr ""
+"La versió de «PostgreSQL» ${old} és obsoleta, però el paquet del client o "
+"del servidor encara estan instal·lats. Heu d'instal·lar les darreres "
+"versions dels paquets (postgresql-${latest} i postgresql-client-${latest}) i "
+"actualitzar els clústers de la versió ${oldversion} amb l'ordre "
+"«pg_upgradecluster» (consulteu la pàgina del manual)."
+
+#. Type: error
+#. Description
+#: ../postgresql-common.templates:1001
+msgid ""
+"Please be aware that the installation of postgresql-${latest} will "
+"automatically create a default cluster ${latest}/main. If you want to "
+"upgrade the ${old}/main cluster, you need to remove the already existing "
+"${latest} cluster (pg_dropcluster --stop ${latest} main, see manpage for "
+"details)."
+msgstr ""
+"Tingueu en present que la instal lació de postgresql-${latest} generarà "
+"automàticament un clúster pre-determinat ${latest}/main. Heu d'eliminar el "
+"clúster ${latest} existent («pg_dropcluster --stop ${latest}) si desitjau "
+"actualitzar el clúster ${old}/main, consulteu la pàgina de manual per "
+"conèixer els detalls."
+
+#. Type: error
+#. Description
+#: ../postgresql-common.templates:1001
+msgid ""
+"The old server and client packages are no longer supported. After the "
+"existing clusters are upgraded, the postgresql-${old} and postgresql-client-"
+"${old} packages should be removed."
+msgstr ""
+"Ja no se dona suport als paquets antics de client i servidor. Haureu "
+"d'eliminar els paquets postgresql-${old} i postgresql-client-${old} després "
+"d'actualitzar els clústers que tingui."
+
+#. Type: error
+#. Description
+#: ../postgresql-common.templates:1001
+msgid ""
+"Please see /usr/share/doc/postgresql-common/README.Debian.gz for details."
+msgstr ""
+"Consulteu « /usr/share/doc/postgresql-common/README.Debian.gz» pels detalls."
+
+#. Type: boolean
+#. Description
+#: ../postgresql-common.templates:2001
+msgid "Enable SSL by default in new PostgreSQL clusters?"
+msgstr "Permet SSL de forma predeterminada en clústers PostgreSQL nous?"
+
+#. Type: boolean
+#. Description
+#: ../postgresql-common.templates:2001
+msgid ""
+"PostgreSQL supports SSL-encrypted connections. This is usually a good thing. "
+"However, if the database is solely accessed using TCP connections on "
+"localhost, SSL can be turned off without introducing security issues."
+msgstr ""
+"PostgreSQL admet connexions SSL encriptades. És una opció adequada. "
+"Tanmateix, si l'accés a la base de dades es fa només amb connexions TCP amb "
+"el servidor local, desactivar SSL no afecta a la seguretat."
+
+#. Type: boolean
+#. Description
+#: ../postgresql-common.templates:2001
+msgid ""
+"UNIX domain socket connections (called \"local\" in pg_hba.conf) are not "
+"affected by this setting. This setting concerns new PostgreSQL clusters "
+"created during package install, or by using the pg_createcluster command. It "
+"does not reconfigure existing clusters."
+msgstr ""
+"Les connexions de sòcol de domini UNIX (anomenades «locals» al fitxer "
+"«pg_hba.conf») no es veuen afectades per aquesta configuració. Aquesta "
+"configuració afecta els clústers PostgreSQL nous generats en al instal·lació "
+"del paquet o mitjançant l'ordre «pg_createcluster». No configura els "
+"clústers existents."
+
+#. Type: boolean
+#. Description
+#: ../postgresql-common.templates:2001
+msgid "If unsure, enable SSL."
+msgstr "En cas de dubte, activau SSL."
+
+#. Type: note
+#. Description
+#: ../postgresql-common.templates:3001
+msgid "PostgreSQL ${version} catalog version changed"
+msgstr "S'ha canviat la versió del catàleg de PostgreSQL ${version}"
+
+#. Type: note
+#. Description
+#: ../postgresql-common.templates:3001
+msgid ""
+"The PostgreSQL cluster ${version} ${cluster} was created using catalog "
+"version ${db_catversion}, but the currently being installed package "
+"postgresql-${version} is using catalog version ${new_catversion}. You will "
+"not be able to use this cluster until it was upgraded to the new catalog "
+"version."
+msgstr ""
+"El clúster ${cluster} de PostgreSQL ${version} es va generar amb la versió "
+"${db_catversion} dels catàleg, però el paquet postgresql-${version} "
+"instal·lat actualment fa servir la versió ${new_catversion} del catàleg. No "
+"podreu fer servir aquest clúster fins que no s'hagi actualitzat a la nova "
+"versió del catàleg."
+
+#. Type: note
+#. Description
+#: ../postgresql-common.templates:3001
+msgid ""
+"The necessary subset of binaries from the old version was saved in "
+"${vartmpdir}. To upgrade the cluster, execute these commands:"
+msgstr ""
+"El subconjunt de binaris necessari de la versió anterior es va desar a "
+"${vartmpdir}. Per actualitzar el clúster, executeu aquestes ordres:"
diff --git a/debian/po/cs.po b/debian/po/cs.po
new file mode 100644
index 0000000..ab72dcb
--- /dev/null
+++ b/debian/po/cs.po
@@ -0,0 +1,128 @@
+# Czech translation of postgresql-common debconf messages.
+# Copyright (C) YEAR THE PACKAGE'S COPYRIGHT HOLDER
+# This file is distributed under the same license as the postgresql-common package.
+# Miroslav Kure <kurem@debian.cz>, 2006-2009.
+#
+msgid ""
+msgstr ""
+"Project-Id-Version: postgresql-common\n"
+"Report-Msgid-Bugs-To: postgresql-common@packages.debian.org\n"
+"POT-Creation-Date: 2016-03-05 11:47+0100\n"
+"PO-Revision-Date: 2009-06-27 10:34+0200\n"
+"Last-Translator: Miroslav Kure <kurem@debian.cz>\n"
+"Language-Team: Czech <debian-l10n-czech@lists.debian.org>\n"
+"Language: cs\n"
+"MIME-Version: 1.0\n"
+"Content-Type: text/plain; charset=UTF-8\n"
+"Content-Transfer-Encoding: 8bit\n"
+
+#. Type: error
+#. Description
+#: ../postgresql-common.templates:1001
+msgid "Obsolete major version ${old}"
+msgstr "Zastaralá hlavní verze ${old}"
+
+#. Type: error
+#. Description
+#: ../postgresql-common.templates:1001
+msgid ""
+"The PostgreSQL version ${old} is obsolete, but the server or client packages "
+"are still installed. Please install the latest packages (postgresql-"
+"${latest} and postgresql-client-${latest}) and upgrade the existing "
+"${oldversion} clusters with pg_upgradecluster (see manpage)."
+msgstr ""
+"PostgreSQL verze ${old} je již zastaralá, ale v systému se stále nachází "
+"balík se serverem a/nebo klientem. Nainstalujte prosím nejnovější balíky "
+"(postgresql-${latest} a postgresql-client-${latest}) a aktualizujte své "
+"klastry ${oldversion} pomocí pg_upgradecluster (viz manuálová stránka)."
+
+#. Type: error
+#. Description
+#: ../postgresql-common.templates:1001
+msgid ""
+"Please be aware that the installation of postgresql-${latest} will "
+"automatically create a default cluster ${latest}/main. If you want to "
+"upgrade the ${old}/main cluster, you need to remove the already existing "
+"${latest} cluster (pg_dropcluster --stop ${latest} main, see manpage for "
+"details)."
+msgstr ""
+"Vemte prosím na vědomí, že instalací postgresql-${latest} se automaticky "
+"vytvoří výchozí klastr ${latest}/main. Chcete-li aktualizovat klastr ${old}/"
+"main, musíte odstranit nově vytvořený klastr ${latest} (pg_dropcluster --"
+"stop ${latest} main, viz manuálová stránka)."
+
+#. Type: error
+#. Description
+#: ../postgresql-common.templates:1001
+msgid ""
+"The old server and client packages are no longer supported. After the "
+"existing clusters are upgraded, the postgresql-${old} and postgresql-client-"
+"${old} packages should be removed."
+msgstr ""
+"Staré balíky serveru a klienta již nejsou podporovány. Po aktualizaci "
+"stávajících klastrů byste měli balíky postgresql-${old} a postgresql-client-"
+"${old} odstranit."
+
+#. Type: error
+#. Description
+#: ../postgresql-common.templates:1001
+msgid ""
+"Please see /usr/share/doc/postgresql-common/README.Debian.gz for details."
+msgstr ""
+"Podrobnosti naleznete v /usr/share/doc/postgresql-common/README.Debian.gz."
+
+#. Type: boolean
+#. Description
+#: ../postgresql-common.templates:2001
+msgid "Enable SSL by default in new PostgreSQL clusters?"
+msgstr ""
+
+#. Type: boolean
+#. Description
+#: ../postgresql-common.templates:2001
+msgid ""
+"PostgreSQL supports SSL-encrypted connections. This is usually a good thing. "
+"However, if the database is solely accessed using TCP connections on "
+"localhost, SSL can be turned off without introducing security issues."
+msgstr ""
+
+#. Type: boolean
+#. Description
+#: ../postgresql-common.templates:2001
+msgid ""
+"UNIX domain socket connections (called \"local\" in pg_hba.conf) are not "
+"affected by this setting. This setting concerns new PostgreSQL clusters "
+"created during package install, or by using the pg_createcluster command. It "
+"does not reconfigure existing clusters."
+msgstr ""
+
+#. Type: boolean
+#. Description
+#: ../postgresql-common.templates:2001
+msgid "If unsure, enable SSL."
+msgstr ""
+
+#. Type: note
+#. Description
+#: ../postgresql-common.templates:3001
+msgid "PostgreSQL ${version} catalog version changed"
+msgstr ""
+
+#. Type: note
+#. Description
+#: ../postgresql-common.templates:3001
+msgid ""
+"The PostgreSQL cluster ${version} ${cluster} was created using catalog "
+"version ${db_catversion}, but the currently being installed package "
+"postgresql-${version} is using catalog version ${new_catversion}. You will "
+"not be able to use this cluster until it was upgraded to the new catalog "
+"version."
+msgstr ""
+
+#. Type: note
+#. Description
+#: ../postgresql-common.templates:3001
+msgid ""
+"The necessary subset of binaries from the old version was saved in "
+"${vartmpdir}. To upgrade the cluster, execute these commands:"
+msgstr ""
diff --git a/debian/po/da.po b/debian/po/da.po
new file mode 100644
index 0000000..8d519cf
--- /dev/null
+++ b/debian/po/da.po
@@ -0,0 +1,143 @@
+# Danish translation postgresql-common.
+# Copyright (C) 2017 THE PACKAGE'S COPYRIGHT HOLDER.
+# This file is distributed under the same license as the postgresql-common package.
+# Joe Hansen (joedalton2@yahoo.dk), 2011, 2014, 2017.
+#
+msgid ""
+msgstr ""
+"Project-Id-Version: postgresql-common\n"
+"Report-Msgid-Bugs-To: postgresql-common@packages.debian.org\n"
+"POT-Creation-Date: 2016-03-05 11:47+0100\n"
+"PO-Revision-Date: 2017-03-04 19:25+0200\n"
+"Last-Translator: Joe Hansen <joedalton2@yahoo.dk>\n"
+"Language-Team: Danish <debian-l10n-danish@lists.debian.org>\n"
+"Language: da\n"
+"MIME-Version: 1.0\n"
+"Content-Type: text/plain; charset=UTF-8\n"
+"Content-Transfer-Encoding: 8bit\n"
+
+#. Type: error
+#. Description
+#: ../postgresql-common.templates:1001
+msgid "Obsolete major version ${old}"
+msgstr "Forældet hovedversion ${old}"
+
+#. Type: error
+#. Description
+#: ../postgresql-common.templates:1001
+msgid ""
+"The PostgreSQL version ${old} is obsolete, but the server or client packages "
+"are still installed. Please install the latest packages (postgresql-"
+"${latest} and postgresql-client-${latest}) and upgrade the existing "
+"${oldversion} clusters with pg_upgradecluster (see manpage)."
+msgstr ""
+"PostgreSQL-versionen ${old} er forældet, men server- eller klientpakkerne er "
+"stadig installeret. Installer venligst de seneste pakker (postgresql-"
+"${latest} og postgresql-client-${latest}) og opgrader de eksisterende "
+"${oldversion}-klynger med pg_upgradecluster (se manpage)."
+
+#. Type: error
+#. Description
+#: ../postgresql-common.templates:1001
+msgid ""
+"Please be aware that the installation of postgresql-${latest} will "
+"automatically create a default cluster ${latest}/main. If you want to "
+"upgrade the ${old}/main cluster, you need to remove the already existing "
+"${latest} cluster (pg_dropcluster --stop ${latest} main, see manpage for "
+"details)."
+msgstr ""
+"Vær venligst opmærksom på at installationen af postgresql-${latest} "
+"automatisk vil oprette en standardklynge ${latest}/main. Hvis du ønsker at "
+"opgradere ${old}/main-klyngen, skal du fjerne den allerede eksisterende "
+"${latest}-klynge (pg_dropcluster --stop ${latest} main, se manpage for "
+"detaljer)."
+
+#. Type: error
+#. Description
+#: ../postgresql-common.templates:1001
+msgid ""
+"The old server and client packages are no longer supported. After the "
+"existing clusters are upgraded, the postgresql-${old} and postgresql-client-"
+"${old} packages should be removed."
+msgstr ""
+"De gamle server- og klientpakker er ikke længere understøttet. Efter de "
+"eksisterende klynger er opgraderet, bør pakkerne postgresql-${old} og "
+"postgresql-client-${old} fjernes."
+
+#. Type: error
+#. Description
+#: ../postgresql-common.templates:1001
+msgid ""
+"Please see /usr/share/doc/postgresql-common/README.Debian.gz for details."
+msgstr ""
+"Se venligst /usr/share/doc/postgresql-common/README.Debian.gz for detaljer."
+
+#. Type: boolean
+#. Description
+#: ../postgresql-common.templates:2001
+msgid "Enable SSL by default in new PostgreSQL clusters?"
+msgstr "Aktiver SSL som standard i nye PostgreSQL-klynger?"
+
+#. Type: boolean
+#. Description
+#: ../postgresql-common.templates:2001
+msgid ""
+"PostgreSQL supports SSL-encrypted connections. This is usually a good thing. "
+"However, if the database is solely accessed using TCP connections on "
+"localhost, SSL can be turned off without introducing security issues."
+msgstr ""
+"PostgreSQL understøtter SSL-krypterede forbindelser. Dette er normalt en god "
+"ting. Hvis databasen alene tilgås via TCP-forbindelser på localhost, så kan "
+"SSL dog slukkes uden at der bliver introduceret sikkerhedsproblemstillinger."
+
+#. Type: boolean
+#. Description
+#: ../postgresql-common.templates:2001
+msgid ""
+"UNIX domain socket connections (called \"local\" in pg_hba.conf) are not "
+"affected by this setting. This setting concerns new PostgreSQL clusters "
+"created during package install, or by using the pg_createcluster command. It "
+"does not reconfigure existing clusters."
+msgstr ""
+"UNIX-domænesokkelforbindelser (kaldt »local« i pg_hba.conf) influeres ikke "
+"af denne indstilling. Denne indstilling vedrører nye PostgreSQL-klynger "
+"oprettet under pakkeinstallation, eller ved at bruge kommandoen "
+"pg_createcluster. Den rekonfigurerer eksisterende klynger."
+
+#. Type: boolean
+#. Description
+#: ../postgresql-common.templates:2001
+msgid "If unsure, enable SSL."
+msgstr "Hvis usikker, aktiver SSL."
+
+#. Type: note
+#. Description
+#: ../postgresql-common.templates:3001
+msgid "PostgreSQL ${version} catalog version changed"
+msgstr "PostgreSQL ${version}-katalogversion ændrede sig"
+
+#. Type: note
+#. Description
+#: ../postgresql-common.templates:3001
+msgid ""
+"The PostgreSQL cluster ${version} ${cluster} was created using catalog "
+"version ${db_catversion}, but the currently being installed package "
+"postgresql-${version} is using catalog version ${new_catversion}. You will "
+"not be able to use this cluster until it was upgraded to the new catalog "
+"version."
+msgstr ""
+"PostgreSQL-klyngen ${version} ${cluster} blev oprettet med katalogversion "
+"${db_catversion}, men den i øjeblikket installeret pakke postgresql-${version} "
+"bruger katalogversion ${new_catversion}. Du vil ikke være i stand til "
+"at bruge denne klynge indtil den er opgraderet til den nye katalogversion."
+
+#. Type: note
+#. Description
+#: ../postgresql-common.templates:3001
+msgid ""
+"The necessary subset of binaries from the old version was saved in "
+"${vartmpdir}. To upgrade the cluster, execute these commands:"
+msgstr ""
+"Det nødvendige undersæt af binære filer fra den gamle version blev "
+"gemt i ${vartmpdir}. For at opgradere klyngen, så kør disse kommandoer:"
+
diff --git a/debian/po/de.po b/debian/po/de.po
new file mode 100644
index 0000000..55f8969
--- /dev/null
+++ b/debian/po/de.po
@@ -0,0 +1,146 @@
+# postgresql-common debconf templates.
+# Copyright (C) 2005 Martin Pitt <mpitt@debian.org>
+# Copyright (C) 2014-2015 Christoph Berg <myon@debian.org>
+# This file is distributed under the same license as the postgresql-common package.
+#
+msgid ""
+msgstr ""
+"Project-Id-Version: postgresql-common\n"
+"Report-Msgid-Bugs-To: postgresql-common@packages.debian.org\n"
+"POT-Creation-Date: 2016-03-05 11:47+0100\n"
+"PO-Revision-Date: 2015-12-06 22:54+0100\n"
+"Last-Translator: Christoph Berg <myon@debian.org>\n"
+"Language-Team: German <de@li.org>\n"
+"Language: de\n"
+"MIME-Version: 1.0\n"
+"Content-Type: text/plain; charset=UTF-8\n"
+"Content-Transfer-Encoding: 8bit\n"
+
+#. Type: error
+#. Description
+#: ../postgresql-common.templates:1001
+msgid "Obsolete major version ${old}"
+msgstr "Veraltete Version ${old}"
+
+#. Type: error
+#. Description
+#: ../postgresql-common.templates:1001
+msgid ""
+"The PostgreSQL version ${old} is obsolete, but the server or client packages "
+"are still installed. Please install the latest packages (postgresql-"
+"${latest} and postgresql-client-${latest}) and upgrade the existing "
+"${oldversion} clusters with pg_upgradecluster (see manpage)."
+msgstr ""
+"Die PostgreSQL-Version ${old} ist veraltet, aber die Server-oder Client-"
+"Pakete sind noch installiert. Bitte installieren Sie die aktuellen Pakete "
+"(postgresql-${latest} und postgresql-client-${latest}) und aktualisieren Sie "
+"die existierenden Cluster mit pg_upgradecluster (siehe man-Seite)."
+
+#. Type: error
+#. Description
+#: ../postgresql-common.templates:1001
+msgid ""
+"Please be aware that the installation of postgresql-${latest} will "
+"automatically create a default cluster ${latest}/main. If you want to "
+"upgrade the ${old}/main cluster, you need to remove the already existing "
+"${latest} cluster (pg_dropcluster --stop ${latest} main, see manpage for "
+"details)."
+msgstr ""
+"Bitte beachten Sie, dass die Installation des Pakets postgresql-${latest} "
+"automatisch einen Standard-Cluster ${latest}/main anlegt. Wenn Sie den "
+"Cluster ${old}/main aktualisieren möchten, müssen Sie den schon vorhandenen "
+"${latest} Cluster entfernen (pg_dropcluster --stop ${latest} main, siehe man-"
+"Seite für Details)."
+
+#. Type: error
+#. Description
+#: ../postgresql-common.templates:1001
+msgid ""
+"The old server and client packages are no longer supported. After the "
+"existing clusters are upgraded, the postgresql-${old} and postgresql-client-"
+"${old} packages should be removed."
+msgstr ""
+"Die alten Server- und Client-Pakete werden nicht mehr unterstützt. Nachdem "
+"die existierenden Cluster aktualisiert werden, sollten die Pakete postgresql-"
+"${old} und postgresql-client-${old} entfernt werden."
+
+#. Type: error
+#. Description
+#: ../postgresql-common.templates:1001
+msgid ""
+"Please see /usr/share/doc/postgresql-common/README.Debian.gz for details."
+msgstr ""
+"Bitte lesen Sie /usr/share/doc/postgresql-common/README.Debian.gz für "
+"Details."
+
+#. Type: boolean
+#. Description
+#: ../postgresql-common.templates:2001
+msgid "Enable SSL by default in new PostgreSQL clusters?"
+msgstr "SSL standardmäßig in neuen PostgreSQL-Clustern aktivieren?"
+
+#. Type: boolean
+#. Description
+#: ../postgresql-common.templates:2001
+msgid ""
+"PostgreSQL supports SSL-encrypted connections. This is usually a good thing. "
+"However, if the database is solely accessed using TCP connections on "
+"localhost, SSL can be turned off without introducing security issues."
+msgstr ""
+"PostgreSQL unterstützt SSL-verschlüsselte Verbindungen, was normalerweise "
+"benutzt werden sollte. Wenn die Datenbank jedoch ausschließlich über TCP-"
+"Verbindungen über localhost benutzt wird, kann SSL abgeschaltet werden, ohne "
+"die Sicherheit zu beeinträchtigen."
+
+#. Type: boolean
+#. Description
+#: ../postgresql-common.templates:2001
+msgid ""
+"UNIX domain socket connections (called \"local\" in pg_hba.conf) are not "
+"affected by this setting. This setting concerns new PostgreSQL clusters "
+"created during package install, or by using the pg_createcluster command. It "
+"does not reconfigure existing clusters."
+msgstr ""
+"Verbindungen über UNIX-Sockets (in der pg_hba.conf \"local\" genannt) sind "
+"nicht von dieser Einstellung betroffen. Diese Einstellung betrifft nur neue "
+"PostgreSQL-Cluster, die während der Paket-Installation oder durch "
+"pg_createcluster angelegt werden. Es konfiguriert bestehende Cluster nicht "
+"um."
+
+#. Type: boolean
+#. Description
+#: ../postgresql-common.templates:2001
+msgid "If unsure, enable SSL."
+msgstr "Aktivieren Sie SSL im Zweifelsfall."
+
+#. Type: note
+#. Description
+#: ../postgresql-common.templates:3001
+msgid "PostgreSQL ${version} catalog version changed"
+msgstr "Geänderte Katalogversion in PostgreSQL ${version}"
+
+#. Type: note
+#. Description
+#: ../postgresql-common.templates:3001
+msgid ""
+"The PostgreSQL cluster ${version} ${cluster} was created using catalog "
+"version ${db_catversion}, but the currently being installed package "
+"postgresql-${version} is using catalog version ${new_catversion}. You will "
+"not be able to use this cluster until it was upgraded to the new catalog "
+"version."
+msgstr ""
+"Der PostgreSQL-Cluster ${version} ${cluster} wurde mit der Katalogversion "
+"${db_catversion} erstellt, aber das gerade installierte Paket postgresql-"
+"${version} benutzt Katalogversion ${new_catversion}. Sie werden diesen "
+"Cluster erst wieder benutzen können, wenn er auf die neue Katalogversion "
+"aktualisiert wurde."
+
+#. Type: note
+#. Description
+#: ../postgresql-common.templates:3001
+msgid ""
+"The necessary subset of binaries from the old version was saved in "
+"${vartmpdir}. To upgrade the cluster, execute these commands:"
+msgstr ""
+"Die notwendigen Programmdateien der alten Version wurden in ${vartmpdir} "
+"gesichert. Benutzen Sie folgende Kommandos um den Cluster zu aktualisieren:"
diff --git a/debian/po/es.po b/debian/po/es.po
new file mode 100644
index 0000000..4450d66
--- /dev/null
+++ b/debian/po/es.po
@@ -0,0 +1,176 @@
+# postgresql-common po-debconf translation to spanish
+# Copyright (C) 2006 Software in the Public Interest, SPI Inc.
+# This file is distributed under the same license as the postgresql-common
+# package.
+#
+# Changes:
+# - Initial translation
+# Javier Fernández-Sanguino , 2006
+# - Updated
+# Javier Fernández-Sanguino , 2007-2008
+# Manuel "Venturi" Porras Peralta <venturi@openmailbox.org>, 2014.
+#
+# Traductores, si no conoce el formato PO, merece la pena leer la
+# documentación de gettext, especialmente las secciones dedicadas a este
+# formato, por ejemplo ejecutando:
+# info -n '(gettext)PO Files'
+# info -n '(gettext)Header Entry'
+#
+# Equipo de traducción al español, por favor lean antes de traducir
+# los siguientes documentos:
+#
+# - El proyecto de traducción de Debian al español
+# http://www.debian.org/intl/spanish/
+# especialmente las notas y normas de traducción en
+# http://www.debian.org/intl/spanish/notas
+#
+# - La guía de traducción de po's de debconf:
+# /usr/share/doc/po-debconf/README-trans
+# o http://www.debian.org/intl/l10n/po-debconf/README-trans
+#
+# Si tiene dudas o consultas sobre esta traducción consulte con el último
+# traductor (campo Last-Translator) y ponga en copia a la lista de
+# traducción de Debian al español (<debian-l10n-spanish@lists.debian.org>)
+#
+#
+msgid ""
+msgstr ""
+"Project-Id-Version: postgresql-common 68\n"
+"Report-Msgid-Bugs-To: postgresql-common@packages.debian.org\n"
+"POT-Creation-Date: 2016-03-05 11:47+0100\n"
+"PO-Revision-Date: 2014-12-21 12:27+0100\n"
+"Last-Translator: Manuel \"Venturi\" Porras Peralta <venturi@openmailbox."
+"org>\n"
+"Language-Team: Español; Castellano <debian-l10n-spanish@lists.debian.org>\n"
+"Language: es\n"
+"MIME-Version: 1.0\n"
+"Content-Type: text/plain; charset=UTF-8\n"
+"Content-Transfer-Encoding: 8bit\n"
+"X-POFile-SpellExtra: PostgreSQL oldversion clúster stop pgdropcluster\n"
+"X-POFile-SpellExtra: client old main clústers pgupgradecluster latest\n"
+"X-POFile-SpellExtra: postgresql\n"
+"Plural-Forms: nplurals=2; plural=(n != 1);\n"
+"X-Generator: Gtranslator 2.91.6\n"
+
+#. Type: error
+#. Description
+#: ../postgresql-common.templates:1001
+msgid "Obsolete major version ${old}"
+msgstr "Versión principal ${old} obsoleta"
+
+#. Type: error
+#. Description
+#: ../postgresql-common.templates:1001
+msgid ""
+"The PostgreSQL version ${old} is obsolete, but the server or client packages "
+"are still installed. Please install the latest packages (postgresql-"
+"${latest} and postgresql-client-${latest}) and upgrade the existing "
+"${oldversion} clusters with pg_upgradecluster (see manpage)."
+msgstr ""
+"La versión de PostgreSQL ${old} está obsoleta, pero el paquete del cliente o "
+"del servidor aún están instalados. Debe instalar las últimas versiones de "
+"los paquetes (postgresql-${latest} y postgresql-client-${latest}) y "
+"actualizar sus clústers ${oldversion} con la orden "
+"«pg_upgradecluster» (consulte la página del manual)."
+
+#. Type: error
+#. Description
+#: ../postgresql-common.templates:1001
+msgid ""
+"Please be aware that the installation of postgresql-${latest} will "
+"automatically create a default cluster ${latest}/main. If you want to "
+"upgrade the ${old}/main cluster, you need to remove the already existing "
+"${latest} cluster (pg_dropcluster --stop ${latest} main, see manpage for "
+"details)."
+msgstr ""
+"Tenga en cuenta que la instalación de postgresql-${latest} creará "
+"automáticamente un clúster por omisión ${latest}/main. Tiene que borrar el "
+"clúster ${latest} existente («pg_dropcluster --stop ${latest}) si desea "
+"actualizar el clúster ${old}/main, consulte la página de manual para conocer "
+"los detalles."
+
+#. Type: error
+#. Description
+#: ../postgresql-common.templates:1001
+msgid ""
+"The old server and client packages are no longer supported. After the "
+"existing clusters are upgraded, the postgresql-${old} and postgresql-client-"
+"${old} packages should be removed."
+msgstr ""
+"Ya no se da soporte a los paquetes antiguos de cliente y servidor. Debería "
+"eliminar los paquetes postgresql-${old} y postgresql-client-${old} después "
+"de actualizar los clústers que tenga."
+
+#. Type: error
+#. Description
+#: ../postgresql-common.templates:1001
+msgid ""
+"Please see /usr/share/doc/postgresql-common/README.Debian.gz for details."
+msgstr ""
+"Para más información consulte «/usr/share/doc/postgresql-common/README."
+"Debian.gz»."
+
+#. Type: boolean
+#. Description
+#: ../postgresql-common.templates:2001
+msgid "Enable SSL by default in new PostgreSQL clusters?"
+msgstr ""
+"¿Desea activar SSL como predeterminado en los nuevos clústers de PostgreSQL?"
+
+#. Type: boolean
+#. Description
+#: ../postgresql-common.templates:2001
+msgid ""
+"PostgreSQL supports SSL-encrypted connections. This is usually a good thing. "
+"However, if the database is solely accessed using TCP connections on "
+"localhost, SSL can be turned off without introducing security issues."
+msgstr ""
+"PostgreSQL admite conexiones cifradas SSL. Esto suele ser una buena idea. "
+"Aún así, si se accede a la base de datos exclusivamente usando conexiones "
+"TCP en «localhost», se puede desactivar el SSL sin provocar problemas de "
+"seguridad."
+
+#. Type: boolean
+#. Description
+#: ../postgresql-common.templates:2001
+msgid ""
+"UNIX domain socket connections (called \"local\" in pg_hba.conf) are not "
+"affected by this setting. This setting concerns new PostgreSQL clusters "
+"created during package install, or by using the pg_createcluster command. It "
+"does not reconfigure existing clusters."
+msgstr ""
+"Esta configuración no afecta a las conexiones a «socket» del dominio UNIX, "
+"llamados «local» en «pg_hba.conf». La configuración afecta a los clústers de "
+"PostgreSQL nuevos creados durante la instalación del paquete o utilizando la "
+"orden «pg_createcluster». No reconfigura ningún clúster ya existente."
+
+#. Type: boolean
+#. Description
+#: ../postgresql-common.templates:2001
+msgid "If unsure, enable SSL."
+msgstr "Si no está seguro, active SSL."
+
+#. Type: note
+#. Description
+#: ../postgresql-common.templates:3001
+msgid "PostgreSQL ${version} catalog version changed"
+msgstr ""
+
+#. Type: note
+#. Description
+#: ../postgresql-common.templates:3001
+msgid ""
+"The PostgreSQL cluster ${version} ${cluster} was created using catalog "
+"version ${db_catversion}, but the currently being installed package "
+"postgresql-${version} is using catalog version ${new_catversion}. You will "
+"not be able to use this cluster until it was upgraded to the new catalog "
+"version."
+msgstr ""
+
+#. Type: note
+#. Description
+#: ../postgresql-common.templates:3001
+msgid ""
+"The necessary subset of binaries from the old version was saved in "
+"${vartmpdir}. To upgrade the cluster, execute these commands:"
+msgstr ""
diff --git a/debian/po/eu.po b/debian/po/eu.po
new file mode 100644
index 0000000..bf63afd
--- /dev/null
+++ b/debian/po/eu.po
@@ -0,0 +1,131 @@
+# translation of eu.po to Euskara
+# postgresql-common Debconf tempaltes basque translation
+# Copyright (C) YEAR THE PACKAGE'S COPYRIGHT HOLDER
+# This file is distributed under the same license as the PACKAGE package.
+#
+# Piarres Beobide <pi@beobide.net>, 2007, 2008.
+msgid ""
+msgstr ""
+"Project-Id-Version: eu\n"
+"Report-Msgid-Bugs-To: postgresql-common@packages.debian.org\n"
+"POT-Creation-Date: 2016-03-05 11:47+0100\n"
+"PO-Revision-Date: 2008-05-27 23:31+0200\n"
+"Last-Translator: Piarres Beobide <pi@beobide.net>\n"
+"Language-Team: Euskara <debian-l10n-basque@lists.debian.org>\n"
+"Language: \n"
+"MIME-Version: 1.0\n"
+"Content-Type: text/plain; charset=UTF-8\n"
+"Content-Transfer-Encoding: 8bit\n"
+"X-Generator: KBabel 1.11.4\n"
+
+#. Type: error
+#. Description
+#: ../postgresql-common.templates:1001
+msgid "Obsolete major version ${old}"
+msgstr "Zaharkituriko ${old} bertsio nagusia"
+
+#. Type: error
+#. Description
+#: ../postgresql-common.templates:1001
+msgid ""
+"The PostgreSQL version ${old} is obsolete, but the server or client packages "
+"are still installed. Please install the latest packages (postgresql-"
+"${latest} and postgresql-client-${latest}) and upgrade the existing "
+"${oldversion} clusters with pg_upgradecluster (see manpage)."
+msgstr ""
+"PostgreSQL ${old} bertsioa zaharkiturik dago, baina bezero edo zerbitzari "
+"paketea oraindik instalaturik dago. Mesedez instalatu azken paketeak "
+"(postgresql-${latest} eta postgresql-client-${latest}) eta dauden "
+"${oldversion} taldeak pg_upgradecluster (manual orria ikusi) erabiliaz "
+"eguneratu."
+
+#. Type: error
+#. Description
+#: ../postgresql-common.templates:1001
+msgid ""
+"Please be aware that the installation of postgresql-${latest} will "
+"automatically create a default cluster ${latest}/main. If you want to "
+"upgrade the ${old}/main cluster, you need to remove the already existing "
+"${latest} cluster (pg_dropcluster --stop ${latest} main, see manpage for "
+"details)."
+msgstr ""
+"Kontu izan postgresql-${latest} instalatzean automatikoki ${latest}/main "
+"taldea sortuko duela. ${old}/main taldea eguneratu nahi baduzu dagoeneko "
+"dagoen ${latest} taldea ezabatu behar duzu (pg_dropcluster --stop ${latest} "
+"main, begiatu manual orrialdea xehetasunentzat)."
+
+#. Type: error
+#. Description
+#: ../postgresql-common.templates:1001
+msgid ""
+"The old server and client packages are no longer supported. After the "
+"existing clusters are upgraded, the postgresql-${old} and postgresql-client-"
+"${old} packages should be removed."
+msgstr ""
+"Zerbitzari eta bezero zahar paketeak ez dira luzaroago onartuko. Dauden "
+"taldeak eguneratu ondoren, postgresql-${old} eta postgresql-client-${old} "
+"paketeak ezabatu beharko lireateke."
+
+#. Type: error
+#. Description
+#: ../postgresql-common.templates:1001
+msgid ""
+"Please see /usr/share/doc/postgresql-common/README.Debian.gz for details."
+msgstr ""
+"Begiratu /usr/share/doc/postgresql-common/README.Debian.gz xehetasunetarako."
+
+#. Type: boolean
+#. Description
+#: ../postgresql-common.templates:2001
+msgid "Enable SSL by default in new PostgreSQL clusters?"
+msgstr ""
+
+#. Type: boolean
+#. Description
+#: ../postgresql-common.templates:2001
+msgid ""
+"PostgreSQL supports SSL-encrypted connections. This is usually a good thing. "
+"However, if the database is solely accessed using TCP connections on "
+"localhost, SSL can be turned off without introducing security issues."
+msgstr ""
+
+#. Type: boolean
+#. Description
+#: ../postgresql-common.templates:2001
+msgid ""
+"UNIX domain socket connections (called \"local\" in pg_hba.conf) are not "
+"affected by this setting. This setting concerns new PostgreSQL clusters "
+"created during package install, or by using the pg_createcluster command. It "
+"does not reconfigure existing clusters."
+msgstr ""
+
+#. Type: boolean
+#. Description
+#: ../postgresql-common.templates:2001
+msgid "If unsure, enable SSL."
+msgstr ""
+
+#. Type: note
+#. Description
+#: ../postgresql-common.templates:3001
+msgid "PostgreSQL ${version} catalog version changed"
+msgstr ""
+
+#. Type: note
+#. Description
+#: ../postgresql-common.templates:3001
+msgid ""
+"The PostgreSQL cluster ${version} ${cluster} was created using catalog "
+"version ${db_catversion}, but the currently being installed package "
+"postgresql-${version} is using catalog version ${new_catversion}. You will "
+"not be able to use this cluster until it was upgraded to the new catalog "
+"version."
+msgstr ""
+
+#. Type: note
+#. Description
+#: ../postgresql-common.templates:3001
+msgid ""
+"The necessary subset of binaries from the old version was saved in "
+"${vartmpdir}. To upgrade the cluster, execute these commands:"
+msgstr ""
diff --git a/debian/po/fi.po b/debian/po/fi.po
new file mode 100644
index 0000000..41fcb0e
--- /dev/null
+++ b/debian/po/fi.po
@@ -0,0 +1,126 @@
+msgid ""
+msgstr ""
+"Project-Id-Version: postgres-common\n"
+"Report-Msgid-Bugs-To: postgresql-common@packages.debian.org\n"
+"POT-Creation-Date: 2016-03-05 11:47+0100\n"
+"PO-Revision-Date: 2008-02-29 15:05+0200\n"
+"Last-Translator: Esko Arajärvi <edu@iki.fi>\n"
+"Language-Team: Finnish <debian-l10n-finnish@lists.debian.org>\n"
+"Language: fi\n"
+"MIME-Version: 1.0\n"
+"Content-Type: text/plain; charset=UTF-8\n"
+"Content-Transfer-Encoding: 8bit\n"
+"X-Poedit-Language: Finnish\n"
+"X-Poedit-Country: FINLAND\n"
+
+#. Type: error
+#. Description
+#: ../postgresql-common.templates:1001
+msgid "Obsolete major version ${old}"
+msgstr "Vanhentunut pääversio ${old}"
+
+#. Type: error
+#. Description
+#: ../postgresql-common.templates:1001
+msgid ""
+"The PostgreSQL version ${old} is obsolete, but the server or client packages "
+"are still installed. Please install the latest packages (postgresql-"
+"${latest} and postgresql-client-${latest}) and upgrade the existing "
+"${oldversion} clusters with pg_upgradecluster (see manpage)."
+msgstr ""
+"Ohjelman PostgreSQL versio ${old} on vanhentunut, mutta palvelin- tai "
+"asiakaspaketteja on vielä asennettuna. Asenna uusimmat paketit (postgresql-"
+"${latest} ja postgresql-client-${latest}) ja päivitä olemassa olevat version "
+"${oldversion} klusterit ohjelmalla pg_upgradecluster (katso man-ohjesivu)."
+
+#. Type: error
+#. Description
+#: ../postgresql-common.templates:1001
+msgid ""
+"Please be aware that the installation of postgresql-${latest} will "
+"automatically create a default cluster ${latest}/main. If you want to "
+"upgrade the ${old}/main cluster, you need to remove the already existing "
+"${latest} cluster (pg_dropcluster --stop ${latest} main, see manpage for "
+"details)."
+msgstr ""
+"Version postgresql-${latest} asennus luo automaattisesti oletusklusterin "
+"${latest}/main. Jos haluat päivittää klusterin ${old}/main, sinun tulee "
+"poistaa jo olemassa oleva klusteri ${latest} (komennolla pg_dropcluster --"
+"stop ${latest} main, lisätietoja man-ohjesivulta)."
+
+#. Type: error
+#. Description
+#: ../postgresql-common.templates:1001
+msgid ""
+"The old server and client packages are no longer supported. After the "
+"existing clusters are upgraded, the postgresql-${old} and postgresql-client-"
+"${old} packages should be removed."
+msgstr ""
+"Vanhoja palvelin- ja asiakaspaketteja ei enää tueta. Kun olemassa olevat "
+"klusterit on päivitetty, paketit postgresql-${old} ja postgresql-client-"
+"${old} tulisi poistaa."
+
+#. Type: error
+#. Description
+#: ../postgresql-common.templates:1001
+msgid ""
+"Please see /usr/share/doc/postgresql-common/README.Debian.gz for details."
+msgstr ""
+"Tiedostosta /usr/share/doc/postgresql-common/README.Debian.gz löytyy "
+"lisätietoja (englanniksi)."
+
+#. Type: boolean
+#. Description
+#: ../postgresql-common.templates:2001
+msgid "Enable SSL by default in new PostgreSQL clusters?"
+msgstr ""
+
+#. Type: boolean
+#. Description
+#: ../postgresql-common.templates:2001
+msgid ""
+"PostgreSQL supports SSL-encrypted connections. This is usually a good thing. "
+"However, if the database is solely accessed using TCP connections on "
+"localhost, SSL can be turned off without introducing security issues."
+msgstr ""
+
+#. Type: boolean
+#. Description
+#: ../postgresql-common.templates:2001
+msgid ""
+"UNIX domain socket connections (called \"local\" in pg_hba.conf) are not "
+"affected by this setting. This setting concerns new PostgreSQL clusters "
+"created during package install, or by using the pg_createcluster command. It "
+"does not reconfigure existing clusters."
+msgstr ""
+
+#. Type: boolean
+#. Description
+#: ../postgresql-common.templates:2001
+msgid "If unsure, enable SSL."
+msgstr ""
+
+#. Type: note
+#. Description
+#: ../postgresql-common.templates:3001
+msgid "PostgreSQL ${version} catalog version changed"
+msgstr ""
+
+#. Type: note
+#. Description
+#: ../postgresql-common.templates:3001
+msgid ""
+"The PostgreSQL cluster ${version} ${cluster} was created using catalog "
+"version ${db_catversion}, but the currently being installed package "
+"postgresql-${version} is using catalog version ${new_catversion}. You will "
+"not be able to use this cluster until it was upgraded to the new catalog "
+"version."
+msgstr ""
+
+#. Type: note
+#. Description
+#: ../postgresql-common.templates:3001
+msgid ""
+"The necessary subset of binaries from the old version was saved in "
+"${vartmpdir}. To upgrade the cluster, execute these commands:"
+msgstr ""
diff --git a/debian/po/fr.po b/debian/po/fr.po
new file mode 100644
index 0000000..08e8bad
--- /dev/null
+++ b/debian/po/fr.po
@@ -0,0 +1,152 @@
+# Translation of postgresql-common debconf templates to French
+# Copyright (C) 2006-2007 Guilhelm Panaget <guilhelm.panaget@free.fr>
+# This file is distributed under the same license as the postgresql-common package.
+#
+# Guilhelm Panaget <guilhelm.panaget@free.fr>
+msgid ""
+msgstr ""
+"Project-Id-Version: postgresql-common\n"
+"Report-Msgid-Bugs-To: postgresql-common@packages.debian.org\n"
+"POT-Creation-Date: 2016-03-05 11:47+0100\n"
+"PO-Revision-Date: 2016-01-04 10:35+0100\n"
+"Last-Translator: Julien Patriarca <leatherface@debian.org>\n"
+"Language-Team: French <debian-l10n-french@lists.debian.org>\n"
+"Language: fr\n"
+"MIME-Version: 1.0\n"
+"Content-Type: text/plain; charset=UTF-8\n"
+"Content-Transfer-Encoding: 8bit\n"
+"X-Generator: Poedit 1.6.10\n"
+
+#. Type: error
+#. Description
+#: ../postgresql-common.templates:1001
+msgid "Obsolete major version ${old}"
+msgstr "Version majeure ${old} obsolète"
+
+#. Type: error
+#. Description
+#: ../postgresql-common.templates:1001
+msgid ""
+"The PostgreSQL version ${old} is obsolete, but the server or client packages "
+"are still installed. Please install the latest packages (postgresql-"
+"${latest} and postgresql-client-${latest}) and upgrade the existing "
+"${oldversion} clusters with pg_upgradecluster (see manpage)."
+msgstr ""
+"La version ${old} de PostgreSQL est obsolète, mais le paquet du client ou du "
+"serveur est toujours installé. Veuillez installer la version la plus récente "
+"des paquets postgresql-${latest} et postgresql-client-${latest} et mettre à "
+"niveau les grappes (« clusters ») en version ${oldversion} avec "
+"« pg_upgradecluster ». Veuillez consulter la page de manuel pour plus de "
+"précisions."
+
+#. Type: error
+#. Description
+#: ../postgresql-common.templates:1001
+msgid ""
+"Please be aware that the installation of postgresql-${latest} will "
+"automatically create a default cluster ${latest}/main. If you want to "
+"upgrade the ${old}/main cluster, you need to remove the already existing "
+"${latest} cluster (pg_dropcluster --stop ${latest} main, see manpage for "
+"details)."
+msgstr ""
+"Veuillez noter que l'installation de postgresql-${latest} créera par défaut "
+"une grappe (« cluster ») ${latest}/main. Si vous souhaitez mettre à niveau "
+"la grappe ${old}/main, il faudra supprimer la grappe ${latest} en exécutant "
+"la commande « pg_dropcluster--stop ${latest} main ». Veuillez consulter la "
+"page de manuel pour plus de précisions."
+
+#. Type: error
+#. Description
+#: ../postgresql-common.templates:1001
+msgid ""
+"The old server and client packages are no longer supported. After the "
+"existing clusters are upgraded, the postgresql-${old} and postgresql-client-"
+"${old} packages should be removed."
+msgstr ""
+"Les anciennes versions des paquets client et serveur ne sont plus "
+"maintenues. Après la mise à niveau des grappes (« clusters »), les paquets "
+"postgresql-${old} et postgresql-client-${old} devraient être supprimés."
+
+#. Type: error
+#. Description
+#: ../postgresql-common.templates:1001
+msgid ""
+"Please see /usr/share/doc/postgresql-common/README.Debian.gz for details."
+msgstr ""
+"Veuillez consulter /usr/share/doc/postgresql-common/README.Debian.gz pour "
+"plus de détails."
+
+#. Type: boolean
+#. Description
+#: ../postgresql-common.templates:2001
+msgid "Enable SSL by default in new PostgreSQL clusters?"
+msgstr ""
+"Faut-il activer le protocole SSL par défaut pour les nouvelles grappes "
+"PostgreSQL ?"
+
+#. Type: boolean
+#. Description
+#: ../postgresql-common.templates:2001
+msgid ""
+"PostgreSQL supports SSL-encrypted connections. This is usually a good thing. "
+"However, if the database is solely accessed using TCP connections on "
+"localhost, SSL can be turned off without introducing security issues."
+msgstr ""
+"PostgreSQL supporte les connexions chiffrées avec SSL. C'est généralement "
+"une bonne chose. Cependant, si la base de données est accédée exclusivement "
+"au travers de connexions TCP locales, SSL peut être désactivé sans pour "
+"autant introduire des failles de sécurité."
+
+#. Type: boolean
+#. Description
+#: ../postgresql-common.templates:2001
+msgid ""
+"UNIX domain socket connections (called \"local\" in pg_hba.conf) are not "
+"affected by this setting. This setting concerns new PostgreSQL clusters "
+"created during package install, or by using the pg_createcluster command. It "
+"does not reconfigure existing clusters."
+msgstr ""
+"Les connexions sur le socket de domaine UNIX (nommées « local » dans pg_hba."
+"conf) ne sont pas affectées par ce réglage. Ce paramètre concerne les "
+"nouvelles grappes PostgreSQL créées lors de l'installation du paquet ou en "
+"utilisant la commande pg_createcluster. Cela ne reconfigure pas les grappes "
+"existantes."
+
+#. Type: boolean
+#. Description
+#: ../postgresql-common.templates:2001
+msgid "If unsure, enable SSL."
+msgstr "Dans le doute, activez SSL."
+
+#. Type: note
+#. Description
+#: ../postgresql-common.templates:3001
+msgid "PostgreSQL ${version} catalog version changed"
+msgstr "La version du catalogue de PostgreSQL ${version} a changé."
+
+#. Type: note
+#. Description
+#: ../postgresql-common.templates:3001
+msgid ""
+"The PostgreSQL cluster ${version} ${cluster} was created using catalog "
+"version ${db_catversion}, but the currently being installed package "
+"postgresql-${version} is using catalog version ${new_catversion}. You will "
+"not be able to use this cluster until it was upgraded to the new catalog "
+"version."
+msgstr ""
+"La grappe${cluster} PostgreSQL ${version} a été créée en utilisant la "
+"version de catalogue ${db_catversion}, mais le paquet postgresql-${version} "
+"actuellement installé utilise la version de catalogue ${new_catversion}. "
+"Vous ne pourrez pas utiliser cette grappe tant que vous n'aurez pas mis à "
+"jour le catalogue vers la nouvelle version."
+
+#. Type: note
+#. Description
+#: ../postgresql-common.templates:3001
+msgid ""
+"The necessary subset of binaries from the old version was saved in "
+"${vartmpdir}. To upgrade the cluster, execute these commands:"
+msgstr ""
+"L'ensemble des exécutables nécessaires de l'ancienne version ont été "
+"sauvegardés dans ${vartmpdir}. Pour mettre à jour la grappe, veuillez "
+"exécuter ces commandes :"
diff --git a/debian/po/gl.po b/debian/po/gl.po
new file mode 100644
index 0000000..24f7d49
--- /dev/null
+++ b/debian/po/gl.po
@@ -0,0 +1,129 @@
+# Galician translation of postgresql-common's debconf templates
+# This file is distributed under the same license as the postgresql-common package.
+# Jacobo Tarrio <jtarrio@debian.org>, 2007, 2008.
+#
+msgid ""
+msgstr ""
+"Project-Id-Version: postgresql-common\n"
+"Report-Msgid-Bugs-To: postgresql-common@packages.debian.org\n"
+"POT-Creation-Date: 2016-03-05 11:47+0100\n"
+"PO-Revision-Date: 2008-05-13 00:18+0100\n"
+"Last-Translator: Jacobo Tarrio <jtarrio@debian.org>\n"
+"Language-Team: Galician <proxecto@trasno.net>\n"
+"Language: gl\n"
+"MIME-Version: 1.0\n"
+"Content-Type: text/plain; charset=UTF-8\n"
+"Content-Transfer-Encoding: 8bit\n"
+
+#. Type: error
+#. Description
+#: ../postgresql-common.templates:1001
+msgid "Obsolete major version ${old}"
+msgstr "Versión ${old} obsoleta"
+
+#. Type: error
+#. Description
+#: ../postgresql-common.templates:1001
+msgid ""
+"The PostgreSQL version ${old} is obsolete, but the server or client packages "
+"are still installed. Please install the latest packages (postgresql-"
+"${latest} and postgresql-client-${latest}) and upgrade the existing "
+"${oldversion} clusters with pg_upgradecluster (see manpage)."
+msgstr ""
+"A versión ${old} de PostgreSQL está obsoleta, pero aínda ten instalado os "
+"paquetes do servidor ou do cliente. Instale os últimos paquetes (postgresql-"
+"${latest} e postgresql-client-${latest}) e actualice os clusters que teñan "
+"${oldversion} mediante pg_upgradecluster (consulte a páxina de manual)."
+
+#. Type: error
+#. Description
+#: ../postgresql-common.templates:1001
+msgid ""
+"Please be aware that the installation of postgresql-${latest} will "
+"automatically create a default cluster ${latest}/main. If you want to "
+"upgrade the ${old}/main cluster, you need to remove the already existing "
+"${latest} cluster (pg_dropcluster --stop ${latest} main, see manpage for "
+"details)."
+msgstr ""
+"Teña en conta que a instalación de postgresql-${latest} ha crear "
+"automaticamente un cluster ${latest}/main por defecto. Se quere actualizar o "
+"cluster ${old}/mail ha ter que eliminar o cluster ${latest} que xa existe "
+"(pg_dropcluster --stop ${latest} main, consulte a páxina man para máis "
+"detalles)."
+
+#. Type: error
+#. Description
+#: ../postgresql-common.templates:1001
+msgid ""
+"The old server and client packages are no longer supported. After the "
+"existing clusters are upgraded, the postgresql-${old} and postgresql-client-"
+"${old} packages should be removed."
+msgstr ""
+"Xa non hai soporte dos paquetes de servidor e cliente vellos. Despois de "
+"actualizar os clusters existentes debería eliminar os paquetes postgresql-"
+"${old} e postgresql-client-${old}."
+
+#. Type: error
+#. Description
+#: ../postgresql-common.templates:1001
+msgid ""
+"Please see /usr/share/doc/postgresql-common/README.Debian.gz for details."
+msgstr ""
+"Consulte /usr/share/doc/postgresql-common/README.Debian.gz para ter máis "
+"detalles."
+
+#. Type: boolean
+#. Description
+#: ../postgresql-common.templates:2001
+msgid "Enable SSL by default in new PostgreSQL clusters?"
+msgstr ""
+
+#. Type: boolean
+#. Description
+#: ../postgresql-common.templates:2001
+msgid ""
+"PostgreSQL supports SSL-encrypted connections. This is usually a good thing. "
+"However, if the database is solely accessed using TCP connections on "
+"localhost, SSL can be turned off without introducing security issues."
+msgstr ""
+
+#. Type: boolean
+#. Description
+#: ../postgresql-common.templates:2001
+msgid ""
+"UNIX domain socket connections (called \"local\" in pg_hba.conf) are not "
+"affected by this setting. This setting concerns new PostgreSQL clusters "
+"created during package install, or by using the pg_createcluster command. It "
+"does not reconfigure existing clusters."
+msgstr ""
+
+#. Type: boolean
+#. Description
+#: ../postgresql-common.templates:2001
+msgid "If unsure, enable SSL."
+msgstr ""
+
+#. Type: note
+#. Description
+#: ../postgresql-common.templates:3001
+msgid "PostgreSQL ${version} catalog version changed"
+msgstr ""
+
+#. Type: note
+#. Description
+#: ../postgresql-common.templates:3001
+msgid ""
+"The PostgreSQL cluster ${version} ${cluster} was created using catalog "
+"version ${db_catversion}, but the currently being installed package "
+"postgresql-${version} is using catalog version ${new_catversion}. You will "
+"not be able to use this cluster until it was upgraded to the new catalog "
+"version."
+msgstr ""
+
+#. Type: note
+#. Description
+#: ../postgresql-common.templates:3001
+msgid ""
+"The necessary subset of binaries from the old version was saved in "
+"${vartmpdir}. To upgrade the cluster, execute these commands:"
+msgstr ""
diff --git a/debian/po/it.po b/debian/po/it.po
new file mode 100644
index 0000000..7e89555
--- /dev/null
+++ b/debian/po/it.po
@@ -0,0 +1,136 @@
+# Italian (it) translation of debconf templates for postgresql-common
+# This file is distributed under the same license as the postgresql-common package.
+# Luca Monducci <luca.mo@tiscali.it>, 2006-2014.
+#
+msgid ""
+msgstr ""
+"Project-Id-Version: postgresql-common 160 italian debconf templates\n"
+"Report-Msgid-Bugs-To: postgresql-common@packages.debian.org\n"
+"POT-Creation-Date: 2016-03-05 11:47+0100\n"
+"PO-Revision-Date: 2014-08-30 10:23+0200\n"
+"Last-Translator: Luca Monducci <luca.mo@tiscali.it>\n"
+"Language-Team: Italian <debian-l10n-italian@lists.debian.org>\n"
+"Language: it\n"
+"MIME-Version: 1.0\n"
+"Content-Type: text/plain; charset=UTF-8\n"
+"Content-Transfer-Encoding: 8bit\n"
+
+#. Type: error
+#. Description
+#: ../postgresql-common.templates:1001
+msgid "Obsolete major version ${old}"
+msgstr "La versione ${old} è obsoleta"
+
+#. Type: error
+#. Description
+#: ../postgresql-common.templates:1001
+msgid ""
+"The PostgreSQL version ${old} is obsolete, but the server or client packages "
+"are still installed. Please install the latest packages (postgresql-"
+"${latest} and postgresql-client-${latest}) and upgrade the existing "
+"${oldversion} clusters with pg_upgradecluster (see manpage)."
+msgstr ""
+"La versione ${old} di PostgreSQL è obsoleta, ma alcuni dei pacchetti server "
+"o client sono ancora installati. Installare i pacchetti più recenti "
+"(postgresql-${latest} e postgresql-client-${latest}) e aggiornare i cluster "
+"${oldversion} esistenti con pg_upgradecluster (consultare la pagina man)."
+
+#. Type: error
+#. Description
+#: ../postgresql-common.templates:1001
+msgid ""
+"Please be aware that the installation of postgresql-${latest} will "
+"automatically create a default cluster ${latest}/main. If you want to "
+"upgrade the ${old}/main cluster, you need to remove the already existing "
+"${latest} cluster (pg_dropcluster --stop ${latest} main, see manpage for "
+"details)."
+msgstr ""
+"Attenzione: l'installazione di postgresql-${latest} crea automaticamente il "
+"cluster predefinito ${latest}/main. Per aggiornare il cluster ${old}/main è "
+"necessario rimuovere cluster ${latest} dopo la sua creazione (pg_dropcluster "
+"--stop ${latest} main, consultare la pagina man per i dettagli)."
+
+#. Type: error
+#. Description
+#: ../postgresql-common.templates:1001
+msgid ""
+"The old server and client packages are no longer supported. After the "
+"existing clusters are upgraded, the postgresql-${old} and postgresql-client-"
+"${old} packages should be removed."
+msgstr ""
+"I vecchi pacchetti di server e client non sono più supportati. Dopo aver "
+"aggiornato i cluster esistenti è consigliabile rimuovere i pacchetti "
+"postgresql-${old} e postgresql-client-${old}."
+
+#. Type: error
+#. Description
+#: ../postgresql-common.templates:1001
+msgid ""
+"Please see /usr/share/doc/postgresql-common/README.Debian.gz for details."
+msgstr ""
+"Consultare /usr/share/doc/postgresql-common/README.Debian.gz per i dettagli."
+
+#. Type: boolean
+#. Description
+#: ../postgresql-common.templates:2001
+msgid "Enable SSL by default in new PostgreSQL clusters?"
+msgstr "Attivare in modo predefinito SSL nei nuovi cluster PostgreSQL?"
+
+#. Type: boolean
+#. Description
+#: ../postgresql-common.templates:2001
+msgid ""
+"PostgreSQL supports SSL-encrypted connections. This is usually a good thing. "
+"However, if the database is solely accessed using TCP connections on "
+"localhost, SSL can be turned off without introducing security issues."
+msgstr ""
+"PostgreSQL supporta connessioni cifrate con SSL e questa è una cosa buona, "
+"tuttavia, se l'accesso al database avviene solo con connessioni TCP da "
+"localhost allora è possibile disabilitare SSL senza il rischio di esporsi a "
+"problemi di sicurezza."
+
+#. Type: boolean
+#. Description
+#: ../postgresql-common.templates:2001
+msgid ""
+"UNIX domain socket connections (called \"local\" in pg_hba.conf) are not "
+"affected by this setting. This setting concerns new PostgreSQL clusters "
+"created during package install, or by using the pg_createcluster command. It "
+"does not reconfigure existing clusters."
+msgstr ""
+"Le connessioni tramite socket di dominio locale UNIX (chiamate \"local\" in "
+"pg_hba.conf) non sono influenzate da questa impostazione. Questa "
+"impostazione riguarda solo i nuovi cluster PostgreSQL creati durante "
+"l'installazione del pacchetto oppure utilizzando il comando pg_createcluster "
+"e non modifica la configurazione di nessuno dei cluster esistenti."
+
+#. Type: boolean
+#. Description
+#: ../postgresql-common.templates:2001
+msgid "If unsure, enable SSL."
+msgstr "Se non si è sicuri, attivare SSL."
+
+#. Type: note
+#. Description
+#: ../postgresql-common.templates:3001
+msgid "PostgreSQL ${version} catalog version changed"
+msgstr ""
+
+#. Type: note
+#. Description
+#: ../postgresql-common.templates:3001
+msgid ""
+"The PostgreSQL cluster ${version} ${cluster} was created using catalog "
+"version ${db_catversion}, but the currently being installed package "
+"postgresql-${version} is using catalog version ${new_catversion}. You will "
+"not be able to use this cluster until it was upgraded to the new catalog "
+"version."
+msgstr ""
+
+#. Type: note
+#. Description
+#: ../postgresql-common.templates:3001
+msgid ""
+"The necessary subset of binaries from the old version was saved in "
+"${vartmpdir}. To upgrade the cluster, execute these commands:"
+msgstr ""
diff --git a/debian/po/ja.po b/debian/po/ja.po
new file mode 100644
index 0000000..68a3a05
--- /dev/null
+++ b/debian/po/ja.po
@@ -0,0 +1,145 @@
+# Copyright (C) 2006 Martin Pitt <mpitt@debian.org>
+# This file is distributed under the same license as the postgresql-common package.
+# Hideki Yamane <henrich@debian.or.jp>, 2006-2008.
+# Takuma Yamada <tyamada@takumayamada.com>, 2016.
+#
+msgid ""
+msgstr ""
+"Project-Id-Version: postgresql-common 155\n"
+"Report-Msgid-Bugs-To: postgresql-common@packages.debian.org\n"
+"POT-Creation-Date: 2016-03-05 11:47+0100\n"
+"PO-Revision-Date: 2016-04-07 11:35+0900\n"
+"Last-Translator: Takuma Yamada <tyamada@takumayamada.com>\n"
+"Language-Team: Japanese <debian-japanese@lists.debian.org>\n"
+"Language: ja\n"
+"MIME-Version: 1.0\n"
+"Content-Type: text/plain; charset=UTF-8\n"
+"Content-Transfer-Encoding: 8bit\n"
+"Plural-Forms: nplurals=1; plural=0;\n"
+"X-Generator: Gtranslator 2.91.6\n"
+
+#. Type: error
+#. Description
+#: ../postgresql-common.templates:1001
+msgid "Obsolete major version ${old}"
+msgstr "廃止されたメジャーバージョン ${old}"
+
+#. Type: error
+#. Description
+#: ../postgresql-common.templates:1001
+msgid ""
+"The PostgreSQL version ${old} is obsolete, but the server or client packages "
+"are still installed. Please install the latest packages (postgresql-"
+"${latest} and postgresql-client-${latest}) and upgrade the existing "
+"${oldversion} clusters with pg_upgradecluster (see manpage)."
+msgstr ""
+"PostgreSQL バージョン ${old} は廃止されましたが、サーバまたはクライアントパッ"
+"ケージがまだインストールされています。最新のパッケージ (postgresql-${latest} "
+"および postgresql-client-${latest}) をインストールして、既存の ${oldversion} "
+"クラスタを pg_upgradecluster でアップグレードしてください (manpage を参照)。"
+
+#. Type: error
+#. Description
+#: ../postgresql-common.templates:1001
+msgid ""
+"Please be aware that the installation of postgresql-${latest} will "
+"automatically create a default cluster ${latest}/main. If you want to "
+"upgrade the ${old}/main cluster, you need to remove the already existing "
+"${latest} cluster (pg_dropcluster --stop ${latest} main, see manpage for "
+"details)."
+msgstr ""
+"postgresql-${latest} のインストールは自動的にデフォルトのクラスタ ${latest}/"
+"main を作成することに注意してください。${old}/main クラスタをアップグレードす"
+"る場合は、既存の ${latest} クラスタを削除する必要があります (pg_dropcluster "
+"--stop ${latest} main、詳細は manpage を参照)。"
+
+#. Type: error
+#. Description
+#: ../postgresql-common.templates:1001
+msgid ""
+"The old server and client packages are no longer supported. After the "
+"existing clusters are upgraded, the postgresql-${old} and postgresql-client-"
+"${old} packages should be removed."
+msgstr ""
+"古いサーバおよびクライアントパッケージはサポートされなくなりました。既存のク"
+"ラスタがアップグレードされた後に、postgresql-${old} および postgresql-client-"
+"${old} パッケージを削除する必要があります。"
+
+#. Type: error
+#. Description
+#: ../postgresql-common.templates:1001
+msgid ""
+"Please see /usr/share/doc/postgresql-common/README.Debian.gz for details."
+msgstr ""
+"詳細は /usr/share/doc/postgresql-common/README.Debian.gz を参照してください。"
+
+#. Type: boolean
+#. Description
+#: ../postgresql-common.templates:2001
+msgid "Enable SSL by default in new PostgreSQL clusters?"
+msgstr "新しい PostgreSQL クラスタではデフォルトで SSL を有効にしますか?"
+
+#. Type: boolean
+#. Description
+#: ../postgresql-common.templates:2001
+msgid ""
+"PostgreSQL supports SSL-encrypted connections. This is usually a good thing. "
+"However, if the database is solely accessed using TCP connections on "
+"localhost, SSL can be turned off without introducing security issues."
+msgstr ""
+"PostgreSQL は SSL で暗号化された接続をサポートしています。これは通常は良いこ"
+"とです。しかし、データベースが単にローカルホスト上の TCP 接続を使用してアクセ"
+"スされる場合は、セキュリティ問題を入れることなく SSL をオフにすることができま"
+"す。"
+
+#. Type: boolean
+#. Description
+#: ../postgresql-common.templates:2001
+msgid ""
+"UNIX domain socket connections (called \"local\" in pg_hba.conf) are not "
+"affected by this setting. This setting concerns new PostgreSQL clusters "
+"created during package install, or by using the pg_createcluster command. It "
+"does not reconfigure existing clusters."
+msgstr ""
+"UNIX ドメインソケット接続 (pg_hba.conf 中で \"local\" と呼ばれる) は、この設"
+"定の影響を受けません。この設定は、パッケージのインストールや "
+"pg_createcluster コマンドの使用で作成される新しい PostgreSQL クラスタに関する"
+"ものです。これは、既存のクラスタを再設定しません。"
+
+#. Type: boolean
+#. Description
+#: ../postgresql-common.templates:2001
+msgid "If unsure, enable SSL."
+msgstr "よくわからない場合は、SSL を有効にします。"
+
+#. Type: note
+#. Description
+#: ../postgresql-common.templates:3001
+msgid "PostgreSQL ${version} catalog version changed"
+msgstr "PostgreSQL ${version} カタログバージョンが変更されました"
+
+#. Type: note
+#. Description
+#: ../postgresql-common.templates:3001
+msgid ""
+"The PostgreSQL cluster ${version} ${cluster} was created using catalog "
+"version ${db_catversion}, but the currently being installed package "
+"postgresql-${version} is using catalog version ${new_catversion}. You will "
+"not be able to use this cluster until it was upgraded to the new catalog "
+"version."
+msgstr ""
+"PostgreSQL クラスタ ${version} {$cluster} は、カタログバージョン "
+"${db_catversioin} を使用して作成されました。しかし、現在インストールされてい"
+"るパッケージ postgresql-${version} は、カタログバージョン ${new_catversion} "
+"を使用しています。新しいカタログバージョンにアップグレードされるまで、このク"
+"ラスタは使用することができません。"
+
+#. Type: note
+#. Description
+#: ../postgresql-common.templates:3001
+msgid ""
+"The necessary subset of binaries from the old version was saved in "
+"${vartmpdir}. To upgrade the cluster, execute these commands:"
+msgstr ""
+"古いバージョンからのバイナリの必要なサブセットは、${vartmpdir} に保存されてい"
+"ました。クラスタをアップグレードするには、次のコマンドを実行します。"
diff --git a/debian/po/nl.po b/debian/po/nl.po
new file mode 100644
index 0000000..15823f0
--- /dev/null
+++ b/debian/po/nl.po
@@ -0,0 +1,150 @@
+# Dutch postgresql-common po-debconf translation,
+# Copyright (C) 2011 THE PACKAGE'S COPYRIGHT HOLDER
+# This file is distributed under the same license as the postgresql-common package.
+#
+# Vincent Zweije <zweije@xs4all.nl>, 2006.
+# Vincent Zweije <vincent@zweije.nl>, 2011.
+# Frans Spiesschaert <Frans.Spiesschaert@yucom.be>, 2014, 2016.
+#
+msgid ""
+msgstr ""
+"Project-Id-Version: postgresql-common 172\n"
+"Report-Msgid-Bugs-To: postgresql-common@packages.debian.org\n"
+"POT-Creation-Date: 2016-03-05 11:47+0100\n"
+"PO-Revision-Date: 2016-01-12 16:00+0100\n"
+"Last-Translator: Frans Spiesschaert <Frans.Spiesschaert@yucom.be>\n"
+"Language-Team: Debian Dutch l10n Team <debian-l10n-dutch@lists.debian.org>\n"
+"Language: nl\n"
+"MIME-Version: 1.0\n"
+"Content-Type: text/plain; charset=UTF-8\n"
+"Content-Transfer-Encoding: 8bit\n"
+"Plural-Forms: nplurals=2; plural=(n != 1);\n"
+"X-Generator: Gtranslator 2.91.6\n"
+
+#. Type: error
+#. Description
+#: ../postgresql-common.templates:1001
+msgid "Obsolete major version ${old}"
+msgstr "Verouderde hoofdversie ${old}"
+
+#. Type: error
+#. Description
+#: ../postgresql-common.templates:1001
+msgid ""
+"The PostgreSQL version ${old} is obsolete, but the server or client packages "
+"are still installed. Please install the latest packages (postgresql-"
+"${latest} and postgresql-client-${latest}) and upgrade the existing "
+"${oldversion} clusters with pg_upgradecluster (see manpage)."
+msgstr ""
+"De PostgreSQL versie ${old} is verouderd, maar het server- en/of "
+"clientpakket zijn nog geïnstalleerd. U dient de nieuwste pakketten "
+"(postgresql-${latest} en postgresql-client-${latest}) te installeren en uw "
+"bestaande ${oldversion} clusters op te waarderen met pg_upgradecluster (zie "
+"de man-pagina)."
+
+#. Type: error
+#. Description
+#: ../postgresql-common.templates:1001
+msgid ""
+"Please be aware that the installation of postgresql-${latest} will "
+"automatically create a default cluster ${latest}/main. If you want to "
+"upgrade the ${old}/main cluster, you need to remove the already existing "
+"${latest} cluster (pg_dropcluster --stop ${latest} main, see manpage for "
+"details)."
+msgstr ""
+"Let op: de installatie van postgresql-${latest} zal automatisch een "
+"standaardcluster ${latest}/main aanmaken. Indien u de cluster ${old}/main "
+"wilt opwaarderen dient u de reeds bestaande cluster ${latest} te verwijderen "
+"met \"pg_dropcluster --stop ${latest} main\". Zie de man-pagina voor details."
+
+#. Type: error
+#. Description
+#: ../postgresql-common.templates:1001
+msgid ""
+"The old server and client packages are no longer supported. After the "
+"existing clusters are upgraded, the postgresql-${old} and postgresql-client-"
+"${old} packages should be removed."
+msgstr ""
+"De oude server- en clientpakketten worden niet langer ondersteund. Nadat u "
+"de bestaande clusters hebt opgewaardeerd, kunt u het beste de pakketten "
+"postgresql-${old} en postgresql-client-${old} verwijderen."
+
+#. Type: error
+#. Description
+#: ../postgresql-common.templates:1001
+msgid ""
+"Please see /usr/share/doc/postgresql-common/README.Debian.gz for details."
+msgstr "Zie /usr/share/doc/postgresql-common/README.Debian.gz voor details."
+
+#. Type: boolean
+#. Description
+#: ../postgresql-common.templates:2001
+msgid "Enable SSL by default in new PostgreSQL clusters?"
+msgstr "Standaard SSL activeren voor nieuwe PostgreSQL clusters?"
+
+#. Type: boolean
+#. Description
+#: ../postgresql-common.templates:2001
+msgid ""
+"PostgreSQL supports SSL-encrypted connections. This is usually a good thing. "
+"However, if the database is solely accessed using TCP connections on "
+"localhost, SSL can be turned off without introducing security issues."
+msgstr ""
+"PostgreSQL ondersteunt verbindingen met SSL-encryptie. Meestal is dit een "
+"goede zaak. Maar als de database enkel op de lokale computer via een TCP-"
+"verbinding benaderd wordt, kan men SSL uitzetten zonder verhoogd "
+"veiligheidsrisico."
+
+#. Type: boolean
+#. Description
+#: ../postgresql-common.templates:2001
+msgid ""
+"UNIX domain socket connections (called \"local\" in pg_hba.conf) are not "
+"affected by this setting. This setting concerns new PostgreSQL clusters "
+"created during package install, or by using the pg_createcluster command. It "
+"does not reconfigure existing clusters."
+msgstr ""
+"'UNIX domain socket' communicatieverbindingen (aangeduid met \"local\" in "
+"pg_hba.conf) worden door deze instelling niet beïnvloed. Deze instelling "
+"heeft betrekking op de nieuwe clusters van PostgreSQL die tijdens de "
+"installatie van het pakket of via het commando pg_createcluster aangemaakt "
+"worden. Bestaande clusters worden niet opnieuw geconfigureerd."
+
+#. Type: boolean
+#. Description
+#: ../postgresql-common.templates:2001
+msgid "If unsure, enable SSL."
+msgstr "Activeer SSL in geval van twijfel."
+
+#. Type: note
+#. Description
+#: ../postgresql-common.templates:3001
+msgid "PostgreSQL ${version} catalog version changed"
+msgstr "PostgreSQL ${version}: de catalogusversie werd gewijzigd"
+
+#. Type: note
+#. Description
+#: ../postgresql-common.templates:3001
+msgid ""
+"The PostgreSQL cluster ${version} ${cluster} was created using catalog "
+"version ${db_catversion}, but the currently being installed package "
+"postgresql-${version} is using catalog version ${new_catversion}. You will "
+"not be able to use this cluster until it was upgraded to the new catalog "
+"version."
+msgstr ""
+"De PostgreSQL cluster ${version} ${cluster} werd aangemaakt met de "
+"catalogusversie ${db_catversion}, maar het pakket postgresql-${version} dat "
+"nu geïnstalleerd wordt, gebruikt catalogusversie ${new_catversion}. U zult "
+"deze cluster niet kunnen gebruiken totdat hij naar de nieuwe catalogusversie "
+"opgewaardeerd werd."
+
+#. Type: note
+#. Description
+#: ../postgresql-common.templates:3001
+msgid ""
+"The necessary subset of binaries from the old version was saved in "
+"${vartmpdir}. To upgrade the cluster, execute these commands:"
+msgstr ""
+"Van de oude versie werd een subset binaire bestanden die u daarvoor nog "
+"nodig heeft, opgeslagen in ${vartmpdir}. Voer de volgende commando's uit om "
+"de cluster op te waarderen:"
diff --git a/debian/po/pt.po b/debian/po/pt.po
new file mode 100644
index 0000000..7066cc2
--- /dev/null
+++ b/debian/po/pt.po
@@ -0,0 +1,145 @@
+# Portuguese translation of postgresql-common debconf messages.
+# This file is distributed under the same license as the postgresql-common package.
+# Ricardo Silva <ardoric@gmail.com>, 2006,2017.
+#
+#
+msgid ""
+msgstr ""
+"Project-Id-Version: postgresql-common 184\n"
+"Report-Msgid-Bugs-To: postgresql-common@packages.debian.org\n"
+"POT-Creation-Date: 2016-03-05 11:47+0100\n"
+"PO-Revision-Date: 2017-08-17 11:35-0000\n"
+"Last-Translator: Ricardo Silva <ardoric@gmail.com>\n"
+"Language-Team: Portuguese <traduz@debianpt.org>\n"
+"Language: pt\n"
+"MIME-Version: 1.0\n"
+"Content-Type: text/plain; charset=UTF-8\n"
+"Content-Transfer-Encoding: 8bit\n"
+"X-Generator: Poedit 1.6.10\n"
+
+#. Type: error
+#. Description
+#: ../postgresql-common.templates:1001
+msgid "Obsolete major version ${old}"
+msgstr "Versão maior ${old} obsoleta"
+
+#. Type: error
+#. Description
+#: ../postgresql-common.templates:1001
+msgid ""
+"The PostgreSQL version ${old} is obsolete, but the server or client packages "
+"are still installed. Please install the latest packages (postgresql-"
+"${latest} and postgresql-client-${latest}) and upgrade the existing "
+"${oldversion} clusters with pg_upgradecluster (see manpage)."
+msgstr ""
+"A versão ${old} do PostgreSQL está obsoleta, mas ainda tem os pacotes de "
+"cliente e/ou do servidor instalados. Por favor instale os últimos pacotes "
+"(postgresql-${latest} e postgresql-client-${latest}) e actualize os seus "
+"clusters ${oldversion} existentes com o pg_upgradecluster (ver página do "
+"manual)."
+
+#. Type: error
+#. Description
+#: ../postgresql-common.templates:1001
+msgid ""
+"Please be aware that the installation of postgresql-${latest} will "
+"automatically create a default cluster ${latest}/main. If you want to "
+"upgrade the ${old}/main cluster, you need to remove the already existing "
+"${latest} cluster (pg_dropcluster --stop ${latest} main, see manpage for "
+"details)."
+msgstr ""
+"Por favor tenha consciência que a instalação de postgresql-${latest} irá "
+"criar automaticamente o cluster por omissão ${latest}/main. Se deseja "
+"actualizar o cluster ${old}/main, precisa de remover o cluster ${latest} "
+"existente (pg_dropcluster --stop ${latest} main, ver página do manual para "
+"detalhes)."
+
+#. Type: error
+#. Description
+#: ../postgresql-common.templates:1001
+msgid ""
+"The old server and client packages are no longer supported. After the "
+"existing clusters are upgraded, the postgresql-${old} and postgresql-client-"
+"${old} packages should be removed."
+msgstr ""
+"Os pacotes de cliente e servidor antigos já não são suportados. Após "
+"actualizar os clusters existentes, deve remover os pacotes postgresql-${old} "
+"e postgresql-client-${old}."
+
+#. Type: error
+#. Description
+#: ../postgresql-common.templates:1001
+msgid ""
+"Please see /usr/share/doc/postgresql-common/README.Debian.gz for details."
+msgstr ""
+"Por favor consulte o ficheiro /usr/share/doc/postgresql-common/README.Debian."
+"gz para mais detalhes."
+
+#. Type: boolean
+#. Description
+#: ../postgresql-common.templates:2001
+msgid "Enable SSL by default in new PostgreSQL clusters?"
+msgstr "Activar SSL por omissão em novos clusters PostgreSQL?"
+
+#. Type: boolean
+#. Description
+#: ../postgresql-common.templates:2001
+msgid ""
+"PostgreSQL supports SSL-encrypted connections. This is usually a good thing. "
+"However, if the database is solely accessed using TCP connections on "
+"localhost, SSL can be turned off without introducing security issues."
+msgstr ""
+"O PostgreSQL suporta ligações cifradas com SSL. Usualmente é boa ideia ter "
+"isto. No entanto, se a base de dados só é acedida por ligações TCP da "
+"máquina local, é possível desligar SSL sem introduzir problemas de segurança."
+
+#. Type: boolean
+#. Description
+#: ../postgresql-common.templates:2001
+msgid ""
+"UNIX domain socket connections (called \"local\" in pg_hba.conf) are not "
+"affected by this setting. This setting concerns new PostgreSQL clusters "
+"created during package install, or by using the pg_createcluster command. It "
+"does not reconfigure existing clusters."
+msgstr ""
+"Ligações por sockets UNIX (do tipo \"local\" no pg_hba.conf) não são "
+"afectadas por esta configuração. Esta configuração diz respeito a novos "
+"clusters de PostgreSQL criados durante a instalação de pacotes, ou usando o "
+"comando pg_createcluster. Clusters existentes não serão reconfigurados."
+
+#. Type: boolean
+#. Description
+#: ../postgresql-common.templates:2001
+msgid "If unsure, enable SSL."
+msgstr "Se não tiver a certeza, active o SSL."
+
+#. Type: note
+#. Description
+#: ../postgresql-common.templates:3001
+msgid "PostgreSQL ${version} catalog version changed"
+msgstr "A versão do catálogo mudou no PostgreSQL {version}"
+
+#. Type: note
+#. Description
+#: ../postgresql-common.templates:3001
+msgid ""
+"The PostgreSQL cluster ${version} ${cluster} was created using catalog "
+"version ${db_catversion}, but the currently being installed package "
+"postgresql-${version} is using catalog version ${new_catversion}. You will "
+"not be able to use this cluster until it was upgraded to the new catalog "
+"version."
+msgstr ""
+"O cluster PostgreSQL ${version} ${cluster} foi criado usando o catálogo na "
+"versão ${db_catversion}, mas o pacote que está a ser instalado postgresql-${version} "
+"usa a versão de catálogo ${new_catversion}. Não será possível usar este "
+"cluster até que seja actualizado para a nova versão de catálogo."
+
+#. Type: note
+#. Description
+#: ../postgresql-common.templates:3001
+msgid ""
+"The necessary subset of binaries from the old version was saved in "
+"${vartmpdir}. To upgrade the cluster, execute these commands:"
+msgstr ""
+"O subconjunto de binários da versão antiga foi guardado em "
+"${vartmpdir}. Para actualizar o cluster, execute os seguintes comandos:"
diff --git a/debian/po/pt_BR.po b/debian/po/pt_BR.po
new file mode 100644
index 0000000..c47680e
--- /dev/null
+++ b/debian/po/pt_BR.po
@@ -0,0 +1,133 @@
+# postgresql-common Brazilian Portuguese translation
+# Copyright (c) 2008 postgresql-common's PACKAGE COPYRIGHT HOLDER
+# This file is distributed under the same license as the postgresql-common package.
+# André Luís Lopes <andrelop@debian.org>, 2006.
+# Eder L. Marques (frolic) <frolic@debian-ce.org>, 2007, 2008.
+#
+msgid ""
+msgstr ""
+"Project-Id-Version: postgresql-common 88+nmu1\n"
+"Report-Msgid-Bugs-To: postgresql-common@packages.debian.org\n"
+"POT-Creation-Date: 2016-03-05 11:47+0100\n"
+"PO-Revision-Date: 2008-07-17 11:44-0300\n"
+"Last-Translator: Eder L. Marques (frolic) <frolic@debian-ce.org>\n"
+"Language-Team: Brazilian Portuguese <debian-l10n-portuguese@lists.debian."
+"org>\n"
+"Language: pt_BR\n"
+"MIME-Version: 1.0\n"
+"Content-Type: text/plain; charset=UTF-8\n"
+"Content-Transfer-Encoding: 8bit\n"
+"pt_BR utf-8\n"
+
+#. Type: error
+#. Description
+#: ../postgresql-common.templates:1001
+msgid "Obsolete major version ${old}"
+msgstr "Versão principal ${old} obsoleta"
+
+#. Type: error
+#. Description
+#: ../postgresql-common.templates:1001
+msgid ""
+"The PostgreSQL version ${old} is obsolete, but the server or client packages "
+"are still installed. Please install the latest packages (postgresql-"
+"${latest} and postgresql-client-${latest}) and upgrade the existing "
+"${oldversion} clusters with pg_upgradecluster (see manpage)."
+msgstr ""
+"O PostgreSQL versão ${old} está obsoleto, mas os pacotes servidor ou cliente "
+"ainda estão instalados. Por favor, instale os últimos pacotes (postgresql-"
+"${latest} e postgresql-client-${latest}) e atualize seus clusters "
+"${oldversion} existentes com o pg_upgradecluster (veja a página de manual)."
+
+#. Type: error
+#. Description
+#: ../postgresql-common.templates:1001
+msgid ""
+"Please be aware that the installation of postgresql-${latest} will "
+"automatically create a default cluster ${latest}/main. If you want to "
+"upgrade the ${old}/main cluster, you need to remove the already existing "
+"${latest} cluster (pg_dropcluster --stop ${latest} main, see manpage for "
+"details)."
+msgstr ""
+"Por favor, esteja ciente de que a instalação do postgresql-${latest} irá "
+"criar automaticamente um cluster padrão ${latest}/main. Se você quer "
+"atualizar o cluster ${old}/main, você precisa remover o cluster ${latest} já "
+"existente (pg_dropcluster --stop ${latest} main, veja a página de manual "
+"para detalhes)."
+
+#. Type: error
+#. Description
+#: ../postgresql-common.templates:1001
+msgid ""
+"The old server and client packages are no longer supported. After the "
+"existing clusters are upgraded, the postgresql-${old} and postgresql-client-"
+"${old} packages should be removed."
+msgstr ""
+"Os antigos pacotes servidor e cliente não são mais suportados. Após os "
+"clusters existentes terem sido atualizados, os pacotes postgresql-${old} e "
+"postgresql-client-${old} deveriam ser removidos."
+
+#. Type: error
+#. Description
+#: ../postgresql-common.templates:1001
+msgid ""
+"Please see /usr/share/doc/postgresql-common/README.Debian.gz for details."
+msgstr ""
+"Por favor, veja /usr/share/doc/postgresql-common/README.Debian.gz para "
+"detalhes."
+
+#. Type: boolean
+#. Description
+#: ../postgresql-common.templates:2001
+msgid "Enable SSL by default in new PostgreSQL clusters?"
+msgstr ""
+
+#. Type: boolean
+#. Description
+#: ../postgresql-common.templates:2001
+msgid ""
+"PostgreSQL supports SSL-encrypted connections. This is usually a good thing. "
+"However, if the database is solely accessed using TCP connections on "
+"localhost, SSL can be turned off without introducing security issues."
+msgstr ""
+
+#. Type: boolean
+#. Description
+#: ../postgresql-common.templates:2001
+msgid ""
+"UNIX domain socket connections (called \"local\" in pg_hba.conf) are not "
+"affected by this setting. This setting concerns new PostgreSQL clusters "
+"created during package install, or by using the pg_createcluster command. It "
+"does not reconfigure existing clusters."
+msgstr ""
+
+#. Type: boolean
+#. Description
+#: ../postgresql-common.templates:2001
+msgid "If unsure, enable SSL."
+msgstr ""
+
+#. Type: note
+#. Description
+#: ../postgresql-common.templates:3001
+msgid "PostgreSQL ${version} catalog version changed"
+msgstr ""
+
+#. Type: note
+#. Description
+#: ../postgresql-common.templates:3001
+msgid ""
+"The PostgreSQL cluster ${version} ${cluster} was created using catalog "
+"version ${db_catversion}, but the currently being installed package "
+"postgresql-${version} is using catalog version ${new_catversion}. You will "
+"not be able to use this cluster until it was upgraded to the new catalog "
+"version."
+msgstr ""
+
+#. Type: note
+#. Description
+#: ../postgresql-common.templates:3001
+msgid ""
+"The necessary subset of binaries from the old version was saved in "
+"${vartmpdir}. To upgrade the cluster, execute these commands:"
+msgstr ""
diff --git a/debian/po/ro.po b/debian/po/ro.po
new file mode 100644
index 0000000..5faa387
--- /dev/null
+++ b/debian/po/ro.po
@@ -0,0 +1,133 @@
+# translation of templates.po to Romanian
+# Copyright (C) YEAR THE PACKAGE'S COPYRIGHT HOLDER
+# This file is distributed under the same license as the PACKAGE package.
+#
+# Igor Stirbu <igor.stirbu@gmail.com>, 2008.
+msgid ""
+msgstr ""
+"Project-Id-Version: templates\n"
+"Report-Msgid-Bugs-To: postgresql-common@packages.debian.org\n"
+"POT-Creation-Date: 2016-03-05 11:47+0100\n"
+"PO-Revision-Date: 2008-07-21 10:32+0300\n"
+"Last-Translator: Igor Stirbu <igor.stirbu@gmail.com>\n"
+"Language-Team: Romanian <debian-l10n-romanian@lists.debian.org>\n"
+"Language: ro\n"
+"MIME-Version: 1.0\n"
+"Content-Type: text/plain; charset=UTF-8\n"
+"Content-Transfer-Encoding: 8bit\n"
+"X-Generator: KBabel 1.11.4\n"
+"Plural-Forms: nplurals=3; plural=n==1 ? 0 : (n==0 || (n%100 > 0 && n%100 < "
+"20)) ? 1 : 2;\n"
+
+#. Type: error
+#. Description
+#: ../postgresql-common.templates:1001
+msgid "Obsolete major version ${old}"
+msgstr "Versiunea majoră învechită ${old}"
+
+# cluster, manpage
+#. Type: error
+#. Description
+#: ../postgresql-common.templates:1001
+msgid ""
+"The PostgreSQL version ${old} is obsolete, but the server or client packages "
+"are still installed. Please install the latest packages (postgresql-"
+"${latest} and postgresql-client-${latest}) and upgrade the existing "
+"${oldversion} clusters with pg_upgradecluster (see manpage)."
+msgstr ""
+"Versiunea PostgreSQL ${old} este învechită, dar pachetele pentru server sau "
+"client sunt încă instalate. Instalați cele mai recente pachete (postgresql-"
+"${latest} și postgresql-client-${latest}) și actualizați clusterele "
+"${oldversion} existente cu pg_upgradecluster (a se vedea pagina de manual)."
+
+#. Type: error
+#. Description
+#: ../postgresql-common.templates:1001
+msgid ""
+"Please be aware that the installation of postgresql-${latest} will "
+"automatically create a default cluster ${latest}/main. If you want to "
+"upgrade the ${old}/main cluster, you need to remove the already existing "
+"${latest} cluster (pg_dropcluster --stop ${latest} main, see manpage for "
+"details)."
+msgstr ""
+"Se atrage atenția că instalarea postgresql-${latest} va crea în mod automat "
+"un cluster implicit ${latest}/main. Dacă doriți să actualizați clusterul "
+"${old}/main, este necesar să eliminați clusterul ${latest} care deja există "
+"(pg_dropcluster --stop ${latest} main, a se vedea pagina de manual pentru "
+"detalii)."
+
+#. Type: error
+#. Description
+#: ../postgresql-common.templates:1001
+msgid ""
+"The old server and client packages are no longer supported. After the "
+"existing clusters are upgraded, the postgresql-${old} and postgresql-client-"
+"${old} packages should be removed."
+msgstr ""
+"Pachetele vechi pentru server și client nu mai sunt întreținute. După "
+"actualizarea clusterelor existente pachetele postgresql-${old} și postgresql-"
+"client-${old} ar trebui dezinstalate."
+
+#. Type: error
+#. Description
+#: ../postgresql-common.templates:1001
+msgid ""
+"Please see /usr/share/doc/postgresql-common/README.Debian.gz for details."
+msgstr ""
+"A se vedea /usr/share/doc/postgresql-common/README.Debian.gz pentru detalii."
+
+#. Type: boolean
+#. Description
+#: ../postgresql-common.templates:2001
+msgid "Enable SSL by default in new PostgreSQL clusters?"
+msgstr ""
+
+#. Type: boolean
+#. Description
+#: ../postgresql-common.templates:2001
+msgid ""
+"PostgreSQL supports SSL-encrypted connections. This is usually a good thing. "
+"However, if the database is solely accessed using TCP connections on "
+"localhost, SSL can be turned off without introducing security issues."
+msgstr ""
+
+#. Type: boolean
+#. Description
+#: ../postgresql-common.templates:2001
+msgid ""
+"UNIX domain socket connections (called \"local\" in pg_hba.conf) are not "
+"affected by this setting. This setting concerns new PostgreSQL clusters "
+"created during package install, or by using the pg_createcluster command. It "
+"does not reconfigure existing clusters."
+msgstr ""
+
+#. Type: boolean
+#. Description
+#: ../postgresql-common.templates:2001
+msgid "If unsure, enable SSL."
+msgstr ""
+
+#. Type: note
+#. Description
+#: ../postgresql-common.templates:3001
+msgid "PostgreSQL ${version} catalog version changed"
+msgstr ""
+
+#. Type: note
+#. Description
+#: ../postgresql-common.templates:3001
+msgid ""
+"The PostgreSQL cluster ${version} ${cluster} was created using catalog "
+"version ${db_catversion}, but the currently being installed package "
+"postgresql-${version} is using catalog version ${new_catversion}. You will "
+"not be able to use this cluster until it was upgraded to the new catalog "
+"version."
+msgstr ""
+
+#. Type: note
+#. Description
+#: ../postgresql-common.templates:3001
+msgid ""
+"The necessary subset of binaries from the old version was saved in "
+"${vartmpdir}. To upgrade the cluster, execute these commands:"
+msgstr ""
diff --git a/debian/po/ru.po b/debian/po/ru.po
new file mode 100644
index 0000000..3e22e80
--- /dev/null
+++ b/debian/po/ru.po
@@ -0,0 +1,148 @@
+# Translation of postgresql-common.po to Russian
+# This file is distributed under the same license as the postgresql-common
+# package.
+#
+# Yuriy Talakan' <yt@amur.elektra.ru>, 2006.
+# Yuriy Talakan' <yt@drsk.ru>, 2007.
+# Sergey Alyoshin <alyoshin.s@gmail.com>, 2008, 2016.
+#
+msgid ""
+msgstr ""
+"Project-Id-Version: postgresql-common_178_ru\n"
+"Report-Msgid-Bugs-To: postgresql-common@packages.debian.org\n"
+"POT-Creation-Date: 2016-03-05 11:47+0100\n"
+"PO-Revision-Date: 2016-02-22 22:03+0300\n"
+"Last-Translator: Sergey Alyoshin <alyoshin.s@gmail.com>\n"
+"Language-Team: Russian <debian-l10n-russian@lists.debian.org>\n"
+"Language: ru\n"
+"MIME-Version: 1.0\n"
+"Content-Type: text/plain; charset=UTF-8\n"
+"Content-Transfer-Encoding: 8bit\n"
+"X-Generator: KBabel 1.9.1\n"
+"Plural-Forms: nplurals=3; plural=(n%10==1 && n%100!=11 ? 0 : n%10>=2 && n"
+"%10<=4 && (n%100<10 || n%100>=20) ? 1 : 2);\n"
+
+#. Type: error
+#. Description
+#: ../postgresql-common.templates:1001
+msgid "Obsolete major version ${old}"
+msgstr "Устаревшая версия ${old}"
+
+#. Type: error
+#. Description
+#: ../postgresql-common.templates:1001
+msgid ""
+"The PostgreSQL version ${old} is obsolete, but the server or client packages "
+"are still installed. Please install the latest packages (postgresql-"
+"${latest} and postgresql-client-${latest}) and upgrade the existing "
+"${oldversion} clusters with pg_upgradecluster (see manpage)."
+msgstr ""
+"PostgreSQL версии ${old} устарел, но пакет сервера или клиента все ещё "
+"установлен. Пожалуйста, установите последние пакеты (postgresql-${latest} и "
+"postgresql-client-${latest}), и обновите ваши существующие кластеры "
+"${oldversion} с помощью pg_upgradecluster (см. man-страницу)."
+
+#. Type: error
+#. Description
+#: ../postgresql-common.templates:1001
+msgid ""
+"Please be aware that the installation of postgresql-${latest} will "
+"automatically create a default cluster ${latest}/main. If you want to "
+"upgrade the ${old}/main cluster, you need to remove the already existing "
+"${latest} cluster (pg_dropcluster --stop ${latest} main, see manpage for "
+"details)."
+msgstr ""
+"Учтите, что установка postgresql-${latest} автоматически создаст кластер по "
+"умолчанию ${latest}/main. Если вы желаете обновить кластер ${old}/main, то "
+"должны удалить существующий кластер ${latest} с помощью pg_dropcluster --"
+"stop ${latest} main (см. man-страницу)."
+
+#. Type: error
+#. Description
+#: ../postgresql-common.templates:1001
+msgid ""
+"The old server and client packages are no longer supported. After the "
+"existing clusters are upgraded, the postgresql-${old} and postgresql-client-"
+"${old} packages should be removed."
+msgstr ""
+"Старые пакеты сервера и клиента более не поддерживаются. После обновления "
+"существующих кластеров, пакеты postgresql-${old} и postgresql-client-${old} "
+"должны быть удалены."
+
+#. Type: error
+#. Description
+#: ../postgresql-common.templates:1001
+msgid ""
+"Please see /usr/share/doc/postgresql-common/README.Debian.gz for details."
+msgstr ""
+"Для дальнейшей информации см. /usr/share/doc/postgresql-common/README.Debian."
+"gz"
+
+#. Type: boolean
+#. Description
+#: ../postgresql-common.templates:2001
+msgid "Enable SSL by default in new PostgreSQL clusters?"
+msgstr "Включить SSL по умолчанию в новых кластерах PostgreSQL?"
+
+#. Type: boolean
+#. Description
+#: ../postgresql-common.templates:2001
+msgid ""
+"PostgreSQL supports SSL-encrypted connections. This is usually a good thing. "
+"However, if the database is solely accessed using TCP connections on "
+"localhost, SSL can be turned off without introducing security issues."
+msgstr ""
+"PostgreSQL поддерживает соединения с SSL-шифрованием. Обычно это хорошо. Но, "
+"если база данных адресуется только по TCP-соединению на локальном "
+"компьютере, то SSL может быть выключен без повышения угроз безопасности."
+
+#. Type: boolean
+#. Description
+#: ../postgresql-common.templates:2001
+msgid ""
+"UNIX domain socket connections (called \"local\" in pg_hba.conf) are not "
+"affected by this setting. This setting concerns new PostgreSQL clusters "
+"created during package install, or by using the pg_createcluster command. It "
+"does not reconfigure existing clusters."
+msgstr ""
+"Соединения сокета домена UNIX (называемые \"local\" в pg_hba.conf) не будут "
+"затронуты этой настройкой. Она касается новых кластеров PostgreSQL, "
+"созданных при установке пакета или командой pg_createcluster. Существующие "
+"кластеры перенастроены не будут."
+
+#. Type: boolean
+#. Description
+#: ../postgresql-common.templates:2001
+msgid "If unsure, enable SSL."
+msgstr "Если не уверены, включите SSL."
+
+#. Type: note
+#. Description
+#: ../postgresql-common.templates:3001
+msgid "PostgreSQL ${version} catalog version changed"
+msgstr "Изменена версия каталога PostgreSQL ${version}"
+
+#. Type: note
+#. Description
+#: ../postgresql-common.templates:3001
+msgid ""
+"The PostgreSQL cluster ${version} ${cluster} was created using catalog "
+"version ${db_catversion}, but the currently being installed package "
+"postgresql-${version} is using catalog version ${new_catversion}. You will "
+"not be able to use this cluster until it was upgraded to the new catalog "
+"version."
+msgstr ""
+"Был создан кластер ${cluster} PostgreSQL ${version} с использованием "
+"каталога версии ${db_catversion}, но устанавливаемый сейчас пакет postgresql-"
+"${version} использует каталог версии ${new_catversion}. Вы не сможете "
+"использовать данный кластер, пока не обновите его до каталога новой версии."
+
+#. Type: note
+#. Description
+#: ../postgresql-common.templates:3001
+msgid ""
+"The necessary subset of binaries from the old version was saved in "
+"${vartmpdir}. To upgrade the cluster, execute these commands:"
+msgstr ""
+"Необходимый набор двоичных файлов из старой версии был сохранён в "
+"${vartmpdir}. Для обновления кластера выполните следующие команды:"
diff --git a/debian/po/sv.po b/debian/po/sv.po
new file mode 100644
index 0000000..8a139a0
--- /dev/null
+++ b/debian/po/sv.po
@@ -0,0 +1,130 @@
+# Translation of postgresql-common debconf template to Swedish
+# Copyright (C) 2009 Martin Bagge <brother@bsnet.se>
+# This file is distributed under the same license as the postgresql-common package.
+#
+# Martin Bagge <brother@bsnet.se>, 2009
+msgid ""
+msgstr ""
+"Project-Id-Version: postgresql-common\n"
+"Report-Msgid-Bugs-To: postgresql-common@packages.debian.org\n"
+"POT-Creation-Date: 2016-03-05 11:47+0100\n"
+"PO-Revision-Date: 2009-07-29 22:47+0100\n"
+"Last-Translator: Martin Bagge <brother@bsnet.se>\n"
+"Language-Team: Swedish <sv@li.org>\n"
+"Language: sv\n"
+"MIME-Version: 1.0\n"
+"Content-Type: text/plain; charset=utf-8\n"
+"Content-Transfer-Encoding: 8bit\n"
+"X-Poedit-Language: Swedish\n"
+"X-Poedit-Country: SWEDEN\n"
+
+#. Type: error
+#. Description
+#: ../postgresql-common.templates:1001
+msgid "Obsolete major version ${old}"
+msgstr "${old} är en utfasad version"
+
+#. Type: error
+#. Description
+#: ../postgresql-common.templates:1001
+msgid ""
+"The PostgreSQL version ${old} is obsolete, but the server or client packages "
+"are still installed. Please install the latest packages (postgresql-"
+"${latest} and postgresql-client-${latest}) and upgrade the existing "
+"${oldversion} clusters with pg_upgradecluster (see manpage)."
+msgstr ""
+"PostgreSQL-versionen ${old} är utfasad men du har fortfarande server- eller "
+"klientpaketen installerade. Installera de senaste paketen (postgresql-"
+"${latest} och postgresql-client-${latest}) och uppgradera ditt befintliga "
+"${oldversion}-kluster med pg_updatecluster (se manualsidan)."
+
+#. Type: error
+#. Description
+#: ../postgresql-common.templates:1001
+msgid ""
+"Please be aware that the installation of postgresql-${latest} will "
+"automatically create a default cluster ${latest}/main. If you want to "
+"upgrade the ${old}/main cluster, you need to remove the already existing "
+"${latest} cluster (pg_dropcluster --stop ${latest} main, see manpage for "
+"details)."
+msgstr ""
+"Observera att installationen av postgresql-${latest} automatiskt skapar ett "
+"standardkluster ${latest}/main. Om du vill uppgradera ${old}/main-klustret, "
+"kommer du behöva ta bort det befintliga ${latest}-klustret (pg_dropcluster --"
+"stop ${latest} main, se manualsida för mer information)."
+
+#. Type: error
+#. Description
+#: ../postgresql-common.templates:1001
+msgid ""
+"The old server and client packages are no longer supported. After the "
+"existing clusters are upgraded, the postgresql-${old} and postgresql-client-"
+"${old} packages should be removed."
+msgstr ""
+"De gamla server- och klientpaketen stöds inte längre. Efter uppgradering av "
+"de existerande klustren bör du ta bort paketen postgresql-${old} och "
+"postgresql-client-${old}."
+
+#. Type: error
+#. Description
+#: ../postgresql-common.templates:1001
+msgid ""
+"Please see /usr/share/doc/postgresql-common/README.Debian.gz for details."
+msgstr ""
+"För mer information läs /usr/share/doc/postgresql-common/README.Debian.gz"
+
+#. Type: boolean
+#. Description
+#: ../postgresql-common.templates:2001
+msgid "Enable SSL by default in new PostgreSQL clusters?"
+msgstr ""
+
+#. Type: boolean
+#. Description
+#: ../postgresql-common.templates:2001
+msgid ""
+"PostgreSQL supports SSL-encrypted connections. This is usually a good thing. "
+"However, if the database is solely accessed using TCP connections on "
+"localhost, SSL can be turned off without introducing security issues."
+msgstr ""
+
+#. Type: boolean
+#. Description
+#: ../postgresql-common.templates:2001
+msgid ""
+"UNIX domain socket connections (called \"local\" in pg_hba.conf) are not "
+"affected by this setting. This setting concerns new PostgreSQL clusters "
+"created during package install, or by using the pg_createcluster command. It "
+"does not reconfigure existing clusters."
+msgstr ""
+
+#. Type: boolean
+#. Description
+#: ../postgresql-common.templates:2001
+msgid "If unsure, enable SSL."
+msgstr ""
+
+#. Type: note
+#. Description
+#: ../postgresql-common.templates:3001
+msgid "PostgreSQL ${version} catalog version changed"
+msgstr ""
+
+#. Type: note
+#. Description
+#: ../postgresql-common.templates:3001
+msgid ""
+"The PostgreSQL cluster ${version} ${cluster} was created using catalog "
+"version ${db_catversion}, but the currently being installed package "
+"postgresql-${version} is using catalog version ${new_catversion}. You will "
+"not be able to use this cluster until it was upgraded to the new catalog "
+"version."
+msgstr ""
+
+#. Type: note
+#. Description
+#: ../postgresql-common.templates:3001
+msgid ""
+"The necessary subset of binaries from the old version was saved in "
+"${vartmpdir}. To upgrade the cluster, execute these commands:"
+msgstr ""
diff --git a/debian/po/templates.pot b/debian/po/templates.pot
new file mode 100644
index 0000000..14b0c12
--- /dev/null
+++ b/debian/po/templates.pot
@@ -0,0 +1,117 @@
+# SOME DESCRIPTIVE TITLE.
+# Copyright (C) YEAR THE PACKAGE'S COPYRIGHT HOLDER
+# This file is distributed under the same license as the postgresql-common package.
+# FIRST AUTHOR <EMAIL@ADDRESS>, YEAR.
+#
+#, fuzzy
+msgid ""
+msgstr ""
+"Project-Id-Version: postgresql-common\n"
+"Report-Msgid-Bugs-To: postgresql-common@packages.debian.org\n"
+"POT-Creation-Date: 2016-03-05 11:47+0100\n"
+"PO-Revision-Date: YEAR-MO-DA HO:MI+ZONE\n"
+"Last-Translator: FULL NAME <EMAIL@ADDRESS>\n"
+"Language-Team: LANGUAGE <LL@li.org>\n"
+"Language: \n"
+"MIME-Version: 1.0\n"
+"Content-Type: text/plain; charset=CHARSET\n"
+"Content-Transfer-Encoding: 8bit\n"
+
+#. Type: error
+#. Description
+#: ../postgresql-common.templates:1001
+msgid "Obsolete major version ${old}"
+msgstr ""
+
+#. Type: error
+#. Description
+#: ../postgresql-common.templates:1001
+msgid ""
+"The PostgreSQL version ${old} is obsolete, but the server or client packages "
+"are still installed. Please install the latest packages (postgresql-"
+"${latest} and postgresql-client-${latest}) and upgrade the existing "
+"${oldversion} clusters with pg_upgradecluster (see manpage)."
+msgstr ""
+
+#. Type: error
+#. Description
+#: ../postgresql-common.templates:1001
+msgid ""
+"Please be aware that the installation of postgresql-${latest} will "
+"automatically create a default cluster ${latest}/main. If you want to "
+"upgrade the ${old}/main cluster, you need to remove the already existing "
+"${latest} cluster (pg_dropcluster --stop ${latest} main, see manpage for "
+"details)."
+msgstr ""
+
+#. Type: error
+#. Description
+#: ../postgresql-common.templates:1001
+msgid ""
+"The old server and client packages are no longer supported. After the "
+"existing clusters are upgraded, the postgresql-${old} and postgresql-client-"
+"${old} packages should be removed."
+msgstr ""
+
+#. Type: error
+#. Description
+#: ../postgresql-common.templates:1001
+msgid ""
+"Please see /usr/share/doc/postgresql-common/README.Debian.gz for details."
+msgstr ""
+
+#. Type: boolean
+#. Description
+#: ../postgresql-common.templates:2001
+msgid "Enable SSL by default in new PostgreSQL clusters?"
+msgstr ""
+
+#. Type: boolean
+#. Description
+#: ../postgresql-common.templates:2001
+msgid ""
+"PostgreSQL supports SSL-encrypted connections. This is usually a good thing. "
+"However, if the database is solely accessed using TCP connections on "
+"localhost, SSL can be turned off without introducing security issues."
+msgstr ""
+
+#. Type: boolean
+#. Description
+#: ../postgresql-common.templates:2001
+msgid ""
+"UNIX domain socket connections (called \"local\" in pg_hba.conf) are not "
+"affected by this setting. This setting concerns new PostgreSQL clusters "
+"created during package install, or by using the pg_createcluster command. It "
+"does not reconfigure existing clusters."
+msgstr ""
+
+#. Type: boolean
+#. Description
+#: ../postgresql-common.templates:2001
+msgid "If unsure, enable SSL."
+msgstr ""
+
+#. Type: note
+#. Description
+#: ../postgresql-common.templates:3001
+msgid "PostgreSQL ${version} catalog version changed"
+msgstr ""
+
+#. Type: note
+#. Description
+#: ../postgresql-common.templates:3001
+msgid ""
+"The PostgreSQL cluster ${version} ${cluster} was created using catalog "
+"version ${db_catversion}, but the currently being installed package "
+"postgresql-${version} is using catalog version ${new_catversion}. You will "
+"not be able to use this cluster until it was upgraded to the new catalog "
+"version."
+msgstr ""
+
+#. Type: note
+#. Description
+#: ../postgresql-common.templates:3001
+msgid ""
+"The necessary subset of binaries from the old version was saved in "
+"${vartmpdir}. To upgrade the cluster, execute these commands:"
+msgstr ""
diff --git a/debian/po/tr.po b/debian/po/tr.po
new file mode 100644
index 0000000..93a64bf
--- /dev/null
+++ b/debian/po/tr.po
@@ -0,0 +1,149 @@
+# SOME DESCRIPTIVE TITLE.
+# Copyright (C) YEAR THE PACKAGE'S COPYRIGHT HOLDER
+# This file is distributed under the same license as the PACKAGE package.
+# Mert Dirik <mertdirik@gmail.com>, 2008.
+# Atila KOÇ <koc@artielektronik.com.tr>, 2015, 2018.
+#
+msgid ""
+msgstr ""
+"Project-Id-Version: postgresql-common\n"
+"Report-Msgid-Bugs-To: postgresql-common@packages.debian.org\n"
+"POT-Creation-Date: 2016-03-05 11:47+0100\n"
+"PO-Revision-Date: 2018-10-22 13:54+0300\n"
+"Last-Translator: Atila KOÇ <koc@artielektronik.com.tr>\n"
+"Language-Team: Debian L10n Turkish <debian-l10n-turkish@lists.debian.org>\n"
+"Language: tr\n"
+"MIME-Version: 1.0\n"
+"Content-Type: text/plain; charset=UTF-8\n"
+"Content-Transfer-Encoding: 8bit\n"
+"Plural-Forms: nplurals=1; plural=0;\n"
+"X-Generator: Poedit 1.8.11\n"
+
+#. Type: error
+#. Description
+#: ../postgresql-common.templates:1001
+msgid "Obsolete major version ${old}"
+msgstr "${old} eskimiş ana sürümü"
+
+#. Type: error
+#. Description
+#: ../postgresql-common.templates:1001
+msgid ""
+"The PostgreSQL version ${old} is obsolete, but the server or client packages "
+"are still installed. Please install the latest packages (postgresql-"
+"${latest} and postgresql-client-${latest}) and upgrade the existing "
+"${oldversion} clusters with pg_upgradecluster (see manpage)."
+msgstr ""
+"PostgreSQL'in ${old} sürümü artık eskimiş olduğu halde sisteminizde hâlâ bu "
+"sürümdeki istemci ya da sunucu paketleri kuruludur. Lütfen en yeni paketleri "
+"(postgresql-${latest} ve postgresql-client-${latest}) kurun ve mevcut "
+"${oldversion} sürüm kümelerini pg_upgradecluster komutunu kullanarak "
+"yükseltin (ayrıntılar için kılavuz sayfasına bakın)."
+
+#. Type: error
+#. Description
+#: ../postgresql-common.templates:1001
+msgid ""
+"Please be aware that the installation of postgresql-${latest} will "
+"automatically create a default cluster ${latest}/main. If you want to "
+"upgrade the ${old}/main cluster, you need to remove the already existing "
+"${latest} cluster (pg_dropcluster --stop ${latest} main, see manpage for "
+"details)."
+msgstr ""
+"postgresql-${latest} kurulumunun öntanımlı ${latest}/main kümesini "
+"oluşturacağını unutmayın. Eğer ${old}/main kümesini yükseltmek istiyorsanız "
+"mevcut ${latest} sürüm kümesini kaldırmalısınız. Bu işi pg_dropcluster --"
+"stop ${latest} main komutuyla yapabilirsiniz (ayrıntılar için kılavuz "
+"sayfasına bakın)."
+
+#. Type: error
+#. Description
+#: ../postgresql-common.templates:1001
+msgid ""
+"The old server and client packages are no longer supported. After the "
+"existing clusters are upgraded, the postgresql-${old} and postgresql-client-"
+"${old} packages should be removed."
+msgstr ""
+"Eski sunucu ve istemci paketleri artık desteklenmiyor. Var olan kümeler "
+"yükseltildikten sonra postgresql-${old} ve postgresql-client-${old} "
+"paketlerinin kaldırılması önerilir."
+
+#. Type: error
+#. Description
+#: ../postgresql-common.templates:1001
+msgid ""
+"Please see /usr/share/doc/postgresql-common/README.Debian.gz for details."
+msgstr ""
+"Ayrıntılar için lütfen /usr/share/doc/postgresql-common/README.Debian.gz "
+"belgesine bakın."
+
+#. Type: boolean
+#. Description
+#: ../postgresql-common.templates:2001
+msgid "Enable SSL by default in new PostgreSQL clusters?"
+msgstr "Yeni PostgreSQL kümelerinde, SSL öntanımlı olarak etkinleştirilsin mi?"
+
+#. Type: boolean
+#. Description
+#: ../postgresql-common.templates:2001
+msgid ""
+"PostgreSQL supports SSL-encrypted connections. This is usually a good thing. "
+"However, if the database is solely accessed using TCP connections on "
+"localhost, SSL can be turned off without introducing security issues."
+msgstr ""
+"PostgreSQL SSL ile şifrelenmiş bağlantıları destekler. SSL kullanmak "
+"genellikle iyidir. Bununla beraber, veritabanına yalnızca yerel makineden "
+"TCP bağlantıları ile erişiliyorsa, SSL'in devre dışı bırakılması güvenlik "
+"açığına neden olmaz."
+
+#. Type: boolean
+#. Description
+#: ../postgresql-common.templates:2001
+msgid ""
+"UNIX domain socket connections (called \"local\" in pg_hba.conf) are not "
+"affected by this setting. This setting concerns new PostgreSQL clusters "
+"created during package install, or by using the pg_createcluster command. It "
+"does not reconfigure existing clusters."
+msgstr ""
+"UNIX bazlı soket bağlantıları (ph_hba.conf dosyasında \"local\" tipi ile "
+"listelenenler) bu ayardan etkilenmezler. Bu ayar paketin kurulumu sırasında "
+"ya da pg_createcluster komutu kullanılarak oluşturulan yeni PostgreSQL "
+"kümelerini ilgilendirir; varolan kümeleri etkilemez."
+
+#. Type: boolean
+#. Description
+#: ../postgresql-common.templates:2001
+msgid "If unsure, enable SSL."
+msgstr "Emin değilseniz, SSL'i etkinleştirin."
+
+#. Type: note
+#. Description
+#: ../postgresql-common.templates:3001
+msgid "PostgreSQL ${version} catalog version changed"
+msgstr "PostgreSQL ${version} katalog sürümü değişti"
+
+#. Type: note
+#. Description
+#: ../postgresql-common.templates:3001
+msgid ""
+"The PostgreSQL cluster ${version} ${cluster} was created using catalog "
+"version ${db_catversion}, but the currently being installed package "
+"postgresql-${version} is using catalog version ${new_catversion}. You will "
+"not be able to use this cluster until it was upgraded to the new catalog "
+"version."
+msgstr ""
+"${version} ${cluster} PostgreSQL kümesi ${db_catversion} katalog sürümü ile "
+"oluşturulmuş, kullanmakta olduğunuz postgresql-${version} sürümü ise "
+"${new_catversion} katalog sürümünü kullanıyor. Yeni katalog sürümüne "
+"yükseltmedikçe bu kümeyi kullanamayacaksınız."
+
+#. Type: note
+#. Description
+#: ../postgresql-common.templates:3001
+msgid ""
+"The necessary subset of binaries from the old version was saved in "
+"${vartmpdir}. To upgrade the cluster, execute these commands:"
+msgstr ""
+"Eski sürümdeki program dosyalarının yükseltme için gerekli olanları "
+"${vartmpdir} dizinine kaydedildi. Kümenizi yükseltmek için şu komutları "
+"çalıştırın:"
diff --git a/debian/po/vi.po b/debian/po/vi.po
new file mode 100644
index 0000000..b9e0184
--- /dev/null
+++ b/debian/po/vi.po
@@ -0,0 +1,131 @@
+# Vietnamese translation for PostgreSQL Common.
+# Copyright © 2007 Free Software Foundation, Inc.
+# Clytie Siddall <clytie@riverland.net.au>, 2007
+#
+msgid ""
+msgstr ""
+"Project-Id-Version: postgresql-common 88+nmu1\n"
+"Report-Msgid-Bugs-To: postgresql-common@packages.debian.org\n"
+"POT-Creation-Date: 2016-03-05 11:47+0100\n"
+"PO-Revision-Date: 2008-07-16 17:00+0930\n"
+"Last-Translator: Clytie Siddall <clytie@riverland.net.au>\n"
+"Language-Team: Vietnamese <vi-VN@googlegroups.com>\n"
+"Language: vi\n"
+"MIME-Version: 1.0\n"
+"Content-Type: text/plain; charset=UTF-8\n"
+"Content-Transfer-Encoding: 8bit\n"
+"Plural-Forms: nplurals=1; plural=0;\n"
+"X-Generator: LocFactoryEditor 1.7b1\n"
+
+#. Type: error
+#. Description
+#: ../postgresql-common.templates:1001
+msgid "Obsolete major version ${old}"
+msgstr "Phiên bản chính cũ ${old}"
+
+#. Type: error
+#. Description
+#: ../postgresql-common.templates:1001
+msgid ""
+"The PostgreSQL version ${old} is obsolete, but the server or client packages "
+"are still installed. Please install the latest packages (postgresql-"
+"${latest} and postgresql-client-${latest}) and upgrade the existing "
+"${oldversion} clusters with pg_upgradecluster (see manpage)."
+msgstr ""
+"Phiên bản PostgreSQL ${old} quá cũ, các gói trình phục vụ hay gói trình "
+"khách vẫn còn được cài đặt. Hãy cài đặt các gói mới nhất (postgresql-"
+"${latest} và postgresql-client-${latest}) rồi nâng cấp các tập hợp "
+"${oldversion} tồn tại bằng chức năng pg_upgradecluster (xem trang hướng dẫn "
+"[man])."
+
+#. Type: error
+#. Description
+#: ../postgresql-common.templates:1001
+msgid ""
+"Please be aware that the installation of postgresql-${latest} will "
+"automatically create a default cluster ${latest}/main. If you want to "
+"upgrade the ${old}/main cluster, you need to remove the already existing "
+"${latest} cluster (pg_dropcluster --stop ${latest} main, see manpage for "
+"details)."
+msgstr ""
+"Ghi chú rằng tiến trình cài đặt postgresql-${latest} sẽ tự động tạo một tập "
+"hợp mặc định ${latest}/main. Muốn nâng cấp tập hợp ${old}/main thì bạn cần "
+"phải gỡ bỏ tập hợp ${latest} cluster đã tồn tại (pg_dropcluster --stop "
+"${latest} main, xem trang hướng dẫn để tìm chi tiết)."
+
+#. Type: error
+#. Description
+#: ../postgresql-common.templates:1001
+msgid ""
+"The old server and client packages are no longer supported. After the "
+"existing clusters are upgraded, the postgresql-${old} and postgresql-client-"
+"${old} packages should be removed."
+msgstr ""
+"Không còn hỗ trợ lại các gói trình phục vụ và gói trình khách. Sau khi nâng "
+"cấp các tập hợp đã tồn tại, khuyên bạn gỡ bỏ các gói postgresql-${old} và "
+"postgresql-client-${old}."
+
+#. Type: error
+#. Description
+#: ../postgresql-common.templates:1001
+msgid ""
+"Please see /usr/share/doc/postgresql-common/README.Debian.gz for details."
+msgstr ""
+"Xem tài liệu Đọc Đi « /usr/share/doc/postgresql-common/README.Debian.gz » để "
+"tìm chi tiết."
+
+#. Type: boolean
+#. Description
+#: ../postgresql-common.templates:2001
+msgid "Enable SSL by default in new PostgreSQL clusters?"
+msgstr ""
+
+#. Type: boolean
+#. Description
+#: ../postgresql-common.templates:2001
+msgid ""
+"PostgreSQL supports SSL-encrypted connections. This is usually a good thing. "
+"However, if the database is solely accessed using TCP connections on "
+"localhost, SSL can be turned off without introducing security issues."
+msgstr ""
+
+#. Type: boolean
+#. Description
+#: ../postgresql-common.templates:2001
+msgid ""
+"UNIX domain socket connections (called \"local\" in pg_hba.conf) are not "
+"affected by this setting. This setting concerns new PostgreSQL clusters "
+"created during package install, or by using the pg_createcluster command. It "
+"does not reconfigure existing clusters."
+msgstr ""
+
+#. Type: boolean
+#. Description
+#: ../postgresql-common.templates:2001
+msgid "If unsure, enable SSL."
+msgstr ""
+
+#. Type: note
+#. Description
+#: ../postgresql-common.templates:3001
+msgid "PostgreSQL ${version} catalog version changed"
+msgstr ""
+
+#. Type: note
+#. Description
+#: ../postgresql-common.templates:3001
+msgid ""
+"The PostgreSQL cluster ${version} ${cluster} was created using catalog "
+"version ${db_catversion}, but the currently being installed package "
+"postgresql-${version} is using catalog version ${new_catversion}. You will "
+"not be able to use this cluster until it was upgraded to the new catalog "
+"version."
+msgstr ""
+
+#. Type: note
+#. Description
+#: ../postgresql-common.templates:3001
+msgid ""
+"The necessary subset of binaries from the old version was saved in "
+"${vartmpdir}. To upgrade the cluster, execute these commands:"
+msgstr ""
diff --git a/debian/postgresql-client-common.dirs b/debian/postgresql-client-common.dirs
new file mode 100644
index 0000000..59b8006
--- /dev/null
+++ b/debian/postgresql-client-common.dirs
@@ -0,0 +1 @@
+etc/postgresql-common
diff --git a/debian/postgresql-client-common.install b/debian/postgresql-client-common.install
new file mode 100644
index 0000000..f6250de
--- /dev/null
+++ b/debian/postgresql-client-common.install
@@ -0,0 +1,6 @@
+PgCommon.pm usr/share/perl5
+debian/maintscripts-functions usr/share/postgresql-common
+debian/supported-versions usr/share/postgresql-common
+pg_wrapper usr/share/postgresql-common
+pgcommon.sh usr/share/postgresql-common
+user_clusters etc/postgresql-common
diff --git a/debian/postgresql-client-common.links b/debian/postgresql-client-common.links
new file mode 100644
index 0000000..2045842
--- /dev/null
+++ b/debian/postgresql-client-common.links
@@ -0,0 +1,21 @@
+usr/share/man/man1/pg_wrapper.1.gz usr/share/man/man7/postgresql-common.7.gz
+usr/share/postgresql-common/pg_wrapper usr/bin/clusterdb
+usr/share/postgresql-common/pg_wrapper usr/bin/createdb
+usr/share/postgresql-common/pg_wrapper usr/bin/createlang
+usr/share/postgresql-common/pg_wrapper usr/bin/createuser
+usr/share/postgresql-common/pg_wrapper usr/bin/dropdb
+usr/share/postgresql-common/pg_wrapper usr/bin/droplang
+usr/share/postgresql-common/pg_wrapper usr/bin/dropuser
+usr/share/postgresql-common/pg_wrapper usr/bin/pg_basebackup
+usr/share/postgresql-common/pg_wrapper usr/bin/pg_dump
+usr/share/postgresql-common/pg_wrapper usr/bin/pg_dumpall
+usr/share/postgresql-common/pg_wrapper usr/bin/pg_isready
+usr/share/postgresql-common/pg_wrapper usr/bin/pg_receivewal
+usr/share/postgresql-common/pg_wrapper usr/bin/pg_receivexlog
+usr/share/postgresql-common/pg_wrapper usr/bin/pg_recvlogical
+usr/share/postgresql-common/pg_wrapper usr/bin/pg_restore
+usr/share/postgresql-common/pg_wrapper usr/bin/pgbench
+usr/share/postgresql-common/pg_wrapper usr/bin/psql
+usr/share/postgresql-common/pg_wrapper usr/bin/reindexdb
+usr/share/postgresql-common/pg_wrapper usr/bin/vacuumdb
+usr/share/postgresql-common/pg_wrapper usr/bin/vacuumlo
diff --git a/debian/postgresql-client-common.lintian-overrides b/debian/postgresql-client-common.lintian-overrides
new file mode 100644
index 0000000..1be6fd4
--- /dev/null
+++ b/debian/postgresql-client-common.lintian-overrides
@@ -0,0 +1,21 @@
+# the manpages for those are in the PostgreSQL packages
+postgresql-client-common: binary-without-manpage usr/bin/clusterdb
+postgresql-client-common: binary-without-manpage usr/bin/createdb
+postgresql-client-common: binary-without-manpage usr/bin/createlang
+postgresql-client-common: binary-without-manpage usr/bin/createuser
+postgresql-client-common: binary-without-manpage usr/bin/dropdb
+postgresql-client-common: binary-without-manpage usr/bin/droplang
+postgresql-client-common: binary-without-manpage usr/bin/dropuser
+postgresql-client-common: binary-without-manpage usr/bin/pg_basebackup
+postgresql-client-common: binary-without-manpage usr/bin/pg_dump
+postgresql-client-common: binary-without-manpage usr/bin/pg_dumpall
+postgresql-client-common: binary-without-manpage usr/bin/pg_isready
+postgresql-client-common: binary-without-manpage usr/bin/pg_receivewal
+postgresql-client-common: binary-without-manpage usr/bin/pg_receivexlog
+postgresql-client-common: binary-without-manpage usr/bin/pg_recvlogical
+postgresql-client-common: binary-without-manpage usr/bin/pg_restore
+postgresql-client-common: binary-without-manpage usr/bin/pgbench
+postgresql-client-common: binary-without-manpage usr/bin/psql
+postgresql-client-common: binary-without-manpage usr/bin/reindexdb
+postgresql-client-common: binary-without-manpage usr/bin/vacuumdb
+postgresql-client-common: binary-without-manpage usr/bin/vacuumlo
diff --git a/debian/postgresql-client-common.manpages b/debian/postgresql-client-common.manpages
new file mode 100644
index 0000000..b88c923
--- /dev/null
+++ b/debian/postgresql-client-common.manpages
@@ -0,0 +1,2 @@
+*.5
+pg_wrapper.1
diff --git a/debian/postgresql-client-common.postrm b/debian/postgresql-client-common.postrm
new file mode 100644
index 0000000..f416938
--- /dev/null
+++ b/debian/postgresql-client-common.postrm
@@ -0,0 +1,12 @@
+#!/bin/sh
+
+set -e
+
+if [ "$1" = purge ]; then
+ # remove psql history file
+ rm -f /var/lib/postgresql/.psql_history
+ rmdir /var/lib/postgresql/ 2>/dev/null || true
+fi
+
+#DEBHELPER#
+
diff --git a/debian/postgresql-common.NEWS b/debian/postgresql-common.NEWS
new file mode 100644
index 0000000..fca02fd
--- /dev/null
+++ b/debian/postgresql-common.NEWS
@@ -0,0 +1,47 @@
+postgresql-common (161) unstable; urgency=medium
+
+ pg_ctlcluster is now enforcing stricter file ownership on the cluster config
+ when invoked as root, including operation via the init.d script or the
+ systemd unit:
+
+ The postgresql.conf owner needs match the data directory owner, or the
+ postgresql.conf file needs to be owned by root.
+
+ Default setups are not affected by this change.
+
+ -- Christoph Berg <myon@debian.org> Fri, 05 Sep 2014 15:48:13 +0200
+
+postgresql-common (159) unstable; urgency=low
+
+ PostgreSQL clusters managed by postgresql-common are now systemd enabled. For
+ each cluster, a service "postgresql@<version>-<name>" is created that can be
+ started/stopped/restarted/reloaded. A parent service "postgresql" acts on
+ all installed (start.conf has "auto") clusters in parallel like the init.d
+ script used to do. /etc/init.d/postgresql can still be used, though the mode
+ of starting individual versions ("/e/i/p start 9.3") no longer works.
+
+ pg_ctlcluster can be used to control clusters, but for start and restart the
+ operation via systemd (using systemctl or the init.d script) is preferred, or
+ else the clusters will not run in cgroups. (Unfortunately this requires
+ root.)
+
+ If the system is not running systemd, nothing changes.
+
+ -- Christoph Berg <myon@debian.org> Fri, 18 Jul 2014 23:52:09 +0300
+
+postgresql-common (158) experimental; urgency=medium
+
+ This postgresql-common release introduces several changes in the defaults
+ used for newly created database clusters, all configurable in
+ /etc/postgresql-common/createcluster.conf:
+
+ * The default log_line_prefix is now '%t [%p-%l] %q%u@%d ' instead of '%t '.
+ * stats_temp_directory aka pg_stat_tmp is set to a subdirectory of
+ /var/run/postgresql by default.
+ * The use of SSL by default is (pre-)configurable via debconf and
+ createcluster.conf.
+
+ If the logging_collector or syslog is being used, pg_lsclusters will show
+ the filename (or "syslog") instead of just "custom" in the Log file column.
+
+ -- Christoph Berg <myon@debian.org> Sat, 05 Jul 2014 16:40:16 +0200
diff --git a/debian/postgresql-common.config b/debian/postgresql-common.config
new file mode 100644
index 0000000..8f169e4
--- /dev/null
+++ b/debian/postgresql-common.config
@@ -0,0 +1,60 @@
+#!/bin/bash
+
+set -e
+
+. /usr/share/debconf/confmodule
+
+# If we have no versions, we do not need to worry about obsolete ones
+if ! [ -d /usr/lib/postgresql ] || \
+ [ ! -e /usr/share/postgresql-common/supported-versions ]; then
+ db_stop
+ exit 0
+fi
+
+# at some points we obsolete major versions within unstable; force the
+# obsoletion notifications when upgrading over those
+if dpkg --compare-versions "$2" lt-nl 71 2>/dev/null; then
+ db_fset postgresql-common/obsolete-major seen false
+fi
+
+# determine versions
+for v in `ls /usr/lib/postgresql/`; do
+ # Ignore old libraries, etc.
+ if [ -x /usr/lib/postgresql/$v/bin/psql ]; then
+ AVAILABLE="$AVAILABLE $v"
+ fi
+done
+
+SUPPORTED=`sh /usr/share/postgresql-common/supported-versions`
+LATEST=`echo "$SUPPORTED" | sort -g | tail -1`
+
+db_fget postgresql-common/obsolete-major seen || true
+
+if [ "$RET" != "true" ]; then
+ for v in $AVAILABLE; do
+ unset sup
+ for s in $SUPPORTED; do
+ if dpkg --compare-versions "$v" ge "$s"; then
+ sup=1
+ break
+ fi
+ done
+ if [ "$sup" ]; then
+ continue
+ fi
+
+ if dpkg -s "postgresql-client-$v" 2>/dev/null | grep -q ^Version: ; then
+ db_fset postgresql-common/obsolete-major seen false
+ db_subst postgresql-common/obsolete-major old $v
+ db_subst postgresql-common/obsolete-major latest $LATEST
+ db_input high postgresql-common/obsolete-major || true
+ db_go || true
+ fi
+ done
+fi
+
+# createcluster.conf
+db_input medium postgresql-common/ssl || true
+db_go || true
+
+db_stop
diff --git a/debian/postgresql-common.dirs b/debian/postgresql-common.dirs
new file mode 100644
index 0000000..75ab851
--- /dev/null
+++ b/debian/postgresql-common.dirs
@@ -0,0 +1,4 @@
+/etc/postgresql
+/etc/postgresql-common/pg_upgradecluster.d
+/var/lib/postgresql
+/var/log/postgresql
diff --git a/debian/postgresql-common.docs b/debian/postgresql-common.docs
new file mode 100644
index 0000000..60121fb
--- /dev/null
+++ b/debian/postgresql-common.docs
@@ -0,0 +1,4 @@
+README.md
+debian/README.Devel
+doc/dependencies.png
+systemd/README.systemd
diff --git a/debian/postgresql-common.install b/debian/postgresql-common.install
new file mode 100644
index 0000000..ebd0c50
--- /dev/null
+++ b/debian/postgresql-common.install
@@ -0,0 +1,19 @@
+createcluster.conf usr/share/postgresql-common
+debian/01autoremove-postgresql etc/apt/apt.conf.d
+debian/init.d-functions usr/share/postgresql-common
+pg_checksystem usr/share/postgresql-common
+pg_config usr/bin
+pg_conftool usr/bin
+pg_createcluster usr/bin
+pg_ctlcluster usr/bin
+pg_dropcluster usr/bin
+pg_lsclusters usr/bin
+pg_renamecluster usr/bin
+pg_updatedicts usr/sbin
+pg_upgradecluster usr/bin
+pg_virtualenv usr/bin
+pgdg usr/share/postgresql-common
+run-upgrade-scripts usr/share/postgresql-common
+t/* usr/share/postgresql-common/t
+testsuite usr/share/postgresql-common
+upgrade-scripts/* usr/share/postgresql-common/upgrade-scripts
diff --git a/debian/postgresql-common.links b/debian/postgresql-common.links
new file mode 100644
index 0000000..2bf1bda
--- /dev/null
+++ b/debian/postgresql-common.links
@@ -0,0 +1 @@
+usr/share/postgresql-common/pg_wrapper usr/bin/pg_archivecleanup
diff --git a/debian/postgresql-common.lintian-overrides b/debian/postgresql-common.lintian-overrides
new file mode 100644
index 0000000..3b2b28e
--- /dev/null
+++ b/debian/postgresql-common.lintian-overrides
@@ -0,0 +1,5 @@
+# the manpages for those are in the PostgreSQL packages
+postgresql-common: binary-without-manpage usr/bin/pg_archivecleanup
+postgresql-common: binary-without-manpage usr/bin/pg_config
+# the init-functions are sourced via /usr/share/postgresql-common/init.d-functions
+postgresql-common: init.d-script-does-not-source-init-functions etc/init.d/postgresql
diff --git a/debian/postgresql-common.logrotate b/debian/postgresql-common.logrotate
new file mode 100644
index 0000000..0cbf10a
--- /dev/null
+++ b/debian/postgresql-common.logrotate
@@ -0,0 +1,10 @@
+/var/log/postgresql/*.log {
+ weekly
+ rotate 10
+ copytruncate
+ delaycompress
+ compress
+ notifempty
+ missingok
+ su root root
+}
diff --git a/debian/postgresql-common.manpages b/debian/postgresql-common.manpages
new file mode 100644
index 0000000..4b21c26
--- /dev/null
+++ b/debian/postgresql-common.manpages
@@ -0,0 +1,9 @@
+pg_conftool.1
+pg_createcluster.1
+pg_ctlcluster.1
+pg_dropcluster.1
+pg_lsclusters.1
+pg_renamecluster.1
+pg_updatedicts.8
+pg_upgradecluster.1
+pg_virtualenv.1
diff --git a/debian/postgresql-common.postgresql.init b/debian/postgresql-common.postgresql.init
new file mode 100644
index 0000000..579fdd2
--- /dev/null
+++ b/debian/postgresql-common.postgresql.init
@@ -0,0 +1,61 @@
+#!/bin/sh
+set -e
+
+### BEGIN INIT INFO
+# Provides: postgresql
+# Required-Start: $local_fs $remote_fs $network $time
+# Required-Stop: $local_fs $remote_fs $network $time
+# Should-Start: $syslog
+# Should-Stop: $syslog
+# Default-Start: 2 3 4 5
+# Default-Stop: 0 1 6
+# Short-Description: PostgreSQL RDBMS server
+### END INIT INFO
+
+# Setting environment variables for the postmaster here does not work; please
+# set them in /etc/postgresql/<version>/<cluster>/environment instead.
+
+[ -r /usr/share/postgresql-common/init.d-functions ] || exit 0
+
+. /usr/share/postgresql-common/init.d-functions
+
+# versions can be specified explicitly
+if [ -n "$2" ]; then
+ versions="$2 $3 $4 $5 $6 $7 $8 $9"
+else
+ get_versions
+fi
+
+case "$1" in
+ start|stop|restart|reload)
+ if [ "$1" = "start" ]; then
+ create_socket_directory
+ fi
+ if [ -z "`pg_lsclusters -h`" ]; then
+ log_warning_msg 'No PostgreSQL clusters exist; see "man pg_createcluster"'
+ exit 0
+ fi
+ for v in $versions; do
+ $1 $v || EXIT=$?
+ done
+ exit ${EXIT:-0}
+ ;;
+ status)
+ LS=`pg_lsclusters -h`
+ # no clusters -> unknown status
+ [ -n "$LS" ] || exit 4
+ echo "$LS" | awk 'BEGIN {rc=0} {if (match($4, "down")) rc=3; printf ("%s/%s (port %s): %s\n", $1, $2, $3, $4)}; END {exit rc}'
+ ;;
+ force-reload)
+ for v in $versions; do
+ reload $v
+ done
+ ;;
+ *)
+ echo "Usage: $0 {start|stop|restart|reload|force-reload|status} [version ..]"
+ exit 1
+ ;;
+esac
+
+exit 0
+
diff --git a/debian/postgresql-common.postgresql.tmpfile b/debian/postgresql-common.postgresql.tmpfile
new file mode 100644
index 0000000..7974636
--- /dev/null
+++ b/debian/postgresql-common.postgresql.tmpfile
@@ -0,0 +1,4 @@
+# Directory for PostgreSQL sockets, lockfiles and stats tempfiles
+d /run/postgresql 2775 postgres postgres - -
+# Log directory
+d /var/log/postgresql 1775 root postgres - -
diff --git a/debian/postgresql-common.postinst b/debian/postgresql-common.postinst
new file mode 100644
index 0000000..6a62738
--- /dev/null
+++ b/debian/postgresql-common.postinst
@@ -0,0 +1,131 @@
+#!/bin/sh
+
+set -e
+[ "$DPKG_MAINTSCRIPT_PACKAGE" ] && . /usr/share/debconf/confmodule
+
+SSL_ROOT=/etc/postgresql-common/root.crt
+
+setup_createclusterconf ()
+{
+ [ "$DPKG_MAINTSCRIPT_PACKAGE" ] || return 0
+ db_get postgresql-common/ssl
+ case $RET in
+ true) SSL=on ;;
+ false) SSL=off ;;
+ *) return ;;
+ esac
+
+ CCTEMPLATE="/usr/share/postgresql-common/createcluster.conf"
+ CCTMP=`mktemp --tmpdir postgresql-common.XXXXXX`
+ trap "rm -f $CCTMP" 0 2 3 15
+ sed -e "s/^ssl =.*/ssl = $SSL/" $CCTEMPLATE > $CCTMP
+ chmod 644 $CCTMP
+ CCCONFIG="/etc/postgresql-common/createcluster.conf"
+ ucf --debconf-ok $CCTMP $CCCONFIG
+ ucfr postgresql-common $CCCONFIG
+ rm -f $CCTMP
+}
+
+if [ "$1" = configure ]; then
+ [ "$DPKG_MAINTSCRIPT_PACKAGE" ] && quiet="--quiet" # RedHat doesn't have this
+ # Make sure the administrative user exists
+ if ! getent passwd postgres > /dev/null; then
+ adduser --system $quiet --home /var/lib/postgresql --no-create-home \
+ --shell /bin/bash --group --gecos "PostgreSQL administrator" postgres
+ fi
+ # if the user was created manually, make sure the group is there as well
+ if ! getent group postgres > /dev/null; then
+ addgroup --system $quiet postgres
+ fi
+ # make sure postgres is in the postgres group
+ if ! id -Gn postgres | grep -qw postgres; then
+ adduser $quiet postgres postgres
+ fi
+
+ # check validity of postgres user and group
+ if [ "`id -u postgres`" -eq 0 ]; then
+ echo "The postgres system user must not have uid 0 (root).
+Please fix this and reinstall this package." >&2
+ exit 1
+ fi
+ if [ "`id -g postgres`" -eq 0 ]; then
+ echo "The postgres system user must not have root as primary group.
+Please fix this and reinstall this package." >&2
+ exit 1
+ fi
+
+ # ensure home directory ownership
+ mkdir -p /var/lib/postgresql
+ su -s /bin/sh postgres -c "test -O /var/lib/postgresql &&
+ test -G /var/lib/postgresql" || \
+ chown postgres:postgres /var/lib/postgresql
+
+ # config directory permissions
+ chown postgres:postgres /etc/postgresql
+
+ # nicer log directory permissions
+ mkdir -p /var/log/postgresql
+ chmod 1775 /var/log/postgresql
+ chown root:postgres /var/log/postgresql
+
+ # create socket directory
+ [ -d /var/run/postgresql ] || \
+ install -d -m 2775 -o postgres -g postgres /var/run/postgresql
+
+ # create default dummy root.crt if not present
+ if ! [ -e "$SSL_ROOT" ]; then
+ cat > "$SSL_ROOT" <<EOF
+This is a dummy root certificate file for PostgreSQL. To enable client side
+authentication, add some certificates to it. Client certificates must be signed
+with any certificate in this file to be accepted.
+
+A reasonable choice is to just symlink this file to
+/etc/ssl/certs/ssl-cert-snakeoil.pem; in this case, client certificates need to
+be signed by the postgresql server certificate, which might be desirable in
+many cases. See chapter "Server Setup and Operation" in the PostgreSQL
+documentation for details (in package postgresql-doc-9.2).
+
+ file:///usr/share/doc/postgresql-doc-9.2/html/ssl-tcp.html
+EOF
+ fi
+
+ # Add postgres user to the ssl-cert group on fresh installs
+ if [ -z "$2" ]; then
+ if getent group ssl-cert >/dev/null; then
+ adduser $quiet postgres ssl-cert
+ fi
+ fi
+
+ if [ "$2" ]; then
+ /usr/share/postgresql-common/run-upgrade-scripts "$2" || true
+ fi
+
+ /usr/share/postgresql-common/pg_checksystem || true
+
+ # Create createcluster.conf from debconf
+ setup_createclusterconf
+
+ # Forget about ucf logrotate config handling
+ if dpkg --compare-versions "$2" lt 183~; then
+ LRCONFIG="/etc/logrotate.d/postgresql-common"
+ ucf --purge $LRCONFIG
+ ucfr --purge postgresql-common $LRCONFIG
+ fi
+
+ # Create tsearch dictionaries on first install
+ if [ -z "$2" ]; then
+ pg_updatedicts
+ fi
+fi
+
+if [ "$1" = triggered ]; then
+ pg_updatedicts || true
+ db_stop
+ exit 0 # skip daemon restart below
+fi
+
+[ "$DPKG_MAINTSCRIPT_PACKAGE" ] && db_stop
+
+#DEBHELPER#
+
+exit 0
diff --git a/debian/postgresql-common.postrm b/debian/postgresql-common.postrm
new file mode 100644
index 0000000..caa8166
--- /dev/null
+++ b/debian/postgresql-common.postrm
@@ -0,0 +1,32 @@
+#!/bin/sh
+
+set -e
+
+if [ remove = "$1" -o abort-install = "$1" -o disappear = "$1" ]; then
+ dpkg-divert --package postgresql-common --remove --rename --divert /usr/bin/pg_config.libpq-dev /usr/bin/pg_config
+fi
+
+if [ "$1" = purge ]; then
+ # remove socket directory
+ rm -rf /var/run/postgresql
+
+ # remove SSL keys
+ rm -rf /etc/postgresql-common/root.crt
+
+ [ -d /etc/postgresql-common ] && rmdir --ignore-fail-on-non-empty /etc/postgresql-common || true
+
+ rm -rf /var/cache/postgresql
+
+ # unregister and remove files maintained by ucf
+ CCCONFIG="/etc/postgresql-common/createcluster.conf"
+ if which ucf >/dev/null; then
+ ucf --purge $CCCONFIG
+ fi
+ if which ucfr >/dev/null; then
+ ucfr --purge postgresql-common $CCCONFIG
+ fi
+ rm -f $CCCONFIG $CCCONFIG.ucf-*
+fi
+
+#DEBHELPER#
+
diff --git a/debian/postgresql-common.preinst b/debian/postgresql-common.preinst
new file mode 100644
index 0000000..7eeae45
--- /dev/null
+++ b/debian/postgresql-common.preinst
@@ -0,0 +1,19 @@
+#!/bin/sh
+
+set -e
+
+case "$1" in
+ install|upgrade)
+ dpkg-divert --package postgresql-common --rename --divert /usr/bin/pg_config.libpq-dev --add /usr/bin/pg_config
+ ;;
+
+ abort-upgrade)
+ ;;
+
+ *)
+ echo "$0 called with unknown argument \`$1'" 1>&2
+ exit 1
+ ;;
+esac
+
+#DEBHELPER#
diff --git a/debian/postgresql-common.sysctl b/debian/postgresql-common.sysctl
new file mode 100644
index 0000000..f5e31ec
--- /dev/null
+++ b/debian/postgresql-common.sysctl
@@ -0,0 +1,12 @@
+# Shared memory settings for PostgreSQL on Linux
+
+# The settings here are upper limits; performance is not affected if the
+# settings are larger than necessary. If other programs use shared memory as
+# well, you will have to coordinate the size settings between them.
+
+# Maximum size of a single shared memory segment in bytes
+#kernel.shmmax = 33554432
+
+# Maximum total size of all shared memory segments in pages (normally 4096 bytes)
+#kernel.shmall = 2097152
+
diff --git a/debian/postgresql-common.templates b/debian/postgresql-common.templates
new file mode 100644
index 0000000..915a4b2
--- /dev/null
+++ b/debian/postgresql-common.templates
@@ -0,0 +1,54 @@
+Template: postgresql-common/obsolete-major
+Type: error
+_Description: Obsolete major version ${old}
+ The PostgreSQL version ${old} is obsolete, but the server
+ or client packages are still installed. Please install the latest packages
+ (postgresql-${latest} and postgresql-client-${latest}) and upgrade the
+ existing ${oldversion} clusters with pg_upgradecluster (see manpage).
+ .
+ Please be aware that the installation of postgresql-${latest} will
+ automatically create a default cluster ${latest}/main. If you want to upgrade
+ the ${old}/main cluster, you need to remove the already existing ${latest}
+ cluster (pg_dropcluster --stop ${latest} main, see manpage for
+ details).
+ .
+ The old server and client packages are no longer supported. After the
+ existing clusters are upgraded, the postgresql-${old} and
+ postgresql-client-${old} packages should be removed.
+ .
+ Please see /usr/share/doc/postgresql-common/README.Debian.gz for details.
+
+Template: postgresql-common/ssl
+Type: boolean
+Default: true
+_Description: Enable SSL by default in new PostgreSQL clusters?
+ PostgreSQL supports SSL-encrypted connections. This is usually a good thing.
+ However, if the database is solely accessed using TCP connections on
+ localhost, SSL can be turned off without introducing security issues.
+ .
+ UNIX domain socket connections (called "local" in pg_hba.conf) are not
+ affected by this setting. This setting concerns new PostgreSQL clusters
+ created during package install, or by using the pg_createcluster command. It
+ does not reconfigure existing clusters.
+ .
+ If unsure, enable SSL.
+
+# The last paragraph of this note does not appear in PO files.
+# It contains shell commands and should not be translated.
+Template: postgresql-common/catversion-bump
+Type: note
+#flag:translate:1,2,3
+_Description: PostgreSQL ${version} catalog version changed
+ The PostgreSQL cluster ${version} ${cluster} was created using catalog
+ version ${db_catversion}, but the currently being installed package
+ postgresql-${version} is using catalog version ${new_catversion}. You will not
+ be able to use this cluster until it was upgraded to the new catalog version.
+ .
+ The necessary subset of binaries from the old version was saved in
+ ${vartmpdir}. To upgrade the cluster, execute these commands:
+ .
+ pg_renamecluster ${version} ${cluster} ${cluster}.old
+ pg_upgradecluster ${version} ${cluster}.old --rename ${cluster} \
+ -m upgrade --old-bindir=${vartmpdir}/bin
+ pg_dropcluster ${version} ${cluster}.old
+ rm -rf ${vartmpdir}
diff --git a/debian/postgresql-common.triggers b/debian/postgresql-common.triggers
new file mode 100644
index 0000000..190de6d
--- /dev/null
+++ b/debian/postgresql-common.triggers
@@ -0,0 +1,5 @@
+# trigger pg_updatedicts on installation of new myspell/hunspell dictionaries
+interest-noawait /usr/share/myspell/dicts
+interest-noawait /usr/share/hunspell
+# also trigger on installation of new server versions so pg_updatedicts can update the symlinks
+interest-noawait /usr/share/postgresql
diff --git a/debian/postgresql-server-dev-all.install b/debian/postgresql-server-dev-all.install
new file mode 100644
index 0000000..0925f8b
--- /dev/null
+++ b/debian/postgresql-server-dev-all.install
@@ -0,0 +1,5 @@
+gitlab usr/share/postgresql-common
+pg_buildext /usr/bin
+pgxs_debian_control.mk /usr/share/postgresql-common/
+dh_make_pgxs/dh_make_pgxs /usr/bin
+dh_make_pgxs/debian /usr/share/postgresql-common/dh_make_pgxs
diff --git a/debian/postgresql-server-dev-all.manpages b/debian/postgresql-server-dev-all.manpages
new file mode 100644
index 0000000..4d91c3a
--- /dev/null
+++ b/debian/postgresql-server-dev-all.manpages
@@ -0,0 +1,2 @@
+dh_make_pgxs/dh_make_pgxs.1
+pg_buildext.1
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..96d7dee
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,46 @@
+#!/usr/bin/make -f
+
+VERSION := $(shell dpkg-parsechangelog | awk '/^Version:/ { print $$2 }')
+ifneq ($(findstring bpo,$(VERSION)),)
+ FLAVOR := debian-backports
+else ifneq ($(findstring pgdg,$(VERSION)),)
+ FLAVOR := pgdg
+ # for apt.postgresql.org builds, pull in the repository key package
+ PGDG_DEPENDS := pgdg-keyring
+else
+ FLAVOR := default
+endif
+SUPPORTED_VERSIONS := $(shell PG_SUPPORTED_VERSIONS="$(FLAVOR)" debian/supported-versions)
+DEFAULT_VER := $(lastword $(SUPPORTED_VERSIONS))
+LIBREADLINE := $(shell dpkg-query -W --showformat '$${Status} $${Package}\n' 'libreadline[0-9]'| sed -n '/ installed / {s/^.* //; p}'|sort -ru | head -n1)
+
+WITH_SYSTEMD=--with systemd
+
+%:
+ dh $@ $(WITH_SYSTEMD)
+
+override_dh_auto_configure:
+ @echo "### Building postgresql-common flavor $(FLAVOR)"
+ @echo "### Supported PostgreSQL versions: $(SUPPORTED_VERSIONS) (default version: $(DEFAULT_VER))"
+
+override_dh_install:
+ dh_install
+ $(MAKE) -C systemd install DESTDIR=$(CURDIR)/debian/postgresql-common
+ install -m 644 -D debian/postgresql-common.sysctl debian/postgresql-common/etc/sysctl.d/30-postgresql-shm.conf
+ /bin/echo -e "# See /usr/share/postgresql-common/supported-versions for documentation of this file\n$(FLAVOR)" > debian/postgresql-client-common/etc/postgresql-common/supported_versions
+
+override_dh_installinit:
+ dh_installinit --name=postgresql -u'defaults 19 21' -r
+
+override_dh_gencontrol:
+ dh_gencontrol -ppostgresql-server-dev-all -- -Vserver-dev-all-depends="$(foreach v,$(SUPPORTED_VERSIONS),postgresql-server-dev-$v,)"
+
+ # the versionless metapackages need to have version numbers which match
+ # the server version, not the p-common version
+ dh_gencontrol -ppostgresql -ppostgresql-client -ppostgresql-doc -ppostgresql-contrib -ppostgresql-all -- \
+ -Vdefault-version="$(DEFAULT_VER)" -v'$(DEFAULT_VER)+$${source:Version}' \
+ -Vpostgresql-all-depends="$(foreach v,$(SUPPORTED_VERSIONS),postgresql-contrib-$v,postgresql-plperl-$v,postgresql-plpython-$v,postgresql-plpython3-$v,postgresql-pltcl-$v,)"
+
+ dh_gencontrol -ppostgresql-client-common -- -Vpgdg:Depends="$(PGDG_DEPENDS)" -Vreadline:Recommends=$(LIBREADLINE)
+
+ dh_gencontrol --remaining-packages
diff --git a/debian/source/format b/debian/source/format
new file mode 100644
index 0000000..89ae9db
--- /dev/null
+++ b/debian/source/format
@@ -0,0 +1 @@
+3.0 (native)
diff --git a/debian/supported-versions b/debian/supported-versions
new file mode 100755
index 0000000..1048827
--- /dev/null
+++ b/debian/supported-versions
@@ -0,0 +1,184 @@
+#!/bin/sh
+
+# print a list of PostgreSQL versions that are supported for the platform this
+# script runs on.
+# Note: Newer installed versions than the highest one listed here are always
+# considered supported, so that backports will not cause an "obsolete" warning.
+#
+# /usr/share/postgresql-common/supported-versions decides which PostgreSQL
+# server versions are supported. This information is used
+# 1) for notifying users of obsolete versions, suggesting to upgrade
+# 2) by postgresql-common itself (in debian/rules) to determine the
+# dependencies of the postgresql meta packages (default version), and to
+# generate the list of postgresql-server-dev-* packages
+# postgresql-server-dev-all depends on
+# 3) by the pg_buildext tool to decide which server versions to build extension
+# modules for
+#
+# The *last* version returned here will be considered the default version, the
+# remaining lines list other supported versions in an undefined order.
+#
+# * PG_SUPPORTED_VERSIONS
+# * DEB_PG_SUPPORTED_VERSIONS
+# * ~/.pg_supported_versions
+# * /etc/postgresql-common/supported_versions
+# (in that order) can be used to override the defaults. (Tokens separated by
+# newlines.)
+#
+# Recognized tokens:
+# default: use the appropiate defaults for the current distribution and release
+# (as determined by os-release or lsb_release)
+# debian [release]: use Debian defaults
+# debian-backports [release]: use Debian Backports defaults
+# ubuntu [release]: use Ubuntu defaults
+# pgdg [release]: use defaults for apt.postgresql.org
+# installed: consider all installed versions supported (determined by
+# postgresql-server-dev-X packages)
+# X: consider this version supported
+#
+# (C) 2005-2016 Martin Pitt <mpitt@debian.org>
+# (C) 2012-2018 Christoph Berg <myon@debian.org>
+
+set -eu
+
+# at build time, use our pgcommon.sh, not the system one (this assumes
+# debian/supported-versions is one directory deeper than ./pgcommon.sh)
+if [ -e "${0%/supported-versions}/../pgcommon.sh" ]; then
+ . "${0%/supported-versions}/../pgcommon.sh"
+else
+ . /usr/share/postgresql-common/pgcommon.sh
+fi
+
+DEFAULT="11"
+
+# functions
+
+default() {
+ case "$DISTRO" in
+ [uU]buntu)
+ ubuntu "$RELEASE"
+ ;;
+ [dD]ebian)
+ debian "$RELEASE"
+ ;;
+ *)
+ echo "supported-versions: WARNING! Unknown distribution: $DISTRO" >&2
+ if echo $ID_LIKE | egrep '(^| )ubuntu($| )' > /dev/null; then
+ echo "ubuntu found in ID_LIKE, treating as Ubuntu" >&2
+ ubuntu "$RELEASE"
+ elif echo $ID_LIKE | egrep '(^| )debian($| )' > /dev/null; then
+ echo "debian found in ID_LIKE, treating as Debian" >&2
+ debian "$RELEASE"
+ else
+ echo "Please submit this as a bug report to your distribution." >&2
+ /bin/echo -e "$DEFAULT"
+ fi
+ ;;
+ esac
+}
+
+ubuntu() {
+ case "$1" in
+ 12.04) /bin/echo -e "9.1" ;;
+ 14.04) /bin/echo -e "9.3" ;;
+ 16.04|16.10) /bin/echo -e "9.5" ;;
+ 17.04|17.10) /bin/echo -e "9.6" ;;
+ 18.04|18.10) /bin/echo -e "10" ;;
+ 19.04) /bin/echo -e "11" ;;
+ *)
+ echo "supported-versions: WARNING: Unknown Ubuntu release: $1" >&2
+ /bin/echo -e "$DEFAULT" ;;
+ esac
+}
+
+debian() {
+ case "$1" in
+ 5.0*) /bin/echo -e "8.3" ;; # Lenny
+ 6.0*) /bin/echo -e "8.4" ;; # Squeeze
+ 7|7.*) /bin/echo -e "9.1" ;; # Wheezy
+ 8|8.*) /bin/echo -e "9.4" ;; # Jessie
+ 9|9.*) /bin/echo -e "9.6" ;; # Stretch
+ 10|10.*) /bin/echo -e "11" ;; # Buster
+ testing | unstable)
+ /bin/echo -e "$DEFAULT" ;;
+ *)
+ echo "supported-versions: WARNING: Unknown Debian release: $1" >&2
+ /bin/echo -e "$DEFAULT" ;;
+ esac
+}
+
+debian_backports() {
+ case "$1" in
+ 5.0*) /bin/echo -e "8.3" ;; # Lenny
+ 6.0*) /bin/echo -e "8.4\n9.1" ;; # Squeeze
+ 7|7.*) /bin/echo -e "9.1\n9.4" ;; # Wheezy
+ 8|8.*) /bin/echo -e "9.4\n9.6" ;; # Jessie
+ 9|9.*) /bin/echo -e "9.6" ;; # Stretch
+ 10|10.*) /bin/echo -e "10" ;; # Buster
+ testing | unstable)
+ /bin/echo -e "$DEFAULT" ;;
+ *)
+ echo "supported-versions: WARNING: Unknown Debian release: $1" >&2
+ /bin/echo -e "$DEFAULT" ;;
+ esac
+}
+
+pgdg() {
+ /bin/echo -e "9.4\n9.5\n9.6\n10\n11"
+}
+
+installed() {
+ dpkg -l 'postgresql-server-dev-[1-9]*' | \
+ sed -ne 's/^ii *postgresql-server-dev-\([^ ]*\).*/\1/p' | \
+ sort -V
+}
+
+# main
+
+if [ "${PG_SUPPORTED_VERSIONS:-}" ] ; then
+ SUPPORTED_VERSIONS=$(echo "$PG_SUPPORTED_VERSIONS" | xargs -n1)
+elif [ "${DEB_PG_SUPPORTED_VERSIONS:-}" ] ; then
+ SUPPORTED_VERSIONS=$(echo "$DEB_PG_SUPPORTED_VERSIONS" | xargs -n1)
+elif [ -f ${HOME:-}/.pg_supported_versions ] ; then
+ SUPPORTED_VERSIONS="$(cat ${HOME:-}/.pg_supported_versions)"
+elif [ -f ${PGSYSCONFDIR:-/etc/postgresql-common}/supported_versions ] ; then
+ SUPPORTED_VERSIONS="$(cat ${PGSYSCONFDIR:-/etc/postgresql-common}/supported_versions)"
+else
+ SUPPORTED_VERSIONS="default"
+fi
+
+echo "$SUPPORTED_VERSIONS" | while read version release; do
+ COMMENT="#"
+ case $version in
+ "") ;;
+ $COMMENT*) ;;
+ default)
+ get_release
+ default
+ ;;
+ debian)
+ get_release
+ debian "${release:-$RELEASE}"
+ ;;
+ debian-backports)
+ get_release
+ debian_backports "${release:-$RELEASE}"
+ ;;
+ ubuntu)
+ get_release
+ ubuntu "${release:-$RELEASE}"
+ ;;
+ pgdg) # apt.postgresql.org
+ get_release
+ pgdg "${release:-$RELEASE}"
+ ;;
+ installed)
+ installed
+ ;;
+ *)
+ /bin/echo -e "$version"
+ ;;
+ esac
+done
+
+exit 0
diff --git a/debian/tests/control b/debian/tests/control
new file mode 100644
index 0000000..a59de84
--- /dev/null
+++ b/debian/tests/control
@@ -0,0 +1,3 @@
+Tests: default-psql
+Depends: postgresql
+Restrictions: needs-root
diff --git a/debian/tests/default-psql b/debian/tests/default-psql
new file mode 100755
index 0000000..3392ea4
--- /dev/null
+++ b/debian/tests/default-psql
@@ -0,0 +1,19 @@
+#!/bin/sh
+# autopkgtest to check that installing the "postgresql" metapackage results in
+# a working cluster
+set -e
+
+# disabled default cluster creation?
+if grep -q '\bcreate_main_cluster\b.*\bfalse\b' /etc/postgresql-common/createcluster.conf; then
+ echo "SKIP: default cluster creation disabled in createcluster.conf"
+ exit 0
+fi
+
+if ! pg_lsclusters | grep -q 'main .* online'; then
+ echo "No running cluster!" >&2
+ pg_lsclusters >&2
+fi
+
+# check that we can connect to template1 on the default cluster
+OUT=$(su - -c 'psql -Atc "select 21*2" template1' postgres)
+[ "$OUT" = "42" ] || { echo "$OUT"; exit 1; }