summaryrefslogtreecommitdiffstats
path: root/setup.cfg
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-14 20:04:50 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-14 20:04:50 +0000
commit782f8df6e41f29dce2db4970a3ad84aaeb7d8c5f (patch)
tree3a88a542cd8074743d251881131510157cfc510b /setup.cfg
parentInitial commit. (diff)
downloadansible-lint-782f8df6e41f29dce2db4970a3ad84aaeb7d8c5f.tar.xz
ansible-lint-782f8df6e41f29dce2db4970a3ad84aaeb7d8c5f.zip
Adding upstream version 4.3.7.upstream/4.3.7upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'setup.cfg')
-rw-r--r--setup.cfg86
1 files changed, 86 insertions, 0 deletions
diff --git a/setup.cfg b/setup.cfg
new file mode 100644
index 0000000..3cd60a4
--- /dev/null
+++ b/setup.cfg
@@ -0,0 +1,86 @@
+[aliases]
+dists = clean --all sdist bdist_wheel
+
+[bdist_wheel]
+universal = 1
+
+[metadata]
+name = ansible-lint
+url = https://github.com/ansible/ansible-lint
+project_urls =
+ Bug Tracker = https://github.com/ansible/ansible-lint/issues
+ CI: GitHub = https://github.com/ansible/ansible-lint/actions?query=workflow:gh+branch:master+event:push
+ Code of Conduct = https://docs.ansible.com/ansible/latest/community/code_of_conduct.html
+ Documentation = https://ansible-lint.readthedocs.io/en/latest/
+ Mailing lists = https://docs.ansible.com/ansible/latest/community/communication.html#mailing-list-information
+ Source Code = https://github.com/ansible/ansible-lint
+description = Checks playbooks for practices and behaviour that could potentially be improved
+long_description = file: README.rst
+long_description_content_type = text/x-rst
+author = Will Thames
+author_email = will@thames.id.au
+maintainer = Ansible by Red Hat
+maintainer_email = info@ansible.com
+license = MIT
+license_file = LICENSE
+classifiers =
+ Development Status :: 5 - Production/Stable
+
+ Environment :: Console
+
+ Intended Audience :: Developers
+ Intended Audience :: Information Technology
+ Intended Audience :: System Administrators
+
+ Operating System :: OS Independent
+
+ License :: OSI Approved :: MIT License
+
+ Programming Language :: Python
+ Programming Language :: Python :: 3
+ Programming Language :: Python :: 3.6
+ Programming Language :: Python :: 3.7
+ Programming Language :: Python :: 3.8
+ Programming Language :: Python :: Implementation
+ Programming Language :: Python :: Implementation :: CPython
+ Programming Language :: Python :: Implementation :: Jython
+ Programming Language :: Python :: Implementation :: PyPy
+
+ Topic :: Software Development :: Bug Tracking
+ Topic :: Software Development :: Quality Assurance
+ Topic :: Software Development :: Testing
+
+ Topic :: Utilities
+keywords =
+ ansible
+ lint
+
+[options]
+use_scm_version = True
+python_requires = >=3.6
+package_dir =
+ = lib
+packages = find:
+zip_safe = False
+
+# These are required during `setup.py` run:
+setup_requires =
+ setuptools_scm>=1.15.0
+ setuptools_scm_git_archive>=1.0
+
+# These are required in actual runtime:
+install_requires =
+ ansible >= 2.8
+ pyyaml
+ rich
+ ruamel.yaml >= 0.15.34,<1; python_version < "3.7"
+ ruamel.yaml >= 0.15.37,<1; python_version >= "3.7"
+ # NOTE: per issue #509 0.15.34 included in debian backports
+ typing-extensions; python_version < "3.8"
+
+[options.entry_points]
+console_scripts =
+ ansible-lint = ansiblelint.__main__:main
+
+[options.packages.find]
+where = lib