summaryrefslogtreecommitdiffstats
path: root/pyproject.toml
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--pyproject.toml13
1 files changed, 13 insertions, 0 deletions
diff --git a/pyproject.toml b/pyproject.toml
new file mode 100644
index 0000000..db5f0f2
--- /dev/null
+++ b/pyproject.toml
@@ -0,0 +1,13 @@
+[build-system]
+requires = [
+ "setuptools >= 42.0.0", # required by pyproject+setuptools_scm integration
+ "setuptools_scm[toml] >= 3.5.0", # required for "no-local-version" scheme
+ "setuptools_scm_git_archive >= 1.0",
+ "wheel",
+]
+build-backend = "setuptools.build_meta"
+
+# ATTENTION: the following section must be kept last in
+# `pyproject.toml` because our CI/CD appends one line in
+# the end when publishing non-tagged versions to test.pypi.org
+[tool.setuptools_scm]