summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py9
1 files changed, 9 insertions, 0 deletions
diff --git a/setup.py b/setup.py
new file mode 100755
index 0000000..b72e95c
--- /dev/null
+++ b/setup.py
@@ -0,0 +1,9 @@
+#! /usr/bin/env python3
+"""Ansible-lint distribution package setuptools installer.
+
+The presence of this file ensures the support
+of pip editable mode *with setuptools only*.
+"""
+from setuptools import setup
+
+__name__ == '__main__' and setup() # pylint: disable=expression-not-assigned