summaryrefslogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-14 20:18:28 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-14 20:18:28 +0000
commitf8363b456f1ab31ee56abad579b215af195093d5 (patch)
treeb1500c675c2e0a55fb75721a854e1510acf7c862 /Makefile
parentInitial commit. (diff)
downloadrich-f8363b456f1ab31ee56abad579b215af195093d5.tar.xz
rich-f8363b456f1ab31ee56abad579b215af195093d5.zip
Adding upstream version 9.11.0.upstream/9.11.0upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile13
1 files changed, 13 insertions, 0 deletions
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..6bed4f7
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,13 @@
+test:
+ pytest --cov-report term-missing --cov=rich tests/ -vv
+format-check:
+ black --check .
+format:
+ black .
+typecheck:
+ mypy -p rich --ignore-missing-imports --warn-unreachable
+typecheck-report:
+ mypy -p rich --ignore-missing-imports --warn-unreachable --html-report mypy_report
+.PHONY: docs
+docs:
+ cd docs; make html