summaryrefslogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--Makefile13
1 files changed, 13 insertions, 0 deletions
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..6bed4f7
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,13 @@
+test:
+ pytest --cov-report term-missing --cov=rich tests/ -vv
+format-check:
+ black --check .
+format:
+ black .
+typecheck:
+ mypy -p rich --ignore-missing-imports --warn-unreachable
+typecheck-report:
+ mypy -p rich --ignore-missing-imports --warn-unreachable --html-report mypy_report
+.PHONY: docs
+docs:
+ cd docs; make html