summaryrefslogtreecommitdiffstats
path: root/debian/perl-framework/Makefile.PL
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-25 04:41:28 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-25 04:41:28 +0000
commit2eeb62e38ae17a3523ad3cd81c3de9f20f9e7742 (patch)
treefe91033d4712f6d836006b998525656b9dd193b8 /debian/perl-framework/Makefile.PL
parentMerging upstream version 2.4.59. (diff)
downloadapache2-2eeb62e38ae17a3523ad3cd81c3de9f20f9e7742.tar.xz
apache2-2eeb62e38ae17a3523ad3cd81c3de9f20f9e7742.zip
Adding debian version 2.4.59-1~deb10u1.debian/2.4.59-1_deb10u1debian
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'debian/perl-framework/Makefile.PL')
-rw-r--r--debian/perl-framework/Makefile.PL20
1 files changed, 20 insertions, 0 deletions
diff --git a/debian/perl-framework/Makefile.PL b/debian/perl-framework/Makefile.PL
index 86e0355..ece2205 100644
--- a/debian/perl-framework/Makefile.PL
+++ b/debian/perl-framework/Makefile.PL
@@ -22,6 +22,26 @@ finddepth(sub {
Apache::TestMM::filter_args();
+# Temporary workaround to allow passing
+# arguments to "perl Makefile.PL"
+# that should go to t/TEST but are not yet
+# supported in an Apache::Test release.
+# Code borrowed from Apache::TestMM::filter_args().
+my %local_args = (
+ limitrequestline => 'Value for LimitRequestLine',
+ limitrequestlinex2 => 'Twice the value for LimitRequestLine',
+);
+my($argv, $args_vars) = Apache::TestConfig::filter_args(\@ARGV, \%local_args);
+@ARGV = @$argv;
+# Merge given vars with default values
+my %local_vars = (
+ limitrequestline => '128',
+ limitrequestlinex2 => '256',
+);
+map {$local_vars{$_} = $args_vars->{$_}} keys %$args_vars;
+
+push(@Apache::TestMM::Argv, %local_vars);
+
for my $script (@scripts) {
Apache::TestMM::generate_script($script);
}