summaryrefslogtreecommitdiffstats
path: root/os/config.m4
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-07 02:04:06 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-07 02:04:06 +0000
commit5dff2d61cc1c27747ee398e04d8e02843aabb1f8 (patch)
treea67c336b406c8227bac912beb74a1ad3cdc55100 /os/config.m4
parentInitial commit. (diff)
downloadapache2-5dff2d61cc1c27747ee398e04d8e02843aabb1f8.tar.xz
apache2-5dff2d61cc1c27747ee398e04d8e02843aabb1f8.zip
Adding upstream version 2.4.38.upstream/2.4.38
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'os/config.m4')
-rw-r--r--os/config.m426
1 files changed, 26 insertions, 0 deletions
diff --git a/os/config.m4 b/os/config.m4
new file mode 100644
index 0000000..3188091
--- /dev/null
+++ b/os/config.m4
@@ -0,0 +1,26 @@
+AC_MSG_CHECKING(for target platform)
+
+case $host in
+*pc-os2-emx*)
+ OS="os2"
+ OS_DIR=$OS
+ ;;
+bs2000*)
+ OS="unix"
+ OS_DIR=$OS
+ ;;
+*cygwin*)
+ OS="cygwin"
+ OS_DIR="unix"
+ ;;
+*mingw32*)
+ OS="win32"
+ OS_DIR=$OS
+ ;;
+*)
+ OS="unix"
+ OS_DIR=$OS;;
+esac
+
+AC_MSG_RESULT($OS)
+APACHE_FAST_OUTPUT(os/${OS_DIR}/Makefile)