summaryrefslogtreecommitdiffstats
path: root/debian/perl-framework/Apache-Test/Makefile.PL
diff options
context:
space:
mode:
Diffstat (limited to 'debian/perl-framework/Apache-Test/Makefile.PL')
-rw-r--r--debian/perl-framework/Apache-Test/Makefile.PL16
1 files changed, 5 insertions, 11 deletions
diff --git a/debian/perl-framework/Apache-Test/Makefile.PL b/debian/perl-framework/Apache-Test/Makefile.PL
index 713b136..2cfec1a 100644
--- a/debian/perl-framework/Apache-Test/Makefile.PL
+++ b/debian/perl-framework/Apache-Test/Makefile.PL
@@ -46,17 +46,6 @@ finddepth(sub {
push @scripts, "$File::Find::dir/$1";
}, '.');
-my $has_mp;
-eval { require mod_perl2 };
-if ($@) {
- eval { require mod_perl };
- if (!$@) {
- $has_mp = 1;
- }
-} else {
- $has_mp = 2;
-}
-
for (@scripts) {
Apache::TestMM::generate_script($_);
}
@@ -74,6 +63,11 @@ my %prereq = (
'Cwd' => '2.06',
);
+# Apache::TestServer uses Win32::Process on Windows.
+if ($^O =~ /MSWin32/i) {
+ $prereq{'Win32::Process'} = '0'
+}
+
# Apache-Test/META.yml is excluded from mp2 distro to make PAUSE
# indexer happy, but then perl Makefile.PL complains about a missing
# META.yml, so autogenerate it if it wasn't in the distro