summaryrefslogtreecommitdiffstats
path: root/debian/apply-export-patch
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-05 18:37:15 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-05 18:37:15 +0000
commit55ad72d44a94298a96b8f05488ca5ed97ef04736 (patch)
tree8aaa712c1d8b8d191b77a7eef4dc42c770e3b3d0 /debian/apply-export-patch
parentAdding upstream version 1:9.11.5.P4+dfsg. (diff)
downloadbind9-55ad72d44a94298a96b8f05488ca5ed97ef04736.tar.xz
bind9-55ad72d44a94298a96b8f05488ca5ed97ef04736.zip
Adding debian version 1:9.11.5.P4+dfsg-5.1+deb10u7.debian/1%9.11.5.P4+dfsg-5.1+deb10u7
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'debian/apply-export-patch')
-rw-r--r--debian/apply-export-patch20
1 files changed, 20 insertions, 0 deletions
diff --git a/debian/apply-export-patch b/debian/apply-export-patch
new file mode 100644
index 0000000..36be293
--- /dev/null
+++ b/debian/apply-export-patch
@@ -0,0 +1,20 @@
+#!/bin/sh
+
+# This pile of horror converts the makefiles into expecting the -export
+# version of the libraries.
+
+set -e
+cd build-udeb
+
+for lib in dns irs isc isccc isccfg lwres; do
+ sed -i "s/lib${lib}\./lib${lib}-export./g" lib/${lib}/Makefile
+done
+
+sed -i 's/ -lisc -ldns -lisccfg$/ -lisc-export -ldns-export -lisccfg-export/' \
+ lib/irs/Makefile
+
+patch -p0 < ../debian/export.diff
+
+for lib in dns irs isc isccc isccfg lwres; do
+ sed -i 's/\(lib'${lib}'\).la/\1-export.la/g' $(find . -name Makefile)
+done