summaryrefslogtreecommitdiffstats
path: root/debian/rules
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-07 05:00:11 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-07 05:00:11 +0000
commit007c860a3c3bf977997c5ef4d622f983ff9c9919 (patch)
treebc3e230e59c77617f5da0f0f79ab00a40e9bf8dc /debian/rules
parentAdding debian version 1:9.11.5.P4+dfsg-5.1+deb10u9. (diff)
downloadbind9-007c860a3c3bf977997c5ef4d622f983ff9c9919.tar.xz
bind9-007c860a3c3bf977997c5ef4d622f983ff9c9919.zip
Adding debian version 1:9.11.5.P4+dfsg-5.1+deb10u10.debian/1%9.11.5.P4+dfsg-5.1+deb10u10
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to '')
-rwxr-xr-xdebian/rules7
1 files changed, 7 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
index deeb37f..bada446 100755
--- a/debian/rules
+++ b/debian/rules
@@ -71,6 +71,12 @@ prepare_version:
clean_version:
if [ -f version.bak ]; then cp version.bak version; fi
+override_dh_auto_test:
+ dh_auto_test
+ -make check
+ -make test
+ -make unit
+
override_dh_autoreconf: prepare_native_pkcs11 prepare_version
dh_autoreconf
@@ -103,6 +109,7 @@ override_dh_auto_configure:
--with-pkcs11=\$${prefix}/lib/softhsm/libsofthsm2.so \
--with-randomdev=/dev/urandom \
--enable-dnstap \
+ --with-cmocka
$(EXTRA_FEATURES)
dh_auto_configure -B build-udeb -- \
--sysconfdir=/etc/bind \