summaryrefslogtreecommitdiffstats
path: root/debian/apply-export-patch
diff options
context:
space:
mode:
Diffstat (limited to 'debian/apply-export-patch')
-rw-r--r--debian/apply-export-patch20
1 files changed, 20 insertions, 0 deletions
diff --git a/debian/apply-export-patch b/debian/apply-export-patch
new file mode 100644
index 0000000..36be293
--- /dev/null
+++ b/debian/apply-export-patch
@@ -0,0 +1,20 @@
+#!/bin/sh
+
+# This pile of horror converts the makefiles into expecting the -export
+# version of the libraries.
+
+set -e
+cd build-udeb
+
+for lib in dns irs isc isccc isccfg lwres; do
+ sed -i "s/lib${lib}\./lib${lib}-export./g" lib/${lib}/Makefile
+done
+
+sed -i 's/ -lisc -ldns -lisccfg$/ -lisc-export -ldns-export -lisccfg-export/' \
+ lib/irs/Makefile
+
+patch -p0 < ../debian/export.diff
+
+for lib in dns irs isc isccc isccfg lwres; do
+ sed -i 's/\(lib'${lib}'\).la/\1-export.la/g' $(find . -name Makefile)
+done