summaryrefslogtreecommitdiffstats
path: root/debian/patches/0002-avoid-invocations-of-git-during-make-installcheck.patch
diff options
context:
space:
mode:
Diffstat (limited to 'debian/patches/0002-avoid-invocations-of-git-during-make-installcheck.patch')
-rw-r--r--debian/patches/0002-avoid-invocations-of-git-during-make-installcheck.patch33
1 files changed, 33 insertions, 0 deletions
diff --git a/debian/patches/0002-avoid-invocations-of-git-during-make-installcheck.patch b/debian/patches/0002-avoid-invocations-of-git-during-make-installcheck.patch
new file mode 100644
index 0000000..01639e5
--- /dev/null
+++ b/debian/patches/0002-avoid-invocations-of-git-during-make-installcheck.patch
@@ -0,0 +1,33 @@
+From: Daniel Kahn Gillmor <dkg@fifthhorseman.net>
+Date: Wed, 12 Sep 2018 09:47:35 -0400
+Subject: avoid invocations of git during "make installcheck"
+
+The continuous integration test suite was printing a warning to stderr
+because of an attempt to invoke git. The debian builds are done from
+tarballs, so invoking git wouldn't make sense anyway.
+---
+ tests/test_integration.mk | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/tests/test_integration.mk b/tests/test_integration.mk
+index a5d36c3..9c0768c 100644
+--- a/tests/test_integration.mk
++++ b/tests/test_integration.mk
+@@ -4,7 +4,7 @@
+ # 1. Run tests from main Deckard repo (generic DNS tests)
+ # 2. Run tests from kresd repo (kresd-specific tests)
+
+-SUBMODULES_DIRTY := $(shell git submodule status --recursive | cut -c 1 | grep -q '[^ ]' && echo $$?)
++SUBMODULES_DIRTY :=
+ REAL_PREFIX=$(realpath $(PREFIX))
+ REAL_CURDIR=$(realpath $(CURDIR))
+
+@@ -12,7 +12,7 @@ REAL_CURDIR=$(realpath $(CURDIR))
+ deckard_DIR := $(TOPSRCDIR)/tests/deckard
+
+ $(deckard_DIR)/Makefile:
+- @git submodule update --init --recursive
++ touch $@
+
+ # this is necessary to avoid multiple parallel but independent runs
+ # of 'make depend' from $(deckard_DIR)/run.sh