summaryrefslogtreecommitdiffstats
path: root/doc/doc.mk
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--doc/doc.mk14
1 files changed, 14 insertions, 0 deletions
diff --git a/doc/doc.mk b/doc/doc.mk
new file mode 100644
index 0000000..58c299e
--- /dev/null
+++ b/doc/doc.mk
@@ -0,0 +1,14 @@
+ifeq ($(HAS_doxygen)|$(HAS_sphinx-build), yes|yes)
+doc-doxygen:
+ @cd doc && $(doxygen_BIN)
+doc-html: doc-doxygen
+ @cd doc && $(sphinx-build_BIN) $(SPHINXFLAGS) -b html . html
+else
+doc-html:
+ $(error doxygen and sphinx must be installed)
+endif
+doc-clean:
+ rm -rf doc/doxyxml doc/*.db doc/html
+
+.PHONY: doc-doxygen doc-html doc-clean
+