summaryrefslogtreecommitdiffstats
path: root/etc/etc.mk
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--etc/etc.mk16
1 files changed, 16 insertions, 0 deletions
diff --git a/etc/etc.mk b/etc/etc.mk
new file mode 100644
index 0000000..b42d30a
--- /dev/null
+++ b/etc/etc.mk
@@ -0,0 +1,16 @@
+etc_SOURCES := icann-ca.pem \
+ config.cluster \
+ config.isp \
+ config.personal \
+ config.splitview \
+ root.hints
+
+etc-install: $(DESTDIR)$(ETCDIR)
+ $(INSTALL) -m 0644 $(addprefix etc/,$(etc_SOURCES)) $(DESTDIR)$(ETCDIR)
+
+etc: etc/root.hints
+
+etc/root.hints:
+ wget -O $@ https://www.internic.net/domain/named.root
+
+.PHONY: etc-install