summaryrefslogtreecommitdiffstats
path: root/arch/arm/probes/kprobes/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'arch/arm/probes/kprobes/Makefile')
-rw-r--r--arch/arm/probes/kprobes/Makefile13
1 files changed, 13 insertions, 0 deletions
diff --git a/arch/arm/probes/kprobes/Makefile b/arch/arm/probes/kprobes/Makefile
new file mode 100644
index 000000000..14db56f49
--- /dev/null
+++ b/arch/arm/probes/kprobes/Makefile
@@ -0,0 +1,13 @@
+# SPDX-License-Identifier: GPL-2.0
+obj-$(CONFIG_KPROBES) += core.o actions-common.o checkers-common.o
+obj-$(CONFIG_ARM_KPROBES_TEST) += test-kprobes.o
+test-kprobes-objs := test-core.o
+
+ifdef CONFIG_THUMB2_KERNEL
+obj-$(CONFIG_KPROBES) += actions-thumb.o checkers-thumb.o
+test-kprobes-objs += test-thumb.o
+else
+obj-$(CONFIG_KPROBES) += actions-arm.o checkers-arm.o
+obj-$(CONFIG_OPTPROBES) += opt-arm.o
+test-kprobes-objs += test-arm.o
+endif