summaryrefslogtreecommitdiffstats
path: root/arch/c6x/boot/dts/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'arch/c6x/boot/dts/Makefile')
-rw-r--r--arch/c6x/boot/dts/Makefile19
1 files changed, 19 insertions, 0 deletions
diff --git a/arch/c6x/boot/dts/Makefile b/arch/c6x/boot/dts/Makefile
new file mode 100644
index 000000000..b212d278e
--- /dev/null
+++ b/arch/c6x/boot/dts/Makefile
@@ -0,0 +1,19 @@
+# SPDX-License-Identifier: GPL-2.0
+#
+# Makefile for device trees
+#
+
+DTC_FLAGS ?= -p 1024
+
+ifneq ($(DTB),)
+obj-y += linked_dtb.o
+endif
+
+quiet_cmd_cp = CP $< $@$2
+ cmd_cp = cat $< >$@$2 || (rm -f $@ && echo false)
+
+# Generate builtin.dtb from $(DTB).dtb
+$(obj)/builtin.dtb: $(obj)/$(DTB).dtb
+ $(call if_changed,cp)
+
+$(obj)/linked_dtb.o: $(obj)/builtin.dtb