summaryrefslogtreecommitdiffstats
path: root/arch/mips/jz4740/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'arch/mips/jz4740/Makefile')
-rw-r--r--arch/mips/jz4740/Makefile19
1 files changed, 19 insertions, 0 deletions
diff --git a/arch/mips/jz4740/Makefile b/arch/mips/jz4740/Makefile
new file mode 100644
index 000000000..88d6aa7d0
--- /dev/null
+++ b/arch/mips/jz4740/Makefile
@@ -0,0 +1,19 @@
+# SPDX-License-Identifier: GPL-2.0
+#
+# Makefile for the Ingenic JZ4740.
+#
+
+# Object file lists.
+
+obj-y += prom.o time.o reset.o setup.o \
+ platform.o timer.o
+
+CFLAGS_setup.o = -I$(src)/../../../scripts/dtc/libfdt
+
+# board specific support
+
+obj-$(CONFIG_JZ4740_QI_LB60) += board-qi_lb60.o
+
+# PM support
+
+obj-$(CONFIG_PM) += pm.o