summaryrefslogtreecommitdiffstats
path: root/arch/x86/power/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'arch/x86/power/Makefile')
-rw-r--r--arch/x86/power/Makefile10
1 files changed, 10 insertions, 0 deletions
diff --git a/arch/x86/power/Makefile b/arch/x86/power/Makefile
new file mode 100644
index 000000000..a47013895
--- /dev/null
+++ b/arch/x86/power/Makefile
@@ -0,0 +1,10 @@
+# SPDX-License-Identifier: GPL-2.0
+OBJECT_FILES_NON_STANDARD_hibernate_asm_$(BITS).o := y
+
+# __restore_processor_state() restores %gs after S3 resume and so should not
+# itself be stack-protected
+nostackp := $(call cc-option, -fno-stack-protector)
+CFLAGS_cpu.o := $(nostackp)
+
+obj-$(CONFIG_PM_SLEEP) += cpu.o
+obj-$(CONFIG_HIBERNATION) += hibernate_$(BITS).o hibernate_asm_$(BITS).o