summaryrefslogtreecommitdiffstats
path: root/drivers/clk/rockchip/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'drivers/clk/rockchip/Makefile')
-rw-r--r--drivers/clk/rockchip/Makefile25
1 files changed, 25 insertions, 0 deletions
diff --git a/drivers/clk/rockchip/Makefile b/drivers/clk/rockchip/Makefile
new file mode 100644
index 000000000..ff35ab463
--- /dev/null
+++ b/drivers/clk/rockchip/Makefile
@@ -0,0 +1,25 @@
+# SPDX-License-Identifier: GPL-2.0
+#
+# Rockchip Clock specific Makefile
+#
+
+obj-y += clk.o
+obj-y += clk-pll.o
+obj-y += clk-cpu.o
+obj-y += clk-half-divider.o
+obj-y += clk-inverter.o
+obj-y += clk-mmc-phase.o
+obj-y += clk-muxgrf.o
+obj-y += clk-ddr.o
+obj-$(CONFIG_RESET_CONTROLLER) += softrst.o
+
+obj-y += clk-px30.o
+obj-y += clk-rv1108.o
+obj-y += clk-rk3036.o
+obj-y += clk-rk3128.o
+obj-y += clk-rk3188.o
+obj-y += clk-rk3228.o
+obj-y += clk-rk3288.o
+obj-y += clk-rk3328.o
+obj-y += clk-rk3368.o
+obj-y += clk-rk3399.o