summaryrefslogtreecommitdiffstats
path: root/drivers/vfio/platform/reset/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'drivers/vfio/platform/reset/Makefile')
-rw-r--r--drivers/vfio/platform/reset/Makefile9
1 files changed, 9 insertions, 0 deletions
diff --git a/drivers/vfio/platform/reset/Makefile b/drivers/vfio/platform/reset/Makefile
new file mode 100644
index 000000000..57abd4f0a
--- /dev/null
+++ b/drivers/vfio/platform/reset/Makefile
@@ -0,0 +1,9 @@
+# SPDX-License-Identifier: GPL-2.0
+vfio-platform-calxedaxgmac-y := vfio_platform_calxedaxgmac.o
+vfio-platform-amdxgbe-y := vfio_platform_amdxgbe.o
+
+ccflags-y += -Idrivers/vfio/platform
+
+obj-$(CONFIG_VFIO_PLATFORM_CALXEDAXGMAC_RESET) += vfio-platform-calxedaxgmac.o
+obj-$(CONFIG_VFIO_PLATFORM_AMDXGBE_RESET) += vfio-platform-amdxgbe.o
+obj-$(CONFIG_VFIO_PLATFORM_BCMFLEXRM_RESET) += vfio_platform_bcmflexrm.o