summaryrefslogtreecommitdiffstats
path: root/fs/fscache/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'fs/fscache/Makefile')
-rw-r--r--fs/fscache/Makefile21
1 files changed, 21 insertions, 0 deletions
diff --git a/fs/fscache/Makefile b/fs/fscache/Makefile
new file mode 100644
index 000000000..79e08e05e
--- /dev/null
+++ b/fs/fscache/Makefile
@@ -0,0 +1,21 @@
+# SPDX-License-Identifier: GPL-2.0
+#
+# Makefile for general filesystem caching code
+#
+
+fscache-y := \
+ cache.o \
+ cookie.o \
+ fsdef.o \
+ main.o \
+ netfs.o \
+ object.o \
+ operation.o \
+ page.o
+
+fscache-$(CONFIG_PROC_FS) += proc.o
+fscache-$(CONFIG_FSCACHE_STATS) += stats.o
+fscache-$(CONFIG_FSCACHE_HISTOGRAM) += histogram.o
+fscache-$(CONFIG_FSCACHE_OBJECT_LIST) += object-list.o
+
+obj-$(CONFIG_FSCACHE) := fscache.o