summaryrefslogtreecommitdiffstats
path: root/net/tls/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'net/tls/Makefile')
-rw-r--r--net/tls/Makefile9
1 files changed, 9 insertions, 0 deletions
diff --git a/net/tls/Makefile b/net/tls/Makefile
new file mode 100644
index 000000000..4d6b728a6
--- /dev/null
+++ b/net/tls/Makefile
@@ -0,0 +1,9 @@
+#
+# Makefile for the TLS subsystem.
+#
+
+obj-$(CONFIG_TLS) += tls.o
+
+tls-y := tls_main.o tls_sw.o
+
+tls-$(CONFIG_TLS_DEVICE) += tls_device.o tls_device_fallback.o