summaryrefslogtreecommitdiffstats
path: root/security/integrity/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'security/integrity/Makefile')
-rw-r--r--security/integrity/Makefile16
1 files changed, 16 insertions, 0 deletions
diff --git a/security/integrity/Makefile b/security/integrity/Makefile
new file mode 100644
index 000000000..04d6e462b
--- /dev/null
+++ b/security/integrity/Makefile
@@ -0,0 +1,16 @@
+# SPDX-License-Identifier: GPL-2.0
+#
+# Makefile for caching inode integrity data (iint)
+#
+
+obj-$(CONFIG_INTEGRITY) += integrity.o
+
+integrity-y := iint.o
+integrity-$(CONFIG_INTEGRITY_AUDIT) += integrity_audit.o
+integrity-$(CONFIG_INTEGRITY_SIGNATURE) += digsig.o
+integrity-$(CONFIG_INTEGRITY_ASYMMETRIC_KEYS) += digsig_asymmetric.o
+
+subdir-$(CONFIG_IMA) += ima
+obj-$(CONFIG_IMA) += ima/
+subdir-$(CONFIG_EVM) += evm
+obj-$(CONFIG_EVM) += evm/