summaryrefslogtreecommitdiffstats
path: root/tools/usb/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'tools/usb/Makefile')
-rw-r--r--tools/usb/Makefile14
1 files changed, 14 insertions, 0 deletions
diff --git a/tools/usb/Makefile b/tools/usb/Makefile
new file mode 100644
index 000000000..01d758d73
--- /dev/null
+++ b/tools/usb/Makefile
@@ -0,0 +1,14 @@
+# SPDX-License-Identifier: GPL-2.0
+# Makefile for USB tools
+
+PTHREAD_LIBS = -lpthread
+WARNINGS = -Wall -Wextra
+CFLAGS = $(WARNINGS) -g -I../include
+LDFLAGS = $(PTHREAD_LIBS)
+
+all: testusb ffs-test
+%: %.c
+ $(CC) $(CFLAGS) -o $@ $^ $(LDFLAGS)
+
+clean:
+ $(RM) testusb ffs-test