summaryrefslogtreecommitdiffstats
path: root/debian/policy/Makefile
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-06 02:44:26 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-06 02:44:26 +0000
commit0cde7a370d07f80208bcd29597cf30d5274f38b0 (patch)
treee228a85db87eb0491d2937e213bbbab19826b682 /debian/policy/Makefile
parentAdding upstream version 2:8.1.0875. (diff)
downloadvim-0cde7a370d07f80208bcd29597cf30d5274f38b0.tar.xz
vim-0cde7a370d07f80208bcd29597cf30d5274f38b0.zip
Adding debian version 2:8.1.0875-5+deb10u2.debian/2%8.1.0875-5+deb10u2
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'debian/policy/Makefile')
-rw-r--r--debian/policy/Makefile31
1 files changed, 31 insertions, 0 deletions
diff --git a/debian/policy/Makefile b/debian/policy/Makefile
new file mode 100644
index 0000000..b5cf01b
--- /dev/null
+++ b/debian/policy/Makefile
@@ -0,0 +1,31 @@
+
+NULL =
+INSTALL_STUFF = \
+ vim-policy.html/ \
+ vim-policy.txt \
+ $(NULL)
+
+all: html text
+
+# to be used on alioth for updating policy linked by pkg-vim project page
+install: all
+ cp -r $(INSTALL_STUFF) ~/pkg-vim/htdocs/
+
+html: vim-policy.html/index.html
+text: vim-policy.txt
+
+export LC_ALL=C.UTF-8
+
+vim-policy.html/index.html: vim-policy.xml *.xml
+ docbook2html $< -o $(dir $@)
+vim-policy.txt: vim-policy.xml *.xml
+ docbook2txt $<
+
+clean:
+ $(RM) -rf $(INSTALL_STUFF)
+
+upload_web: all
+ scp -rC $(INSTALL_STUFF) alioth.debian.org:/srv/home/groups/pkg-vim/htdocs/
+
+.PHONY: html text upload_web
+