summaryrefslogtreecommitdiffstats
path: root/debian/perl-framework/Makefile.PL
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--debian/perl-framework/Makefile.PL38
1 files changed, 38 insertions, 0 deletions
diff --git a/debian/perl-framework/Makefile.PL b/debian/perl-framework/Makefile.PL
new file mode 100644
index 0000000..86e0355
--- /dev/null
+++ b/debian/perl-framework/Makefile.PL
@@ -0,0 +1,38 @@
+use ExtUtils::MakeMaker;
+
+use 5.005;
+
+use lib qw(Apache-Test/lib);
+
+use Apache::Test5005compat;
+
+use Apache::TestMM qw(test clean);
+use Apache::TestReport ();
+use Apache::TestSmoke ();
+use Apache::TestRun ();
+
+use File::Find qw(finddepth);
+
+my @scripts = ();
+
+finddepth(sub {
+ return unless /^(?!.#)(.*?\.pl)\.PL$/;
+ push @scripts, "$File::Find::dir/$1";
+}, '.');
+
+Apache::TestMM::filter_args();
+
+for my $script (@scripts) {
+ Apache::TestMM::generate_script($script);
+}
+
+for my $util (qw(Report Smoke Run)) {
+ my $class = "Apache::Test${util}";
+ $class->generate_script;
+}
+
+WriteMakefile(
+ NAME => 'httpd-test',
+ VERSION => '0.01',
+ clean => { FILES => "@scripts" },
+);