summaryrefslogtreecommitdiffstats
path: root/po/CMakeLists.txt
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-05 18:07:13 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-05 18:07:13 +0000
commit636c7dc17286d93d788c741d15fd756aeda066d5 (patch)
treee7ae158cc54f591041a061b9865bcae51854f15c /po/CMakeLists.txt
parentInitial commit. (diff)
downloadapt-upstream/1.8.2.3.tar.xz
apt-upstream/1.8.2.3.zip
Adding upstream version 1.8.2.3.upstream/1.8.2.3upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to '')
-rw-r--r--po/CMakeLists.txt52
1 files changed, 52 insertions, 0 deletions
diff --git a/po/CMakeLists.txt b/po/CMakeLists.txt
new file mode 100644
index 0000000..a8893e8
--- /dev/null
+++ b/po/CMakeLists.txt
@@ -0,0 +1,52 @@
+include(Translations)
+
+set(languages_excluded
+ he ## disabled by translator request #313283
+)
+
+apt_add_translation_domain(
+ DOMAIN libapt-pkg${APT_PKG_MAJOR}
+ TARGETS apt-pkg
+ EXCLUDE_LANGUAGES ${languages_excluded}
+)
+
+apt_add_translation_domain(
+ DOMAIN apt
+ TARGETS apt apt-cache apt-get apt-config apt-cdrom apt-helper apt-mark
+ apt-private
+ # Methods
+ connectlib file copy store gpgv cdrom http ftp rred rsh mirror
+ SCRIPTS ../dselect/install ../dselect/update
+ EXCLUDE_LANGUAGES ${languages_excluded}
+)
+
+apt_add_translation_domain(
+ DOMAIN apt-utils
+ TARGETS apt-sortpkgs
+ apt-extracttemplates
+ apt-internal-solver
+ apt-dump-solver
+ apt-internal-planner
+ apt-ftparchive
+ EXCLUDE_LANGUAGES ${languages_excluded}
+)
+
+apt_add_translation_domain(
+ DOMAIN libapt-inst${APT_INST_MAJOR}
+ TARGETS apt-inst
+ EXCLUDE_LANGUAGES ${languages_excluded}
+)
+
+apt_add_update_po(
+ TEMPLATE
+ apt-all
+ DOMAINS
+ libapt-pkg${APT_PKG_MAJOR}
+ libapt-inst${APT_INST_MAJOR}
+ apt
+ apt-utils
+ EXCLUDE_LANGUAGES
+ ${languages_excluded}
+)
+
+apt_add_po_statistics("${languages_excluded}")