summaryrefslogtreecommitdiffstats
path: root/contrib/dlz/example/Makefile
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--contrib/dlz/example/Makefile16
1 files changed, 16 insertions, 0 deletions
diff --git a/contrib/dlz/example/Makefile b/contrib/dlz/example/Makefile
new file mode 100644
index 0000000..5e84043
--- /dev/null
+++ b/contrib/dlz/example/Makefile
@@ -0,0 +1,16 @@
+# for building the dlz_example driver we don't use
+# the bind9 build structure as the aim is to provide an
+# example that is separable from the bind9 source tree
+
+# this means this Makefile is not portable, so the testsuite
+# skips this test on platforms where it doesn't build
+
+CFLAGS=-Wall -fPIC -g
+
+all: dlz_example.so
+
+dlz_example.so: dlz_example.o
+ $(CC) $(CFLAGS) -shared -o dlz_example.so dlz_example.o
+
+clean:
+ rm -f dlz_example.o dlz_example.so