summaryrefslogtreecommitdiffstats
path: root/unit/Makefile.in
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--unit/Makefile.in36
1 files changed, 36 insertions, 0 deletions
diff --git a/unit/Makefile.in b/unit/Makefile.in
new file mode 100644
index 0000000..342380e
--- /dev/null
+++ b/unit/Makefile.in
@@ -0,0 +1,36 @@
+# Copyright (C) Internet Systems Consortium, Inc. ("ISC")
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+# See the COPYRIGHT file distributed with this work for additional
+# information regarding copyright ownership.
+
+srcdir = @srcdir@
+VPATH = @srcdir@
+top_srcdir = @top_srcdir@
+
+# Attempt to disable parallel processing.
+.NOTPARALLEL:
+.NO_PARALLEL:
+SUBDIRS = @ATFBUILD@
+TARGETS = atf
+
+@BIND9_MAKE_RULES@
+
+#
+# install ATF libraries, if configured with --with-atf
+#
+atf:
+ @for i in ${ALL_SUBDIRS}; do \
+ if [ "$$i" != "nulldir" -a -d $$i ]; then \
+ (cd $$i; ${MAKE} ${MAKEDEFS} install) || exit 1; \
+ fi; \
+ done
+
+clean distclean::
+ rm -rf ./atf
+
+distclean::
+ rm unittest.sh