summaryrefslogtreecommitdiffstats
path: root/unit/atf-src/admin/Makefile.am.inc
diff options
context:
space:
mode:
Diffstat (limited to 'unit/atf-src/admin/Makefile.am.inc')
-rw-r--r--unit/atf-src/admin/Makefile.am.inc38
1 files changed, 38 insertions, 0 deletions
diff --git a/unit/atf-src/admin/Makefile.am.inc b/unit/atf-src/admin/Makefile.am.inc
new file mode 100644
index 0000000..12b02b8
--- /dev/null
+++ b/unit/atf-src/admin/Makefile.am.inc
@@ -0,0 +1,38 @@
+# Copyright (c) 2007 The NetBSD Foundation, Inc.
+# All rights reserved.
+#
+# Redistribution and use in source and binary forms, with or without
+# modification, are permitted provided that the following conditions
+# are met:
+# 1. Redistributions of source code must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+# 2. Redistributions in binary form must reproduce the above copyright
+# notice, this list of conditions and the following disclaimer in the
+# documentation and/or other materials provided with the distribution.
+#
+# THIS SOFTWARE IS PROVIDED BY THE NETBSD FOUNDATION, INC. AND
+# CONTRIBUTORS ``AS IS'' AND ANY EXPRESS OR IMPLIED WARRANTIES,
+# INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED.
+# IN NO EVENT SHALL THE FOUNDATION OR CONTRIBUTORS BE LIABLE FOR ANY
+# DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL
+# DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE
+# GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS
+# INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER
+# IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN
+# IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+dist-hook: check-style
+PHONY_TARGETS += check-style
+check-style:
+ $(srcdir)/admin/check-style.sh
+
+EXTRA_DIST += admin/check-style-common.awk \
+ admin/check-style-c.awk \
+ admin/check-style-cpp.awk \
+ admin/check-style-man.awk \
+ admin/check-style-shell.awk \
+ admin/check-style.sh
+
+# vim: syntax=make:noexpandtab:shiftwidth=8:softtabstop=8