summaryrefslogtreecommitdiffstats
path: root/scripts/dpkg-genbuilddeps.sh
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-06 00:39:23 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-06 00:39:23 +0000
commite3b16b3856bdd5c1645f4609d61bf5a16c026930 (patch)
treed9def3b6f6f46b166fc6f516775350fedeefbef6 /scripts/dpkg-genbuilddeps.sh
parentInitial commit. (diff)
downloaddevscripts-e3b16b3856bdd5c1645f4609d61bf5a16c026930.tar.xz
devscripts-e3b16b3856bdd5c1645f4609d61bf5a16c026930.zip
Adding upstream version 2.19.5+deb10u1.upstream/2.19.5+deb10u1upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'scripts/dpkg-genbuilddeps.sh')
-rwxr-xr-xscripts/dpkg-genbuilddeps.sh41
1 files changed, 41 insertions, 0 deletions
diff --git a/scripts/dpkg-genbuilddeps.sh b/scripts/dpkg-genbuilddeps.sh
new file mode 100755
index 0000000..1744e10
--- /dev/null
+++ b/scripts/dpkg-genbuilddeps.sh
@@ -0,0 +1,41 @@
+#!/bin/bash
+set -e
+
+PROGNAME=`basename $0`
+
+if [ $# -gt 0 ]; then
+ case $1 in
+ -h|--help)
+ cat <<EOF
+Usage: $PROGNAME [options] [<arg> ...]
+Build package and generate build dependencies.
+All args are passed to dpkg-buildpackage.
+Options:
+ -h, --help This help
+ -v, --version Report version and exit
+EOF
+ exit 1
+ ;;
+ -v|--version)
+ echo "$PROGNAME wrapper for dpkg-depcheck:"
+ dpkg-depcheck --version
+ exit 1
+ ;;
+ esac
+fi
+
+if ! [ -x debian/rules ]; then
+ echo "$PROGNAME must be run in the source package directory" >&2
+ exit 1
+fi
+
+if ! dpkg -L build-essential >/dev/null 2>&1
+then
+ echo "You must have the build-essential package installed to use $PROGNAME" >&2
+ echo "You can try running the dpkg-depcheck program directly as:" >&2
+ echo "dpkg-depcheck --all dpkg-buildpackage -us -uc -b -rfakeroot $*" >&2
+ exit 1
+fi
+
+echo "Warning: if this program hangs, kill it and read the manpage!" >&2
+dpkg-depcheck -b dpkg-buildpackage -us -uc -b "$@"