summaryrefslogtreecommitdiffstats
path: root/scripts/setup.py
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-06 00:39:23 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-06 00:39:23 +0000
commite3b16b3856bdd5c1645f4609d61bf5a16c026930 (patch)
treed9def3b6f6f46b166fc6f516775350fedeefbef6 /scripts/setup.py
parentInitial commit. (diff)
downloaddevscripts-e3b16b3856bdd5c1645f4609d61bf5a16c026930.tar.xz
devscripts-e3b16b3856bdd5c1645f4609d61bf5a16c026930.zip
Adding upstream version 2.19.5+deb10u1.upstream/2.19.5+deb10u1upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'scripts/setup.py')
-rwxr-xr-xscripts/setup.py29
1 files changed, 29 insertions, 0 deletions
diff --git a/scripts/setup.py b/scripts/setup.py
new file mode 100755
index 0000000..5908616
--- /dev/null
+++ b/scripts/setup.py
@@ -0,0 +1,29 @@
+#!/usr/bin/python3
+
+import os
+import re
+
+from setuptools import setup
+
+from devscripts.test import SCRIPTS
+
+
+def get_version():
+ # look/set what version we have
+ changelog = "../debian/changelog"
+ if os.path.exists(changelog):
+ head = open(changelog, encoding="utf8").readline()
+ match = re.compile(r".*\((.*)\).*").match(head)
+ if match:
+ return match.group(1)
+ raise Exception("Failed to determine version from debian/changelog")
+
+
+if __name__ == '__main__':
+ setup(
+ name='devscripts',
+ version=get_version(),
+ scripts=SCRIPTS,
+ packages=['devscripts', 'devscripts/test'],
+ test_suite='devscripts.test',
+ )