summaryrefslogtreecommitdiffstats
path: root/test/Makefile
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-06 00:39:23 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-06 00:39:23 +0000
commite3b16b3856bdd5c1645f4609d61bf5a16c026930 (patch)
treed9def3b6f6f46b166fc6f516775350fedeefbef6 /test/Makefile
parentInitial commit. (diff)
downloaddevscripts-upstream/2.19.5+deb10u1.tar.xz
devscripts-upstream/2.19.5+deb10u1.zip
Adding upstream version 2.19.5+deb10u1.upstream/2.19.5+deb10u1upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'test/Makefile')
-rw-r--r--test/Makefile34
1 files changed, 34 insertions, 0 deletions
diff --git a/test/Makefile b/test/Makefile
new file mode 100644
index 0000000..5603d31
--- /dev/null
+++ b/test/Makefile
@@ -0,0 +1,34 @@
+
+OUR_TESTS= \
+ perl \
+ annotate-output \
+ checkbashisms \
+ dd-list \
+ debchange \
+ debdiff \
+ debrepro \
+ debsign \
+ mergechanges \
+ mk-origtargz \
+ package_lifecycle \
+ sadt \
+ uscan \
+ uscan_ftp \
+ uscan_git \
+ uscan_mangle \
+ perltidy \
+
+test: $(foreach i,$(OUR_TESTS),test_$(i).test)
+
+%.test: %
+ ./$<
+
+test-installed: $(foreach i,$(OUR_TESTS),test_$(i).test_installed)
+
+%.test_installed: %
+ ./$< --installed
+
+online-test:
+ ./test_uscan_online
+
+.PHONY: test test-installed online-test