summaryrefslogtreecommitdiffstats
path: root/test/Makefile
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--test/Makefile34
1 files changed, 34 insertions, 0 deletions
diff --git a/test/Makefile b/test/Makefile
new file mode 100644
index 0000000..5603d31
--- /dev/null
+++ b/test/Makefile
@@ -0,0 +1,34 @@
+
+OUR_TESTS= \
+ perl \
+ annotate-output \
+ checkbashisms \
+ dd-list \
+ debchange \
+ debdiff \
+ debrepro \
+ debsign \
+ mergechanges \
+ mk-origtargz \
+ package_lifecycle \
+ sadt \
+ uscan \
+ uscan_ftp \
+ uscan_git \
+ uscan_mangle \
+ perltidy \
+
+test: $(foreach i,$(OUR_TESTS),test_$(i).test)
+
+%.test: %
+ ./$<
+
+test-installed: $(foreach i,$(OUR_TESTS),test_$(i).test_installed)
+
+%.test_installed: %
+ ./$< --installed
+
+online-test:
+ ./test_uscan_online
+
+.PHONY: test test-installed online-test