summaryrefslogtreecommitdiffstats
path: root/README
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--README129
-rw-r--r--README.l10n85
2 files changed, 214 insertions, 0 deletions
diff --git a/README b/README
new file mode 100644
index 0000000..6a26e87
--- /dev/null
+++ b/README
@@ -0,0 +1,129 @@
+dpkg - Debian's package maintenance system
+
+The primary interface for the dpkg suite is the ‘dselect’ program;
+a more low-level and less user-friendly interface is available in
+the form of the ‘dpkg’ command.
+
+
+Releases
+--------
+
+The current legacy, stable and development releases can be found at:
+
+ <http://ftp.debian.org/debian/pool/main/d/dpkg/>
+
+For older releases check:
+
+ <http://snapshot.debian.org/package/dpkg/>
+
+
+Mailing List
+------------
+
+The subscription interface and web archives can be found at:
+
+ <https://lists.debian.org/debian-dpkg/>
+
+The mailing list address is (no subscription required to post):
+
+ debian-dpkg@lists.debian.org
+
+
+Source Repository
+-----------------
+
+ <https://git.dpkg.org/cgit/dpkg/dpkg.git>
+
+
+Building from git source
+------------------------
+
+To prepare the dpkg source tree from git before starting the build process
+some required software needs to be installed:
+
+ GNU autoconf >= 2.60
+ GNU automake >= 1.11
+ GNU libtool >= 2.0
+ GNU autopoint >= 0.19.7 (from GNU gettext)
+ GNU gettext >= 0.19.7 (only with --enable-nls)
+
+After installing the needed software, and running the following command on
+the git tree:
+
+ $ ./autogen
+
+the source should be roughly equivalent to the distributed tar source.
+
+To enable translated documentation this software will be needed:
+
+ po4a >= 0.43
+
+
+Building from tar source
+------------------------
+
+The minimum software required to configure and build dpkg from a tarball is:
+
+ C89 compiler with few C99 extensions (see doc/coding-style.txt)
+ perl (see doc/coding-style.txt)
+ pkg-config
+ GNU make
+
+To enable optional functionality or programs, this software might be needed:
+
+ libmd (used by libdpkg, currently falling back to embedded code)
+ libz (from zlib, used instead of gzip command-line tool)
+ liblzma (from xz utils, used instead of xz command-line tool)
+ libbz2 (from bzip2, used instead of bzip2 command-line tool)
+ libselinux
+ curses compatible library (needed on --enable-dselect)
+
+To run the test suite («make check»):
+
+ Test::MinimumVersion perl module (optional, author)
+ Test::Pod perl module (optional)
+ Test::Pod::Coverage perl module (optional, author)
+ Test::Spelling perl module (optional, author)
+ Test::Strict perl module (optional)
+ Test::Synopsis perl module (optional, author)
+ Test::Perl::Critic perl module (optional, author)
+ aspell (optional, author)
+ aspell-en (optional, author)
+ codespell (optional, author)
+ cppcheck (optional, author)
+ fakeroot (optional)
+ gpg (optional)
+ i18nspector (optional, author)
+ shellcheck (optional, author)
+
+ Define the environment variable DPKG_DEVEL_MODE or AUTHOR_TESTING to run
+ the test suite in development mode, to include tests that might not be
+ pertinent during normal release builds.
+
+To enable additional developer's documentation («make doc») this software
+will be needed:
+
+ pod2man
+ doxygen
+ dot
+
+To enable code coverage («./configure --enable-coverage; make coverage»)
+this software is needed:
+
+ lcov (from the Linux Test Project)
+ Devel-Cover perl module
+
+The build process is done by running the usual «./configure; make». To
+see all available configuration options please run «./configure --help».
+The following configure options might be of interest to disable specific
+programs:
+
+ --disable-dselect
+ --disable-start-stop-daemon
+ --disable-update-alternatives
+
+And the following to disable modifications to the build flags:
+
+ --disable-compiler-warnings
+ --disable-compiler-optimizations
+ --disable-linker-optimizations
diff --git a/README.l10n b/README.l10n
new file mode 100644
index 0000000..549675f
--- /dev/null
+++ b/README.l10n
@@ -0,0 +1,85 @@
+Translators, when adding/updating your translation files, please follow
+the following rules:
+
+* Update debian/changelog:
+
+ - Beware that you should NOT update any of the legacy ChangeLog.old
+ files for translation updates.
+
+* Format of entries in debian/changelog:
+
+ Translation updates should go in a dedicated "[ Updated foo translations ]"
+ section:
+
+==========================================================
+dpkg (1.13.15) unstable; urgency=low
+
+ .../...
+
+ [ Updated programs translations ]
+ * Catalan (Jordi Mallach).
+ * Portuguese (Miguel Figueiredo).
+ * Swedish (Daniel Nylander).
+==========================================================
+
+ New translations should go in a dedicated section named
+ "[ New scripts translations ]":
+
+==========================================================
+dpkg (1.13.15) unstable; urgency=low
+
+ .../...
+
+ [ New dselect translations ]
+ * Vogon (Douglas Adams).
+==========================================================
+
+ This file contents MUST be encoded in UTF-8, and the entries inserted
+ in language alphabetical order.
+
+* Format of commit message
+
+ The formats above only apply to the debian/changelog file.
+ They do not apply to the commit message. Following recommendations
+ of <https://wiki.debian.org/Teams/Dpkg/GitUsage> you should start the
+ commit message with a summary line, followed by an empty line and a
+ a detailed/long description. For example:
+
+==========================================================
+Update German translation of manual pages
+
+Update to 1354t.
+==========================================================
+
+ Note that the update should mention the file statistics as XXXtYYYfZZZu.
+
+ "XXXt" means "XXX translated strings".
+ "YYYf" means "YYY fuzzy strings strings".
+ "ZZZu" means "ZZZ untranslated strings".
+ YYY or ZZZ may be omitted if they are null.
+
+* Use of po/LINGUAS, dselect/po/LINGUAS or scripts/po/LINGUAS:
+
+ When ADDING a new translation, don't forget adding the language to
+ the LINGUAS file, otherwise it will not be used.
+
+* Always CHECK your translations:
+
+ You MUST check your PO files for validity.
+
+ The correct syntax for doing so is:
+
+ $ msgmerge -U <file> dpkg.pot
+ $ msgfmt -c -o /dev/null --statistics <file>
+ $ msgcat <file> >/dev/null
+
+ - msgmerge updates your file with the current POT file.
+ - msgfmt checks it for validity.
+ - msgcat may detect encoding problems.
+
+ In addition to the above, the easiest way to check that the po4a
+ translations have valid POD markup, is to try to build them (please
+ see the Building sections in the README file for further details
+ regarding the setup of the source tree):
+
+ $ make -C man