summaryrefslogtreecommitdiffstats
path: root/dselect/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--dselect/Makefile.am74
1 files changed, 74 insertions, 0 deletions
diff --git a/dselect/Makefile.am b/dselect/Makefile.am
new file mode 100644
index 0000000..9206603
--- /dev/null
+++ b/dselect/Makefile.am
@@ -0,0 +1,74 @@
+## Process this file with automake to produce Makefile.in
+
+SUBDIRS = methods po
+
+localedir = $(datadir)/locale
+pkgconfdir = $(sysconfdir)/@PACKAGE@
+
+AM_CPPFLAGS = \
+ -DLOCALEDIR=\"$(localedir)\" \
+ -DADMINDIR=\"$(admindir)\" \
+ -DLIBDIR=\"$(pkglibexecdir)\" \
+ -DLOCALLIBDIR=\"/usr/local/lib/dpkg\" \
+ -idirafter $(top_srcdir)/lib/compat \
+ -iquote $(builddir) \
+ -I$(top_builddir) \
+ -I$(top_srcdir)/lib
+AM_CXXFLAGS = \
+ -fno-rtti \
+ -fno-exceptions \
+ $(nil)
+if HAVE_LINKER_AS_NEEDED
+AM_LDFLAGS = \
+ -Wl,--as-needed
+endif
+
+
+bin_PROGRAMS = dselect
+
+dselect_SOURCES = \
+ cxx-support.cc \
+ dselect.h \
+ dselect-curses.h \
+ basecmds.cc \
+ baselist.cc \
+ basetop.cc \
+ bindings.cc bindings.h \
+ curkeys.cc \
+ helpmsgs.cc helpmsgs.h \
+ main.cc \
+ methkeys.cc \
+ methlist.cc \
+ method.cc method.h \
+ methparse.cc \
+ pkgcmds.cc \
+ pkgdepcon.cc \
+ pkgdisplay.cc \
+ pkginfo.cc \
+ pkgkeys.cc \
+ pkglist.cc pkglist.h \
+ pkgsublist.cc \
+ pkgtop.cc
+
+dselect_LDADD = \
+ $(CURSES_LIBS) \
+ ../lib/dpkg/libdpkg.la \
+ $(LIBINTL)
+
+
+EXTRA_DIST = keyoverride mkcurkeys.pl
+CLEANFILES = curkeys.h
+
+curkeys.$(OBJEXT): curkeys.h
+curkeys.h: $(srcdir)/keyoverride $(srcdir)/mkcurkeys.pl
+ $(AM_V_GEN) cursesfile=`echo '#include "dselect-curses.h"' | \
+ $(CPP) $(CPPFLAGS) -I$(top_builddir) -I $(srcdir) - | \
+ grep '[^-]curses\.h' | head -n 1 | \
+ sed -e 's/^[^"]*"//; s/".*$$//'`; \
+ if [ "$$cursesfile" = "" ]; then \
+ echo "can't find curses file"; exit 1; \
+ fi; \
+ $(PERL) $(srcdir)/mkcurkeys.pl $< $$cursesfile >$@
+
+install-data-local:
+ $(MKDIR_P) $(DESTDIR)$(pkgconfdir)/dselect.cfg.d