summaryrefslogtreecommitdiffstats
path: root/scripts/mk/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'scripts/mk/Makefile.am')
-rw-r--r--scripts/mk/Makefile.am25
1 files changed, 25 insertions, 0 deletions
diff --git a/scripts/mk/Makefile.am b/scripts/mk/Makefile.am
new file mode 100644
index 0000000..54a41e7
--- /dev/null
+++ b/scripts/mk/Makefile.am
@@ -0,0 +1,25 @@
+## Process this file with automake to produce Makefile.in
+
+dist_pkgdata_DATA = \
+ architecture.mk \
+ buildflags.mk \
+ buildtools.mk \
+ default.mk \
+ pkg-info.mk \
+ vendor.mk
+
+do_path_subst = $(AM_V_GEN) sed \
+ -e "s:dpkg_datadir[[:space:]]*=[[:space:]]*[^[:space:]]*:dpkg_datadir = $(pkgdatadir):"
+
+install-data-hook:
+ mv $(DESTDIR)$(pkgdatadir)/default.mk \
+ $(DESTDIR)$(pkgdatadir)/default.mk.tmp
+ $(do_path_subst) <$(DESTDIR)$(pkgdatadir)/default.mk.tmp \
+ >$(DESTDIR)$(pkgdatadir)/default.mk
+ rm -f $(DESTDIR)$(pkgdatadir)/default.mk.tmp
+
+ mv $(DESTDIR)$(pkgdatadir)/buildtools.mk \
+ $(DESTDIR)$(pkgdatadir)/buildtools.mk.tmp
+ $(do_path_subst) <$(DESTDIR)$(pkgdatadir)/buildtools.mk.tmp \
+ >$(DESTDIR)$(pkgdatadir)/buildtools.mk
+ rm -f $(DESTDIR)$(pkgdatadir)/buildtools.mk.tmp