summaryrefslogtreecommitdiffstats
path: root/scripts/t/mk/buildflags.mk
diff options
context:
space:
mode:
Diffstat (limited to 'scripts/t/mk/buildflags.mk')
-rw-r--r--scripts/t/mk/buildflags.mk14
1 files changed, 14 insertions, 0 deletions
diff --git a/scripts/t/mk/buildflags.mk b/scripts/t/mk/buildflags.mk
new file mode 100644
index 0000000..feed5e3
--- /dev/null
+++ b/scripts/t/mk/buildflags.mk
@@ -0,0 +1,14 @@
+DEB_CPPFLAGS_MAINT_APPEND = -DTEST_MK=test
+
+include $(srcdir)/mk/buildflags.mk
+
+test:
+ test "$(CFLAGS)" = "$(TEST_CFLAGS)"
+ test "$(CPPFLAGS)" = "$(TEST_CPPFLAGS) -DTEST_MK=test"
+ test "$(CXXFLAGS)" = "$(TEST_CXXFLAGS)"
+ test "$(FCFLAGS)" = "$(TEST_FCFLAGS)"
+ test "$(FFLAGS)" = "$(TEST_FFLAGS)"
+ test "$(GCJFLAGS)" = "$(TEST_GCJFLAGS)"
+ test "$(LDFLAGS)" = "$(TEST_LDFLAGS)"
+ test "$(OBJCFLAGS)" = "$(TEST_OBJCFLAGS)"
+ test "$(OBJCXXFLAGS)" = "$(TEST_OBJCXXFLAGS)"