summaryrefslogtreecommitdiffstats
path: root/debian/rules
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-06 00:49:15 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-06 00:49:15 +0000
commit4a0a4a1bbaf8ab3441a86d8907205f5512838e42 (patch)
tree612fdcac7755d5f7bfcb76f8d8ff52b4fc3e4733 /debian/rules
parentAdding upstream version 0.133+deb10u1. (diff)
downloadinitramfs-tools-4a0a4a1bbaf8ab3441a86d8907205f5512838e42.tar.xz
initramfs-tools-4a0a4a1bbaf8ab3441a86d8907205f5512838e42.zip
Adding debian version 0.133+deb10u1.debian/0.133+deb10u1debian
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to '')
-rwxr-xr-xdebian/rules26
1 files changed, 26 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..97a16df
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,26 @@
+#!/usr/bin/make -f
+
+%:
+ dh $@ --with bash-completion
+
+# On Debian we can use either busybox or busybox-static, but on Ubuntu
+# and derivatives only busybox-initramfs will work.
+BUSYBOX_PACKAGES := $(shell if dpkg-vendor --derives-from ubuntu; then echo busybox-initramfs; else echo busybox busybox-static; fi)
+BUSYBOX_MIN_VERSION := 1:1.22.0-17~
+
+override_dh_gencontrol:
+ echo >> debian/initramfs-tools-core.substvars "busybox:Breaks=$(wordlist 2,100,$(BUSYBOX_PACKAGES:%=, % (<< $(BUSYBOX_MIN_VERSION))))"
+ echo >> debian/initramfs-tools-core.substvars "busybox:Recommends=$(wordlist 2,100,$(BUSYBOX_PACKAGES:%=| % (>= $(BUSYBOX_MIN_VERSION))))"
+ dh_gencontrol
+
+override_dh_install:
+ sed -e 's,@BUSYBOX_PACKAGES@,$(wordlist 2,100,$(BUSYBOX_PACKAGES:%=or %)),' \
+ -e 's/@BUSYBOX_MIN_VERSION@/$(BUSYBOX_MIN_VERSION)/' \
+ mkinitramfs > debian/initramfs-tools-core/usr/sbin/mkinitramfs
+ chmod 755 debian/initramfs-tools-core/usr/sbin/mkinitramfs
+ dh_install
+
+override_dh_auto_test:
+ifeq (,$(filter nocheck,$(DEB_BUILD_OPTIONS)))
+ shellcheck -e SC1090,SC1091 -s dash hook-functions $$(find hooks scripts -type f) $$({ find . -maxdepth 1 -type f -executable; find debian -maxdepth 1 -type f; find docs kernel -type f; } | xargs grep -l '^#!/bin/sh')
+endif