summaryrefslogtreecommitdiffstats
path: root/debian/rules
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-06 00:50:22 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-06 00:50:22 +0000
commit4283a547939c204787a35239ff31758cccf2674f (patch)
tree961e298be9b22e950ab392515aa18ebb3de9bcd9 /debian/rules
parentAdding upstream version 2.18+dfsg. (diff)
downloadirker-af931c3ee05daaeb6de6691c89915ef0d81626d2.tar.xz
irker-af931c3ee05daaeb6de6691c89915ef0d81626d2.zip
Adding debian version 2.18+dfsg-3.debian/2.18+dfsg-3debian
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules19
1 files changed, 19 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..5aa4868
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,19 @@
+#!/usr/bin/make -f
+
+dfsg:
+ # no origin known and no source available
+ rm -f irker-logo.png
+
+%:
+ dh ${@} --with python2
+
+override_dh_auto_build:
+ DESTDIR="$(CURDIR)/debian/irker" dh_auto_build
+
+override_dh_auto_install:
+ DESTDIR="$(CURDIR)/debian/irker" dh_auto_install
+
+ cp irkerhook.py debian/irker/usr/bin/irkerhook
+
+override_dh_installchangelogs:
+ dh_installchangelogs NEWS