summaryrefslogtreecommitdiffstats
path: root/etc/etc.mk
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-06 00:55:53 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-06 00:55:53 +0000
commit3d0386f27ca66379acf50199e1d1298386eeeeb8 (patch)
treef87bd4a126b3a843858eb447e8fd5893c3ee3882 /etc/etc.mk
parentInitial commit. (diff)
downloadknot-resolver-3d0386f27ca66379acf50199e1d1298386eeeeb8.tar.xz
knot-resolver-3d0386f27ca66379acf50199e1d1298386eeeeb8.zip
Adding upstream version 3.2.1.upstream/3.2.1upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'etc/etc.mk')
-rw-r--r--etc/etc.mk16
1 files changed, 16 insertions, 0 deletions
diff --git a/etc/etc.mk b/etc/etc.mk
new file mode 100644
index 0000000..b42d30a
--- /dev/null
+++ b/etc/etc.mk
@@ -0,0 +1,16 @@
+etc_SOURCES := icann-ca.pem \
+ config.cluster \
+ config.isp \
+ config.personal \
+ config.splitview \
+ root.hints
+
+etc-install: $(DESTDIR)$(ETCDIR)
+ $(INSTALL) -m 0644 $(addprefix etc/,$(etc_SOURCES)) $(DESTDIR)$(ETCDIR)
+
+etc: etc/root.hints
+
+etc/root.hints:
+ wget -O $@ https://www.internic.net/domain/named.root
+
+.PHONY: etc-install