summaryrefslogtreecommitdiffstats
path: root/tests/deckard/contrib/libfaketime/test/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'tests/deckard/contrib/libfaketime/test/Makefile')
-rw-r--r--tests/deckard/contrib/libfaketime/test/Makefile31
1 files changed, 31 insertions, 0 deletions
diff --git a/tests/deckard/contrib/libfaketime/test/Makefile b/tests/deckard/contrib/libfaketime/test/Makefile
new file mode 100644
index 0000000..94d1a2e
--- /dev/null
+++ b/tests/deckard/contrib/libfaketime/test/Makefile
@@ -0,0 +1,31 @@
+CC = gcc
+
+CFLAGS = -std=gnu99 -Wall -DFAKE_STAT -Werror -Wextra
+LDFLAGS = -lrt -lpthread
+
+SRC = timetest.c
+OBJ = ${SRC:.c=.o}
+
+all: timetest test
+
+.c.o:
+ ${CC} -c ${CFLAGS} $<
+
+timetest: ${OBJ}
+ ${CC} -o $@ ${OBJ} ${LDFLAGS}
+
+test: timetest functest
+ @echo
+ @./test.sh
+
+# run functional tests
+functest:
+ ./testframe.sh functests
+
+clean:
+ @rm -f ${OBJ} timetest
+
+distclean: clean
+ @echo
+
+.PHONY: all test clean distclean