summaryrefslogtreecommitdiffstats
path: root/python/Makefile.am
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-06 00:53:35 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-06 00:53:35 +0000
commit69c6a41ffb878ef98c9378ed4b1634a404cfaa7f (patch)
treeb2a4f704565d62fbb129ab9dc3b35977c50e6e7f /python/Makefile.am
parentInitial commit. (diff)
downloadknot-69c6a41ffb878ef98c9378ed4b1634a404cfaa7f.tar.xz
knot-69c6a41ffb878ef98c9378ed4b1634a404cfaa7f.zip
Adding upstream version 2.7.6.upstream/2.7.6upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'python/Makefile.am')
-rw-r--r--python/Makefile.am15
1 files changed, 15 insertions, 0 deletions
diff --git a/python/Makefile.am b/python/Makefile.am
new file mode 100644
index 0000000..dd76d62
--- /dev/null
+++ b/python/Makefile.am
@@ -0,0 +1,15 @@
+EXTRA_DIST = \
+ libknot/__init__.py.in \
+ libknot/control.py \
+ setup.py.in \
+ stats_http.py \
+ stats_influxdb.py
+
+clean-local:
+ -rm -rf dist *.egg-info
+
+dist: clean-local
+ python3 setup.py sdist
+
+upload:
+ twine upload dist/*