summaryrefslogtreecommitdiffstats
path: root/python/setup.py.in
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-06 00:53:35 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-06 00:53:35 +0000
commit69c6a41ffb878ef98c9378ed4b1634a404cfaa7f (patch)
treeb2a4f704565d62fbb129ab9dc3b35977c50e6e7f /python/setup.py.in
parentInitial commit. (diff)
downloadknot-d02c1c4ad3b5dddb2ceca2c451a5b417770810ef.tar.xz
knot-d02c1c4ad3b5dddb2ceca2c451a5b417770810ef.zip
Adding upstream version 2.7.6.upstream/2.7.6upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'python/setup.py.in')
-rw-r--r--python/setup.py.in27
1 files changed, 27 insertions, 0 deletions
diff --git a/python/setup.py.in b/python/setup.py.in
new file mode 100644
index 0000000..8d57bc9
--- /dev/null
+++ b/python/setup.py.in
@@ -0,0 +1,27 @@
+import setuptools
+
+setuptools.setup(
+ name='libknot',
+ version='@PACKAGE_VERSION@',
+ description='Python bindings for libknot',
+ author='Daniel Salzman',
+ author_email='daniel.salzman@nic.cz',
+ url='https://gitlab.labs.nic.cz/knot/knot-dns',
+ license='GPL-3.0',
+ packages=['libknot'],
+ classifiers=[ # See https://pypi.org/classifiers
+ 'Development Status :: 5 - Production/Stable',
+ 'Intended Audience :: Developers',
+ 'Intended Audience :: System Administrators',
+ 'License :: OSI Approved :: GNU General Public License v3 (GPLv3)',
+ 'Programming Language :: Python :: 3',
+ 'Programming Language :: Python :: 3.4',
+ 'Programming Language :: Python :: 3.5',
+ 'Programming Language :: Python :: 3.6',
+ 'Programming Language :: Python :: 3.7',
+ 'Programming Language :: Python :: 3.8',
+ 'Topic :: Internet :: Name Service (DNS)',
+ 'Topic :: Software Development :: Libraries',
+ 'Topic :: System :: Systems Administration',
+ ]
+)