summaryrefslogtreecommitdiffstats
path: root/samples/Makefile.am
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-06 00:53:35 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-06 00:53:35 +0000
commit69c6a41ffb878ef98c9378ed4b1634a404cfaa7f (patch)
treeb2a4f704565d62fbb129ab9dc3b35977c50e6e7f /samples/Makefile.am
parentInitial commit. (diff)
downloadknot-69c6a41ffb878ef98c9378ed4b1634a404cfaa7f.tar.xz
knot-69c6a41ffb878ef98c9378ed4b1634a404cfaa7f.zip
Adding upstream version 2.7.6.upstream/2.7.6upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'samples/Makefile.am')
-rw-r--r--samples/Makefile.am34
1 files changed, 34 insertions, 0 deletions
diff --git a/samples/Makefile.am b/samples/Makefile.am
new file mode 100644
index 0000000..c253c91
--- /dev/null
+++ b/samples/Makefile.am
@@ -0,0 +1,34 @@
+edit = sed \
+ -e 's|@version[@]|$(PACKAGE_VERSION)|g' \
+ -e 's|@package[@]|$(PACKAGE_NAME)|g' \
+ -e 's|@localstatedir[@]|$(localstatedir)|g' \
+ -e 's|@prefix[@]|$(prefix)|g' \
+ -e 's|@sysconfdir[@]|$(sysconfdir)|g' \
+ -e 's|@config_dir[@]|$(config_dir)|g' \
+ -e 's|@storage_dir[@]|$(storage_dir)|g' \
+ -e 's|@run_dir[@]|$(run_dir)|g'
+
+knot.sample.conf: knot.sample.conf.in
+ rm -f $@ $@.tmp
+ srcdir=''; \
+ test -f ./$@.in || srcdir=$(srcdir)/; \
+ $(edit) $${srcdir}$@.in >$@.tmp
+ mv $@.tmp $@
+
+EXTRA_DIST = knot.sample.conf.in example.com.zone
+
+if HAVE_DAEMON
+
+install-data-local: knot.sample.conf
+ if [ \! -f $(DESTDIR)/$(config_dir)/knot.sample.conf ]; then \
+ $(INSTALL) -d $(DESTDIR)/$(config_dir); \
+ $(INSTALL_DATA) knot.sample.conf $(srcdir)/example.com.zone $(DESTDIR)/$(config_dir); \
+ fi
+uninstall-local:
+ -rm -rf $(DESTDIR)/$(config_dir)/knot.sample.conf \
+ $(DESTDIR)/$(config_dir)/example.com.zone
+
+endif # HAVE_DAEMON
+
+clean-local:
+ rm -f knot.sample.conf