summaryrefslogtreecommitdiffstats
path: root/arch/arm/mach-iop33x/Makefile
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--arch/arm/mach-iop33x/Makefile8
-rw-r--r--arch/arm/mach-iop33x/Makefile.boot3
2 files changed, 11 insertions, 0 deletions
diff --git a/arch/arm/mach-iop33x/Makefile b/arch/arm/mach-iop33x/Makefile
new file mode 100644
index 000000000..e95db30d8
--- /dev/null
+++ b/arch/arm/mach-iop33x/Makefile
@@ -0,0 +1,8 @@
+#
+# Makefile for the linux kernel.
+#
+
+obj-y := irq.o uart.o
+
+obj-$(CONFIG_ARCH_IQ80331) += iq80331.o
+obj-$(CONFIG_MACH_IQ80332) += iq80332.o
diff --git a/arch/arm/mach-iop33x/Makefile.boot b/arch/arm/mach-iop33x/Makefile.boot
new file mode 100644
index 000000000..760a0efe7
--- /dev/null
+++ b/arch/arm/mach-iop33x/Makefile.boot
@@ -0,0 +1,3 @@
+ zreladdr-y += 0x00008000
+params_phys-y := 0x00000100
+initrd_phys-y := 0x00800000